gperftools-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138
  1. Name: gperftools
  2. Version: 2.0
  3. Release: 3%{?_dist_release}
  4. License: BSD
  5. Group: Development/Tools
  6. Summary: Very fast malloc and performance analysis tools
  7. Summary(ja): 超高速な malloc と性能分析ツール
  8. URL: http://code.google.com/p/gperftools/
  9. Source0: http://gperftools.googlecode.com/files/%{name}-%{version}.tar.gz
  10. # http://code.google.com/p/gperftools/issues/detail?id=444
  11. Patch0: gperftools-2.0-glibc216.patch
  12. # ppc64 still broken, bz 238390
  13. ExclusiveArch: %{ix86} x86_64 ppc %{arm}
  14. %ifnarch ppc ppc64
  15. BuildRequires: libunwind-devel >= 1.0.1
  16. %endif
  17. %description
  18. Perf Tools is a collection of performance analysis tools, including a
  19. high-performance multi-threaded malloc() implementation that works
  20. particularly well with threads and STL, a thread-friendly heap-checker,
  21. a heap profiler, and a cpu-profiler.
  22. %package devel
  23. Summary: Development libraries and headers for gperftools
  24. Summary(ja): gperftools の開発用ライブラリとヘッダ
  25. Group: Development/Libraries
  26. Requires: %{name}-libs = %{version}-%{release}
  27. Provides: google-perftools-devel = %{version}-%{release}
  28. Obsoletes: google-perftools-devel < 2.0
  29. %description devel
  30. Libraries and headers for developing applications that use gperftools.
  31. %package libs
  32. Summary: Libraries provided by gperftools
  33. Summary(ja): gperftools ライブラリ
  34. Provides: google-perftools = %{version}-%{release}
  35. Obsoletes: google-perftools < 2.0
  36. %description libs
  37. Libraries provided by gperftools, including libtcmalloc and libprofiler.
  38. %package -n pprof
  39. Summary: CPU and Heap Profiler tool
  40. Summary(ja): CPU および Heap プロファイルツール
  41. Requires: gv, graphviz
  42. BuildArch: noarch
  43. Provides: google-perftools = %{version}-%{release}
  44. Obsoletes: google-perftools < 2.0
  45. %description -n pprof
  46. Pprof is a heap and CPU profiler tool, part of the gperftools suite.
  47. %prep
  48. %setup -q
  49. %patch0 -p1 -b .glibc216
  50. # Fix end-of-line encoding
  51. sed -i 's/\r//' README_windows.txt
  52. # No need to have exec permissions on source code
  53. chmod -x src/sampler.h src/sampler.cc
  54. %build
  55. CXXFLAGS=`echo $RPM_OPT_FLAGS -DTCMALLOC_LARGE_PAGES| sed -e 's/-Wp,-D_FORTIFY_SOURCE=2//g'`
  56. %configure --disable-static
  57. # Bad rpath!
  58. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  59. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  60. # Can't build with smp_mflags
  61. make
  62. %install
  63. make DESTDIR=%{buildroot} docdir=%{_docdir}/%{name}-%{version}/ install
  64. find %{buildroot} -type f -name "*.la" -exec rm -f {} ';'
  65. # Zero files
  66. rm -rf %{buildroot}%{_docdir}/%{name}-%{version}/NEWS
  67. # Delete useless files
  68. rm -rf %{buildroot}%{_docdir}/%{name}-%{version}/INSTALL
  69. %check
  70. # http://code.google.com/p/google-perftools/issues/detail?id=153
  71. %ifnarch ppc
  72. # Their test suite is junk. Disabling.
  73. # LD_LIBRARY_PATH=./.libs make check
  74. %endif
  75. %post libs -p /sbin/ldconfig
  76. %postun libs -p /sbin/ldconfig
  77. %files -n pprof
  78. %{_bindir}/pprof
  79. %{_mandir}/man1/*
  80. %files devel
  81. %{_docdir}/%{name}-%{version}/
  82. %{_includedir}/google/
  83. %{_includedir}/gperftools/
  84. %{_libdir}/*.so
  85. %{_libdir}/pkgconfig/*.pc
  86. %files libs
  87. %{_libdir}/*.so.*
  88. %changelog
  89. * Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-3
  90. - rebuild with gcc-5.4.0
  91. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-2
  92. - rebuild with libunwind-1.0.1
  93. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
  94. - update to 2.0, rename to gperftools
  95. * Wed Oct 14 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4-1
  96. - new upstream release
  97. * Tue Jun 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.91-0vl1
  98. - initial build for Vine Linux
  99. * Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-3
  100. - The tests work fine for me locally, but some of them fail inside mock.
  101. * Sun Apr 29 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-2
  102. - no support for ppc yet
  103. * Mon Apr 23 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.91-1
  104. - alright, lets see if this works now.
  105. * Wed Oct 13 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-2
  106. - change group to Development/Tools
  107. * Mon Oct 10 2005 Tom "spot" Callaway <tcallawa@redhat.com> 0.3-1
  108. - initial package for Fedora Extras