lyx-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279
  1. %define texmf %{_datadir}/texmf
  2. %define build_texmf %{buildroot}%{texmf}
  3. %define exec_texhash [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash 2>/dev/null
  4. Summary: WYSIWYM (What You See Is What You Mean) word processor with LaTeX output
  5. Summary(ja): LaTeX 形式で保存できるワードプロセッサ
  6. Name: lyx
  7. Version: 2.0.0
  8. Release: 1%{?_dist_release}
  9. License: GPLv2+
  10. Group: Applications/Editors
  11. URL: http://www.lyx.org/
  12. Source0: ftp://ftp.lyx.org/pub/lyx/stable/lyx-%{version}.tar.xz
  13. Source1: lyxrc.dist
  14. Source10: lyx.desktop
  15. ## upstreamable patches
  16. # submitted, but upstream rejected it. we currently agree to disagree.
  17. Patch50: lyx-2.0.0rc1-xdg_open.patch
  18. # hunspell pkgconfig support
  19. Patch51: lyx-2.0.0-hunspell_pkgconfig.patch
  20. # vine
  21. # BuildRequires: aiksaurus-devel
  22. # BuildRequires: aspell-devel
  23. BuildRequires: enchant-devel
  24. BuildRequires: hunspell-devel
  25. BuildRequires: libboost-devel
  26. BuildRequires: libboost-filesystem
  27. BuildRequires: libboost-signals
  28. BuildRequires: libboost-regex
  29. BuildRequires: desktop-file-utils
  30. BuildRequires: gettext
  31. BuildRequires: python
  32. BuildRequires: xorg-x11-devel
  33. BuildRequires: qt4-devel
  34. BuildRequires: libpng-devel
  35. BuildRequires: glib2-devel
  36. BuildRequires: zlib-devel
  37. Requires(post): texlive-common
  38. Requires(postun): texlive-common
  39. Requires: ghostscript
  40. Requires: python
  41. Requires: qt4
  42. Requires: latex-xft-fonts
  43. Requires: xdg-utils
  44. Requires: rcs
  45. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. %description
  49. LyX is a modern approach to writing documents which breaks with the
  50. obsolete "typewriter paradigm" of most other document preparation
  51. systems.
  52. It is designed for people who want professional quality output
  53. with a minimum of time and effort, without becoming specialists in
  54. typesetting.
  55. The major innovation in LyX is WYSIWYM (What You See Is What You Mean).
  56. That is, the author focuses on content, not on the details of formatting.
  57. This allows for greater productivity, and leaves the final typesetting
  58. to the backends (like LaTeX) that are specifically designed for the task.
  59. With LyX, the author can concentrate on the contents of his writing,
  60. and let the computer take care of the rest.
  61. This is LyX built with the Qt frontend.
  62. %description -l ja
  63. LaTeX形式で出力もできるワードプロセッサです。数式の入力も簡単にできます。
  64. 特別な知識が無くても、最小限の努力でプロ並の出力を得られるように設計
  65. してあります。
  66. %prep
  67. %setup -q
  68. %patch50 -p1 -b .xdg_open
  69. %patch51 -p1 -b .hunspell_pkgconfig
  70. ./autogen.sh
  71. %build
  72. %configure \
  73. --disable-dependency-tracking \
  74. --disable-rpath \
  75. --enable-build-type=release \
  76. --disable-debug \
  77. --enable-optimization="%{optflags}" \
  78. --without-included-boost \
  79. --enable-shared \
  80. --disable-static \
  81. \
  82. --with-frontend=qt4 \
  83. --without-aiksaurus \
  84. --with-enchant \
  85. --with-hunspell \
  86. ;
  87. %__make %{?_smp_mflags}
  88. # # make sure all .gmo files are regenerated from .po files
  89. # (cd po; make update-gmo)
  90. %install
  91. %__rm -rf ${RPM_BUILD_ROOT}
  92. %__make DESTDIR=${RPM_BUILD_ROOT} install
  93. # misc/extras
  94. %__install -p -m644 -D %{SOURCE1} %{buildroot}%{_datadir}/lyx/lyxrc.dist
  95. # Set up the lyx-specific class files where TeX can see them
  96. %__mkdir_p %{build_texmf}/tex/latex
  97. %__mv %{buildroot}%{_datadir}/lyx/tex %{build_texmf}/tex/latex/lyx
  98. # desktop & icon
  99. desktop-file-install --vendor="vine" \
  100. --dir="${RPM_BUILD_ROOT}%{_datadir}/applications" %{SOURCE10}
  101. %__install -p -D -m644 lib/images/lyx.png \
  102. %{buildroot}%{_datadir}/icons/hicolor/48x48/apps/lyx.png
  103. # ghost'd files
  104. touch %{buildroot}%{_datadir}/lyx/lyxrc.defaults
  105. touch %{buildroot}%{_datadir}/lyx/{packages,textclass}.lst
  106. # unpackaged files
  107. %__rm -rf %{buildroot}%{_datadir}/lyx/fonts
  108. %find_lang %{name}
  109. %clean
  110. %__rm -rf ${RPM_BUILD_ROOT}
  111. %post
  112. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  113. %postun
  114. if [ $1 -eq 0 ] ; then
  115. %{exec_texhash} >& /dev/null
  116. update-desktop-database -q &> /dev/null
  117. touch --no-create %{_datadir}/icons/hicolor &> /dev/null
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  119. fi
  120. %posttrans
  121. %{exec_texhash} >& /dev/null
  122. update-desktop-database -q &> /dev/null
  123. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  124. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  125. %files -f %{name}.lang
  126. %defattr(-,root,root,-)
  127. %doc ABOUT-NLS ANNOUNCE COPYING README UPGRADING NEWS lib/CREDITS
  128. %{_bindir}/*
  129. %{_datadir}/lyx/
  130. %{texmf}/tex/latex/lyx/
  131. %{_datadir}/applications/*.desktop
  132. %{_datadir}/icons/hicolor/*/*/*
  133. %{_mandir}/man*/*
  134. %config(noreplace) %{_datadir}/lyx/lyxrc.dist
  135. %ghost %{_datadir}/lyx/lyxrc.defaults
  136. %ghost %{_datadir}/lyx/*.lst
  137. %ghost %{_datadir}/lyx/doc/LaTeXConfig.lyx
  138. %changelog
  139. * Sat Jun 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2.0.0-1
  140. - new upstream release
  141. - dropped BuildRequires: aspell-devel
  142. - added BuildRequires:
  143. - libboost-regex
  144. - enchant-devel
  145. - hunspell-devel
  146. * Thu Dec 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.8-1
  147. - new upstream release
  148. * Sun Aug 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.7-1
  149. - new upstream release
  150. - TeX Live 2009
  151. - dropped Requires: xdvik, dvipdfmx
  152. * Sun Jan 10 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.5-1
  153. - new upstream release
  154. - updated Patch0: lyx-1.6.5-xdg_open.patch
  155. * Sun Jul 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.6.3-1
  156. - new upstream release
  157. - dropped old source files
  158. - change License: GPLv2+
  159. - added lyx.desktop
  160. - added BuildRequires:
  161. - aspell-devel
  162. - desktop-file-utils
  163. - gettext
  164. - python
  165. - qt4-devel
  166. - zlib-devel
  167. - libboost-devel
  168. - libboost-filesystem
  169. - libboost-signals
  170. - libpng-devel
  171. - glib2-devel
  172. - added Requires:
  173. - ghostscript
  174. - dvipdfmx
  175. - xdvik
  176. - qt4
  177. - xdg-utils
  178. - optimized some configure options
  179. * Fri Oct 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.4-1vl5
  180. - applied new versioning policy, spec in utf-8
  181. * Sat Apr 07 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.4-0vl1
  182. - updated to 1.4.4 with the most recent CJK patch
  183. - updated Patch1
  184. * Sat Dec 30 2006 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.4.2-0vl1
  185. - base spec file : Vine Linux BTS #219
  186. * Mon Nov 6 2006 M.H
  187. - new upstream release
  188. - base spec file CJK-LyX-qt.spec and VinePlus lyx.spec
  189. * Wed Sep 13 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.4-0vl3
  190. - changed Group to Applications/Editors
  191. * Sat Jan 28 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org>
  192. - rebuild with qt-3.3.5
  193. * Sun Jun 13 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.3.4-0vl1
  194. - new upstream version
  195. - change frontend, xforms -> qt
  196. - require tetex, qt, latex-xft-fonts
  197. - change applnk file
  198. - change Group
  199. * Thu Aug 21 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.1.6fix4-0vl1
  200. - new upstream version
  201. - add mime-info
  202. - minor change in spec file
  203. * Sat Nov 11 2000 Masato Bito <masato@nets.ce.hiroshima-cu.ac.jp>
  204. - 1.0.3_jp-4
  205. - added BuildPrereq:
  206. * Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
  207. - 1.0.3_jp-3
  208. - minor change in spec file
  209. - build for Vine Linux 2.1
  210. * Wed Jan 5 2000 Jun Nishii <jun@vinelinux.org>
  211. - change group
  212. * Wed Dec 22 1999 Jun Nishii <jun@vinelinux.org>
  213. - updated to lyx-1.0.3
  214. - rebuild for Vine Linux 2.0
  215. * Wed May 5 1999 Jun Nishii <jun@vinelinux.org>
  216. - merged Japanese Documents
  217. * Tue May 4 1999 Jun Nishii <jun@vinelinux.org>
  218. - first build