xorg-x11-font-utils-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302
  1. %define pkgname font-utils
  2. Summary: X.Org X11 font utilities
  3. Summary(ja): X.Org X11 font ユーティリティ
  4. Name: xorg-x11-%{pkgname}
  5. Version: 7.7
  6. Release: 2%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.4.tar.bz2
  11. Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
  12. Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
  13. Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.1.1.tar.bz2
  14. Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.3.0.tar.bz2
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pkgconfig
  17. # xorg-x11-libXfont-devel needed for bdftopcf
  18. BuildRequires: libXfont-devel
  19. # xorg-x11-libX11-devel needed for fonttosfnt
  20. BuildRequires: libX11-devel
  21. # xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
  22. BuildRequires: libfontenc-devel >= 0.99.2-2
  23. # freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
  24. BuildRequires: freetype2-devel
  25. # zlib-devel needed for bdftopcf
  26. BuildRequires: zlib-devel
  27. # xorg-x11-proto-devel is needed for mkfontscale, which includes headers
  28. # from it directly.
  29. BuildRequires: xorg-x11-proto-devel
  30. BuildRequires: xorg-x11-util-macros
  31. BuildRequires: autoconf
  32. Requires(pre): xorg-x11-filesystem
  33. # NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
  34. # bug #173875 is installed in order for mkfontscale/mkfontdir to work
  35. # properly. It is a "pre" dep, to ensure libfontenc gets installed before
  36. # xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
  37. # set, avoiding a possible race condition.
  38. Requires(pre): libfontenc
  39. Provides: %{pkgname}
  40. Provides: XOrg-%{pkgname} = %{version}
  41. Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
  42. # NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
  43. # is needed for upgrades to work properly from OS releases that had XFree86
  44. Obsoletes: XFree86-font-utils, XOrg-font-utils
  45. # NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
  46. # this is needed for upgrades to work.
  47. Obsoletes: XFree86
  48. # NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
  49. # xorg-x11-font-utils in 6.7.99.903-3
  50. Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
  51. # NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
  52. Obsoletes: XOrg-tools <= 6.7.99.903-3
  53. Vendor: Project Vine
  54. Distribution: Vine Linux
  55. Packager: Takemikaduchi
  56. %description
  57. X.Org X11 font utilities required for font installation, conversion,
  58. and generation.
  59. %package -n bdftruncate
  60. Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
  61. Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
  62. Group: Applications/System
  63. %description -n bdftruncate
  64. bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
  65. other ISO10646-1 BDF fonts in which all characters above a threshold
  66. code value are stored unencoded. This is often desirable because the
  67. Xlib API and X11 protocol data structures used for representing font
  68. metric information are extremely inefficient when handling sparsely
  69. populated fonts.
  70. %prep
  71. %setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
  72. %build
  73. # Build all apps
  74. {
  75. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
  76. pushd $app-*
  77. # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
  78. case $app in
  79. font-util)
  80. autoconf
  81. ;;
  82. esac
  83. %configure
  84. make
  85. popd
  86. done
  87. }
  88. %install
  89. rm -rf $RPM_BUILD_ROOT
  90. # Install all apps
  91. {
  92. for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
  93. pushd $app-*
  94. make install DESTDIR=$RPM_BUILD_ROOT
  95. popd
  96. done
  97. for i in */README ; do
  98. [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
  99. done
  100. for i in */COPYING ; do
  101. grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
  102. done
  103. }
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %files
  107. %defattr(-,root,root,-)
  108. %doc README-* COPYING-*
  109. %{_bindir}/bdftopcf
  110. %{_bindir}/fonttosfnt
  111. %{_bindir}/mkfontdir
  112. %{_bindir}/mkfontscale
  113. %{_bindir}/ucs2any
  114. # blech. this one should be in -filesystem
  115. %dir %{_datadir}/fonts/X11
  116. %dir %{_datadir}/fonts/X11/util
  117. %{_datadir}/fonts/X11/util/map-*
  118. %{_datadir}/aclocal/fontutil.m4
  119. %{_libdir}/pkgconfig/fontutil.pc
  120. %{_mandir}/man1/bdftopcf.1*
  121. %{_mandir}/man1/fonttosfnt.1*
  122. %{_mandir}/man1/mkfontdir.1*
  123. %{_mandir}/man1/mkfontscale.1*
  124. %{_mandir}/man1/ucs2any.1*
  125. %files -n bdftruncate
  126. %defattr(-,root,root,-)
  127. %{_bindir}/bdftruncate
  128. %{_mandir}/man1/bdftruncate.1*
  129. %changelog
  130. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
  131. - mkfontscale-1.1.1
  132. - font-util-1.3.0
  133. * Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
  134. - bdftopcf-1.0.4
  135. * Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
  136. - mkfontdir-1.0.7
  137. - mkfontscale-1.1.0
  138. - add BuildRequires: xorg-x11-util-macros
  139. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
  140. - mkfontscale-1.0.9
  141. * Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
  142. - mkfontdir-1.0.6
  143. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
  144. - bdftopcf-1.0.3
  145. - mkfontscale-1.0.8
  146. - font-util-1.2.0
  147. * Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
  148. - rebuild with rpm-4.8.1 for pkg-config file
  149. * Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
  150. - bdftopcf-1.0.2
  151. - mkfontdir-1.0.5
  152. - mkfontscale-1.0.7
  153. - font-util-1.1.1
  154. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
  155. - mkfontscale 1.0.6
  156. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
  157. - fonttosfnt 1.0.4
  158. - mkfontdir 1.0.4
  159. - mkfontscale 1.0.5
  160. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
  161. - new versioning policy
  162. * Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
  163. - initial build for Vine Linux
  164. * Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
  165. - Move bdftruncate (and its perl dependency) to a subpackage.
  166. - %%doc for the non-empty READMEs and non-stub COPYINGs.
  167. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
  168. - Rebuild for build id
  169. * Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
  170. - bdftopcf 1.0.1
  171. - Superstition bump to 7.2-1
  172. * Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
  173. - mkfontdir 1.0.3
  174. * Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
  175. - fonttosfnt 1.0.3
  176. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
  177. - Remove X11R6 symlinks.
  178. * Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
  179. - Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
  180. with new freetype 2.2.
  181. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
  182. - rebuild
  183. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
  184. - Update to font-util-1.0.1 from X11R7.1
  185. - Set package version to X11 release the tarballs are based from.
  186. * Wed Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
  187. - Update mkfontdir
  188. * Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
  189. - Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
  190. itself. Leftover from the original package template it seems. (#182439)
  191. * Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
  192. - Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
  193. mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
  194. binaries. This will provide backward compatibilty for Fedora Core 5, however
  195. 3rd party developers and rpm package maintainers should update to using the
  196. new X11R7 locations immediately, as these compatibility links are temporary,
  197. and will be removed from a future OS release.
  198. - Remove system directories from file manifest to appease the banshees.
  199. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
  200. - bump again for double-long bug on ppc(64)
  201. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
  202. - rebuilt for new gcc4.1 snapshot and glibc changes
  203. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
  204. - Updated all utilities to the versions shipped in X11R7.0.
  205. * Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
  206. - Updated all utilities to version 1.0.0 from X11R7 RC4.
  207. - Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
  208. - Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
  209. variable "fontdir" to the fontutil.pc file which all of the font packages
  210. can autodetect and use instead of having to put manual fontdir overrides
  211. in every single rpm package.
  212. * Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
  213. - Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
  214. and font-util to version 0.99.2 from X11R7 RC3.
  215. - Changed manpage dir from man1x back to man1 due to another upstream change.
  216. - Added fontutil.m4 to file manifest.
  217. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
  218. - Changed package version to 0.99.1 to match the upstream font-util tarball
  219. version, and added "Epoch: 1" to the package for upgrades.
  220. - Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
  221. mapfiles data to install into datadir instead of libdir (#173943)
  222. - Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
  223. libfontenc to be installed that fixes bug #173453, and to also force it
  224. to be installed before xorg-x11-font-utils in a multi-package rpm
  225. transaction, which will ensure that when font packages get installed
  226. during upgrades via anaconda or yum, that the right libfontenc is being
  227. used by mkfontscale/mkfontdir.
  228. - Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
  229. people rebuilding xorg-x11-font-utils, as they'll need to install the new
  230. libfontenc now anyway before they can install the font-utils package.
  231. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
  232. - require newer filesystem (#172610)
  233. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
  234. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  235. X11R7 RC1.
  236. * Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
  237. - Glob util/map-* files in file manifest.
  238. - Added missing "Obsoletes: xorg-x11-font-utils".
  239. - Added "BuildRequires: pkgconfig".
  240. * Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
  241. - Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
  242. ucs2any, bdftruncate.
  243. * Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
  244. - Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
  245. X11R7 RC1.
  246. - Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
  247. - Updated file manifest to to find the manpages in "man1x".
  248. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
  249. - Initial build.