gamin-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define python_archlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  3. Summary: Library providing the FAM File Alteration Monitor API
  4. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  5. Name: gamin
  6. Version: 0.1.10
  7. Release: 3%{?_dist_release}
  8. License: LGPLv2
  9. Group: System Environment/Daemons
  10. Source: gamin-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. URL: http://www.gnome.org/~veillard/gamin/
  13. Obsoletes: fam
  14. Provides: fam
  15. BuildRequires: glib2-devel, python, python-devel
  16. %description
  17. The Gamin library provides an API and ABI compatible file alteration
  18. monitor mechanism compatible with FAM but not dependent on a system wide
  19. daemon.
  20. %description -l ja
  21. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  22. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  23. パープログラムをオンデマンドに起動します。
  24. %package devel
  25. Summary: Development files for the Gamin library
  26. Summary(ja): Gamin ライブラリの開発用ファイル
  27. Group: Development/Libraries
  28. Requires: gamin = %{version}-%{release}
  29. Obsoletes: fam-devel
  30. Provides: fam-devel
  31. %description devel
  32. The Gamin library provides an API and ABI compatible file alteration
  33. monitor mechanism compatible with FAM but not dependent on a system wide
  34. daemon.
  35. %description devel -l ja
  36. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  37. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  38. パープログラムをオンデマンドに起動します。
  39. %package python
  40. Summary: Python bindings for the Gamin library
  41. Summary(ja): Gamin ライブラリ用の Python バインディング
  42. Group: Development/Libraries
  43. Requires: gamin = %{version}-%{release}
  44. Requires: %{_libdir}/python%(echo `python -c "import sys; print sys.version[0:3]"`)
  45. %description python
  46. The gamin-python package contains a module that allow monitoring of
  47. files and directories from the Python language based on the support
  48. of the gamin package.
  49. %description python -l ja
  50. gamin-python は gamin ライブラリを利用して Python 言語からファイルや
  51. ディレクトリのモニタリングを行うためのモジュールです。
  52. ## to build compat32 for x86_64 architecture support
  53. %package -n compat32-%{name}
  54. Summary: Library providing the FAM File Alteration Monitor API
  55. Summary(ja): FAM (File Alteration Monitor) API を提供するライブラリ
  56. Group: System Environment/Daemons
  57. Requires: gamin = %{version}-%{release}
  58. %description -n compat32-%{name}
  59. The Gamin library provides an API and ABI compatible file alteration
  60. monitor mechanism compatible with FAM but not dependent on a system wide
  61. daemon.
  62. %description -n compat32-%{name} -l ja
  63. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  64. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  65. パープログラムをオンデマンドに起動します。
  66. %package -n compat32-%{name}-devel
  67. Summary: Development files for the Gamin library
  68. Summary(ja): Gamin ライブラリの開発用ファイル
  69. Group: Development/Libraries
  70. Requires: compat32-gamin = %{version}-%{release}
  71. %description -n compat32-%{name}-devel
  72. The Gamin library provides an API and ABI compatible file alteration
  73. monitor mechanism compatible with FAM but not dependent on a system wide
  74. daemon.
  75. %description -n compat32-%{name}-devel -l ja
  76. Gamin ライブラリは FAM と API/ABI 互換のファイル変更検知システムを提供
  77. します。FAM とは違いシステムワイドなデーモンを利用せず、ユーザ毎のヘル
  78. %prep
  79. %setup -q
  80. %build
  81. %configure
  82. %__make %{?_smp_mflags}
  83. %install
  84. rm -fr %{buildroot}
  85. %makeinstall
  86. ## remove unuse files
  87. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  88. rm -f $RPM_BUILD_ROOT%{python_archlib}/*.la
  89. %clean
  90. rm -fr %{buildroot}
  91. %post -p /sbin/ldconfig
  92. %postun -p /sbin/ldconfig
  93. %post -n compat32-%{name} -p /sbin/ldconfig
  94. %postun -n compat32-%{name} -p /sbin/ldconfig
  95. %files
  96. %defattr(-, root, root)
  97. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  98. %doc doc/*.html
  99. %doc doc/*.gif
  100. %doc doc/*.txt
  101. %{_libdir}/lib*.so.*
  102. %{_libexecdir}/gam_server
  103. %files devel
  104. %defattr(-, root, root)
  105. %{_libdir}/lib*.so
  106. %{_libdir}/*a
  107. %{_includedir}/fam.h
  108. %{_libdir}/pkgconfig/gamin.pc
  109. %files python
  110. %defattr(-, root, root)
  111. %doc AUTHORS ChangeLog NEWS README Copyright TODO
  112. %{_libdir}/python*/site-packages/gamin.py*
  113. %{_libdir}/python*/site-packages/_gamin*
  114. %doc python/tests/*.py
  115. %doc doc/python.html
  116. %if %{build_compat32}
  117. %files -n compat32-%{name}
  118. %defattr(-, root, root)
  119. %{_libdir}/lib*.so.*
  120. %files -n compat32-%{name}-devel
  121. %defattr(-, root, root)
  122. %{_libdir}/lib*.so
  123. %{_libdir}/*a
  124. %{_libdir}/pkgconfig/gamin.pc
  125. %endif
  126. %changelog
  127. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 0.1.10-3
  128. - build with rpm-4.8.1-1 for pkg-config file
  129. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.1.10-2
  130. - rebuild with python-2.6
  131. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.10-1
  132. - new upstream release
  133. * Sun Sep 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.1.9-3
  134. - fix license tag to LGPLv2
  135. - import patches from Fedora development
  136. - Patch0: don't poll for non-existant watched files
  137. - Patch1: Fix a memory leak
  138. - Patch2: workaround for missing struct ucred in glibc headers
  139. (fixed x86_64/ppc compilation)
  140. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.1.9-2
  141. - spec in utf-8
  142. - removed *.la
  143. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.1.9-1
  144. - added compat32-* packages for x86_64 architecture support
  145. - applied new versioning policy
  146. * Wed Mar 05 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.1.9-0vl1
  147. - new upstream release
  148. - Patch10 was included in upstream, dropped
  149. * Fri Apr 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.1.8-0vl2
  150. - added Patch10 (<BTS:507>) which should be fixed in the new upstream release
  151. * Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.8-0vl1
  152. - new upstream release
  153. * Mon Sep 4 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.1.7-0vl2
  154. - stop removing *.la
  155. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.1.7-0vl1
  156. - initial build for Vine Linux
  157. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2.1
  158. - bump again for double-long bug on ppc(64)
  159. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.1.7-1.2
  160. - rebuilt for new gcc4.1 snapshot and glibc changes
  161. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  162. - rebuilt
  163. * Thu Oct 27 2005 Daniel Veillard <veillard@redhat.com> 0.1.7-1
  164. - hopefully fixes gam_server crashes
  165. - some portability fixes
  166. - removed a minor leak
  167. * Thu Sep 8 2005 Daniel Veillard <veillard@redhat.com> 0.1.6-1
  168. - revamp of the inotify back-end
  169. - memory leak fix
  170. - various fixes and cleanups
  171. * Tue Aug 9 2005 Daniel Veillard <veillard@redhat.com> 0.1.5-1
  172. - Improvement of configuration, system wide configuration files and
  173. per filesystem type default
  174. - Rewrite of the inotify back-end, reduce resources usage, tuning in
  175. case of busy resources
  176. - Documentation updates
  177. - Changes to compile inotify back-end on various architectures
  178. - Debugging output improvements
  179. * Tue Aug 2 2005 Daniel Veillard <veillard@redhat.com> 0.1.3-1
  180. - Fix to compile on older gcc versions
  181. - Inotify back-end changes and optimizations
  182. - Debug ouput cleanup, pid and process name reports
  183. - Dropped kernel monitor bugfix
  184. - Removed the old glist copy used for debugging
  185. - Maintain mounted filesystems knowledge, and per fstype preferences
  186. * Wed Jul 13 2005 Daniel Veillard <veillard@redhat.com> 0.1.2-1
  187. - inotify back end patches, ready for the new inotify support in kernel
  188. - lot of server code cleanup patches
  189. - fixed an authentication problem
  190. * Fri Jun 10 2005 Daniel Veillard <veillard@redhat.com> 0.1.1-1
  191. - gamin_data_conn_event fix
  192. - crash from bug gnome #303932
  193. - Inotify and mounted media #171201
  194. - mounted media did not show up on Desktop #159748
  195. - write may not be atomic
  196. - Monitoring a directory when it is a file
  197. - Portability to Hurd/Mach and various code cleanups
  198. - Added support for ~ as user home alias in .gaminrc
  199. * Thu May 12 2005 Daniel Veillard <veillard@redhat.com> 0.1.0-1
  200. - Close inherited file descriptors on exec of gam_server
  201. - Cancelling a monitor send back a FAMAcknowledge
  202. - Fixed for big files > 2GB
  203. - Bug when monitoring a non existing directory
  204. - Make client side thread safe
  205. - Unreadable directory fixes
  206. - Better flow control handling
  207. - Updated to latest inotify version: 0.23-6
  208. * Tue Mar 15 2005 Daniel Veillard <veillard@redhat.com> 0.0.26-1
  209. - Fix an include problem showing up with gcc4</li>
  210. - Fix the crash on failed tree assert bug #150471 based on patch from Dean Brettle
  211. - removed an incompatibility with SGI FAM #149822
  212. * Tue Mar 1 2005 Daniel Veillard <veillard@redhat.com> 0.0.25-1
  213. - Fix a configure problem reported by Martin Schlemmer
  214. - Fix the /media/* and /mnt/* mount blocking problems from 0.0.24 e.g. #142637
  215. - Fix the monitoring of directory using poll and not kernel
  216. * Fri Feb 18 2005 Daniel Veillard <veillard@redhat.com> 0.0.24-1
  217. - more documentation
  218. - lot of serious bug fixes including Gnome Desktop refresh bug
  219. - extending the framework for more debug (configure --enable-debug-api)
  220. - extending the python bindings for watching the same resource multiple times
  221. and adding debug framework support
  222. - growing the regression tests a lot based on python bindings
  223. - inotify-0.19 patch from John McCutchan
  224. - renamed python private module to _gamin to follow Python PEP 8
  225. * Tue Feb 8 2005 Daniel Veillard <veillard@redhat.com> 0.0.23-1
  226. - memory corruption fix from Mark on the client side
  227. - extending the protocol and API to allow skipping Exists and EndExists
  228. events to avoid deadlock on reconnect or when they are not used.
  229. * Mon Jan 31 2005 Daniel Veillard <veillard@redhat.com> 0.0.22-1
  230. - bit of python bindings improvements, added test
  231. - fixed 3 bugs
  232. * Wed Jan 26 2005 Daniel Veillard <veillard@redhat.com> 0.0.21-1
  233. - Added Python support
  234. - Updated for inotify-0.18
  235. * Thu Jan 6 2005 Daniel Veillard <veillard@redhat.com> 0.0.20-1
  236. - Frederic Crozat seems to have found the GList corruption which may fix
  237. #132354 and related problems
  238. - Frederic Crozat also fixed poll only mode
  239. * Fri Dec 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.19-1
  240. - still chasing the loop bug, made another pass at checking GList,
  241. added own copy with memory poisonning of GList implementation.
  242. - fixed a compile issue when compiling without debug
  243. * Fri Nov 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.18-1
  244. - still chasing the loop bug, checked and cleaned up all GList use
  245. - patch from markmc to minimize load on busy apps
  246. * Wed Oct 20 2004 Daniel Veillard <veillard@redhat.com> 0.0.16-1
  247. - chasing #132354, lot of debugging, checking and testing and a bit
  248. of refactoring
  249. * Sat Oct 16 2004 Daniel Veillard <veillard@redhat.com> 0.0.15-1
  250. - workaround to detect loops and avoid the nasty effects, see RedHat bug #132354
  251. * Sun Oct 3 2004 Daniel Veillard <veillard@redhat.com> 0.0.14-1
  252. - Found and fixed the annoying bug where update were not received
  253. should fix bugs ##132429, #133665 and #134413
  254. - new mechanism to debug on-the-fly by sending SIGUSR2 to client or server
  255. - Added documentation about internals
  256. * Fri Oct 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.13-1
  257. - applied portability fixes
  258. - hardened the code while chasing a segfault
  259. * Thu Sep 30 2004 Daniel Veillard <veillard@redhat.com> 0.0.12-1
  260. - potential fix for a hard to reproduce looping problem.
  261. * Mon Sep 27 2004 Daniel Veillard <veillard@redhat.com> 0.0.11-1
  262. - update to the latest version of inotify
  263. - inotify support compiled in by default
  264. - fix ABI FAM compatibility problems #133162
  265. * Tue Sep 21 2004 Daniel Veillard <veillard@redhat.com> 0.0.10-1
  266. - more documentation
  267. - Added support for a configuration file $HOME/.gaminrc
  268. - fixes FAM compatibility issues with FAMErrno and FamErrlist #132944
  269. * Wed Sep 1 2004 Daniel Veillard <veillard@redhat.com> 0.0.9-1
  270. - fix crash with konqueror #130967
  271. - exclude kernel (dnotify) monitoring for /mnt//* /media//*
  272. * Thu Aug 26 2004 Daniel Veillard <veillard@redhat.com> 0.0.8-1
  273. - Fixes crashes of the gam_server
  274. - try to correct the kernel/poll switching mode
  275. * Tue Aug 24 2004 Daniel Veillard <veillard@redhat.com> 0.0.7-1
  276. - add support for both polling and dnotify simultaneously
  277. - fixes monitoring of initially missing files
  278. - load control on very busy resources #124361, desactivating
  279. dnotify and falling back to polling for CPU drain
  280. * Thu Aug 19 2004 Daniel Veillard <veillard@redhat.com> 0.0.6-1
  281. - fixes simple file monitoring should close RH #129974
  282. - relocate gam_server in $(libexec)
  283. * Thu Aug 5 2004 Daniel Veillard <veillard@redhat.com> 0.0.5-1
  284. - Fix a crash when the client binary forks the gam_server and an
  285. atexit handler is run.
  286. * Wed Aug 4 2004 Daniel Veillard <veillard@redhat.com> 0.0.4-1
  287. - should fix KDE build problems