xl2tpd-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370
  1. %define src_dir_name xl2tpd-%{version}
  2. Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
  3. Name: xl2tpd
  4. Version: 1.3.3
  5. Release: 1%{?_dist_release}
  6. # No version specified.
  7. License: GPL+
  8. Url: http://www.xelerance.com/software/xl2tpd/
  9. Group: System Environment/Daemons
  10. # https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz
  11. Source0: xl2tpd-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  13. Requires: ppp
  14. BuildRequires: libpcap-devel
  15. BuildRequires: openssl-devel
  16. Requires(post): /sbin/chkconfig
  17. Requires(preun): /sbin/chkconfig
  18. Requires(preun): /sbin/service
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: tomop
  22. %description
  23. xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
  24. L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
  25. sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
  26. servers. Another important application is Virtual Private Networks where
  27. the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
  28. RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
  29. Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
  30. implementations such as Openswan.
  31. Example configuration files for such a setup are included in this RPM.
  32. xl2tpd works by opening a pseudo-tty for communicating with pppd.
  33. It runs completely in userspace.
  34. xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
  35. NAT'ed IP's by different clients (eg all clients connecting from their
  36. linksys internal IP 192.168.1.101) as well as multiple clients behind
  37. the same NAT router.
  38. xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
  39. or via a patch in contrib for 2.4.x kernels.
  40. Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
  41. It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
  42. %prep
  43. %setup -q -n %{src_dir_name}
  44. %build
  45. make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
  46. %install
  47. rm -rf %{buildroot}
  48. make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
  49. install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
  50. install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
  51. install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
  52. install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
  53. install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
  54. install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
  55. %clean
  56. rm -rf %{buildroot}
  57. %post
  58. /sbin/chkconfig --add xl2tpd
  59. %preun
  60. if [ $1 -eq 0 ]; then
  61. /sbin/service xl2tpd stop > /dev/null 2>&1
  62. /sbin/chkconfig --del xl2tpd
  63. fi
  64. %postun
  65. if [ $1 -ge 1 ]; then
  66. /sbin/service xl2tpd condrestart 2>&1 >/dev/null
  67. fi
  68. %files
  69. %defattr(-,root,root)
  70. %doc BUGS CHANGES CREDITS LICENSE README.* TODO doc/rfc2661.txt
  71. %doc doc/README.patents examples/chapsecrets.sample
  72. %{_sbindir}/xl2tpd
  73. %{_sbindir}/xl2tpd-control
  74. %{_bindir}/pfc
  75. %{_mandir}/*/*
  76. %dir %{_sysconfdir}/xl2tpd
  77. %config(noreplace) %{_sysconfdir}/xl2tpd/*
  78. %config(noreplace) %{_sysconfdir}/ppp/*
  79. %attr(0755,root,root) %{_initrddir}/xl2tpd
  80. %dir %{_localstatedir}/run/xl2tpd
  81. %ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
  82. %changelog
  83. * Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
  84. - new upstream release.
  85. * Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
  86. - new upstream release.
  87. * Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
  88. - new upstream release.
  89. * Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
  90. - built for Vine Linux.
  91. * Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
  92. - Updated to 1.2.8
  93. - Add ghosting for l2tp pipe (bz#656725)
  94. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
  95. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  96. * Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
  97. - fix md5 of init script in sources
  98. * Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
  99. - Updated to 1.2.7
  100. - Added more DEBUG build options to the make command
  101. - Minor cleanups
  102. * Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
  103. - Bump for EVR
  104. * Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
  105. - Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
  106. - Fix mix space/tab in spec file
  107. - Added missing keyword Default-Stop
  108. * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  110. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
  111. - Bump version for tagging mistake
  112. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
  113. -Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
  114. * Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
  115. - Upgraded to 1.2.4
  116. - Merged spec file with upstream
  117. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  119. * Thu Oct 9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
  120. - Updated to new upstream release
  121. * Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
  122. - fix license tag
  123. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
  124. - Autorebuild for GCC 4.3
  125. * Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
  126. - Upgraded to new release upstream
  127. - Removed l2tpd to xl2tpd migration in post
  128. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
  129. - Rebuild for selinux ppc32 issue.
  130. * Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
  131. - Upgraded to 1.1.11
  132. - Include new split README.*
  133. * Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
  134. - Upgraded to 1.1.09
  135. * Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
  136. - Bump for EVR
  137. * Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
  138. - Upgraded to 1.1.08
  139. - This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
  140. * Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
  141. - Fixed version usage in source macro
  142. * Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
  143. - Upgraded to 1.1.07
  144. - Added /var/run/xl2tpd to the spec file so this pacakge
  145. owns /var/run/xl2tpd
  146. * Thu Dec 7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
  147. - Changed space/tab replacing method
  148. * Wed Dec 6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
  149. - Added -p to keep original timestamps
  150. - Added temporary hack to change space/tab in init file.
  151. - Added /sbin/service dependancy
  152. * Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
  153. - Added Requires(post) / Requires(preun)
  154. - changed init file to create /var/run/xl2tpd fixed a tab/space
  155. - changed control file to be within /var/run/xl2tpd/
  156. * Tue Dec 5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
  157. - Changed Mr. Karlsen's name to not be a utf8 problem
  158. - Fixed Obosoletes/Provides to be more specific wrt l2tpd.
  159. - Added dist tag which accidentally got deleted.
  160. * Mon Dec 4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
  161. - Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
  162. * Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
  163. - Pulled up sourceforget.net CVS fixes.
  164. - various debugging added, but debugging should not be on by default.
  165. - async/sync conversion routines must be ready for possibility that the read
  166. will block due to routing loops.
  167. - refactor control socket handling.
  168. - move all logic about pty usage to pty.c. Try ptmx first, if it fails try
  169. legacy ptys
  170. - rename log() to l2tp_log(), as "log" is a math function.
  171. - if we aren't deamonized, then log to stderr.
  172. - added install: and DESTDIR support.
  173. * Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
  174. - Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
  175. * Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
  176. - Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
  177. * Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
  178. - l2tpd.org has been hijacked. Project moved back to SourceForge:
  179. http://l2tpd.sourceforge.net
  180. * Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
  181. - Small Makefile fixes. Explicitly use gcc instead of cc.
  182. Network services library was not linked on Solaris due to typo.
  183. * Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
  184. - Choosing between SysV or BSD style ptys is now configurable through
  185. a compile-time boolean "unix98pty".
  186. * Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
  187. - Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
  188. Requires the N_HDLC kernel module.
  189. * Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
  190. - Updated the README.
  191. * Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
  192. - Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
  193. (http://l2tpd.graffl.net/msg01790.html)
  194. Long overdue. Rereleasing 10jdl.
  195. * Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
  196. - [SECURITY FIX] Added fix from Debian because of a bss-based
  197. buffer overflow.
  198. (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
  199. - Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
  200. directories /etc/{freeswan,openswan,strongswan}. Install our
  201. configuration files to /etc/ipsec.d and create symbolic links in
  202. those directories.
  203. * Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
  204. - Removed 'leftnexthop=' lines. Not relevant for recent versions
  205. of FreeS/WAN and derivates.
  206. * Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-9jdl
  207. - Added "noccp" because of too much MPPE/CCP messages sometimes.
  208. * Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
  209. - Added patch in order to prevent StopCCN messages.
  210. * Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
  211. - MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
  212. For Windows 2000/XP it doesn't seem to matter.
  213. - Typo in l2tpd.conf (192.168.128/25).
  214. * Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-8jdl
  215. - Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
  216. value but some apps had problems with the default value.
  217. * Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
  218. - Added workaround for the missing hostname bug in the MSL2TP client
  219. ('Specify your hostname', error 629: "You have been disconnected
  220. from the computer you are dialing").
  221. * Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-7jdl
  222. - Added the "listen-addr" global parameter for l2tpd.conf. By
  223. default, the daemon listens on *all* interfaces. Use
  224. "listen-addr" if you want it to bind to one specific
  225. IP address (interface), for security reasons. (See also:
  226. http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
  227. - Explained in l2tpd.conf that two different IP addresses should be
  228. used for 'listen-addr' and 'local ip'.
  229. - Modified init script. Upgrades should work better now. You
  230. still need to start/chkconfig l2tpd manually.
  231. - Renamed the example Openswan .conf files to better reflect
  232. the situation. There are two variants using different portselectors.
  233. Previously I thought Windows 2000/XP used portselector 17/0
  234. and the rest used 17/1701. But with the release of an updated
  235. IPsec client by Microsoft, it turns out that 17/0 must have
  236. been a mistake: the updated client now also uses 17/1701.
  237. * Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-6jdl
  238. - Changed sample chap-secrets to be valid only for specific
  239. IP addresses.
  240. * Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
  241. - Adjustments for SuSE8.x (thanks, Bernhard!)
  242. - Added sample chap-secrets.
  243. * Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
  244. - Replaced Dominique's patch by Damion de Soto's, which does not
  245. depend on the N_HDLC kernel module.
  246. * Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
  247. - Seperate example config files for Win9x (MSL2TP) and Win2K/XP
  248. due to left/rightprotoport differences.
  249. Fixing preun for Red Hat.
  250. * Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
  251. - Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
  252. Error fixed: source6 was used for both PSK and CERT.
  253. * Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
  254. - Added Dominique Cressatti's pty patch in another attempt to
  255. prevent the Windows 2000 Professional "loopback detected" error.
  256. Seems to work!
  257. * Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
  258. - Added 'connect-delay' to PPP parameters in an attempt to
  259. prevent the Windows 2000 Professional "loopback detected" error.
  260. Didn't seem to work.
  261. * Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
  262. - Did not build on Red Hat 8.0. Solved by adding comments(?!).
  263. Bug detected in spec file: chkconfig --list l2tpd does not work
  264. on Red Hat 8.0. Not important enough to look into yet.
  265. * Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
  266. - Tested on Red Hat, required some changes. No gprintf. Used different
  267. pty patch, otherwise wouldn't run. Added buildroot sanity check.
  268. * Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
  269. - Specfile adapted from Mandrake Cooker. The original RPM can be
  270. retrieved through:
  271. http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
  272. - Config path changed from /etc/l2tp/ to /etc/l2tpd/
  273. (Seems more logical and rp-l2tp already uses /etc/l2tp/).
  274. - Do not run at boot or install. The original RPM uses a config file
  275. which is completely commented out, but it still starts l2tpd on all
  276. interfaces. Could be a security risk. This RPM does not start l2tpd,
  277. the sysadmin has to edit the config file and start l2tpd explicitly.
  278. - Renamed patches to start with l2tpd-
  279. - Added dependencies for pppd, glibc-devel.
  280. - Use %%{name} as much as possible.
  281. - l2tp-secrets contains passwords, thus should not be world readable.
  282. - Removed dependency on rpm-helper.
  283. * Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
  284. - from Per 0yvind Karlsen <peroyvind@delonic.no> :
  285. - PreReq and Requires
  286. - Fix preun_service
  287. * Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
  288. - Move l2tpd from /usr/bin to /usr/sbin
  289. - Added SysV initscript
  290. - Patch0
  291. - Patch1
  292. * Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
  293. - Initial release