GeoIP-vl.spec 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188
  1. %define geoipupadte_ver 2.0.0
  2. Name: GeoIP
  3. Version: 1.6.0
  4. Release: 1%{?_dist_release}
  5. Summary: C library for country/city/organization to IP address or hostname mapping
  6. Group: Development/Libraries
  7. License: GPLv2+ and LGPLv2+
  8. URL: http://www.maxmind.com/app/c
  9. Source0: https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/GeoIP-%{version}.tar.gz
  10. Source1: https://github.com/maxmind/geoipupdate/releases/download/v%{geoipupadte_ver}/geoipupdate-%{geoipupadte_ver}.tar.gz
  11. Source2: LICENSE.txt
  12. Source3: fetch-geoipdata-city.pl
  13. Source4: fetch-geoipdata.pl
  14. Source5: README.Fedora
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  16. Obsoletes: geoip < %{version}-%{release}
  17. Provides: geoip = %{version}-%{release}
  18. BuildRequires: curl-devel, zlib-devel
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. Packager: tomop
  22. %description
  23. GeoIP is a C library that enables the user to find the country that any IP
  24. address or hostname originates from. It uses a file based database that is
  25. accurate as of March 2003. This database simply contains IP blocks as keys, and
  26. countries as values. This database should be more complete and accurate than
  27. using reverse DNS lookups.
  28. %package devel
  29. Summary: Development headers and libraries for GeoIP
  30. Group: Development/Libraries
  31. Requires: %{name} = %{version}-%{release}
  32. Provides: geoip-devel = %{version}-%{release}
  33. Obsoletes: geoip-devel < %{version}-%{release}
  34. %description devel
  35. Development headers and libraries for building GeoIP-based applications
  36. %prep
  37. %setup -q -a 1
  38. install -D -m644 %{SOURCE2} LICENSE.txt
  39. install -D -m644 %{SOURCE3} fetch-geoipdata-city.pl
  40. install -D -m644 %{SOURCE4} fetch-geoipdata.pl
  41. install -D -m644 %{SOURCE5} README.fedora
  42. %build
  43. autoreconf -ivf
  44. %configure --disable-static --disable-dependency-tracking
  45. make %{?_smp_mflags}
  46. pushd geoipupdate-%{geoipupadte_ver}
  47. ./bootstrap
  48. %configure
  49. make %{?_smp_mflags}
  50. popd
  51. %install
  52. rm -rf %{buildroot}
  53. make DESTDIR=%{buildroot} install
  54. # nix the stuff we don't need like .la files.
  55. rm -f %{buildroot}%{_libdir}/*.la
  56. mkdir -p %{buildroot}%{_datadir}/GeoIP
  57. pushd geoipupdate-%{geoipupadte_ver}
  58. make DESTDIR=%{buildroot} install
  59. popd
  60. mkdir -p geoipupdate
  61. cp -f geoipupdate-%{geoipupadte_ver}/{ChangeLog.md,LICENSE,README.md} ./geoipupdate/
  62. %clean
  63. rm -rf %{buildroot}
  64. %post -p /sbin/ldconfig
  65. %postun -p /sbin/ldconfig
  66. %files
  67. %defattr(-,root,root,-)
  68. %doc AUTHORS COPYING ChangeLog README.* TODO INSTALL LICENSE* fetch-* geoipupdate
  69. %{_libdir}/libGeoIP.so.*
  70. %{_bindir}/geoiplookup6
  71. %{_bindir}/geoiplookup
  72. %{_bindir}/geoipupdate
  73. %config(noreplace) %{_sysconfdir}/GeoIP.conf.default
  74. %config(noreplace) %{_sysconfdir}/GeoIP.conf
  75. %{_datadir}/GeoIP
  76. %{_mandir}/man1/geoiplookup.1*
  77. %{_mandir}/man1/geoiplookup6.1*
  78. %{_mandir}/man1/geoipupdate.1*
  79. %files devel
  80. %defattr(-,root,root,-)
  81. %{_libdir}/pkgconfig/geoip.pc
  82. %{_includedir}/GeoIP.h
  83. %{_includedir}/GeoIPCity.h
  84. %{_libdir}/libGeoIP.so
  85. %changelog
  86. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.0-1
  87. - new upstream release.
  88. * Mon Oct 08 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-3
  89. - initial build for Vine Linux.
  90. * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2.1
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  92. * Tue Sep 6 2011 Michael Fleming <mfleming+rpm@thatfleminggent.com> - 1.4.8-1.1
  93. - Remove -ipv6 path
  94. - Bump to 1.4.8 release
  95. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-0.2.20090931cvs
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  97. * Mon Aug 31 2009 Matt Domsch <mdomsch@fedoraproject.org> - 1.4.7.0.1.20090931
  98. - apply CVS HEAD 20090931 which includes IPv6 functions
  99. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-2
  100. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  101. * Sun Mar 08 2009 Michael Fleming <mfleming+rpm@enlartenment.com> - 1.4.6-1
  102. - Add geoiplookup6 man page
  103. - Update to 1.4.6
  104. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-3
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  106. * Sat Nov 29 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.5-2
  107. - Update to 1.4.5
  108. - Fix database URL locations in Perl helper scripts
  109. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-2
  110. - Autorebuild for GCC 4.3
  111. * Mon Jan 28 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.4-1
  112. - New upstream release.
  113. * Wed Sep 5 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.3-1
  114. - New upstream release.
  115. - Fix GeoIPCity fetcher script
  116. - Update License tag
  117. * Mon Feb 12 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.2-1
  118. - New upstream release.
  119. * Mon Jan 8 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-2
  120. - License is actually LGPL now.
  121. * Sun Jan 7 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-1
  122. - New upstream release
  123. - Add fetch-geoipdata* scripts to pull free databases automatically if
  124. desired (bz #198137)
  125. - README.fedora added to briefly explain above.
  126. * Mon Nov 27 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-4
  127. - Fix %%install scripts to satisfy newer mock builds
  128. * Sun Sep 3 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-3
  129. - Upstream upgrade
  130. - Added LICENSE.txt file to %%doc, covering GeoIP country/city data license
  131. (bz #198137)
  132. * Mon May 15 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.17-1
  133. - New upstream release (minor fixes)
  134. * Mon May 1 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.16-1
  135. - New upstream release
  136. - Add INSTALL document to package.
  137. * Sat Feb 18 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-3
  138. - Fix Obsoletes/Provides for old "geoip"-convention packages
  139. - Move .so symlinks to -devel where they should be
  140. * Fri Feb 10 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-2
  141. - Remamed to match upstream tarball name
  142. - Removed static libraries
  143. - Added symlinks to packages
  144. - Mark config file noreplace
  145. * Sun Feb 5 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-1
  146. - Initial review package for Extras