google-gadgets-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280
  1. #define svnrev 1449
  2. #define alphatag 20090430svn%{svnrev}
  3. Name: google-gadgets
  4. Summary: Google Gadgets platform for Linux
  5. Version: 0.11.2
  6. Release: 1%{?_dist_release}
  7. Group: User Interface/Desktops
  8. License: ASL 2.0
  9. URL: http://code.google.com/p/google-gadgets-for-linux/
  10. Source0: http://google-gadgets-for-linux.googlecode.com/files/google-gadgets-for-linux-%{version}.tar.bz2
  11. #Source0: %{name}-%{version}-r%{svnrev}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: curl-devel libxml2-devel zlib-devel libtool-ltdl-devel
  14. # still needed even if we're not buliding gtkmoz element, for JavaScript
  15. %if %{?_dist_release} == "vl5"
  16. BuildRequires: xulrunner-devel-unstable
  17. %else
  18. BuildRequires: xulrunner-devel
  19. %endif
  20. BuildRequires: WebKit-gtk-devel
  21. BuildRequires: dbus-devel gstreamer-devel gstreamer-plugins-base-devel
  22. BuildRequires: cairo-devel gtk2-devel librsvg2-devel
  23. BuildRequires: qt4-devel zip
  24. # Desktop integration
  25. BuildRequires: NetworkManager-devel startup-notification-devel
  26. # libxml2-devel needed for desktop file generation
  27. BuildRequires: libxml2-devel desktop-file-utils
  28. BuildRequires: pkgconfig
  29. Requires: %{name}-frontend = %{version}-%{release}
  30. Requires: hicolor-icon-theme
  31. %description
  32. Google Gadgets for Linux provides a platform for running desktop
  33. gadgets under Linux, catering to the unique needs of Linux users. It
  34. can run, without modification, many Google Desktop gadgets as well as
  35. the Universal Gadgets on iGoogle.
  36. %package gtk
  37. Summary: GTK+ front-end for %{name}
  38. Summary(ja): Google Gadgets の GTK+ 版フロントエンド
  39. Group: User Interface/Desktops
  40. Requires: %{name} = %{version}-%{release}
  41. Provides: %{name}-frontend = %{version}-%{release}
  42. %description gtk
  43. The %{name}-gtk package contains the GTK+ front-end for %{name}.
  44. %package qt
  45. Summary: Qt front-end for %{name}
  46. Summary(ja): Google Gadgets の Qt 版フロントエンド
  47. Group: User Interface/Desktops
  48. Requires: %{name} = %{version}-%{release}
  49. Provides: %{name}-frontend = %{version}-%{release}
  50. %description qt
  51. The %{name}-qt package contains the Qt front-end for %{name}.
  52. %package devel
  53. Summary: Development files for %{name}
  54. Summary(ja): %{name} の開発用ファイル
  55. Group: Development/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. Requires: pkgconfig dbus-devel gtk2-devel qt4-devel
  58. Requires: %{name}-gtk
  59. Requires: %{name}-qt
  60. %description devel
  61. The %{name}-devel package contains libraries and header files for
  62. developing applications that use %{name}.
  63. %prep
  64. %setup -q -n %{name}-for-linux-%{version}
  65. # Permission fixes
  66. chmod -x ggadget/qt/utilities.h
  67. # Fix invalid desktop file MIME type
  68. # http://code.google.com/p/google-gadgets-for-linux/issues/detail?id=360
  69. for f in hosts/*/ggl-*.desktop.in; do
  70. sed -i 's|;app/gg;|;|' $f
  71. done
  72. %build
  73. #autotools/bootstrap.sh
  74. #ln -s %{_datadir}/automake-*/mkinstalldirs libltdl/
  75. %configure --disable-static \
  76. --with-browser-plugins-dir=%{_libdir}/mozilla/plugins
  77. # Rpath fix by Mamoru Tasaka
  78. # we don't want to obliterate all RPATHs, since it is used during build
  79. # Add library search path
  80. sed -i.libdir_syssearch -e \
  81. '/sys_lib_dlsearch_path_spec/s|/usr/lib |/usr/lib /usr/lib64 /lib /lib64 |' \
  82. configure
  83. # Remove the redundant RPATH for %%{_libdir}, already searched by Fedora libtool
  84. sed -i.extra_R -e \
  85. 's|-R\$(libdir)||' \
  86. hosts/*/Makefile.in
  87. # default compile flags are impossibly strict
  88. make %{?_smp_mflags} DEFAULT_COMPILE_FLAGS=
  89. # Remove quotes from .pc files
  90. find . -name '*.pc' -exec sed -i 's|\"||g' '{}' \;
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT \
  94. INSTALL="install -p" CPPROG="cp -p"
  95. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  96. # reinstall desktop files
  97. for i in gtk qt; do
  98. desktop-file-install \
  99. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  100. --delete-original \
  101. $RPM_BUILD_ROOT%{_datadir}/applications/ggl-$i.desktop
  102. done
  103. # wipe prematurely-generated MIME info
  104. rm -rf $RPM_BUILD_ROOT%{_datadir}/mime
  105. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/mimeinfo.cache
  106. %clean
  107. rm -rf $RPM_BUILD_ROOT
  108. %post
  109. /sbin/ldconfig
  110. touch --no-create %{_datadir}/icons/hicolor || :
  111. %postun
  112. /sbin/ldconfig
  113. if [ $1 -eq 0 ] ; then
  114. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  115. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  116. fi
  117. %posttrans
  118. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  119. %post gtk
  120. /sbin/ldconfig
  121. update-desktop-database &> /dev/null || :
  122. %postun gtk
  123. /sbin/ldconfig
  124. update-desktop-database &> /dev/null || :
  125. %post qt
  126. /sbin/ldconfig
  127. update-desktop-database &> /dev/null || :
  128. %postun qt
  129. /sbin/ldconfig
  130. update-desktop-database &> /dev/null || :
  131. %files
  132. %defattr(-,root,root,-)
  133. %doc AUTHORS COPYING README
  134. %{_libdir}/google-gadgets
  135. %exclude %{_libdir}/google-gadgets/gtkmoz-browser-child
  136. %exclude %{_libdir}/google-gadgets/modules/gtk*.so
  137. %exclude %{_libdir}/google-gadgets/modules/qt*.so
  138. %exclude %{_libdir}/google-gadgets/include
  139. %{_libdir}/lib*.so.*
  140. %exclude %{_libdir}/lib*gtk*
  141. %exclude %{_libdir}/lib*qt*
  142. %{_datadir}/google-gadgets
  143. %{_datadir}/pixmaps/google-gadgets.png
  144. %{_datadir}/icons/hicolor/*/*/*.png
  145. %files gtk
  146. %defattr(-,root,root,-)
  147. %{_bindir}/ggl-gtk
  148. %{_libdir}/libggadget-gtk*.so.*
  149. %{_libdir}/google-gadgets/gtkmoz-browser-child
  150. %{_libdir}/google-gadgets/modules/gtk*.so
  151. %{_datadir}/applications/*gtk.desktop
  152. %{_datadir}/applications/*designer.desktop
  153. %files qt
  154. %defattr(-,root,root,-)
  155. %{_bindir}/ggl-qt
  156. %{_libdir}/libggadget-qt*.so.*
  157. %{_libdir}/google-gadgets/modules/qt*.so
  158. %{_datadir}/applications/*qt.desktop
  159. %files devel
  160. %defattr(-,root,root,-)
  161. %{_includedir}/google-gadgets
  162. %{_libdir}/lib*.so
  163. %{_libdir}/google-gadgets/include
  164. %{_libdir}/pkgconfig/*.pc
  165. %changelog
  166. * Thu Sep 30 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.2-1
  167. - new upstream release
  168. - built with rpm-4.8.1 for pkg-config
  169. - dropt Patch0
  170. - added BR: WebKit-gtk-devel
  171. - removed invalid MIME entry from .desktop files
  172. * Sat Oct 24 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.1-1
  173. - new upstream release
  174. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.11.0-2
  175. - Initial build for Vine Linux
  176. * Wed Jul 1 2009 Michel Salim <michel@erdos.localdomain> - 0.11.0-1
  177. - Update to 0.11.0
  178. * Sat May 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.10.6-0.1.20090430svn1449%{?dist}
  179. - Update to SVN checkout, for xulrunner 1.9.1 compatibility
  180. * Mon Apr 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-6
  181. - Rebuild against newer gecko
  182. * Fri Mar 27 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-4
  183. - Rebuild against newer gecko
  184. * Fri Mar 06 2009 Jan Horak <jhorak@redhat.com> - 0.10.5-3
  185. - Rebuild against newer gecko
  186. * Wed Feb 04 2009 Christopher Aillon <caillon@redhat.com> - 0.10.5-2
  187. - Rebuild against newer gecko
  188. * Wed Jan 14 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.10.5-1
  189. - 0.10.5, req'd by kde
  190. * Tue Dec 30 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.4-2
  191. - BR: Network-Manager-devel, startup-notification-devel
  192. - Pass the browser plugin directory to ./configure
  193. - Move designer desktop entry to -gtk subpackage
  194. * Sat Dec 20 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.4-1
  195. - Update to 0.10.4 (#477251)
  196. - -devel: Requires: %%name-gtk %%name-qt (devel symlinks)
  197. - BR: pkgconfig (automatic pkgconfig deps)
  198. * Sun Nov 23 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.3-1
  199. - Update to 0.10.3
  200. * Sat Nov 8 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.10.1-5
  201. - s/qt-devel/qt4-devel/
  202. - -qt: fix summary
  203. * Tue Sep 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-4
  204. - Unquote version strings in .pc files
  205. * Thu Aug 28 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-3
  206. - RPATH and timestamp fixes from Mamoru Tasaka
  207. * Tue Aug 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-2
  208. - Fix desktop file creation
  209. * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.1-1
  210. - Update to 0.10.1
  211. * Mon Jul 14 2008 Michel Salim <salimma@fedoraproject.org> - 0.10.0-1
  212. - Update to 0.10.0
  213. - Add missing dependencies for -devel subpackage
  214. * Sun Jul 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.3-1
  215. - Update to 0.9.3
  216. * Fri Jun 6 2008 Michel Salim <salimma@fedoraproject.org> - 0.9.1-1
  217. - Initial package