audit-vl.spec 28 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782
  1. %bcond_with systemd
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define _unpackaged_files_terminate_build 1
  4. Summary: User space tools for kernel auditing
  5. Name: audit
  6. Version: 3.1.2
  7. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  8. License: GPLv2+
  9. Group: system,admin-tools
  10. Distribution: Vine Linux
  11. Vendor: Project Vine
  12. URL: https://people.redhat.com/sgrubb/audit/
  13. Source0: https://github.com/linux-audit/audit-userspace/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. Patch1: audit-3.0.8-flex-array-workaround.patch
  15. Patch2: audit-3.0.8-undo-flex-array.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. BuildRequires: gettext intltool libtool swig
  18. BuildRequires: python-devel python-rpm-macros
  19. BuildRequires: python3-devel python3-rpm-macros
  20. BuildRequires: openldap-devel
  21. BuildRequires: krb5-devel
  22. BuildRequires: kernel-headers >= 2.6.18
  23. BuildRequires: libcap-ng-devel
  24. BuildRequires: automake >= 1.9
  25. BuildRequires: autoconf >= 2.59
  26. %if %{with systemd}
  27. %{?systemd_requires}
  28. %else
  29. Requires(post): /sbin/chkconfig
  30. Requires(preun): /sbin/chkconfig
  31. Requires(preun): /sbin/service
  32. Requires(postun): /sbin/service
  33. %endif
  34. Requires: %{name}-libs = %{version}-%{release}
  35. Requires(pre): coreutils
  36. %description
  37. The audit package contains the user space utilities for
  38. storing and searching the audit records generate by
  39. the audit subsystem in the Linux kernel.
  40. %package libs
  41. Summary: Dynamic library for libaudit
  42. License: LGPLv2+
  43. Group: system
  44. %description libs
  45. The audit-libs package contains the dynamic libraries needed for
  46. applications to use the audit framework.
  47. %package libs-devel
  48. Summary: Header files and static library for libaudit
  49. License: LGPLv2+
  50. Group: programming
  51. Requires: %{name}-libs = %{version}-%{release}
  52. Requires: kernel-headers >= 2.6.18
  53. %description libs-devel
  54. The audit-libs-devel package contains the static libraries and header
  55. files needed for developing applications that need to use the audit
  56. framework libraries.
  57. %package libs-python
  58. Summary: Python2 bindings for libaudit
  59. License: LGPLv2+
  60. Group: programming
  61. Requires: %{name}-libs = %{version}-%{release}
  62. %description libs-python
  63. The audit-libs-python package contains the bindings so that libaudit
  64. and libauparse can be used by python2.
  65. %package libs-python3
  66. Summary: Python3 bindings for libaudit
  67. License: LGPLv2+
  68. Group: programming
  69. Provides: python-audit = %{version}-%{release}
  70. Requires: %{name}-libs = %{version}-%{release}
  71. %description libs-python3
  72. The audit-libs-python3 package contains the bindings so that libaudit
  73. and libauparse can be used by python3.
  74. %package -n audispd-plugins
  75. Summary: Plugins for the audit event dispatcher
  76. Group: system
  77. License: GPLv2+
  78. Provides: python3-audit = %{version}-%{release}
  79. Requires: %{name} = %{version}-%{release}
  80. Requires: %{name}-libs = %{version}-%{release}
  81. %description -n audispd-plugins
  82. The audispd-plugins package provides plugins for the real-time
  83. interface to the audit system, audispd. These plugins can do things
  84. like relay events to remote machines or analyze events for suspicious
  85. behavior.
  86. %package -n audispd-plugins-zos
  87. Summary: z/OS plugin for the audit event dispatcher
  88. Group: system
  89. License: GPLv2+
  90. Requires: %{name}%{?_isa} = %{version}-%{release}
  91. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  92. Requires: openldap
  93. %description -n audispd-plugins-zos
  94. The audispd-plugins-zos package provides a plugin that will forward all
  95. incoming audit events, as they happen, to a configured z/OS SMF (Service
  96. Management Facility) database, through an IBM Tivoli Directory Server
  97. (ITDS) set for Remote Audit service.
  98. %package -n compat32-%{name}-libs
  99. Summary: Dynamic library for libaudit
  100. License: LGPLv2+
  101. Group: system,legacy
  102. %description -n compat32-%{name}-libs
  103. The audit-libs package contains the dynamic libraries needed for
  104. applications to use the audit framework.
  105. %debug_package
  106. %prep
  107. %setup -q -n audit-userspace-%{version}
  108. cp /usr/include/linux/audit.h lib/
  109. %patch1 -p1
  110. autoreconf -vif
  111. # Remove the ids code, its not ready
  112. sed -i 's/ ids / /' audisp/plugins/Makefile.am
  113. sed -i 's/ ids / /' audisp/plugins/Makefile.in
  114. %build
  115. %configure --sbindir=/sbin --libdir=/%{_lib} \
  116. --with-python=yes --with-python3=yes \
  117. --with-libcap-ng=yes --enable-gssapi-krb5=yes \
  118. --enable-zos-remote \
  119. --enable-experimental \
  120. %if %{with systemd}
  121. --enable-systemd
  122. %else
  123. %{nil}
  124. %endif
  125. make CFLAGS="%{optflags}" %{?_smp_mflags}
  126. %install
  127. rm -rf $RPM_BUILD_ROOT
  128. mkdir -p $RPM_BUILD_ROOT/{sbin,etc/{sysconfig,audit/plugins.d,rc.d/init.d,audit/rules.d}}
  129. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/{man5,man8}
  130. mkdir -p $RPM_BUILD_ROOT/%{_lib}
  131. mkdir -p $RPM_BUILD_ROOT/%{_libdir}/audit
  132. mkdir -p --mode=0700 $RPM_BUILD_ROOT/%{_var}/log/audit
  133. mkdir -p $RPM_BUILD_ROOT/%{_var}/spool/audit
  134. make DESTDIR=$RPM_BUILD_ROOT install
  135. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  136. # This winds up in the wrong place when libtool is involved
  137. mv $RPM_BUILD_ROOT/%{_lib}/libaudit.a $RPM_BUILD_ROOT%{_libdir}
  138. mv $RPM_BUILD_ROOT/%{_lib}/libauparse.a $RPM_BUILD_ROOT%{_libdir}
  139. curdir=`pwd`
  140. cd $RPM_BUILD_ROOT/%{_libdir}
  141. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libaudit.so.*.*.*\``
  142. ln -s ../../%{_lib}/$LIBNAME libaudit.so
  143. LIBNAME=`basename \`ls $RPM_BUILD_ROOT/%{_lib}/libauparse.so.*.*.*\``
  144. ln -s ../../%{_lib}/$LIBNAME libauparse.so
  145. cd $curdir
  146. # Remove these items so they don't get picked up.
  147. rm -f $RPM_BUILD_ROOT/%{_lib}/libaudit.so
  148. rm -f $RPM_BUILD_ROOT/%{_lib}/libauparse.so
  149. find $RPM_BUILD_ROOT -name '*.la' -delete
  150. find $RPM_BUILD_ROOT/%{_libdir}/python?.?/site-packages -name '*.a' -delete
  151. # Move the pkgconfig file
  152. mv $RPM_BUILD_ROOT/%{_lib}/pkgconfig $RPM_BUILD_ROOT%{_libdir}
  153. # On platforms with 32 & 64 bit libs, we need to coordinate the timestamp
  154. touch -r ./audit.spec $RPM_BUILD_ROOT/etc/libaudit.conf
  155. touch -r ./audit.spec $RPM_BUILD_ROOT/usr/share/man/man5/libaudit.conf.5.gz
  156. # undo the workaround
  157. cur=`pwd`
  158. cd $RPM_BUILD_ROOT
  159. patch -p0 < %{PATCH2}
  160. find . -name '*.orig' -delete
  161. cd $cur
  162. %if %{with systemd}
  163. rm -rf %{buildroot}%{_libexecdir}/initscripts
  164. rm -f %{buildroot}%{_libexecdir}/audit-functions
  165. %endif
  166. %check
  167. make check
  168. # Get rid of make files so that they don't get packaged.
  169. rm -f rules/Makefile*
  170. %clean
  171. rm -rf $RPM_BUILD_ROOT
  172. rm -rf zos-remote-policy
  173. %post
  174. # This is to migrate users from audit-1.0.x installations
  175. if [ -f /etc/auditd.conf ]; then
  176. mv /etc/auditd.conf /etc/audit/auditd.conf
  177. fi
  178. if [ -f /etc/audit.rules ]; then
  179. mv /etc/audit.rules /etc/audit/audit.rules
  180. fi
  181. # This is to enable the dispatcher option which was commented out
  182. if [ -f /etc/audit/auditd.conf ]; then
  183. grep '^dispatcher' /etc/audit/auditd.conf >/dev/null
  184. if [ $? -eq 1 ] ; then
  185. tmp=`mktemp /etc/audit/auditd-post.XXXXXX`
  186. if [ -n $tmp ]; then
  187. sed 's|^#dispatcher|dispatcher|g' /etc/audit/auditd.conf > $tmp && \
  188. cat $tmp > /etc/audit/auditd.conf
  189. rm -f $tmp
  190. fi
  191. fi
  192. fi
  193. # Copy default rules into place on new installation
  194. files=`ls /etc/audit/rules.d/ 2>/dev/null | wc -w`
  195. if [ "$files" -eq 0 ] ; then
  196. # FESCO asked for audit to be off by default. #1117953
  197. if [ -e %{_datadir}/%{name}/sample-rules/10-no-audit.rules ] ; then
  198. cp %{_datadir}/%{name}/sample-rules/10-no-audit.rules /etc/audit/rules.d/audit.rules
  199. else
  200. touch /etc/audit/rules.d/audit.rules
  201. fi
  202. chmod 0600 /etc/audit/rules.d/audit.rules
  203. fi
  204. %if %{with systemd}
  205. %systemd_post auditd.service
  206. %else
  207. /sbin/chkconfig --add auditd
  208. %endif
  209. %preun
  210. %if %{with systemd}
  211. %systemd_preun auditd.service
  212. %else
  213. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  214. /sbin/service auditd stop > /dev/null 2>&1
  215. /sbin/chkconfig --del auditd
  216. fi
  217. %endif
  218. %postun
  219. %if %{with systemd}
  220. %systemd_postun_with_restart auditd.service
  221. %else
  222. if [ $1 -ge 1 ]; then
  223. /sbin/service auditd condrestart > /dev/null 2>&1 || :
  224. fi
  225. %endif
  226. %files libs
  227. %defattr(-,root,root)
  228. %{!?_licensedir:%global license %%doc}
  229. %license COPYING.LIB
  230. /%{_lib}/libaudit.*
  231. /%{_lib}/libauparse.*
  232. %config(noreplace) %attr(640,root,root) /etc/libaudit.conf
  233. %{_mandir}/man5/libaudit.conf.5.gz
  234. %files libs-devel
  235. %defattr(-,root,root)
  236. %{!?_licensedir:%global license %%doc}
  237. %license COPYING.LIB
  238. %doc contrib/skeleton.c contrib/plugin
  239. %{_libdir}/libaudit.a
  240. %{_libdir}/libauparse.a
  241. %{_libdir}/libaudit.so
  242. %{_libdir}/libauparse.so
  243. %{_includedir}/libaudit.h
  244. %{_includedir}/auparse.h
  245. %{_includedir}/auparse-defs.h
  246. %{_datadir}/aclocal/audit.m4
  247. %{_libdir}/pkgconfig/audit.pc
  248. %{_libdir}/pkgconfig/auparse.pc
  249. %{_mandir}/man3/*
  250. %files libs-python
  251. %defattr(-,root,root)
  252. %attr(755,root,root) %{python_sitearch}/_audit.so
  253. %attr(755,root,root) %{python_sitearch}/auparse.so
  254. %{python_sitearch}/audit.py*
  255. %files libs-python3
  256. %defattr(-,root,root,-)
  257. %attr(755,root,root) %{python3_sitearch}/*
  258. %files
  259. %defattr(-,root,root,-)
  260. %doc README ChangeLog rules init.d/auditd.cron
  261. %{!?_licensedir:%global license %%doc}
  262. %license COPYING
  263. %dir %{_datadir}/%{name}
  264. %dir %{_datadir}/%{name}/sample-rules
  265. %attr(644,root,root) %{_datadir}/%{name}/sample-rules/*
  266. %attr(644,root,root) %{_mandir}/man8/auditctl.8.gz
  267. %attr(644,root,root) %{_mandir}/man8/auditd.8.gz
  268. %attr(644,root,root) %{_mandir}/man8/aureport.8.gz
  269. %attr(644,root,root) %{_mandir}/man8/ausearch.8.gz
  270. %attr(644,root,root) %{_mandir}/man8/autrace.8.gz
  271. %attr(644,root,root) %{_mandir}/man8/aulast.8.gz
  272. %attr(644,root,root) %{_mandir}/man8/aulastlog.8.gz
  273. %attr(644,root,root) %{_mandir}/man8/auvirt.8.gz
  274. %attr(644,root,root) %{_mandir}/man8/augenrules.8.gz
  275. %attr(644,root,root) %{_mandir}/man8/ausyscall.8.gz
  276. %attr(644,root,root) %{_mandir}/man7/audit.rules.7.gz
  277. %attr(644,root,root) %{_mandir}/man5/auditd.conf.5.gz
  278. %attr(644,root,root) %{_mandir}/man5/ausearch-expression.5.gz
  279. %attr(644,root,root) %{_mandir}/man5/auditd-plugins.5.gz
  280. %attr(750,root,root) /sbin/auditctl
  281. %attr(750,root,root) /sbin/auditd
  282. %attr(755,root,root) /sbin/ausearch
  283. %attr(755,root,root) /sbin/aureport
  284. %attr(750,root,root) /sbin/autrace
  285. %attr(750,root,root) /sbin/augenrules
  286. %attr(750,root,root) %{_bindir}/aulastlog
  287. %attr(750,root,root) %{_bindir}/aulast
  288. %attr(755,root,root) %{_bindir}/ausyscall
  289. %attr(755,root,root) %{_bindir}/auvirt
  290. %attr(750,root,root) %dir %{_var}/log/audit
  291. %attr(750,root,root) %dir /etc/audit
  292. %attr(750,root,root) %dir /etc/audit/rules.d
  293. %attr(750,root,root) %dir /etc/audit/plugins.d
  294. %config(noreplace) %attr(640,root,root) /etc/audit/auditd.conf
  295. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/rules.d/audit.rules
  296. %ghost %config(noreplace) %attr(640,root,root) /etc/audit/audit.rules
  297. %config(noreplace) %attr(640,root,root) /etc/audit/audit-stop.rules
  298. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/af_unix.conf
  299. %if %{with systemd}
  300. %attr(644,root,root) %{_unitdir}/auditd.service
  301. %else
  302. %config(noreplace) %attr(640,root,root) /etc/sysconfig/auditd
  303. %attr(755,root,root) /etc/rc.d/init.d/auditd
  304. %endif
  305. %files -n audispd-plugins
  306. %defattr(-,root,root,-)
  307. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-remote.conf
  308. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-remote.conf
  309. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/syslog.conf
  310. %config(noreplace) %attr(640,root,root) /etc/audit/audisp-statsd.conf
  311. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/au-statsd.conf
  312. %attr(750,root,root) /sbin/audisp-af_unix
  313. %attr(750,root,root) /sbin/audisp-remote
  314. %attr(750,root,root) /sbin/audisp-syslog
  315. %attr(750,root,root) /sbin/audisp-statsd
  316. %attr(700,root,root) %dir %{_var}/spool/audit
  317. %attr(644,root,root) %{_mandir}/man5/audisp-remote.conf.5.gz
  318. %attr(644,root,root) %{_mandir}/man8/audisp-af_unix.8.gz
  319. %attr(644,root,root) %{_mandir}/man8/audisp-remote.8.gz
  320. %attr(644,root,root) %{_mandir}/man8/audisp-syslog.8.gz
  321. %attr(644,root,root) %{_mandir}/man8/audisp-statsd.8.gz
  322. %files -n audispd-plugins-zos
  323. %attr(644,root,root) %{_mandir}/man8/audispd-zos-remote.8.gz
  324. %attr(644,root,root) %{_mandir}/man5/zos-remote.conf.5.gz
  325. %config(noreplace) %attr(640,root,root) /etc/audit/plugins.d/audispd-zos-remote.conf
  326. %config(noreplace) %attr(640,root,root) /etc/audit/zos-remote.conf
  327. %attr(750,root,root) /sbin/audispd-zos-remote
  328. %if %{build_compat32}
  329. %files -n compat32-%{name}-libs
  330. %{!?_licensedir:%global license %%doc}
  331. %license COPYING.LIB
  332. %defattr(-,root,root)
  333. %attr(755,root,root) /%{_lib}/libaudit.*
  334. %attr(755,root,root) /%{_lib}/libauparse.*
  335. %endif
  336. %changelog
  337. * Tue Aug 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.2-1
  338. - new upstream release.
  339. * Wed May 03 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-2
  340. - imported Patch2 from rawhide.
  341. * Sat Apr 29 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
  342. - new upstream release.
  343. - imported Patch1 from rawhide.
  344. * Fri Feb 10 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1-1
  345. - new upstream release.
  346. * Tue Aug 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.9-1
  347. - new upstream release.
  348. * Wed Mar 30 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.8-1
  349. - new upstream release.
  350. * Mon Jan 24 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.7-1
  351. - new upstream release.
  352. * Sat Oct 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.6-1
  353. - new upstream release.
  354. * Wed Sep 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
  355. - new upstream release.
  356. - dropped Patch1.
  357. - dropped ldconfig scriptlets.
  358. * Fri Feb 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.1-1
  359. - new upstream release.
  360. - dropped Patch1.
  361. - imported Patch1 from rawhide.
  362. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.8.5-1
  363. - new upstream release.
  364. - imported Patch1 from rawhide.
  365. * Sat Sep 09 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.7.7-1
  366. - new upstream release.
  367. - dropped all patches.
  368. - dropped system-config-audit.
  369. - added python3 bindings.
  370. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-4
  371. - fix sca_release
  372. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-3
  373. - create compat32-audit-libs subpackage
  374. * Wed Feb 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.18-2
  375. - rebuild with python-2.7.2
  376. - add Patch12 (audit-1.7.18-libaudit.patch)
  377. * Sun Apr 03 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.18-1
  378. - new upstream release
  379. - rebuild with krb5-1.8.2
  380. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-6
  381. - forgot to increment sca_release macro (why on earth is sca_release
  382. individually defined from main package's release number anyway?)
  383. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-5
  384. - rebuilt with gcc-4.4.3-3 on ppc
  385. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.7.6-4
  386. - rebuilt with rpm-4.8.0-3 (on ppc)
  387. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.7.6-3
  388. - rebuild with python-2.6
  389. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-2
  390. - rebuild with openldap-2.4.11
  391. * Mon Sep 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  392. - initial build for Vine Linux
  393. - disable krb5, prelude and selinux
  394. - add ja.po (XXX: minimal)
  395. * Thu Sep 11 2008 Steve Grubb <sgrubb@redhat.com> 1.7.6-1
  396. - Add subject to audit daemon events (Chu Li)
  397. - Add tcp_wrappers support for auditd
  398. - Updated syscall tables for 2.6.27 kernel
  399. - Audit connect/disconnect of remote clients
  400. - Add GSS/Kerberos encryption to the remote protocol (DJ Delorie)
  401. * Mon Aug 25 2008 Steve Grubb <sgrubb@redhat.com> 1.7.5-1
  402. - Update system-config-audit to 0.4.8
  403. - Whole lot of bug fixes - see ChangeLog for details
  404. - Reimplement auditd main loop using libev
  405. - Add TCP listener to auditd to receive remote events
  406. - Fix scheduler problem (#457061)
  407. * Thu Jul 03 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-2
  408. - Move ausearch-expression to main package (#453437)
  409. * Mon May 19 2008 Steve Grubb <sgrubb@redhat.com> 1.7.4-1
  410. - Fix interpreting of keys in syscall records
  411. - Don't error on name=(null) PATH records in ausearch/report
  412. - Add key report to aureport
  413. - Update system-config-audit to 0.4.7 (Miloslav Trmac)
  414. - Add support for the filetype field option in auditctl new to 2.6.26 kernels
  415. * Fri May 09 2008 Steve Grubb <sgrubb@redhat.com> 1.7.3-1
  416. - Fix output of keys in ausearch interpretted mode
  417. - Fix ausearch/report --start now to not be reset to midnight
  418. - audispd now has a priority boost config option
  419. - Look for laddr in avcs reported via prelude
  420. - Detect page 0 mmaps and alert via prelude
  421. * Fri Apr 18 2008 Steve Grubb <sgrubb@redhat.com> 1.7.2-6
  422. - Fix overflow in audit_log_user_command, better (#438840)
  423. - ausearch was not matching path in avc records
  424. - audisp-prelude attempt to reposition index after examining each type
  425. - correct building of mls policy
  426. - Fix auparse iterating in auparse_find_field and next_field
  427. - Don't alert on USER_AVC's - they are not quite right
  428. * Tue Apr 08 2008 Steve Grubb <sgrubb@redhat.com> 1.7.1-1
  429. - Fix buffer overflow in audit_log_user_command, again (#438840)
  430. - Fix memory leak in EOE code in auditd (#440075)
  431. - In auditctl, don't use new operators in legacy rule format
  432. - Made a couple corrections in alpha & x86_64 syscall tables (Miloslav Trmac)
  433. * Fri Apr 04 2008 Steve Grubb <sgrubb@redhat.com> 1.7-3
  434. - Fix memleak in auditd eoe code
  435. * Tue Apr 01 2008 Steve Grubb <sgrubb@redhat.com> 1.7-2
  436. - Remove LSB headers from init scripts
  437. - Fix buffer overflow in audit_log_user_command again
  438. * Sun Mar 30 2008 Steve Grubb <sgrubb@redhat.com> 1.7-1
  439. - Handle user space avcs in prelude plugin
  440. - Fix watched account login detection for some failed login attempts
  441. - Couple fixups in audit logging functions (Miloslav Trmac)
  442. - Add support in auditctl for virtual keys
  443. - auparse_find_field_next was not iterating correctly, fixed it
  444. - Add idmef alerts for access or execution of watched file
  445. - Fix buffer overflow in audit_log_user_command
  446. - Add basic remote logging plugin - only sends & no flow control
  447. - Update ausearch with interpret fixes from auparse
  448. * Sun Mar 09 2008 Steve Grubb <sgrubb@redhat.com> 1.6.9-1
  449. - Apply hidden attribute cleanup patch (Miloslav Trmac)
  450. - Apply auparse expression interface patch (Miloslav Trmac)
  451. - Fix potential memleak in audit event dispatcher
  452. - Update system-config-audit to version 0.4.6 (Miloslav Trmac)
  453. - audisp-prelude alerts now controlled by config file
  454. - Updated syscall table for 2.6.25 kernel
  455. - Apply patch correcting acct field being misencoded (Miloslav Trmac)
  456. - Added watched account login detection for prelude plugin
  457. * Thu Feb 14 2008 Steve Grubb <sgrubb@redhat.com> 1.6.8-1
  458. - Update for gcc 4.3
  459. - Cleanup descriptors in audispd before running plugin
  460. - Fix 'recent' keyword for aureport/search
  461. - Fix SE Linux policy for zos_remote plugin
  462. - Add event type for group password authentication attempts
  463. - Couple of updates to the translation tables
  464. - Add detection of failed group authentication to audisp-prelude
  465. * Thu Jan 31 2008 Steve Grubb <sgrubb@redhat.com> 1.6.7-2
  466. - In ausearch/report, prefer -if to stdin
  467. - In ausearch/report, add new command line option --input-logs (#428860)
  468. - Updated audisp-prelude based on feedback from prelude-devel
  469. - Added prelude alert for promiscuous socket being opened
  470. - Added prelude alert for SE Linux policy enforcement changes
  471. - Added prelude alerts for Forbidden Login Locations and Time
  472. - Applied patch to auparse fixing error handling of searching by
  473. interpreted value (Miloslav Trmac)
  474. * Sat Jan 19 2008 Steve Grubb <sgrubb@redhat.com> 1.6.6-1
  475. - Add prelude IDS plugin for IDMEF alerts
  476. - Add --user option to aulastlog command
  477. - Use desktop-file-install for system-config-audit
  478. - Avoid touching auditd.conf most of the time (#408501)
  479. * Fri Jan 11 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-3
  480. - Updates for spec file review
  481. - Adjust permission on selinux policy file
  482. * Mon Jan 07 2008 Steve Grubb <sgrubb@redhat.com> 1.6.5-1
  483. - Fix config parser to allow either 0640 or 0600 for audit logs (#427062)
  484. - Check for audit log being writable by owner in auditd
  485. - If auditd logging was suspended, it can be resumed with SIGUSR2 (#251639)
  486. - Updated CAPP, LSPP, and NISPOM rules for new capabilities
  487. - Added aulastlog utility
  488. * Sun Dec 30 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-3
  489. - Allow 0600 file perms for audit logs
  490. * Sat Dec 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6.4-1
  491. - fchmod of log file was on wrong variable (#426934)
  492. - Allow use of errno strings for exit codes in audit rules
  493. * Sat Dec 29 2007 Miloslav Trmač <mitr@redhat.com> - 1.6.3-2
  494. - Don't fchmod() /dev/null to mode 0400 (#426934)
  495. * Thu Dec 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6.3-1
  496. - Add kernel release string to DEAMON_START events
  497. - Fix keep_logs when num_logs option disabled (#325561)
  498. - Fix auparse to handle node fields for syscall records
  499. - Update system-config-audit to version 0.4.5 (Miloslav Trmac)
  500. - Add keyword week-ago to aureport & ausearch start/end times
  501. - Fix audit log permissions on rotate. If group is root 0400, otherwise 0440
  502. - Add RACF zos remote audispd plugin (Klaus Kiwi)
  503. - Add event queue overflow action to audispd
  504. * Mon Oct 1 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-2
  505. - Don't retry if the rt queue is full.
  506. * Tue Sep 25 2007 Steve Grubb <sgrubb@redhat.com> 1.6.2-1
  507. - Add support for searching by posix regular expressions in auparse
  508. - Route DEAMON events into rt interface
  509. - If event pipe is full, try again after doing local logging
  510. - Optionally add node/machine name to records in audit daemon
  511. - Update ausearch/aureport to specify nodes to search on
  512. - Fix segfault interpretting saddr fields in avcs
  513. * Thu Sep 6 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-2
  514. - Fix uninitialized variable in auparse (John Dennis)
  515. * Sun Sep 2 2007 Steve Grubb <sgrubb@redhat.com> 1.6.1-1
  516. - External plugin support in place
  517. - Fix reference counting in auparse python bindings (#263961)
  518. - Moved default af_unix plugin socket to /var/run/audispd_events
  519. * Wed Aug 29 2007 Steve Grubb <sgrubb@redhat.com> 1.6-3
  520. - Add newline to audispd string formatted events
  521. * Tue Aug 28 2007 Steve Grubb <sgrubb@redhat.com> 1.6-2
  522. - spec file cleanups
  523. - Update to s-c-audit 0.4.3
  524. * Mon Aug 27 2007 Steve Grubb <sgrubb@redhat.com> 1.6-1
  525. - Update Licence tags
  526. - Adding perm field should not set syscall added flag in auditctl
  527. - Fix segfault when aureport -if option is used
  528. - Fix auditctl to better check keys on rule lines
  529. - Add support for audit by TTY and other new event types
  530. - Auditd config option for group permission of audit logs
  531. - Swig messed up a variable in ppc's python bindings causing crashes. (#251327)
  532. - New audit event dispatcher
  533. - Update syscall tables for 2.6.23 kernel
  534. * Wed Jul 25 2007 Steve Grubb <sgrubb@redhat.com> 1.5.6-1
  535. - Fix potential buffer overflow in print clone flags of auparse
  536. - Fix python traceback parsing watches without perm statement (Miloslav Trmac)
  537. - Update auditctl to handle legacy kernels when putting a watch on a dir
  538. - Fix acct interpretation in auparse
  539. * Tue Jul 17 2007 Miloslav Trmač <mitr@redhat.com> - 1.5.5-5
  540. - Fix a double free when auditd receives SIGHUP
  541. - Move the system-config-audit menu entry to the Administration menu
  542. * Tue Jul 10 2007 Steve Grubb <sgrubb@redhat.com> 1.5.5-1
  543. - Add system-config-audit (Miloslav Trmac)
  544. - Correct bug in audit_make_equivalent function (Al Viro)
  545. * Tue Jun 26 2007 Steve Grubb <sgrubb@redhat.com> 1.5.4-1
  546. - Add feed interface to auparse library (John Dennis)
  547. - Apply patch to libauparse for unresolved symbols (#241178)
  548. - Apply patch to add line numbers for file events in libauparse (John Dennis)
  549. - Change seresults to seresult in libauparse (John Dennis)
  550. - Add unit32_t definition to swig (#244210)
  551. - Add support for directory auditing
  552. - Update acct field to be escaped
  553. * Tue May 01 2007 Steve Grubb <sgrubb@redhat.com> 1.5.3-1
  554. - Change buffer size to prevent truncation of DAEMON events with large labels
  555. - Fix memory leaks in auparse (John Dennis)
  556. - Update syscall tables for 2.6.21 kernel
  557. - Update capp & lspp rules
  558. - New python bindings for libauparse (John Dennis)
  559. * Wed Apr 04 2007 Steve Grubb <sgrubb@redhat.com> 1.5.2-1
  560. - New event dispatcher (James Antill)
  561. - Apply patches fixing man pages and Makefile.am (Philipp Hahn)
  562. - Apply patch correcting python libs permissions (Philipp Hahn)
  563. - Fix auditd segfault on reload
  564. - Fix bug in auparse library for file pointers and descriptors
  565. - Extract subject information out of daemon events for ausearch
  566. * Thu Mar 29 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-2
  567. - Remove requires kernel-headers for python-libs
  568. - Apply patch to prevent segfaults on auditd reload
  569. * Tue Mar 20 2007 Steve Grubb <sgrubb@redhat.com> 1.5.1-1
  570. - Updated autrace to monitor *at syscalls
  571. - Add support in libaudit for AUDIT_BIT_TEST(^) and AUDIT_MASK_TEST (&)
  572. - Finish reworking auditd config parser
  573. - In auparse, interpret open, fcntl, and clone flags
  574. - In auparse, when interpreting execve record types, run args through unencode
  575. - Add support for OBJ_PID message type
  576. - Event dispatcher updates
  577. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-2
  578. - rebuild
  579. * Fri Mar 2 2007 Steve Grubb <sgrubb@redhat.com> 1.5-1
  580. - NEW audit dispatcher program & plugin framework
  581. - Correct hidden variables in libauparse
  582. - Added NISPOM sample rules
  583. - Verify accessibility of files passed in auparse_init
  584. - Fix bug in parser library interpreting socketcalls
  585. - Add support for stdio FILE pointer in auparse_init
  586. - Adjust init script to allow anyone to status auditd (#230626)
  587. * Tue Feb 20 2007 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  588. - Add man pages
  589. - Reduce text relocations in parser library
  590. - Add -n option to auditd for no fork
  591. - Add exec option to space_left, admin_space_left, disk_full,
  592. and disk_error - eg EXEC /usr/local/script
  593. * Fri Feb 16 2007 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  594. - updated audit_rule_fieldpair_data to handle perm correctly (#226780)
  595. - Finished search options for audit parsing library
  596. - Fix ausearch -se to work correctly
  597. - Fix auditd init script for /usr on netdev (#228528)
  598. - Parse avc seperms better when there are more than one
  599. * Sun Feb 04 2007 Steve Grubb <sgrubb@redhat.com> 1.4-1
  600. - New report about authentication attempts
  601. - Updates for python 2.5
  602. - update autrace to have resource usage mode
  603. - update auditctl to support immutable config
  604. - added audit_log_user_command function to libaudit api
  605. - interpret capabilities
  606. - added audit event parsing library
  607. - updates for 2.6.20 kernel
  608. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-2
  609. - Make more adjustments for python 2.5
  610. * Sun Dec 10 2006 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  611. - Fix a couple parsing problems (#217952)
  612. - Add tgkill to S390* syscall tables (#218484)
  613. - Fix error messages in ausearch/aureport
  614. * Wed Dec 6 2006 Jeremy Katz <katzj@redhat.com> - 1.3-4
  615. - rebuild against python 2.5
  616. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-3
  617. - Fix timestamp for libaudit.conf (#218053)
  618. * Thu Nov 30 2006 Steve Grubb <sgrubb@redhat.com> 1.3-2
  619. - Fix minor parsing problem and add new msg types
  620. * Tue Nov 28 2006 Steve Grubb <sgrubb@redhat.com> 1.3-1
  621. - ausearch & aureport implement uid/gid caching
  622. - In ausearch & aureport, extract addr when hostname is unknown
  623. - In ausearch & aureport, test audit log presence O_RDONLY
  624. - New ausearch/aureport time keywords: recent, this-week, this-month, this-year
  625. - Added --add & --delete option to aureport
  626. - Update res parsing in config change events
  627. - Increase the size on audit daemon buffers
  628. - Parse avc_path records in ausearch/aureport
  629. - ausearch has new output mode, raw, for extracting events
  630. - ausearch/aureport can now read stdin
  631. - Rework AVC processing in ausearch/aureport
  632. - Added long options to ausearch and aureport
  633. * Tue Oct 24 2006 Steve Grubb <sgrubb@redhat.com> 1.2.9-1
  634. - In auditd if num_logs is zero, don't rotate on SIGUSR1 (#208834)
  635. - Fix some defines in libaudit.h
  636. - Some auditd config strings were not initialized in aureport (#211443)
  637. - Updated man pages
  638. - Add Netlabel event types to libaudit
  639. - Update aureports to current audit event types
  640. - Update autrace a little
  641. - Deprecated all the old audit_rule functions from public API
  642. - Drop auparse library for the moment
  643. * Fri Sep 29 2006 Steve Grubb <sgrubb@redhat.com> 1.2.8-1
  644. - Add dist tag and bump version (#208532)
  645. - Make internal auditd buffers bigger for context info
  646. - Correct address resolving of hostname in logging functions
  647. - Do not allow multiple msgtypes in same audit rule in auditctl (#207666)
  648. - Only =, != operators for arch & inode fields in auditctl (#206427)
  649. - Updated audit message type table
  650. - Remove watches from aureport since FS_WATCH is deprecated
  651. - Add audit_log_avc back temporarily (#208152)