keepassx-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. %define ver 0.4.4
  2. %define rel 1
  3. Name: keepassx
  4. Version: %{ver}
  5. Release: %{rel}%{_dist_release}
  6. Summary: Cross-platform password manager
  7. Summary(ja): クロスプラットフォーム パスワードマネージャー
  8. Group: Applications/Accessories
  9. License: GPLv2+
  10. URL: http://www.keepassx.org/
  11. Source0: http://download.sf.net/keepassx/keepassx-%{version}.tar.gz
  12. Patch1: keepassx-0.3.3-gcc43.patch
  13. Patch2: keepassx-0.4.3-gcc47.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: qt4-devel > 4.1
  16. BuildRequires: libXtst-devel
  17. BuildRequires: ImageMagick
  18. BuildRequires: desktop-file-utils
  19. Requires: hicolor-icon-theme
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: iwaim
  23. %description
  24. KeePassX is an application for people with extremly high demands on secure personal data management.
  25. KeePassX saves many different information e.g. user names, passwords, urls, attachemts and comments in one single database. For a better management user-defined titles and icons can be specified for each single entry.
  26. Furthermore the entries are sorted in groups, which are customizable as well.
  27. The integrated search function allows to search in a single group or the complete database.
  28. KeePassX offers a little utility for secure password generation. The password generator is very customizable, fast and easy to use. Especially someone who generates passwords frequently will appreciate this feature.
  29. The complete database is always encrypted either with AES (alias Rijndael) or Twofish encryption algorithm using a 256 bit key. Therefore the saved information can be considered as quite safe. KeePassX uses a database format that is compatible with KeePass Password Safe for MS Windows.
  30. %prep
  31. %setup -q
  32. %patch1 -p0 -b .gcc43
  33. %patch2 -p1 -b .gcc47
  34. %build
  35. export CFLAGS=$RPM_OPT_FLAGS
  36. export CXXFLAGS=$RPM_OPT_FLAGS
  37. qmake PREFIX=%{_prefix}
  38. make %{?_smp_mflags}
  39. %install
  40. make install INSTALL_ROOT=%{buildroot}
  41. # Use png in _datadir/icons/hicolor instead of xpm in pixmaps
  42. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/
  43. convert %{buildroot}%{_datadir}/pixmaps/keepassx.xpm \
  44. %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/keepassx.png
  45. rm -f %{buildroot}%{_datadir}/pixmaps/keepassx.xpm
  46. # Menu
  47. sed -i -e 's/^Exec=keepassx$/Exec=keepassx %f/g' \
  48. %{buildroot}%{_datadir}/applications/%{name}.desktop
  49. desktop-file-install \
  50. --dir %{buildroot}%{_datadir}/applications \
  51. --delete-original \
  52. --add-mime-type application/x-keepass \
  53. %{buildroot}%{_datadir}/applications/%{name}.desktop
  54. # Associate KDB files
  55. cat > x-keepass.desktop << EOF
  56. [Desktop Entry]
  57. Comment=
  58. Hidden=false
  59. Icon=keepassx.png
  60. MimeType=application/x-keepass
  61. Patterns=*.kdb;*.KDB
  62. Type=MimeType
  63. EOF
  64. install -D -m 644 -p x-keepass.desktop \
  65. %{buildroot}%{_datadir}/mimelnk/application/x-keepass.desktop
  66. %check
  67. make check
  68. %{_bindir}/desktop-file-validate %{buildroot}%{_datadir}/applications/%{name}.desktop
  69. %post
  70. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  71. if [ -x %{_bindir}/update-desktop-database ] ; then
  72. %{_bindir}/update-desktop-database &> /dev/null ||:
  73. fi
  74. if [ -x %{_bindir}/update-mime-database ] ; then
  75. %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
  76. fi
  77. %postun
  78. if [ $1 -eq 0 ] ; then
  79. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  80. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  81. %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  82. fi
  83. fi
  84. if [ -x %{_bindir}/update-desktop-database ] ; then
  85. %{_bindir}/update-desktop-database &> /dev/null ||:
  86. fi
  87. if [ -x %{_bindir}/update-mime-database ] ; then
  88. %{_bindir}/update-mime-database %{_datadir}/mime &> /dev/null || :
  89. fi
  90. %posttrans
  91. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  92. %{_bindir}/gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  93. fi
  94. %files
  95. %doc share/keepassx/license.html
  96. %{_bindir}/keepassx
  97. %{_datadir}/keepassx
  98. %{_datadir}/applications/*.desktop
  99. %{_datadir}/mimelnk/application/*.desktop
  100. %{_datadir}/mime/packages/*.xml
  101. %{_datadir}/icons/hicolor/*/apps/keepassx.png
  102. %changelog
  103. * Thu Dec 22 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 0.4.4-1
  104. - update to 0.4.4
  105. * Sat Feb 7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.4.3-2
  106. - rebuilt on current VineSeed
  107. - moved to Applications/Accessories Group
  108. * Wed Dec 19 2012 IWAI, Masaharu <iwai@alib.jp> 0.4.3-1
  109. - initial build for Vine Linux
  110. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-6
  111. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  112. * Fri Mar 30 2012 Tom Callaway <spot@fedoraproject.org> - 0.4.3-5
  113. - fix FTBFS on gcc 4.7
  114. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-4
  115. - Rebuilt for c++ ABI breakage
  116. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-3
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  118. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.3-2
  119. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  120. * Sun Mar 14 2010 Aurelien Bompard <abompard@fedoraproject.org> - 0.4.3-1
  121. - version 0.4.3
  122. * Sun Jan 03 2010 Aurelien Bompard <abompard@fedoraproject.org> - 0.4.1-1
  123. - version 0.4.1
  124. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.0-3
  125. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  126. * Sat Apr 18 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-2
  127. - add patch0 to fix bug 496035
  128. * Thu Mar 26 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.4.0-1
  129. - version 0.4.0
  130. - drop patch0 (upstream)
  131. * Thu Mar 12 2009 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-3
  132. - backport fix from upstream for bug #489820
  133. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.4-2
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  135. * Tue Nov 11 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.4-1
  136. - version 0.3.4
  137. * Sat Aug 23 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-2
  138. - rebase patch for version 0.3.3
  139. * Tue Aug 12 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.3-1
  140. - version 0.3.3
  141. * Mon Jul 21 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.2-1
  142. - version 0.3.2
  143. * Sun Mar 16 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.1-1
  144. - version 0.3.1
  145. - drop xdg patch, keepassx now uses QDesktopServices
  146. * Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-3.a
  147. - version 0.3.0a
  148. * Wed Mar 05 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-2
  149. - patch for gcc 4.3
  150. * Sun Mar 02 2008 Aurelien Bompard <abompard@fedoraproject.org> 0.3.0-1
  151. - version 0.3.0
  152. - drop helpwindow patch (feature dropped upstream)
  153. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.2.2-5
  154. - Autorebuild for GCC 4.3
  155. * Sun Oct 07 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-4
  156. - use xdg-open instead of htmlview
  157. * Sat Aug 25 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-3
  158. - fix license tag
  159. - rebuild for BuildID
  160. * Wed Jun 27 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-2
  161. - fix help button
  162. - use htmlview instead of the hardcoded konqueror
  163. * Sun Mar 04 2007 Aurelien Bompard <abompard@fedoraproject.org> 0.2.2-1
  164. - initial package