lua-vl.spec 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157
  1. %define name lua
  2. %define version 5.1.4
  3. %define release 4%{?_dist_release}
  4. Summary: Lua is a powerful, light-weight programming language designed for extending applications.
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Source0: http://www.lua.org/ftp/%{name}-%{version}.tar.gz
  9. Patch0: lua-5.1.4-autotoolize.patch
  10. License: MIT (Lua 5.0 license)
  11. Group: Development/Languages
  12. URL: http://www.lua.org/
  13. #Requires:
  14. BuildRequires: readline-devel, ncurses-devel
  15. # apt-get remove readline-devel
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. Provides: lua = 5.1
  18. %description
  19. Lua is an extension programming language designed to support
  20. general procedural programming with data description facilities.
  21. It also offers good support for object-oriented programming,
  22. functional programming, and data-driven programming.
  23. Lua is intended to be used as a powerful, light-weight configuration language
  24. for any program that needs one.
  25. Lua is implemented as a library, written in clean C
  26. (that is, in the common subset of ANSI C and C++).
  27. %description -l ja
  28. Luaは拡張プログラミング言語である。データ記述機能を持ち、
  29. 汎用の手続き型プログラミングをサポートするようデザインされた。
  30. オブジェクト指向プログラミング、関数型プログラミング、
  31. データ駆動型プログラミングもサポートしている。
  32. Luaは、パワフルで軽いコンフィギュレーション言語としての意図もあり、
  33. コンフィギュレーションが必要なあらゆるプログラムに使うことができる。
  34. Luaは クリーンな C (つまり、ANSI C と C++ の共通のサブセット) で書かれ、
  35. ライブラリとして実装されている。
  36. %package devel
  37. Summary: Libraries and include files for Lua.
  38. Group: Development/Languages
  39. Requires: %{name} = %{version}-%{release}
  40. Requires: ncurses-devel, pkgconfig
  41. %description devel
  42. Libraries and include files for Lua.
  43. %package static
  44. Summary: Static library for %{name}
  45. Group: System Environment/Libraries
  46. Requires: %{name} = %{version}-%{release}
  47. %description static
  48. This package contains the static version of liblua for %{name}.
  49. %prep
  50. rm -rf ${RPM_BUILD_ROOT}
  51. %setup -q
  52. %patch0 -p1 -E
  53. # fix perms on auto files
  54. chmod u+x \
  55. autogen.sh config.guess config.sub configure depcomp install-sh missing
  56. %build
  57. %configure --with-readline
  58. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  59. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  60. # hack so that only /usr/bin/lua gets linked with readline as it is the
  61. # only one which needs this and otherwise we get License troubles
  62. make %{?_smp_mflags} LIBS="-lm -ldl" luac_LDADD="liblua.la -lm -ldl"
  63. # also remove readline from lua.pc
  64. sed -i 's/-lreadline -lncurses //g' etc/lua.pc
  65. %install
  66. rm -rf $RPM_BUILD_ROOT
  67. make install DESTDIR=$RPM_BUILD_ROOT
  68. rm $RPM_BUILD_ROOT%{_libdir}/*.la
  69. mkdir -p $RPM_BUILD_ROOT%{_libdir}/lua/5.1
  70. mkdir -p $RPM_BUILD_ROOT%{_datadir}/lua/5.1
  71. %clean
  72. rm -rf ${RPM_BUILD_ROOT}
  73. %files
  74. %defattr(-,root,root,-)
  75. %doc COPYRIGHT HISTORY README doc/*.html doc/*.gif
  76. %{_bindir}/lua*
  77. %{_libdir}/liblua-*.so
  78. %{_mandir}/man1/lua*.1*
  79. %dir %{_libdir}/lua
  80. %dir %{_libdir}/lua/5.1
  81. %dir %{_datadir}/lua
  82. %dir %{_datadir}/lua/5.1
  83. %files devel
  84. %defattr(-,root,root,-)
  85. %{_includedir}/l*.h
  86. %{_includedir}/l*.hpp
  87. %{_libdir}/liblua.so
  88. %{_libdir}/pkgconfig/*.pc
  89. %files static
  90. %defattr(-,root,root,-)
  91. %{_libdir}/*.a
  92. %changelog
  93. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.1.4-4
  94. - rebuild with rpm-4.8.1 for pkg-config file
  95. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-3
  96. - rebuilt with gcc-4.4.3-3 on ppc
  97. * Fri Feb 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.1.4-2
  98. - rebuilt with rpm-4.8.0-3 (on ppc)
  99. * Wed Feb 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 5.1.4-1
  100. - new upstream release
  101. - add lua-static subpackage
  102. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 5.1.2-1vl5
  103. - applied new versioning policy and spec in utf-8
  104. * Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl2
  105. - rebuild for VineSeed
  106. * Sun Aug 5 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.2-0vl1
  107. - initial build for Vine Linux 4.1
  108. - source update
  109. * Sat Aug 4 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.1.1-0vlmp1
  110. - rebuild for Vine Linux 4.1
  111. * Fri Jan 19 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-3
  112. - Remove "-lreadline -lncurses" from lua.pc (bz 213895)
  113. * Sun Oct 15 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-2
  114. - Only link /usr/bin/lua with readline / do not link %%{_libdir}/liblua-5.1.so
  115. with readline so that we don't cause any License troubles for packages
  116. linking against liblua-5.1.so, otherwise lua could drag the GPL only readline
  117. lib into the linking of non GPL apps.
  118. * Sat Oct 14 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 5.1.1-1
  119. - New upstream release 5.1.1
  120. - Fix detection of readline during compile (iow add readline support back)
  121. * Sat Jul 23 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 5.0.2vlmp1
  122. - initial build for Vine Linux 3.2