gnome-python-desktop-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define glib_version 2.24.0
  3. %define gtk_version 2.20.0
  4. %define pygtk_version 2.14.0
  5. %define gnome_python_version 2.28.0
  6. %define libgnome_keyring_version 2.30.0
  7. %define gnome_panel_version 2.30.0
  8. %define gnome_desktop_version 2.30.0
  9. %define gtksourceview_version 1.1.90
  10. %define libgtop_version 2.28.0
  11. %define gnome_media_version 2.30.0
  12. %define metacity_version 2.30.0
  13. %define librsvg2_version 2.26.0
  14. %define totem_version 2.30.0
  15. %define libwnck_version 2.30.0
  16. %define bug_buddy_version 2.30.0
  17. %define evolution_data_server_version 2.30.0
  18. ### Abstract ###
  19. Name: gnome-python-desktop
  20. Version: 2.30.2
  21. Release: 2%{?_dist_release}
  22. License: GPL/LGPL
  23. Group: Development/Libraries
  24. Summary: The sources for additional PyGNOME Python extension modules
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. Source: gnome-python-desktop-%{version}.tar.bz2
  27. ### Dependencies ###
  28. Requires: gnome-python >= %{gnome_python_version}
  29. ### Build Dependencies ###
  30. BuildRequires: glib2-devel >= %{glib_version}
  31. BuildRequires: gtk2-devel >= %{gtk_version}
  32. BuildRequires: python >= 2.6
  33. BuildRequires: pygtk2-devel >= %{pygtk_version}
  34. BuildRequires: gnome-python-devel >= %{gnome_python_version}
  35. BuildRequires: libgnome-keyring-devel >= %{libgnome_keyring_version}
  36. BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
  37. BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
  38. BuildRequires: libgnomeprint-devel
  39. BuildRequires: libgnomeprintui-devel
  40. BuildRequires: evince-devel
  41. BuildRequires: evolution-data-server >= %{evolution_data_server_version}
  42. BuildRequires: gtksourceview-devel >= %{gtksourceview_version}
  43. BuildRequires: libgtop2-devel >= %{libgtop_version}
  44. BuildRequires: gnome-media-devel >= %{gnome_media_version}
  45. BuildRequires: metacity-devel >= %{metacity_version}
  46. BuildRequires: brasero-devel
  47. BuildRequires: librsvg2-devel >= %{librsvg2_version}
  48. BuildRequires: pycairo-devel
  49. BuildRequires: totem-pl-parser-devel >= %{totem_version}
  50. BuildRequires: totem >= %{totem_version}
  51. BuildRequires: libwnck-devel >= %{libwnck_version}
  52. BuildRequires: bug-buddy >= %{bug_buddy_version}
  53. BuildRequires: libSM-devel
  54. %description
  55. The gnome-python-desktop package contains the source packages for additional
  56. Python bindings for GNOME. It should be used together with gnome-python.
  57. %package -n gnome-python-applet
  58. Summary: Python bindings for GNOME Panel applets.
  59. Group: Development/Libraries
  60. Requires: %{name} = %{version}-%{release}
  61. # applets from GNOME 1.4 are no longer supported - we only have 1 panel
  62. Obsoletes: pygnome-applet
  63. %description -n gnome-python-applet
  64. This module contains a wrapper that allows GNOME Panel applets to be
  65. written in Python.
  66. %package -n gnome-python-bugbuddy
  67. Summary: Python bindings for interacting with bug-buddy
  68. Group: Development/Libraries
  69. Requires: %{name} = %{version}-%{release}
  70. Requires: bug-buddy >= %{bug_buddy_version}
  71. %description -n gnome-python-bugbuddy
  72. This module contains a wrapper that allows the use of bug-buddy via
  73. Python.
  74. %package -n gnome-python-evolution
  75. Summary: Python bindings for interacting with evolution
  76. Group: Development/Libraries
  77. Requires: %{name} = %{version}-%{release}
  78. Requires: evolution-data-server >= %{evolution_data_server_version}
  79. %description -n gnome-python-evolution
  80. This module contains a wrapper that allows the use of evolution via
  81. Python.
  82. %package -n gnome-python-gnomeprint
  83. Summary: Python bindings for interacting with libgnomeprint
  84. Group: Development/Libraries
  85. Requires: %{name} = %{version}-%{release}
  86. Requires: libgnomeprint
  87. Requires: libgnomeprintui
  88. %description -n gnome-python-gnomeprint
  89. This module contains a wrapper that allows the use of libgnomeprint via
  90. Python.
  91. %package -n gnome-python-gtksourceview
  92. Summary: Python bindings for interacting with the gtksourceview library
  93. Group: Development/Libraries
  94. Requires: %{name} = %{version}-%{release}
  95. Requires: gtksourceview >= %{gtksourceview_version}
  96. Requires: gnome-python-gnomeprint
  97. %description -n gnome-python-gtksourceview
  98. This module contains a wrapper that allows the use of gtksourceview via
  99. Python.
  100. %package -n gnome-python-libwnck
  101. Summary: Python bindings for interacting with libwnck
  102. Group: Development/Libraries
  103. Requires: libwnck >= %{libwnck_version}
  104. %description -n gnome-python-libwnck
  105. This module contains a wrapper that allows the use of libwnck via
  106. Python.
  107. %package -n gnome-python-libgtop2
  108. Summary: Python bindings for interacting with libgtop
  109. Group: Development/Libraries
  110. Requires: %{name} = %{version}-%{release}
  111. Requires: libgtop2 >= %{libgtop_version}
  112. %description -n gnome-python-libgtop2
  113. This module contains a wrapper that allows the use of libgtop via
  114. Python.
  115. %package -n gnome-python-brasero
  116. Summary: Python bindings for interacting with brasero
  117. Group: Development/Libraries
  118. Requires: %{name} = %{version}-%{release}
  119. Requires: brasero-libs
  120. %description -n gnome-python-brasero
  121. This module contains a wrapper that allows the use of brasero
  122. via Python.
  123. %package -n gnome-python-metacity
  124. Summary: Python bindings for interacting with metacity
  125. Group: Development/Libraries
  126. Requires: %{name} = %{version}-%{release}
  127. Requires: metacity >= %{metacity_version}
  128. %description -n gnome-python-metacity
  129. This module contains a wrapper that allows the use of metacity
  130. via Python.
  131. %package -n gnome-python-totem
  132. Summary: Python bindings for interacting with totem
  133. Group: Development/Libraries
  134. Requires: %{name} = %{version}-%{release}
  135. Requires: totem >= %{totem_version}
  136. %description -n gnome-python-totem
  137. This module contains a wrapper that allows the use of totem
  138. via Python.
  139. %package -n gnome-python-rsvg
  140. Summary: Python bindings for interacting with librsvg
  141. Group: Development/Libraries
  142. Requires: librsvg2 >= %{librsvg2_version}
  143. Requires: pycairo
  144. %description -n gnome-python-rsvg
  145. This module contains a wrapper that allows the use of librsvg
  146. via Python.
  147. %package -n gnome-python-gnomedesktop
  148. Summary: Python bindings for interacting with gnome-desktop
  149. Group: Development/Libraries
  150. Requires: %{name} = %{version}-%{release}
  151. Requires: gnome-desktop >= %{gnome_desktop_version}
  152. %description -n gnome-python-gnomedesktop
  153. This module contains a wrapper that allows the use of gnome-desktop
  154. via Python.
  155. %package -n gnome-python-gnomekeyring
  156. Summary: Python bindings for interacting with gnome-keyring
  157. Group: Development/Libraries
  158. Requires: %{name} = %{version}-%{release}
  159. Requires: libgnome-keyring >= %{libgnome_keyring_version}
  160. %description -n gnome-python-gnomekeyring
  161. This module contains a wrapper that allows the use of gnome-keyring
  162. via Python.
  163. %package -n gnome-python-evince
  164. Summary: Python bindings for interacting with evince
  165. Group: Development/Libraries
  166. Requires: %{name} = %{version}-%{release}
  167. Requires: evince
  168. %description -n gnome-python-evince
  169. This module contains a wrapper that allows the use of evince
  170. via Python.
  171. %prep
  172. %setup -q -n gnome-python-desktop-%{version}
  173. %build
  174. ./waf configure --prefix=%{_prefix} --libdir=%{_libdir} --enable-metacity
  175. ./waf build %{?_smp_mflags}
  176. %install
  177. rm -rf $RPM_BUILD_ROOT
  178. ./waf install --destdir=$RPM_BUILD_ROOT
  179. find $RPM_BUILD_ROOT -name '*.la' -exec rm {} \;
  180. rm -rf $RPM_BUILD_ROOT/%{_libdir}/python*/site-packages/gtk-2.0/gksu
  181. %clean
  182. rm -rf $RPM_BUILD_ROOT
  183. %files
  184. %defattr(-,root,root,-)
  185. %doc AUTHORS ChangeLog NEWS
  186. %{_libdir}/pkgconfig/gnome-python-desktop-2.0.pc
  187. %{_datadir}/pygtk
  188. %files -n gnome-python-applet
  189. %defattr(-,root,root,-)
  190. %{python_sitearch}/gtk-2.0/gnomeapplet.so
  191. %defattr(644,root,root,755)
  192. %doc ../gnome-python-desktop-%{version}/examples/applet/*
  193. %files -n gnome-python-bugbuddy
  194. %defattr(-,root,root,-)
  195. %{python_sitearch}/gtk-2.0/bugbuddy.py*
  196. %files -n gnome-python-evolution
  197. %defattr(-,root,root,-)
  198. %dir %{python_sitearch}/gtk-2.0/evolution/
  199. %{python_sitearch}/gtk-2.0/evolution/*
  200. %files -n gnome-python-gnomeprint
  201. %defattr(-,root,root,-)
  202. %{python_sitearch}/gtk-2.0/gnomeprint/
  203. %{_datadir}/gtk-doc/html/pygnomeprint
  204. %{_datadir}/gtk-doc/html/pygnomeprintui
  205. %defattr(644,root,root,755)
  206. %doc ../gnome-python-desktop-%{version}/examples/gnomeprint/*
  207. %files -n gnome-python-gtksourceview
  208. %defattr(-,root,root,-)
  209. %{python_sitearch}/gtk-2.0/gtksourceview.so
  210. %{_datadir}/gtk-doc/html/pygtksourceview
  211. %defattr(644,root,root,755)
  212. %doc ../gnome-python-desktop-%{version}/examples/gtksourceview/*
  213. %files -n gnome-python-libwnck
  214. %defattr(-,root,root,-)
  215. %{python_sitearch}/gtk-2.0/wnck.so
  216. %defattr(644,root,root,755)
  217. %doc ../gnome-python-desktop-%{version}/examples/wnck_example.py
  218. %files -n gnome-python-libgtop2
  219. %defattr(-,root,root,-)
  220. %{python_sitearch}/gtk-2.0/gtop.so
  221. %files -n gnome-python-brasero
  222. %defattr(-,root,root,-)
  223. %{python_sitearch}/gtk-2.0/braseroburn.so
  224. %{python_sitearch}/gtk-2.0/braseromedia.so
  225. %defattr(644,root,root,755)
  226. %doc ../gnome-python-desktop-%{version}/examples/braseroburn/*
  227. %doc ../gnome-python-desktop-%{version}/examples/braseromedia/*
  228. %files -n gnome-python-metacity
  229. %defattr(-,root,root,-)
  230. %{python_sitearch}/gtk-2.0/metacity.so
  231. %files -n gnome-python-totem
  232. %defattr(-,root,root,-)
  233. %{python_sitearch}/gtk-2.0/mediaprofiles.so
  234. %{python_sitearch}/gtk-2.0/totem
  235. %files -n gnome-python-rsvg
  236. %{python_sitearch}/gtk-2.0/rsvg.so
  237. %defattr(644,root,root,755)
  238. %doc ../gnome-python-desktop-%{version}/examples/rsvg/*
  239. %files -n gnome-python-gnomedesktop
  240. %{python_sitearch}/gtk-2.0/gnomedesktop
  241. %files -n gnome-python-gnomekeyring
  242. %{python_sitearch}/gtk-2.0/gnomekeyring.so
  243. %defattr(644,root,root,755)
  244. %doc ../gnome-python-desktop-%{version}/examples/keyring*.py
  245. %files -n gnome-python-evince
  246. %{python_sitearch}/gtk-2.0/evince.so
  247. %changelog
  248. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-2
  249. - rebuild with rpm-4.8.1 for pkg-config file
  250. - change BuildRequires: gnome-panel-devel instead of gnome-panel
  251. - change BuildRequires: gnome-media-devel instead of gnome-media
  252. - add BuildRequires: libSM-devel
  253. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  254. - new upstream release
  255. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  256. - new upstream release
  257. - add BuildRequires: totem
  258. - change BuildRequires: gnome-keyring-devel -> libgnome-keyring-devel
  259. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  260. - rebuild for python-2.6
  261. * Sat Nov 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
  262. - new upstream release
  263. - added gnome-python-brasero, gnome-python-evince package
  264. - remove gnome-python-nautilus-cd-burner package
  265. - used waf instead of configure script
  266. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  267. - new upstream release
  268. * Sat Oct 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.24.0-1
  269. - new upstream release
  270. - added BuildRequires: pycairo-devel
  271. * Wed Jul 23 2008 Shu KONNO <owa@bg.wakwak.com> - 2.20.0-3
  272. - rebuilt with python-2.5.2
  273. * Wed Apr 16 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.20.0-2
  274. - re-enable BuildRequires: gnome-python-devel
  275. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.22.0-1vl5
  276. - new upstream release
  277. - added gnome-python-evolution subpackage
  278. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.20.0-0vl1
  279. - new upstream release
  280. * Sun Jul 08 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.18.0-1vl2
  281. - add BuildRequires: gnome-media
  282. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.18.0-1vl1
  283. - initial build for Vine Linux
  284. * Mon Mar 12 2007 Matthew Barnes <mbarnes@redhat.com> - 2.18.0-1.fc7
  285. - Update to 2.18.0
  286. * Wed Feb 28 2007 Matthias Clasen <mclasen@redhat.com> - 2.17.93-1
  287. - Update to 2.17.93
  288. * Sun Feb 25 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.92-1.fc7
  289. - Update to 2.17.92
  290. - Remove patch for GNOME bug #401760 (fixed upstream).
  291. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-3.fc7
  292. - Add patch for GNOME bug #401760 (plparser fails to build).
  293. * Mon Feb 05 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-2.fc7
  294. - Rename spec file to gnome-python2-desktop.spec (RH bug #225832).
  295. * Mon Jan 08 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.3-1
  296. - Update to 2.17.3
  297. * Sun Jan 07 2007 Matthew Barnes <mbarnes@redhat.com> - 2.17.2-1
  298. - Update to 2.17.2
  299. - New gnome-python2-bugbuddy subpackage.
  300. - Update version requirements to match configure.ac.
  301. - Use python_sitearch macro for installing libraries.
  302. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.17.1-2
  303. - rebuild for python 2.5
  304. - BR gnome-python2-devel
  305. * Sat Oct 21 2006 Matthias Clasen <mclasen@redhat.com> - 2.17.1-1
  306. - Update to 2.17.1
  307. * Tue Sep 5 2006 Matthias Clasen <mclasen@redhat.com> - 2.16.0-1.fc6
  308. - Update to 2.16.0
  309. * Tue Aug 22 2006 Dan Williams <dcbw@redhat.com> - 2.15.90-2.fc6
  310. - Remove unecessary dependencies on gnome-python2-desktop from
  311. -libwnck and -rsvg subpackages (OLPC)
  312. * Fri Aug 4 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.90-1.fc6
  313. - Update to 2.15.90
  314. * Thu Jul 20 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-2
  315. - Rebuild against dbus
  316. * Thu Jul 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.4-1
  317. - Update to 2.15.4
  318. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4.1
  319. - rebuild
  320. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-4
  321. - Create gnomekeyring subpackage
  322. - block out the nautilus-cd stuff
  323. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> - 2.15.3-2
  324. - Bump for new nautilus-cd-burner
  325. * Tue Jun 13 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.3-1
  326. - Update to 2.15.3
  327. * Tue May 30 2006 Matthias Clasen <mclasen@redhat.com> - 2.15.2-1
  328. - Update to 2.15.2
  329. - Add subpackages gnome-python2-rsvg and gnome-python2-gnomedesktop
  330. * Wed May 24 2006 John (J5) Palmieri <johnp@redhat.com> - 2.14.0-2
  331. - Add pygtk2 BR
  332. * Mon Mar 13 2006 Ray Strode <rstrode@redhat.de> 2.14.0-1
  333. - Update to 2.14.0
  334. * Tue Feb 28 2006 Karsten Hopp <karsten@redhat.de> 2.13.3-2
  335. - Buildrequires: python-devel
  336. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.13.3-1.1
  337. - bump again for double-long bug on ppc(64)
  338. * Mon Feb 6 2006 John (J5) Palmieri <johnp@redhat.com> - 2.13.3-1
  339. - Initial build.