gnome-do-vl.spec 8.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258
  1. %define mainver 0.8.3
  2. Name: gnome-do
  3. Version: 0.8.3.1
  4. Release: 3%{?_dist_release}
  5. Summary: An intelligent launcher tool for Gnome
  6. Summary(ja): Gnome 用の高機能ランチャー
  7. License: GPLv3+
  8. Group: Applications/Accessories
  9. URL: http://do.davebsd.com/
  10. Source0: http://edge.launchpad.net/do/0.8/%{mainver}/+download/gnome-do-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. # Various Mono dependencies are not available for ppc64; see bug 241850.
  13. ExcludeArch: ppc64
  14. BuildRequires: mono-devel, mono-addins
  15. BuildRequires: desktop-file-utils
  16. BuildRequires: ndesk-dbus
  17. BuildRequires: ndesk-dbus-glib
  18. BuildRequires: gtk-sharp2
  19. BuildRequires: notify-sharp-devel
  20. BuildRequires: gnome-sharp2, gnome-desktop-sharp2 >= 2.26
  21. BuildRequires: gnome-keyring-sharp-devel
  22. BuildRequires: gettext
  23. BuildRequires: perl-XML-Parser
  24. BuildRequires: intltool
  25. BuildRequires: gtk2-devel
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: wnck-sharp
  28. BuildRequires: gconf-sharp2
  29. BuildRequires: rsvg2-sharp
  30. Requires(pre): GConf2
  31. Requires(post): GConf2
  32. Requires(preun): GConf2
  33. Requires: gnome-keyring-sharp, gnome-desktop-sharp2
  34. Requires: pkgconfig
  35. Packager: kazutaka
  36. %description
  37. GNOME Do (Do) is an intelligent launcher tool that makes performing
  38. common tasks on your computer simple and efficient. Do not only
  39. allows you to search for items in your desktop environment
  40. (e.g. applications, contacts, bookmarks, files, music), it also
  41. allows you to specify actions to perform on search results
  42. (e.g. run, open, email, chat, play).
  43. %description -l ja
  44. GNOME Do (Do) は高機能なランチャーツールです。 PC を使った一
  45. 般的なタスクをシンプルかつ効率的に実行できるようにします。Do
  46. はデスクトップ環境の様々なアイテム(例えばアプリケーションや
  47. 連絡先、ブックマーク、ファイル、音楽等)の検索だけでなく、検索
  48. した結果をどう操作するのか(例えば開く、メールに添付、チャット、
  49. 再生する等)を指定することができます。
  50. %package devel
  51. Summary: Development files for GNOME Do
  52. SUmmary(ja): GNOME Do の開発用ファイル
  53. Group: Development/Libraries
  54. Requires: %{name} = %{version}-%{release}
  55. Requires: pkgconfig
  56. %description devel
  57. Development files for GNOME Do
  58. %description devel -l ja
  59. GNOME Do の開発用ファイルです。
  60. %prep
  61. %setup -q
  62. %build
  63. %configure
  64. make %{?_smp_mflags}
  65. %install
  66. rm -rf ${RPM_BUILD_ROOT}
  67. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  68. make install DESTDIR=${RPM_BUILD_ROOT}
  69. desktop-file-install \
  70. --dir ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/autostart \
  71. --add-only-show-in=GNOME \
  72. ${RPM_BUILD_ROOT}%{_datadir}/applications/gnome-do.desktop
  73. desktop-file-install --delete-original \
  74. --dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
  75. --remove-category Application \
  76. ${RPM_BUILD_ROOT}%{_datadir}/applications/%{name}.desktop
  77. #own this dir:
  78. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}
  79. %find_lang %{name}
  80. %pre
  81. if [ "$1" -gt 1 ]; then
  82. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  83. gconftool-2 --makefile-uninstall-rule \
  84. %{_sysconfdir}/gconf/schemas/%{name}.schemas >/dev/null || :
  85. fi
  86. %post
  87. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  88. gconftool-2 --makefile-install-rule \
  89. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  90. touch --no-create %{_datadir}/icons/hicolor
  91. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  92. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  93. fi
  94. %preun
  95. if [ "$1" -eq 0 ]; then
  96. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  97. gconftool-2 --makefile-uninstall-rule \
  98. %{_sysconfdir}/gconf/schemas/%{name}.schemas > /dev/null || :
  99. fi
  100. %postun
  101. touch --no-create %{_datadir}/icons/hicolor
  102. if [ -x %{_bindir}/gtk-update-icon-cache ] ; then
  103. %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
  104. fi
  105. %clean
  106. rm -rf ${RPM_BUILD_ROOT}
  107. %files -f %{name}.lang
  108. %defattr(-,root,root,-)
  109. %doc AUTHORS COPYING COPYRIGHT
  110. %{_bindir}/gnome-do/
  111. %{_libdir}/gnome-do/
  112. %{_datadir}/gnome-do/
  113. %config(noreplace) %{_sysconfdir}/xdg/autostart/gnome-do.desktop
  114. %config(noreplace) %{_sysconfdir}/gconf/schemas/*
  115. %{_datadir}/icons/hicolor/*/apps/gnome-do.*
  116. %{_datadir}/applications/*
  117. %files devel
  118. %defattr(-,root,root,-)
  119. %{_libdir}/pkgconfig/*
  120. %changelog
  121. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.3.1-3
  122. - rebuild with rpm-4.8.1 for pkg-config file
  123. - add BuildRequires: gconf-sharp2, rsvg2-sharp
  124. * Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 0.8.3.1-2
  125. - rebuilt with mono-addins-0.5
  126. * Sun Jan 10 2010 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.3.1-1
  127. - new upstream release
  128. * Fri Jul 10 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.2-1
  129. - new upstream release
  130. - drop Patch0 (merged in upstream)
  131. * Fri Jun 12 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-3
  132. - change Group to Applications/Accessories
  133. * Fri Jun 12 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.8.1.3-2
  134. - add BuildRequires: wnck-sharp
  135. * Thu Jun 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.8.1.3-1
  136. - initial build for Vine Linux based on fedora development
  137. * Fri Apr 10 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-5
  138. - Fix .desktop issue, install in both autostart and applications
  139. - Rebuild for new gnome-desktop-sharp
  140. - Add missing gnome-desktop-sharp requires
  141. - Fix Ndesk-dbus Requires
  142. * Wed Apr 01 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-3
  143. - Add patch to fix issue where applications wasn't being indexed
  144. * Tue Mar 17 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.1.3-2
  145. - New upstream release
  146. * Tue Mar 3 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-4
  147. - Own _datadir/gnome-do
  148. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.0-3
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  150. * Sat Feb 7 2009 Michel Salim <salimma@fedoraproject.org> - 0.8.0-2
  151. - Rebuild against new mono-addins
  152. * Fri Jan 30 2009 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.8.0-1
  153. - New upstream release
  154. * Thu Jan 29 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1.0-3
  155. - Remove Tomboy dependency (bz #481183)
  156. - Updated description, from Do
  157. * Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.6.1.0-2
  158. - rebuild against new gnome-sharp
  159. * Wed Oct 08 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.1.0-1
  160. - New Upstream Release
  161. * Fri Oct 03 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.1-1
  162. - New upstream release
  163. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.6.0.0-1
  164. - New upstream release
  165. * Wed Jun 11 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.5.0.1-4
  166. - New upstream release
  167. - Add gnome-desktop-sharp dependency
  168. * Wed Jun 04 2008 Caol叩n McNamara <caolanm@redhat.com> - 0.4.2.0-2
  169. - rebuild for dependancies
  170. * Tue Apr 22 2008 Sindre Pedersen Bj淡rdal <sindrepb@fedoraproject.org> - 0.4.2.0-1
  171. - New upstream release
  172. * Tue Apr 01 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-2
  173. - #439793 - correct URL
  174. * Sat Mar 29 2008 David Nielsen <gnomeuser@gmail.com> - 0.4.0.1-1
  175. - Bump to 0.4.0.1
  176. - Hopefully bring an end to the endless dups of 432201
  177. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-2
  178. - Fix 432201
  179. * Thu Feb 21 2008 David Nielsen <david@lovesunix.net> - 0.3.1-1
  180. - Bump to 0.3.1
  181. * Wed Feb 06 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-5
  182. - #431589 - Force runtime dependency on ndesk-dbus(-glib)
  183. * Mon Feb 04 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-4
  184. - #431462 - Correctly pull in Tomboy runtime dependency
  185. * Fri Jan 25 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-3
  186. - autostart gnome-do in quiet mode with the user session
  187. - to invoke gnome-do use super+space
  188. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-2
  189. - Fix BuildRequires
  190. * Tue Jan 22 2008 David Nielsen <david@lovesunix.net> - 0.3.0.1-1
  191. - bump to 0.3.0.1
  192. - update patches
  193. * Sat Nov 17 2007 David Nielsen <david@lovesunix.net> - 0.0.2-2
  194. - updated libdir patch
  195. - cleaned up desktop-file-install invocation
  196. - correct BuildRequires
  197. * Mon Nov 12 2007 David Nielsen <david@lovesunix.net> - 0.0.2-1
  198. - Initial package