gnome-bluetooth-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419
  1. Summary: GNOME Bluetooth Subsystem
  2. Summary(ja): GNOME Bluetooth サブシステム
  3. Name: gnome-bluetooth
  4. Version: 2.30.0
  5. Release: 2%{?_dist_release}
  6. License: GPLv2+
  7. Group: System Environment/Libraries
  8. URL: http://live.gnome.org/GnomeBluetooth
  9. Source0: http://ftp.gnome.org/pub/gnome/sources/gnome-bluetooth/0.11/%{name}-%{version}.tar.bz2
  10. Source1: 61-gnome-bluetooth-rfkill.rules
  11. #----------------------------------------------------------------------------
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. #----------------------------------------------------------------------------
  14. #BuildRequires: autoconf >= 2.57
  15. BuildRequires: bluez-libs-devel >= 2.8
  16. #BuildRequires: bluez-utils
  17. BuildRequires: libgnomeui-devel >= 2.2
  18. BuildRequires: libbonobo-devel >= 2.0
  19. BuildRequires: GConf2-devel >= 2.0
  20. BuildRequires: hal-devel
  21. BuildRequires: unique-devel
  22. BuildRequires: libnotify-devel
  23. BuildRequires: gnome-doc-utils
  24. BuildRequires: gir-repository-devel
  25. BuildRequires: intltool, automake, libtool, gettext
  26. Requires: %{name}-libs = %{version}-%{release}
  27. Requires(pre): GConf2
  28. Requires(post): GConf2
  29. Requires(preun): GConf2
  30. Requires: bluez >= 4.42
  31. Requires: obexd
  32. ExcludeArch: s390 s390x
  33. ## Patch1: gnome-bluetooth-0.8.0-desktop.patch
  34. #----------------------------------------------------------------------------
  35. %description
  36. This package contains a library with widgets for Bluetooth applications.
  37. %description -l ja
  38. このパッケージには、 Bluetooth アプリケーションのためのウィジェットと
  39. ライブラリが含まれます。
  40. #----------------------------------------------------------------------------
  41. %package libs
  42. Summary: Libraries for applications, which use gnome-bluetooth
  43. Summary(ja):Gnome-bluetooth を使用するアプリケーション用ライブラリ
  44. Group: Development/Libraries
  45. %description libs
  46. This package contains the libraries for applications,
  47. which use gnome-bluetooth.
  48. %description libs -l ja
  49. このパッケージには Gnome-bluetoothを使用するアプリケーション用の
  50. ライブラリが含まれています。
  51. #----------------------------------------------------------------------------
  52. %package devel
  53. Summary: Files for the development of applications, which use gnome-bluetooth
  54. Summary(ja): Gnome-bluetoothを使用するアプリケーション開発用ファイル
  55. Group: Development/Libraries
  56. License: LGPLv2+
  57. Requires: %{name}-libs = %{version}-%{release}
  58. Requires: gtk-doc pkgconfig
  59. Requires: glib2-devel
  60. Requires: libbtctl-devel
  61. %description devel
  62. This package contains the files for the development of applications,
  63. which will use gnome-bluetooth.
  64. %description devel -l ja
  65. このパッケージにはGnome-bluetoothを使用するアプリケーションを
  66. 開発するためのヘッダーファイルなどが含まれています(develパッケージ)
  67. #----------------------------------------------------------------------------
  68. %prep
  69. %setup -q -n gnome-bluetooth-%{version}
  70. ## %patch1 -p1 -b .dfix
  71. %build
  72. %configure --disable-desktop-update --disable-icon-update --disable-nautilus-sendto
  73. make %{?_smp_mflags}
  74. #----------------------------------------------------------------------------
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  78. make DESTDIR=$RPM_BUILD_ROOT install
  79. # we do not want .la files
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/gnome-vfs-2.0/modules/libbluetooth.*a
  81. rm -f $RPM_BUILD_ROOT%{_libdir}/libgnome-bluetooth.la
  82. rm -f $RPM_BUILD_ROOT/%{_libdir}/gnome-bluetooth/plugins/*.la
  83. rm -f $RPM_BUILD_ROOT/%{_libdir}/nautilus-sendto/plugins/*.la
  84. install -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT/lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  85. # Remove the gnome-obex-server
  86. # rm -rf $RPM_BUILD_ROOT%{_bindir}/ $RPM_BUILD_ROOT%{_datadir}/applications/ $RPM_BUILD_ROOT%{_sysconfdir}/
  87. %find_lang gnome-bluetooth2
  88. %find_lang %{name} --with-gnome
  89. cat %{name}.lang >> gnome-bluetooth2.lang
  90. # save space by linking identical images in translated docs
  91. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  92. for f in $helpdir/C/figures/*.png; do
  93. b="$(basename $f)"
  94. for d in $helpdir/*; do
  95. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  96. g="$d/figures/$b"
  97. if [ -f "$g" ]; then
  98. if cmp -s $f $g; then
  99. rm "$g"; ln -s "../../C/figures/$b" "$g"
  100. fi
  101. fi
  102. fi
  103. done
  104. done
  105. %clean
  106. rm -rf $RPM_BUILD_ROOT
  107. %pre
  108. #if [ "$1" -gt 1 ]; then
  109. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  110. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  111. # gconftool-2 --makefile-uninstall-rule \
  112. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  113. # fi
  114. #fi
  115. if [ "$1" -gt 1 ]; then
  116. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  117. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  118. gconftool-2 --makefile-uninstall-rule \
  119. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas >/dev/null || :
  120. fi
  121. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  122. gconftool-2 --makefile-uninstall-rule \
  123. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  124. >& /dev/null || :
  125. fi
  126. fi
  127. %post
  128. scrollkeeper-update -q
  129. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  130. gconftool-2 --makefile-install-rule \
  131. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  132. >& /dev/null || :
  133. %preun
  134. #if [ "$1" -eq 0 ]; then
  135. # export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  136. # if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  137. # gconftool-2 --makefile-uninstall-rule \
  138. # %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  139. # fi
  140. #fi
  141. if [ "$1" -eq 0 ]; then
  142. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  143. if [ -f %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas ] ; then
  144. gconftool-2 --makefile-uninstall-rule \
  145. %{_sysconfdir}/gconf/schemas/gnome-obex-server.schemas > /dev/null || :
  146. fi
  147. if [ -f %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas ] ; then
  148. gconftool-2 --makefile-uninstall-rule \
  149. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas \
  150. >& /dev/null || :
  151. fi
  152. fi
  153. %postun
  154. scrollkeeper-update -q
  155. if [ $1 -eq 0 ] ; then
  156. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  157. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  158. fi
  159. %post libs
  160. /sbin/ldconfig
  161. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  162. %posttrans libs
  163. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  164. %postun libs
  165. /sbin/ldconfig
  166. if [ $1 -eq 0 ] ; then
  167. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  168. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  169. fi
  170. #----------------------------------------------------------------------------
  171. %files -f %{name}.lang
  172. %defattr(-, root, root)
  173. %doc README NEWS COPYING
  174. %{_sysconfdir}/gconf/schemas/bluetooth-manager.schemas
  175. %{_sysconfdir}/xdg/autostart/bluetooth-applet.desktop
  176. %{_bindir}/bluetooth-*
  177. %{_libdir}/gnome-bluetooth/
  178. %{_datadir}/applications/*.desktop
  179. %{_datadir}/gnome-bluetooth/
  180. %{_datadir}/locale/*
  181. %{_mandir}/man1/*
  182. /lib/udev/rules.d/61-gnome-bluetooth-rfkill.rules
  183. %files libs
  184. %defattr(-,root,root,-)
  185. %doc COPYING.LIB
  186. %{_libdir}/libgnome-bluetooth.so.*
  187. %{_libdir}/girepository-1.0/GnomeBluetooth-1.0.typelib
  188. %{_datadir}/icons/hicolor/*/apps/*
  189. %{_datadir}/icons/hicolor/*/status/*
  190. %files devel
  191. %defattr(-,root,root,-)
  192. %{_includedir}/gnome-bluetooth/
  193. %{_libdir}/libgnome-bluetooth.so
  194. %{_libdir}/pkgconfig/gnome-bluetooth-1.0.pc
  195. %{_datadir}/gir-1.0/GnomeBluetooth-1.0.gir
  196. %{_datadir}/gtk-doc/html/gnome-bluetooth/
  197. #----------------------------------------------------------------------------
  198. # Maintainers: babasaki@mindgear.org
  199. #
  200. #----------------------------------------------------------------------------
  201. %changelog
  202. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-2
  203. - rebuild with rpm-4.8.1 for pkg-config file
  204. * Wed Apr 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  205. - new upstream release
  206. - add BuildRequires: gir-repository-devel
  207. - add configure option (--disable-nautilus-sendto)
  208. * Wed Dec 30 2009 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  209. - new upstream release
  210. - merge spec file from FC package
  211. * Fri Oct 24 2008 Seiichirou Babasaki 0.11.0-6
  212. - Update to 0.11.0 (VineSeed)
  213. - added "# Maintainers: " comments.
  214. - changed UTF-8 encode at gnome-bluetooth.vsc.spec
  215. - FedoraCore - LOGS
  216. -- 0.11.0-5
  217. -- Rebuild against new bluez-libs
  218. -- 0.11.0-4
  219. -- Changed name of icon file(#444811)
  220. -- 0.11.0-3
  221. -- Remove gnome-obex-server, we should use gnome-user-share now
  222. -- 0.11.0-1
  223. -- gcc43 rebuild
  224. -- 0.11.0 - Update to 0.11.0
  225. -- 0.10.0 - Update to 0.10.0
  226. -- 0.9.1-4
  227. -- marked gnome-obex-server.schemas as config file
  228. -- changed upstream URL
  229. -- 0.9.1-3
  230. -- fixed wrong source URL
  231. -- 0.9.1-2
  232. -- rebuilt for F8
  233. -- changed license tag to GPLv2 and LGPLv2+
  234. -- 0.9.1-1
  235. -- Upgrade to 0.9.1 to fix a crasher in the server
  236. -- 0.9.0-1
  237. -- Update for 0.9.0
  238. -- Fix installation of the python bindings
  239. -- 0.8.0-4
  240. -- Remove unncessary gconfd killing from scripts (#224561)
  241. -- 0.8.0-3
  242. -- corrected BuildRoot
  243. -- smp flags added
  244. -- specfile cleanup
  245. -- fixed desktop file
  246. - Updated specfile
  247. * Fri Sep 26 2008 Seiichirou Babasaki 0.8.0-2
  248. - Updated specfile
  249. * Wed Jan 16 2008 Seiichirou Babasaki 0.8.0-1
  250. - Import gnome-bluetooth - Packager: Babasaki
  251. - Updated specfile (downgrade -> 0.8.0-0vl1)
  252. #----------------------------------------------------------------------------
  253. * Mon Nov 13 2006 Harald Hoyer <harald@redhat.com> - 0.8.0-1
  254. - version 0.8.0
  255. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-10.1
  256. - rebuild
  257. * Wed Jun 14 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-10
  258. - bump for new openobex
  259. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-9
  260. - Missing automake, libtool, gettext BR
  261. * Sun Jun 11 2006 Jesse Keating <jkeating@redhat.com> - 0.7.0-6
  262. - Bump for new libbluetooth
  263. * Wed May 31 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-6
  264. - add dependency on bluez-utils, cosmetic tweaks (bug #190280)
  265. * Tue May 30 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-5
  266. - install schemata correctly (bug #193518)
  267. * Mon May 29 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-3
  268. - more build requires (bug #193374)
  269. * Mon Feb 27 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-2
  270. - pydir fixes for lib64
  271. * Thu Feb 16 2006 Harald Hoyer <harald@redhat.com> - 0.7.0-1
  272. - version 0.7.0
  273. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2.1
  274. - bump again for double-long bug on ppc(64)
  275. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.6.0-2.2
  276. - rebuilt for new gcc4.1 snapshot and glibc changes
  277. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  278. - rebuilt
  279. * Fri Oct 07 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-2
  280. - Fix relative path for the icons in desktop files which no longer works
  281. with the icon cache.
  282. * Wed Sep 28 2005 Harald Hoyer <harald@redhat.com> - 0.6.0-1
  283. - new version 0.6.0
  284. * Tue Aug 16 2005 Warren Togami <wtogami@redhat.com> 0.5.1-14
  285. - rebuild for new cairo
  286. * Thu Jul 7 2005 Matthias Saou <http://freshrpms.net/> 0.5.1-13
  287. - Minor spec file cleanups.
  288. - Fix relative path for the icons in desktop files which no longer works
  289. with the icon cache.
  290. - Remove useless zero epochs.
  291. - Remove explicit python abi requirement, it's automatic for FC4 and up.
  292. * Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-12
  293. - removed base requirement from libs
  294. * Tue Mar 29 2005 Warren Togami <wtogami@redhat.com> - 0.5.1-11
  295. - devel req glib2-devel libbtctl-devel for pkgconfig (#152488)
  296. * Wed Mar 02 2005 Harald Hoyer <harald@redhat.com>
  297. - rebuilt
  298. * Mon Feb 21 2005 Harald Hoyer <harald@redhat.com> - 0.5.1-9
  299. - added gnome hbox patch for bug rh#149215
  300. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-8
  301. - added requires for python-abi
  302. * Tue Dec 07 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-7
  303. - split package into app, libs and devel
  304. * Mon Oct 25 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-6
  305. - fixed again gnome-bluetooth-manager script for 64bit (bug 134864)
  306. * Fri Oct 08 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-5
  307. - buildrequire pygtk2-devel (bug 135032)
  308. - fixed gnome-bluetooth-manager script for 64bit (bug 134864)
  309. - fixed segfault on file receive (bug 133041)
  310. * Mon Sep 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-4
  311. - buildrequire libbtctl-devel
  312. - buildrequire openobex-devel >= 1.0.1
  313. - pythondir -> pyexecdir
  314. * Wed Jul 28 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-3
  315. - added build dependency for librsvg2-devel
  316. * Tue Jul 27 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-2
  317. - added pydir patch
  318. * Thu Jul 22 2004 Harald Hoyer <harald@redhat.com> - 0.5.1-1
  319. - version 0.5.1
  320. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  321. - rebuilt
  322. * Tue May 25 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-8
  323. - corrected BuildRequires
  324. * Wed Mar 10 2004 Harald Hoyer <harald@redhat.com> - 0.4.1-7
  325. - added EggToolBar patch for gcc34
  326. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  327. - rebuilt
  328. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  329. - rebuilt
  330. * Mon Jan 26 2004 Harald Hoyer <harald@redhat.de> 0.4.1-4
  331. - added autofoo patch
  332. * Thu Aug 28 2003 Harald Hoyer <harald@redhat.de> 0.4.1-3
  333. - add .so to gnome-vfs module, if libtool does not!
  334. * Thu Aug 07 2003 Harald Hoyer <harald@redhat.de> 0.4.1-2
  335. - call libtool finish
  336. * Wed Aug 6 2003 Harald Hoyer <harald@redhat.de> 0.4.1-1
  337. - new version 0.4.1
  338. * Wed Jun 5 2003 Harald Hoyer <harald@redhat.de> 0.4-1
  339. - initial RPM