glade3-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202
  1. %define helpdir glade3
  2. Version: 3.6.7
  3. Release: 4%{?_dist_release}
  4. Summary: A user interface builder for the GTK+ toolkit and GNOME
  5. Summary(ja): GTK+ツールキット及びGNOME向けのユーザインターフェースビルダー
  6. Name: glade3
  7. License: GPL
  8. Group: Applications/Development
  9. URL: http://glade.gnome.org/
  10. Source0: http://ftp.gnome.org/pub/GNOME/sources/glade3/3.6/%{name}-%{version}.tar.bz2
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. BuildRequires: gtk2-devel >= 2.14.0
  13. BuildRequires: libxml2-devel >= 2.4.0
  14. BuildRequires: libbonoboui-devel
  15. BuildRequires: libgnomeui-devel
  16. BuildRequires: libSM-devel
  17. #BuildRequires(install): desktop-file-utils
  18. BuildRequires: gnome-doc-utils
  19. Requires: gtk2 >= 2.14.0
  20. Requires: libxml2 >= 2.4.0
  21. Requires: libbonoboui
  22. Requires: libgnomeui
  23. Requires: devhelp
  24. Prereq: scrollkeeper
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. %description
  28. Glade is a RAD tool to enable quick & easy development of user interfaces
  29. for the Gtk+ toolkit and the GNOME desktop environment.
  30. The user interfaces designed in Glade are stored in XML format,
  31. enabling easy integration with external tools.
  32. In particular libglade can load the XML files and create the interfaces
  33. at runtime. The DTD for the XML files is included with libglade, and is
  34. also at http://glade.gnome.org/glade-2.0.dtd.
  35. Other tools are available which can turn the XML files into source code
  36. in languages such as C++, Perl and Python.
  37. %description -l ja
  38. Gladeは、GTK+ツールキットやGNOME向けのユーザインターフェースを素早く簡単に開
  39. 発する事が可能なRADツールです。
  40. Gladeでデザインされたユーザインターフェースは外部ツールに用意に統合可能なXML
  41. フォーマットで保存されます。
  42. 特にlibgladeは、XMLファイルを読み込み、ランタイムにインターフェースを生成す
  43. ることが出来ます。このXMLファイルのDTDは、libgladeに含まれており、
  44. http://glade.gnome.org/glade-2.0.dtdにもあります。
  45. このXMLファイルをC++、PerlやPythonといった言語のソースコードに変換する他のツー
  46. ルも利用可能です。
  47. %package devel
  48. Summary: the Glade UI Builder core library
  49. Group: Development/Libraries
  50. Requires: %{name} = %{version}-%{release}
  51. Requires: gtk2-devel >= 2.12.0
  52. Requires: libxml2-devel >= 2.4.0
  53. Requires: libbonoboui-devel
  54. Requires: libgnomeui-devel
  55. %description devel
  56. the Glade UI Builder core library to integrate Glade into your application
  57. and integrate your custom (GTK+ based) widget toolkit into the Glade
  58. UI Builder.
  59. %prep
  60. %setup -q
  61. pushd src
  62. ## change gnome help directory
  63. mv glade-window.c glade-window.c.orig
  64. sed "s|GLADE_GNOMEHELPDIR, \"glade\"|GLADE_GNOMEHELPDIR, \"%{helpdir}\"|" \
  65. glade-window.c.orig > glade-window.c
  66. popd
  67. %build
  68. %configure --disable-scrollkeeper --disable-static
  69. %__make %{_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. %makeinstall
  73. #desktop-file-install \
  74. # --vendor gnome \
  75. # --delete-original \
  76. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  77. # $RPM_BUILD_ROOT%{_datadir}/applications/*
  78. rm -rf $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  79. rm -f $RPM_BUILD_ROOT%{_libdir}/glade3/modules/*.la
  80. rm -f $RPM_BUILD_ROOT%{_libdir}/libgladeui-1.la
  81. ## change gnome help directory
  82. mv $RPM_BUILD_ROOT%{_datadir}/gnome/help/glade $RPM_BUILD_ROOT%{_datadir}/gnome/help/%{helpdir}
  83. mv $RPM_BUILD_ROOT%{_datadir}/omf/glade $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
  84. pushd $RPM_BUILD_ROOT%{_datadir}/omf/%{helpdir}
  85. files=`ls *.omf`
  86. for omf in $files; do
  87. mv $omf $omf.orig
  88. sed "s|help/glade/|help/%{helpdir}/|g" $omf.orig > $omf
  89. rm $omf.orig
  90. done
  91. popd
  92. %find_lang %{name}
  93. %clean
  94. rm -rf $RPM_BUILD_ROOT
  95. %post
  96. /sbin/ldconfig
  97. scrollkeeper-update -p /var/lib/scrollkeeper -o %{_datadir}/omf/%{helpdir}
  98. touch --no-create %{_datadir}/icons/hicolor
  99. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  100. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  101. fi
  102. %postun
  103. /sbin/ldconfig
  104. scrollkeeper-update > /dev/null 2>&1 || :
  105. touch --no-create %{_datadir}/icons/hicolor
  106. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  107. gtk-update-icon-cache -q %{_datadir}/icons/hicolor
  108. fi
  109. %files -f %{name}.lang
  110. %defattr(-,root,root)
  111. %{_bindir}/glade-3
  112. %{_libdir}/libgladeui-1.so.*
  113. %{_libdir}/glade3/modules/*.so
  114. %{_datadir}/applications/*
  115. %{_datadir}/glade3
  116. %{_datadir}/gtk-doc/html/gladeui
  117. %{_datadir}/gnome/help/%{helpdir}
  118. %{_datadir}/icons/hicolor/*/apps/glade-3.png
  119. %{_datadir}/icons/hicolor/scalable/apps/glade-3.svg
  120. %{_datadir}/omf/%{helpdir}
  121. %files devel
  122. %defattr(-,root,root)
  123. %{_includedir}/libgladeui-1.0/gladeui/*
  124. %{_libdir}/pkgconfig/*.pc
  125. %{_libdir}/libgladeui-1.so
  126. %changelog
  127. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.7-4
  128. - rebuild with rpm-4.8.1 for pkg-config file
  129. - add BuildRequires: libSM-devel
  130. * Fri Nov 06 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-3
  131. - add gnome-doc-utils to BR
  132. - comment out desktop-file-install
  133. * Tue Nov 03 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-2
  134. - rebuild with gtk2-2.18.2
  135. * Sat Aug 01 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.6.7-1
  136. - new upstream release
  137. - care ld and icon cache
  138. - define helpdir
  139. * Sun May 17 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.3-1
  140. - new upstream release
  141. - spec in utf-8 (fixed)
  142. * Fri May 01 2009 Shu KONNO <owa@bg.wakwak.com> 3.6.2-2
  143. - spec in utf-8
  144. * Sun Apr 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.6.2-1
  145. - new upstream release
  146. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 3.5.2-1
  147. - new upstream version.
  148. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.5-1
  149. - new upstream version.
  150. - update Requires.
  151. - update description.
  152. * Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-2vl5
  153. - use macro for release
  154. * Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.4.1-1vl5
  155. - apply new virsioning policy.
  156. - remove *.la
  157. * Fri Jan 04 2008 Shu KONNO <owa@bg.wakwak.com> 3.4.1-0vl
  158. - new upstream version
  159. - added Requires: devhelp
  160. - added Prereq: scrollkeeper
  161. - added disable-scrollkeeper to configure
  162. - added scrollkeeper-update in %%post and %%postun sections
  163. - changed gnome help directory temporarily
  164. * Sun Dec 17 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.0.3-0vl
  165. - build for VineSeed