compiz-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782
  1. # build with kde4
  2. %bcond_with kde
  3. %define dialogversion 0.7.18
  4. %define kde_dialogversion 0.0.5
  5. %define core_plugins blur clone commands cube dbus decoration fade ini inotify minimize move obs place png regex resize rotate scale screenshot switcher video water wobbly zoom fs
  6. %define gnome_plugins annotate gconf glib svg gnomecompat
  7. # List of plugins passed to ./configure. The order is important
  8. %define plugins core,glib,gconf,dbus,png,svg,video,screenshot,decoration,clone,place,fade,minimize,move,resize,switcher,scale,wall
  9. Summary: OpenGL window and compositing manager
  10. Summary(ja): OpenGL ウィンドウ・コンポジットマネージャ
  11. Name: compiz
  12. URL: http://www.go-compiz.org
  13. License: X11/MIT/GPL
  14. Group: User Interface/Desktops
  15. Version: 0.8.6
  16. Release: 2%{?_dist_release}
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  18. # libdrm is not available on these arches
  19. ExcludeArch: s390 s390x ppc64
  20. Requires: xorg-x11-server-Xorg
  21. Requires: mesa-libGL
  22. Requires(post): desktop-file-utils
  23. BuildRequires: libX11-devel, libdrm-devel, libwnck-devel
  24. BuildRequires: libXfixes-devel, libXrandr-devel, libXrender-devel
  25. BuildRequires: libXcomposite-devel, libXdamage-devel, libXext-devel
  26. BuildRequires: libXt-devel, libXmu-devel, libICE-devel, libSM-devel
  27. BuildRequires: control-center-devel, GConf2-devel
  28. BuildRequires: gnome-desktop-devel >= 2.30.0
  29. BuildRequires: metacity-devel
  30. BuildRequires: desktop-file-utils
  31. BuildRequires: intltool >= 0.35
  32. BuildRequires: gettext
  33. BuildRequires: dbus-devel
  34. BuildRequires: librsvg2-devel
  35. BuildRequires: mesa-libGLU-devel
  36. BuildRequires: fuse-devel
  37. %if %{with kde}
  38. BuildRequires: kdebase-workspace-devel
  39. BUildRequires: dbus-qt-devel
  40. %endif
  41. Source0: http://releases.compiz.org/%{version}/%{name}-%{version}.tar.bz2
  42. Source1: desktop-effects-%{dialogversion}.tar.bz2
  43. Source2: kde-desktop-effects-%{kde_dialogversion}.tar.bz2
  44. Source3: compiz-gtk
  45. Source4: compiz-gtk.desktop
  46. # Make sure that former beryl users still have bling
  47. Obsoletes: beryl-core
  48. # Patches from fedora
  49. Patch102: desktop-effects-0.7.17-wall-plugin.patch
  50. Patch103: composite-cube-logo.patch
  51. Patch111: gconf-core-plugin-loopfix.patch
  52. # Make sure configuration plugins never get unloaded
  53. Patch123: compiz-0.7.8-pin-initial-plugins.patch
  54. # Patches from ubuntu
  55. Patch200: 014-fix-gtk-window-decorator-no-argb-crash.patch
  56. Patch210: 049-damage-report-non-empty.patch
  57. # build fix
  58. Patch300: compiz-0.8.2-gconf-buildfix.patch
  59. %description
  60. Compiz is one of the first OpenGL-accelerated compositing window
  61. managers for the X Window System. The integration allows it to perform
  62. compositing effects in window management, such as a minimization
  63. effect and a cube workspace. Compiz is an OpenGL compositing manager
  64. that use Compiz use EXT_texture_from_pixmap OpenGL extension for
  65. binding redirected top-level windows to texture objects.
  66. %package devel
  67. Summary: Development packages for compiz
  68. Summary(ja): compiz の開発パッケージ
  69. Group: Development/Libraries
  70. Requires: compiz = %{version}-%{release}
  71. Requires: pkgconfig
  72. Requires: libXcomposite-devel libXfixes-devel libXdamage-devel libXrandr-devel
  73. Requires: libXinerama-devel libICE-devel libSM-devel libxml2-devel
  74. Requires: libxslt-devel startup-notification-devel
  75. %description devel
  76. The compiz-devel package includes the header files,
  77. and developer docs for the compiz package.
  78. Install compiz-devel if you want to develop plugins for the compiz
  79. windows and compositing manager.
  80. %package gnome
  81. Summary: Compiz gnome integration bits
  82. Summary(ja): Compiz gnome integration bits
  83. Group: User Interface/Desktops
  84. Requires: gnome-session
  85. Requires: metacity
  86. Requires: libwnck
  87. Requires: glx-utils
  88. Requires: %{name} = %{version}
  89. Requires(pre): GConf2
  90. Requires(post): GConf2
  91. Requires(preun): GConf2
  92. Obsoletes: compiz < 0.5.2-8
  93. Obsoletes: beryl-gnome
  94. %description gnome
  95. The compiz-gnome package contains gtk-window-decorator,
  96. and other gnome integration related stuff.
  97. %if %{with kde}
  98. %package kde
  99. Summary: Compiz kde integration bits
  100. Summary(ja): Compiz kde integration bits
  101. Group: User Interface/Desktops
  102. Requires: %{name} = %{version}
  103. Requires: compiz-manager
  104. Obsoletes: beryl-kde
  105. %description kde
  106. The compiz-kde package contains kde-window-decorator,
  107. and other kde integration related stuff.
  108. %endif
  109. %prep
  110. %setup -q -T -b1 -n desktop-effects-%{dialogversion}
  111. #%setup -q -T -b2 -n kde-desktop-effects-%{kde_dialogversion}
  112. %setup -q
  113. pushd ../desktop-effects-%{dialogversion}
  114. %patch102 -p1 -b .wall-plugin
  115. popd
  116. %patch103 -p1 -b .composite-cube-logo
  117. %patch111 -p1 -b .gconf-core-loop
  118. ## %patch123 -p1 -b .initial-plugins
  119. %patch200 -p1 -b .fix-gtk-window-decorator-no-argb-crash
  120. %patch210 -p1 -b .damage-report-non-empty
  121. ## %patch300 -p1 -b .gconf-buildfix
  122. %build
  123. rm -rf $RPM_BUILD_ROOT
  124. CPPFLAGS="$CPPFLAGS -I$RPM_BUILD_ROOT%{_includedir}"
  125. export CPPFLAGS
  126. #needed to find kde4 libs
  127. #LDFLAGS="$LDFLAGS -L%{_libdir}/kde4/devel"
  128. #export LDFLAGS
  129. libtoolize
  130. autoreconf
  131. %configure \
  132. %{?with_kde: --enable-kde4 } \
  133. %{!?with_kde: --disable-kde4 } \
  134. --disable-kde \
  135. --enable-gconf \
  136. --enable-dbus \
  137. --enable-place \
  138. --enable-librsvg \
  139. --enable-gtk \
  140. --enable-metacity \
  141. --enable-gnome \
  142. --with-default-plugins=%{plugins} \
  143. --enable-gnome-keybindings
  144. make %{?_smp_mflags} imagedir=%{_datadir}/pixmaps
  145. # desktop-effects
  146. cd ../desktop-effects-%{dialogversion}
  147. %configure
  148. %install
  149. rm -rf $RPM_BUILD_ROOT
  150. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  151. make DESTDIR=$RPM_BUILD_ROOT install || exit 1
  152. unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
  153. echo INSTALLING DESKTOP EFFECTS
  154. pushd ../desktop-effects-%{dialogversion}
  155. make DESTDIR=$RPM_BUILD_ROOT install || exit 1
  156. #desktop-file-install --vendor vine --delete-original \
  157. # --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  158. # $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  159. rm -f $RPM_BUILD_ROOT%{_datadir}/applications/desktop-effects.desktop
  160. popd
  161. # install compiz-gtk/compiz-gtk.desktop
  162. install %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}
  163. desktop-file-install --vendor="" \
  164. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  165. %{SOURCE4}
  166. %if %{with kde}
  167. # kde-desktop-effects
  168. echo INSTALLING KDE DESKTOP EFFECTS
  169. pushd ../kde-desktop-effects-%{kde_dialogversion}
  170. cp -a kde-desktop-effects.sh $RPM_BUILD_ROOT/%{_bindir}/
  171. mkdir -p $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  172. cp -a ChangeLog COPYING README $RPM_BUILD_ROOT/%{_docdir}/compiz-kde-%{version}
  173. iconlist="16 24 32 36 48 96"
  174. for i in $iconlist; do
  175. mkdir -p $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/
  176. cp -p ../desktop-effects-%{dialogversion}/desktop-effects$i.png $RPM_BUILD_ROOT/%{_datadir}/icons/hicolor/$i\x$i/apps/kde-desktop-effects.png
  177. done
  178. desktop-file-install --vendor="" \
  179. --dir=%{buildroot}%{_datadir}/applications/kde \
  180. kde-desktop-effects.desktop
  181. popd
  182. %endif
  183. %if !%{with kde}
  184. rm -f $RPM_BUILD_ROOT%{_datadir}/compiz/kconfig.xml
  185. %endif
  186. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
  187. find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} ';'
  188. %find_lang compiz
  189. %find_lang desktop-effects
  190. cat compiz.lang > core-files.txt
  191. cat desktop-effects.lang > gnome-files.txt
  192. for f in %{core_plugins}; do
  193. echo %{_libdir}/compiz/lib$f.so
  194. echo %{_datadir}/compiz/$f.xml
  195. done >> core-files.txt
  196. for f in %{gnome_plugins}; do
  197. echo %{_libdir}/compiz/lib$f.so
  198. echo %{_datadir}/compiz/$f.xml
  199. done >> gnome-files.txt
  200. %post -p /sbin/ldconfig
  201. %postun -p /sbin/ldconfig
  202. %post gnome
  203. update-desktop-database -q %{_datadir}/applications
  204. export GCONF_CONFIG_SOURCE=`/usr/bin/gconftool-2 --get-default-source`
  205. for f in %{core_plugins} %{gnome_plugins} core; do
  206. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  207. | xargs gconftool-2 --makefile-install-rule >& /dev/null || :
  208. gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  209. touch --no-create %{_datadir}/icons/hicolor
  210. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  211. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  212. fi
  213. %pre gnome
  214. if [ "$1" -gt 1 ]; then
  215. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  216. for f in %{core_plugins} %{gnome_plugins} core; do
  217. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  218. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  219. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  220. fi
  221. %preun gnome
  222. if [ "$1" -eq 0 ]; then
  223. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  224. for f in %{core_plugins} %{gnome_plugins} core; do
  225. echo %{_sysconfdir}/gconf/schemas/compiz-${f}.schemas; done \
  226. | xargs gconftool-2 --makefile-uninstall-rule >& /dev/null || :
  227. gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/gwd.schemas >& /dev/null || :
  228. fi
  229. %postun gnome
  230. touch --no-create %{_datadir}/icons/hicolor
  231. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  232. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  233. fi
  234. %if %{with kde}
  235. %post kde
  236. update-desktop-database -q %{_datadir}/applications/kde
  237. touch --no-create %{_datadir}/icons/hicolor
  238. %postun kde
  239. touch --no-create %{_datadir}/icons/hicolor
  240. %endif
  241. %clean
  242. rm -rf $RPM_BUILD_ROOT
  243. %files -f core-files.txt
  244. %defattr(-, root, root)
  245. %doc AUTHORS ChangeLog COPYING* README TODO
  246. %{_bindir}/compiz
  247. %{_libdir}/libdecoration.so.*
  248. %dir %{_libdir}/compiz
  249. %dir %{_datadir}/compiz
  250. %{_datadir}/compiz/*.png
  251. %{_datadir}/compiz/core.xml
  252. %files gnome -f gnome-files.txt
  253. %defattr(-, root, root)
  254. %{_bindir}/gtk-window-decorator
  255. %{_bindir}/compiz-gtk
  256. %{_bindir}/desktop-effects
  257. %{_libdir}/window-manager-settings/libcompiz.so
  258. %{_datadir}/gnome/wm-properties/compiz-wm.desktop
  259. %{_datadir}/applications/compiz.desktop
  260. %{_datadir}/gnome-control-center/keybindings/50-compiz-desktop-key.xml
  261. %{_datadir}/gnome-control-center/keybindings/50-compiz-key.xml
  262. %{_datadir}/compiz/desktop-effects.glade
  263. %{_datadir}/applications/compiz-gtk.desktop
  264. #{_datadir}/applications/vine-desktop-effects.desktop
  265. %{_datadir}/icons/hicolor/16x16/apps/desktop-effects.png
  266. %{_datadir}/icons/hicolor/24x24/apps/desktop-effects.png
  267. %{_datadir}/icons/hicolor/32x32/apps/desktop-effects.png
  268. %{_datadir}/icons/hicolor/36x36/apps/desktop-effects.png
  269. %{_datadir}/icons/hicolor/48x48/apps/desktop-effects.png
  270. %{_datadir}/icons/hicolor/96x96/apps/desktop-effects.png
  271. %{_sysconfdir}/gconf/schemas/*.schemas
  272. %if %{with kde}
  273. %files kde
  274. %defattr(-, root, root)
  275. %{_bindir}/kde4-window-decorator
  276. %{_docdir}/compiz-kde-%{version}
  277. %{_bindir}/kde-desktop-effects.sh
  278. %{_datadir}/applications/kde/kde-desktop-effects.desktop
  279. %{_datadir}/icons/hicolor/*/apps/kde-desktop-effects.png
  280. %{_datadir}/compiz/kconfig.xml
  281. %endif
  282. %files devel
  283. %defattr(-, root, root)
  284. %{_libdir}/pkgconfig/compiz.pc
  285. %{_libdir}/pkgconfig/libdecoration.pc
  286. %{_libdir}/pkgconfig/compiz-cube.pc
  287. %{_libdir}/pkgconfig/compiz-gconf.pc
  288. %{_libdir}/pkgconfig/compiz-scale.pc
  289. %{_datadir}/compiz/schemas.xslt
  290. %{_includedir}/compiz
  291. %{_libdir}/libdecoration.so
  292. %changelog
  293. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-2
  294. - rebuild with rpm-4.8.1 for pkg-config file
  295. * Sat Apr 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.8.6-1
  296. - new upstream release (build on GNOME-2.30)
  297. - drop Patch123, Patch300
  298. * Sat Nov 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-4
  299. - rebuild with mesa-7.6
  300. - add Patch300 to build with gconf-2.28
  301. * Thu Jun 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-3
  302. - disable glib plugin in compiz-gtk
  303. - use direct rendering on virtualbox video adaptor.
  304. * Tue May 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-2
  305. - add Requires: glx-utils to compiz-gnome
  306. * Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.2-1
  307. - new upstream release
  308. * Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-8
  309. - re-enable metacity decoration on gtk-window-decorator
  310. - BR: metacity-devel instead of metacity
  311. * Fri May 01 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.7.8-7
  312. - fix pre/post scripts for speeding up gconf schema installation
  313. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-6
  314. - add ccp compiz option to compiz-gtk
  315. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-5
  316. - remove desktop-effect.desktop
  317. - we use gnome-appearance-properties integrated version.
  318. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-4
  319. - add Patch121,122 from upstream fix.
  320. - add Patch123: make sure configuration plugins never get unloaded
  321. - add Patch124: memleak fix from upstream
  322. - add Patch125: make the terminal keybind work
  323. - add Patch120,126,127 for kde42
  324. - add Patch128: gwd fix from upstream
  325. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-3
  326. - rebuild with gnome-desktop-2.26.0
  327. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-2
  328. - add compiz-gtk scripts and desktop file from fedora
  329. * Thu Oct 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.8-1
  330. - new upstream release
  331. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-2
  332. - rebuild with gnome-desktop-2.24.0
  333. * Wed Jun 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.6-1
  334. - new upstream release
  335. * Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.4-1
  336. - new upstream release
  337. * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.2-1
  338. - initial build for Vine Linux
  339. * Thu Mar 27 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-3
  340. - Fix gconf plugin loop RH #438794, patch based on
  341. older one from Guillaume Seguin
  342. - Add core to default plugin list
  343. * Wed Mar 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 0.7.2-2
  344. - Reword kde-desktop-effects messages to mention Compiz by name (#438883)
  345. * Mon Mar 24 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.7.2-1
  346. - Update to 0.7.2
  347. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.6.2-7
  348. - Autorebuild for GCC 4.3
  349. * Thu Jan 17 2008 Kristian H淡gsberg <krh@redhat.com> - 0.6.2-6
  350. - Update to desktop-effects version 0.7.17 which include more
  351. translations and move desktop-effects translations to compiz-gnome.
  352. - Fix spelling in beryl-core obsoletes.
  353. * Mon Jan 07 2008 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-5
  354. - Update buildrequires (kwd uses the kde3 api)
  355. * Tue Nov 6 2007 Stepan Kasal <skasal@redhat.com> - 0.6.2-4
  356. - Fix a typo in description of the main package.
  357. - All descriptions should end with a dot (unlike the summary line)
  358. * Thu Oct 25 2007 Sebastian Vahl <fedora@deadbabylon.de> - 0.6.2-3
  359. - Include kde-desktop-effects in kde subpackage
  360. * Tue Oct 23 2007 Adel Gadllah <adel.gadllah@gmail.com> - 0.6.2-2
  361. - Obsolete berly-core
  362. * Mon Oct 22 2007 Warren Togami <wtogami@redhat.com> - 0.6.2-1
  363. - 0.6.2
  364. * Fri Oct 12 2007 Kristian H淡gsberg <krh@redhat.com> - 0.6.0-2
  365. - Disable scale corner initiate and install a GNOME key config entry.
  366. * Wed Oct 10 2007 Warren Togami <wtogami@redhat.com> - 0.6.0-1
  367. - 0.6.0 final
  368. - always-restack-windows-on-map
  369. * Tue Oct 9 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-14
  370. - Make compiz behave with gnome-terminal (#304051)
  371. * Fri Oct 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.5.2-13
  372. - Also install gwd.schemas (#319621)
  373. * Thu Sep 20 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-12
  374. - Update to more recent 0.6 branch snapshot (fixes #253575).
  375. * Fri Sep 14 2007 Warren Togami <wtogami@redhat.com> - 0.5.2-11
  376. - compiz-gnome: install core schema so it actually works
  377. - remove unnecessary gconf stuff from %%install
  378. * Tue Aug 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-9
  379. - Make compiz-gnome Obsolete the older compiz package so yum/anaconda
  380. will pull it in (thans to Adel Gadllah).
  381. * Wed Aug 22 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-8
  382. - Bump to desktop-effects 0.7.7 to avoid kill decorator when popping
  383. up dialog.
  384. - Fix broken gconf install and uninstall rules.
  385. - Pick up shadowman logo for RHEL builds (#232398).
  386. * Tue Aug 21 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-7.0ec3ec
  387. - Add more-sm-junk.patch so we set SM restart style to
  388. SmRestartIfRunning on exit (#247163, #245971).
  389. - Add Requires to compiz-devel (#253407).
  390. - Update to desktop-effects 0.7.6, which terminates decorator when
  391. switching to metacity or on compiz failure (#215247, #215032).
  392. * Fri Aug 17 2007 Adel Gadllah <adel.gadllah@gmail.com> 0.5.2-6.0ec3ec
  393. - Split into gnome and kde subpackages
  394. - Minor cleanups
  395. * Wed Aug 15 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-5.0ec3ec
  396. - Reorder plugin list to avoid 'place' getting removed on startup.
  397. - Add run-command-key.patch to put the run command key in the GNOME
  398. keyboard shortcut dialog (#213576).
  399. - Drop a bunch of obsolete patches.
  400. - Bump mesa-libGL and X server requires to fix TFP bugs for
  401. power-of-two textures (#251935).
  402. - Rebase fedora-logo and composite-cube-logo patch.
  403. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-4.0ec3ec
  404. - Build with desktop-effects so we don't pick up metacity work spaces.
  405. Fixes #250568.
  406. * Tue Aug 14 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3.0ec3ec
  407. - Build git snapshot from fedora branch at
  408. git://people.freedesktop.org/~krh/compiz, brances from 0.6 upstream
  409. branch.
  410. - Fixes #237486.
  411. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-3
  412. - Require desktop-effects 0.7.3 and gnome-session 2.19.6-5 which pass
  413. 'glib' on the command line too.
  414. * Fri Aug 10 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-2
  415. - Move xml meta data files to main package.
  416. * Thu Aug 9 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.2-1
  417. - Update to 0.5.2.
  418. - Require at least gnome-session 2.19.6-2 so gnome-wm starts compiz
  419. with LIBGL_ALWAYS_INDIRECT set.
  420. * Wed Jun 27 2007 Kristian H淡gsberg <krh@redhat.com> - 0.5.0-1
  421. - Update to 0.5.0
  422. * Tue Jun 5 2007 Matthias Clasen <mclasen@redhat.com> - 0.4.0-1
  423. - Update to 0.4.0
  424. * Mon Jun 4 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-10
  425. - Rebuild against new libwnck
  426. * Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 0.3.6-9
  427. - Don't install INSTALL
  428. * Mon Apr 16 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-8
  429. - Update metacity build requires to metacity-devel.
  430. * Wed Apr 4 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 0.3.6-7
  431. - Fix typo in ./configure option.
  432. * Wed Apr 4 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-6
  433. - Add place and clone plugins to default plugin list.
  434. * Wed Mar 28 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-5
  435. - Update URL (#208214).
  436. - Require at least metacity 2.18 (#232831).
  437. - Add close-session.patch to deregister from SM when replaced (#229113).
  438. * Tue Mar 27 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6-4
  439. - Explicitly disable KDE parts (#234128).
  440. * Mon Mar 26 2007 Matthias Clasen <mclasen@redhat.com> 0.3.6-3
  441. - Fix some directory ownership issues (#233825)
  442. - Small spec cleanups
  443. * Tue Feb 6 2007 Kristian H淡gsberg <krh@redhat.com> 0.3.6
  444. - Require gnome-session > 2.16 so it starts gtk-window-decorator.
  445. - Update to desktop-effects 0.7.1 that doesn't refuse to work with Xinerama.
  446. * Tue Jan 16 2007 Kristian H淡gsberg <krh@redhat.com> - 0.3.6-1
  447. - Update to 0.3.6, update patches.
  448. - Drop autotool build requires.
  449. - Drop glfinish.patch, cow.patch, resize-offset.patch and icon-menu-patch.
  450. - Add libdecoration.so
  451. - Update to desktop-effects-0.7.0, which spawns the right decorator
  452. and plays nicely with unknown plugins.
  453. * Sat Nov 25 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-2
  454. - Update the fedora logo patch (#217224)
  455. * Thu Nov 23 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.4-1
  456. - Update to 0.3.4
  457. * Wed Nov 15 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-2
  458. - Use cow by default, bug 208044
  459. * Fri Nov 10 2006 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
  460. - Update to 0.3.2
  461. - Drop upstreamed patches
  462. - Work with new metacity theme api
  463. * Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.32.20060818git.fc6
  464. - Install the .desktop file with desktop-file-install. Add X-Red-Hat-Base to make it appear in "Preferences", rather than "More Preferences".
  465. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  466. - Add buildrequires on intltool
  467. * Sat Sep 30 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.31.20060818git.fc6
  468. - Build
  469. * Fri Sep 29 2006 Soren Sandmann <sandmann@redhat.com>
  470. - Update to desktop-effects-0.6.163, which has translation enabled. (Bug 208257)
  471. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.30.20060817git.fc6
  472. - Add patch to terminate keyboard moves when a mouse buttons is pressed. (Bug 207792).
  473. * Thu Sep 28 2006 Soren Sandmann <sandmann@redhat.com>
  474. - Change default plugin list to not include the plane plugin. (Bug 208448).
  475. - Change default keybinding for shrink to be Pause (Bug 206187).
  476. * Wed Sep 27 2006 Soren Sandmann <sandmann@redhat.com>
  477. - Add patch to show a menu when the window icon is clicked. (Bug 201629).
  478. * Tue Sep 26 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.29.20060817git.fc6
  479. - Add restart.patch to make compiz ask the session manager to restart it
  480. if it crashes (bug 200280).
  481. * Mon Sep 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.28.20060817git.fc6
  482. - Change plane.patch to not do cyclical window movement in dimensions
  483. where the desktop has size 1 (bug 207263).
  484. * Thu Sep 21 2006 Soren Sandmann <sandmann@redhat.com>
  485. - Add patch to fix resizing smaller than minimum size (resize-offset.patch, bug 201623).
  486. * Tue Sep 19 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.27.20060817git.fc6
  487. - Change .plane patch to
  488. (a) not set the background color to pink in the plane plugin.
  489. (b) allow workspaces with horizontal sizes less then 4.
  490. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.26.20060817git.fc6
  491. - Change plane patch to correctly initialize the screen size to the
  492. defaults (bug 206088).
  493. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  494. - Run update-desktop-database and gtk-update-icon-cache in post. Add icons
  495. to list of packaged files. Also bump to 0.6.137 of dialog (which just makes
  496. directories before attempting to install to them).
  497. * Mon Sep 18 2006 Soren Sandmann <sandmann@redhat.com>
  498. - Upgrade to 0.6.107 of the desktop-effects dialog box. Only change is
  499. that the new version has icons.
  500. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  501. - Add patch to fix mispositioning of window decorator event windows (bug 201624)
  502. * Fri Sep 15 2006 Soren Sandmann <sandamnn@redhat.com>
  503. - Upgrade to version 0.6.83 of desktop-effects. (bug 206500)
  504. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  505. - Add patch to only accept button 1 for close/minimize/maximize (bug 201628)
  506. * Fri Sep 15 2006 Soren Sandmann <sandmann@redhat.com>
  507. - Add patch to fix thumbnail sorting (bug 201605)
  508. * Thu Sep 14 2006 Soren Sandmann <sandmann@redhat.com>
  509. - Add patch to fix double clicking (bug 201783).
  510. * Tue Sep 12 2006 Soren Sandmann <sandmann@redhat.com>
  511. - Don't attempt to move the viewport when dx = dy = 0.(last bit of 206088).
  512. * Tue Sep 12 2006 Soren Sandmann <sandamnn@redhat.com>
  513. - Fix plane.patch to draw correctly when no timeout is running. (206088).
  514. * Wed Sep 6 2006 Kristian H淡gsberg <krh@redhat.com>
  515. - Update fbconfig-depth-fix.patch to also skip fbconfigs without
  516. corresponding visuals.
  517. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.25.20060817git.fc6
  518. - Make number of vertical size configurable
  519. * Tue Sep 5 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.24.20060817git.fc6
  520. - Fix vertical viewport support in the plane patch.
  521. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.23.20060817git.fc6
  522. - Upgrade to 0.6.61 of the dialog
  523. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  524. - Add libtool to BuildRequires
  525. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  526. - Add automake and autoconf to BuildRequires
  527. * Fri Sep 1 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.22.20060817git.fc6
  528. - Add a patch to put viewports on a plane.
  529. * Wed Aug 30 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.21.20060817git.fc6
  530. - Drop gl-include-inferiors.patch now that compiz uses COW and the X
  531. server evicts offscreen pixmaps automatically on
  532. GLX_EXT_texture_from_pixmap usage.
  533. * Tue Aug 29 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.20.20060817git.fc6
  534. - Add cow.patch to make compiz use the composite overlay window.
  535. * Fri Aug 25 2006 Soren Sandmann <sandmann@redhat.com> - 0.0.13-0.19-20060817git.fc6
  536. - Rebase to desktop-effects 0.6.41
  537. * Fri Aug 25 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.18.20060817git.fc6
  538. - Rebase to desktop-effects 0.6.19 and drop
  539. desktop-effects-0.6.1-delete-session.patch
  540. * Tue Aug 22 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.17.20060817git.fc6
  541. - Add patch from upstream to also use sync protocol for override
  542. redirect windows (sync-override-redirect-windows.patch).
  543. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.16.20060817git.fc6
  544. - Rebase to latest upstream changes which has the rest of the bindings
  545. rewrite. Add resize-move-keybindings.patch to make move and resize
  546. bindings work like metacity.
  547. - Add back scale plugin.
  548. * Thu Aug 10 2006 Ray Strode <rstrode@redhat.com> 0.0.13-0.15.20060721git.fc5.aiglx
  549. - Add Requires: gnome-session 2.15.90-2.fc6 (bug 201473)
  550. - unlink session file on changing wms (bug 201473)
  551. * Thu Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.14.20060721git.fc5.aiglx
  552. - Add Requires: gnome-session 2.15.4-3
  553. * Wed Aug 3 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  554. - New version of dialog box. Macro the version number.
  555. * Wed Aug 2 2006 Soren Sandmann <sandmann@redhat.com> 0.0.13-0.13.20060721git.fc5.aiglx
  556. - Add 'desktop effects' dialog box.
  557. * Mon Jul 31 2006 Kristian H淡gsberg <krh@redhat.com> 0.0.13-0.12.20060721git.fc5.aiglx
  558. - Add libwnck requires.
  559. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.11.20060721git.fc5.aiglx
  560. - Bump and build for fc5 AIGLX repo.
  561. * Wed Jul 26 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.12.20060721git
  562. - Fix gconf hooks.
  563. * Tue Jul 25 2006 Kristian H淡gsberg <krh@redhat.com>
  564. - Require system-logos instead.
  565. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.10.20060721git
  566. - Bump version to work around tagging weirdness.
  567. * Mon Jul 24 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.9.20060721git
  568. - Add devel package and require redhat-logos instead of fedora-logos (#199757).
  569. * Fri Jul 21 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.8.20060720git
  570. - Add workaround for AIGLX throttling problem.
  571. * Thu Jul 20 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-0.7.20060720git
  572. - Drop scale plugin from snapshot.
  573. * Tue Jul 18 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.6.20060717git
  574. - Don't build on s390
  575. * Mon Jul 17 2006 Matthias Clasen <mclasen@redhat.com> - 0.0.13-0.5.20060717git
  576. - Do some changes forced upon us by package review
  577. * Thu Jul 13 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13-5.1
  578. - Use sane numbering scheme.
  579. * Fri Jul 7 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-4
  580. - Drop the fullscreen hardcode patch and require X server that has
  581. GLX_MESA_copy_sub_buffer.
  582. * Tue Jun 27 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-3
  583. - Unbreak --replace.
  584. * Thu Jun 15 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-2
  585. - Add Requires, fix start-compiz.sh.
  586. * Wed Jun 14 2006 Kristian H淡gsberg <krh@redhat.com> - 0.0.13.fedora1-1
  587. - Spec file for compiz, borrowing bits and pieces from Alphonse Van
  588. Assches spec file (#192432).