kdemultimedia-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612
  1. Name: kdemultimedia
  2. Summary: KDE multimedia applications
  3. Summary(ja): KDE マルチメディアアプリケーション集
  4. Version: 4.7.0
  5. Release: 1%{?_dist_release}
  6. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdemultimedia-%{version}.tar.bz2
  7. # Vine Patches
  8. # build with taglib < 1.6
  9. Patch700: kdemultimedia-4.4.5-juk_taglib.patch
  10. # not build with ffmpeg
  11. Patch701: kdemultimedia-4.6.0-noffmpeg.patch
  12. License: GPLv2+
  13. Group: Applications/Multimedia
  14. URL: http://www.kde.org/
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. # This one is normal, FLAC_OGG_LIBRARY is not actually used anyway:
  17. # FLAC_OGG_LIBRARY:FILEPATH=FLAC_OGG_LIBRARY-NOTFOUND
  18. BuildRequires: alsa-lib-devel
  19. BuildRequires: cdparanoia-devel
  20. BuildRequires: flac-devel
  21. BuildRequires: glib2-devel
  22. BuildRequires: kdebase-workspace-devel >= %{version}
  23. BuildRequires: kdelibs4-devel
  24. BuildRequires: libtheora-devel
  25. ## needed to build Kscd, keep for now -- Kevin
  26. #BuildRequires: libtunepimp-devel
  27. BuildRequires: libmusicbrainz3-devel
  28. BuildRequires: libvorbis-devel
  29. # KMix PulseAudio integration is not anywhere near shippable.
  30. # Almost everything is commented out, it basically does nothing.
  31. BuildRequires: pulseaudio-libs-devel
  32. BuildRequires: soprano-devel
  33. BuildRequires: taglib-devel
  34. BuildRequires: xine-lib-devel libxcb-devel
  35. Requires: %{name}-libs = %{version}-%{release}
  36. Requires: kdelibs4 >= %{version}
  37. Requires: kdebase-workspace >= %{version}
  38. Provides: dragonplayer = 2.0.2-0.1
  39. Obsoletes: dragonplayer < 2.0.2-0.1
  40. Obsoletes: %{name}-extras < %{version}-%{release}
  41. Obsoletes: kmidi koncd
  42. Provides: kdemultimedia4 = %{version}-%{release}
  43. Obsoletes: kdemultimedia4 < %{version}-%{release}
  44. %description
  45. Multimedia applications for the K Desktop Environment.
  46. What it is
  47. ----------
  48. * dragonplayer (a simple video player)
  49. * juk (a music manager and player)
  50. * kmix (an audio mixer)
  51. * kscd (an Audio-CD player)
  52. %package libs
  53. Summary: Runtime libraries for %{name}
  54. Summary(ja): %{name} のランタイムライブラリ
  55. Group: System Environment/Libraries
  56. License: LGPLv2+ and GPLv2+
  57. Obsoletes: %{name}-extras-libs < %{version}-%{release}
  58. Conflicts: dragonplayer < 2.0.2-0.1
  59. %description libs
  60. %{summary}.
  61. %package devel
  62. Summary: Developer files for %{name}
  63. Summary(ja): %{name} の開発用ファイル
  64. Group: Development/Libraries
  65. Requires: %{name}-libs = %{version}-%{release}
  66. Requires: kdelibs4-devel
  67. Provides: kdemultimedia4-devel = %{version}-%{release}
  68. Obsoletes: kdemultimedia4-devel < %{version}-%{release}
  69. %description devel
  70. %{summary}.
  71. %prep
  72. %setup -q -n kdemultimedia-%{version}
  73. %if %{?_dist_release} == "vl5"
  74. %patch700 -p1 -b .taglib
  75. %endif
  76. %patch701 -p1 -b .ffmpeg
  77. %build
  78. mkdir -p %{_target_platform}
  79. pushd %{_target_platform}
  80. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  81. %cmake \
  82. -DCMAKE_BUILD_TYPE=release \
  83. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  84. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  85. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  86. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  87. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  88. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  89. ..
  90. popd
  91. make %{?_smp_mflags} -C %{_target_platform}
  92. %install
  93. rm -rf $RPM_BUILD_ROOT
  94. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %post
  98. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  99. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  100. %posttrans
  101. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  102. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  103. update-desktop-database -q &> /dev/null ||:
  104. %postun
  105. if [ $1 -eq 0 ] ; then
  106. touch --no-create %{_datadir}/icons/hicolor &> /dev/null ||:
  107. touch --no-create %{_datadir}/icons/oxygen &> /dev/null ||:
  108. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
  109. gtk-update-icon-cache %{_datadir}/icons/oxygen &> /dev/null ||:
  110. update-desktop-database -q &> /dev/null ||:
  111. fi
  112. %post libs -p /sbin/ldconfig
  113. %postun libs -p /sbin/ldconfig
  114. %files
  115. %defattr(-,root,root)
  116. %{_bindir}/*
  117. %{_datadir}/kde4/apps/dragonplayer
  118. %{_datadir}/kde4/apps/juk
  119. %{_datadir}/kde4/apps/kmix
  120. %{_datadir}/kde4/apps/kconf_update/*
  121. %{_datadir}/kde4/apps/konqsidebartng
  122. %{_datadir}/kde4/apps/kscd
  123. %{_datadir}/kde4/apps/plasma/services/mixer.operations
  124. %{_datadir}/kde4/apps/solid/actions/dragonplayer-opendvd.desktop
  125. %{_datadir}/kde4/apps/solid/actions/kscd-play-audiocd.desktop
  126. %{_datadir}/kde4/apps/solid/actions/solid_audiocd.desktop
  127. %{_datadir}/kde4/apps/videothumbnail/
  128. %{_datadir}/config/dragonplayerrc
  129. %{_datadir}/applications/kde4/*
  130. %{_datadir}/autostart/*
  131. %{_datadir}/kde4/services/*
  132. %{_datadir}/config.kcfg/*
  133. %{_datadir}/dbus-1/interfaces/*
  134. %{_docdir}/HTML/en/dragonplayer/
  135. %{_docdir}/HTML/en/juk/
  136. %{_docdir}/HTML/en/kcontrol/
  137. %{_docdir}/HTML/en/kioslave/
  138. %{_docdir}/HTML/en/kmix/
  139. %{_datadir}/icons/hicolor/*/*/*
  140. %{_datadir}/icons/oxygen/*/actions/player-volume-muted.*
  141. %{_datadir}/icons/oxygen/*/actions/kscd-dock.*
  142. %{_libdir}/libkdeinit*.so
  143. %files libs
  144. %defattr(-,root,root,-)
  145. %{_libdir}/lib*.so.*
  146. %{_libdir}/kde4/*
  147. %files devel
  148. %defattr(-,root,root)
  149. %{_includedir}/kde4/audiocdencoder.h
  150. %{_includedir}/kde4/libkcddb
  151. %{_includedir}/kde4/libkcompactdisc
  152. %{_libdir}/lib*.so
  153. %exclude %{_libdir}/libkdeinit*.so
  154. %changelog
  155. * Thu Aug 4 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.7.0-1
  156. - new upstream release
  157. * Sun Jun 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.4-1
  158. - new upstream release
  159. * Sun Mar 13 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.1-1
  160. - new upstream release
  161. * Sun Feb 27 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-2
  162. - added BR: soprano-devel
  163. * Sun Feb 20 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
  164. - new upstream release
  165. - updated Patch701
  166. * Tue Aug 24 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
  167. - added Provides: kdemultimedia4
  168. - added Provides: kdemultimedia4-devel to devel package
  169. * Sat Aug 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  170. - new upstream release
  171. - added Patch701 to avoid link with ffmpeg
  172. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  173. - new upstream release
  174. - added Conflicts: kdemultimedia3
  175. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  176. - new upstream release
  177. * Wed Apr 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  178. - new upstream release
  179. * Sun Mar 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  180. - new upstream release
  181. * Sat Mar 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
  182. - new upstream release
  183. - built with new toolchain
  184. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  185. - new upstream release
  186. * Sun Oct 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-1
  187. - new upstream release
  188. * Mon Sep 7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  189. - new upstream release
  190. - used %%cmake macro
  191. * Sun Aug 30 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  192. - new upstream release
  193. - split libs sub-package
  194. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-3
  195. - added Japanese summary, spec in UTF-8
  196. - updated BR
  197. * Sat Mar 2 2009 TOSHI <milk-tea1977@dune.ocn.ne.jp> 3.5.8-2vl4
  198. - Change BuildPrereq: (Use BuildRequires)
  199. - Change BuildRequires: self-build-libmad
  200. - applied vine versioning policy
  201. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  202. - rebuild for VineSeed
  203. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  204. - new upstream release
  205. * Thu Sep 20 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl4
  206. - rebuild without acl
  207. * Tue Aug 21 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl3
  208. - rebuild with flac-1.2.0
  209. * Tue Jul 3 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  210. - rebuild for VineSeed
  211. - add BuildPrereq: cdparanoia-devel
  212. - delete our own copy of cdparanoia and BuildConflicts: cdparanoia-devel
  213. * Tue May 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  214. - new upstream release
  215. - enable-cdparanoia
  216. * Tue Jan 23 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  217. - new upstream release
  218. * Sun Oct 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.5-0vl3
  219. - added --with-qt-libraries and --enable-libsuffix option
  220. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  221. - rebuild for VineSeed
  222. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  223. - new upstream release
  224. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  225. - rebuild for VineSeed
  226. * Tue Aug 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  227. - new upstream release
  228. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  229. - rebuild for VineSeed
  230. * Wed May 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  231. - new upstream release
  232. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  233. - rebuild for VineSeed
  234. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  235. - new upstream release
  236. - remove BuildPrereq: gstreamer-plugins-devel
  237. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  238. - rebuild for VineSeed
  239. * Tue Jan 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  240. - new upstream release
  241. * Thu Dec 8 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl2
  242. - rebuild for VineSeed
  243. * Mon Nov 28 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl1
  244. - new upstream release
  245. * Mon Nov 14 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.0-0vl0.rc1
  246. - new upstream release
  247. - add --includedir=%%{_includedir}/kde to configure option
  248. * Mon Oct 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.92-0vl1
  249. - new upstream release
  250. * Tue Sep 20 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.91-0vl1
  251. - new upstream release
  252. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl4
  253. - rebuild for VineSeed
  254. * Thu Aug 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl3
  255. - rebuild with kdelibs-3.4.2
  256. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl2
  257. - build for VineSeed
  258. - add --disable-rpath to configure option
  259. - add alsa support for VineSeed
  260. * Mon Jun 6 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.1-0vl1
  261. - new upstream release
  262. - use %%{?_smp_mflags} for make option
  263. * Sat Mar 19 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl2
  264. - rebuild for VineSeed
  265. * Thu Mar 17 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.4.0-0vl1
  266. - new upstream release
  267. - change configure option
  268. - add BuildPrereq: gstreamer-plugins-devel libmad-devel
  269. * Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl3
  270. - rebuild with flac-1.1.2 (VineSeed)
  271. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl2
  272. - rebuild for VineSeed
  273. * Sat Jan 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.2-0vl1
  274. - new upstream release
  275. - move all files under %%{_libdir} to main package
  276. - add --sysconfdir=/etc to configure option
  277. - add /etc/xdg/menus/applications-merged/kde-multimedia-music.menu to %%files
  278. * Sat Oct 23 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl2
  279. - rebuild with flac-1.1.1 (VineSeed)
  280. * Thu Oct 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.3.1-0vl1
  281. - source upgrade
  282. - add patch0 again
  283. - update %%files
  284. * Wed Aug 11 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl2
  285. - rebuild with qt32
  286. * Mon Jun 14 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.3-0vl1
  287. - source upgrade
  288. - remove lines about vine26
  289. - add URL: http://www.kde.org/
  290. - remove patch0 and patch1
  291. - add BuildPrereq: audiofile-devel flac-devel taglib-devel gstreamer-devel
  292. - add BuildConflicts: cdparanoia-devel
  293. * Sat May 1 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.2-0vl1
  294. - source upgrade
  295. - kernel-2.4.26 does not need patch0
  296. * Sun Mar 21 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.2.1-0vl1
  297. - source upgrade
  298. * Sat Jan 17 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl2
  299. - rebuild for VineSeedPlus
  300. * Mon Jan 12 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.5-0vl1
  301. - source upgrade
  302. - build for VinePlus/2.6
  303. - (VinePlus/2.6) BuildPrereq: autoconf258
  304. - build without cdparanoia
  305. * Thu Jan 8 2004 Tomoya TAKA <taka@vinelinux.org> 3.1.4-0vl2
  306. - add Patch1 to resolve conflicting typedef on alpha
  307. - remove ExcludeArch: alpha
  308. * Sun Dec 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.4-0vl1
  309. - source upgrade
  310. - change spec to build with gcc3
  311. - add Patch0 to build kaudiocreator
  312. (patch to /usr/include/asm/byteorder.h)
  313. - include our own copy of cdparanoia, nuke FixupTOC() from it
  314. - build without cdparanoia-devel
  315. - revised description
  316. - change spec to make monolithic package only
  317. - add Obsoletes: kmidi koncd
  318. - remove KOnCD configuration
  319. - rename timidity to avoid conflict with timidy++
  320. * Mon Jul 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.3-0vl1
  321. - source upgrade
  322. - change spec to build with gcc295
  323. - change make option for SMP and add script
  324. * Sat Jun 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.1.2-0vl1
  325. - source upgrade
  326. - change spec to build both VineSeed and Vine2.5/2.6
  327. - remove all patches
  328. - add BuildPrereq: cdparanoia-devel cdrtools-devel
  329. - built with libpng >= 1.2.5 when %%{vine26} is set to 0 (ie VineSeedPlus)
  330. - change spec to build with g++-2.95.3
  331. * Sat Oct 19 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl2
  332. - objprelink2 support only ix86 (add %%ifarch %%{ix86} ... )
  333. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.4-0vl1
  334. - source upgrade
  335. - BuildPrereq: autoconf253 objprelink2
  336. * Mon Aug 26 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.3-0vl1
  337. - source upgrade
  338. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.0.2-1vl2
  339. - rebuild with libvorbis-1.0-0vl1
  340. * Tue Jul 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.0.2-1vl1
  341. - build for Vine Linux 2.5 / VineSeed
  342. - delete Epoch
  343. - objprelink (i386 only)
  344. - add %%define monolithic 1
  345. - add BuildPrereq: autoconf252 automake15 libogg-devel libvorbis-devel
  346. - delete BuildPrereq: desktop-file-utils and use default .desktop files
  347. - koncd: delete Requires: mkisofs and add Requires: cdrdao
  348. - kmidi: change Requires: timidity++ -> TiMidity++
  349. delete Obsoletes: kdemultimedia
  350. - devel: Requires: kdemultimedia = %%{version}-%%{rel}
  351. * Wed Jul 10 2002 Than Ngo <than@redhat.com> 3.0.2-1
  352. - 3.0.2
  353. - use desktop-file-install
  354. * Thu Jun 06 2002 Than Ngo <than@redhat.com> 3.0.1-3
  355. - rebuild
  356. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  357. - automated rebuild
  358. * Fri May 10 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.1-1
  359. - 3.0.1
  360. * Wed Apr 17 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-3
  361. - Make sure we link to the just built libraries instead of libs in the
  362. build environment from older releases
  363. * Tue Apr 16 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-2
  364. - Update ABI
  365. - Add cdrecord/mkisofs requirements for KOnCD (#63606)
  366. - Tell koncd where to find cdrecord and mkisofs (#63604)
  367. * Wed Mar 27 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-1
  368. - 3.0.0 final
  369. * Thu Mar 21 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020321.1
  370. - Adapt spec file to recent changes in base
  371. * Thu Mar 7 2002 Bernhard Rosenkraenzer <bero@redhat.com> 3.0.0-0.cvs20020307.1
  372. - Update
  373. - Rename subpackages
  374. * Fri Feb 1 2002 Tim Powers <timp@redhat.com>
  375. - kdemultimedia-devel shouldn't obsolete itself
  376. - temporarily ExcludeArch ia64
  377. * Mon Aug 6 2001 Than Ngo <than@redhat.com> 2.2-1
  378. - update to 2.2 release
  379. * Fri Aug 3 2001 Than Ngo <than@redhat.com> 2.2-0.cvs20010803.1
  380. - update
  381. - fix bug #24132
  382. - get rid of aktion
  383. * Sun Jul 22 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010722.1
  384. - Update
  385. - move devel files to a separate package
  386. - Add BuildPrereqs (#44914)
  387. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  388. - 2.1-respin
  389. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  390. - 2.1
  391. * Tue Feb 13 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  392. - Remove copyrighted midi files (#26431)
  393. - Use a real file list rather than find/sed (#26565)
  394. - Fix build with current glibc
  395. * Thu Feb 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  396. - Replace absolute symlinks with relative ones (#24794)
  397. - Don't use more than 2 CPUs at build time to shut up asok
  398. * Mon Jan 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  399. - Update
  400. * Mon Jan 1 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  401. - Update
  402. - Don't optimize on sparc, compiler breakage
  403. * Wed Dec 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  404. - Update to CVS
  405. - re-exclude ia64, the compiler can't handle this package
  406. * Sun Oct 22 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  407. - 2.0 final
  408. * Tue Oct 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  409. - 2.0
  410. * Thu Aug 24 2000 Than Ngo <than@redhat.com>
  411. - update kdemultimedia-1.93
  412. - fix to rebuilt with gcc-2.96
  413. * Mon Aug 7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  414. - new version
  415. * Wed Jul 19 2000 Than Ngo <than@redhat.de>
  416. - fix to build against gcc-2.96-40 on sparc, alpha
  417. - disable motif
  418. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  419. - SMPify
  420. - don't hardcode QTDIR
  421. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  422. - use gcc 2.96
  423. - new snapshot
  424. * Sun Jul 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  425. - use kernelcc
  426. - new snapshot
  427. * Fri Jun 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  428. - Obsoletes: aktion (it's included now)
  429. * Wed Jun 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  430. - new snapshot
  431. - ExcludeArch ia64 for now
  432. * Sat Apr 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  433. - 2.0 snapshot
  434. * Tue Feb 29 2000 Preston Brown <pbrown@redhat.com>
  435. - fix localkscd patch, broken since 6.1 (#9404).
  436. * Fri Feb 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  437. - Remove (world!) write permissions to %%{prefix}/share/apps/kscd/cddb/*
  438. - fix description
  439. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  440. - Change the kmix error message (Bug #9065)
  441. - Fix kmidi behavior when trying to play an empty playlist (Bug #8843)
  442. - Fix compilation with kernel 2.3.x headers
  443. * Sat Jan 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  444. - current version from KDE_1_1_BRANCH
  445. - work around make install-strip breakage
  446. - Rebuild for 6.2
  447. * Sat Sep 25 1999 Preston Brown <pbrown@redhat.com>
  448. - patched kscd to use local user directory for cddb entries
  449. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  450. - mark doc files as such
  451. * Thu Sep 09 1999 Preston Brown <pbrown@redhat.com>
  452. - 1.1.2 release.
  453. * Mon Jun 14 1999 Preston Brown <pbrown@redhat.com>
  454. - snapshot, includes kde 1.1.1 + fixes
  455. * Mon Apr 19 1999 Preston Brown <pbrown@redhat.com>
  456. - last snapshot before release
  457. * Tue Apr 13 1999 Preston Brown <pbrown@redhat.com>
  458. - snapshot from today fixed kmid freeze issues
  459. * Mon Apr 12 1999 Preston Brown <pbrown@redhat.com>
  460. - latest stable snapshot
  461. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  462. - Injected new description and group.
  463. * Mon Feb 08 1999 Preston Brown <pbrown@redhat.com>
  464. - upgraded to KDE 1.1 final.
  465. * Sat Feb 06 1999 Preston Brown <pbrown@redhat.com>
  466. - complies w/new RPM, newer libstdc++
  467. * Wed Jan 06 1999 Preston Brown <pbrown@redhat.com>
  468. - re-merged in updates from Duncan Haldane