dblatex-vl.spec 8.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. Name: dblatex
  3. Version: 0.3.5
  4. Release: 1%{?_dist_release}
  5. Summary: DocBook to LaTeX/ConTeXt Publishing
  6. BuildArch: noarch
  7. Group: Applications/Publishing
  8. License: GPLv2+
  9. URL: http://dblatex.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
  11. #Source1: http://docbook.sourceforge.net/release/xsl/current/COPYING
  12. Source1: COPYING-docbook-xsl
  13. Patch0: dblatex-0.2.7-external-which.patch
  14. ##!! ad-hoc patch for no deb
  15. Patch10: dblatex-0.3.4-no-deb.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  17. BuildRequires: texlive-vtlpkg >= 2013
  18. BuildRequires: python-devel
  19. BuildRequires: python-which
  20. BuildRequires: libxslt docbook-dtds ImageMagick
  21. ## Need epstopdf, fig2dev
  22. BuildRequires: texlive-collection-fontutils
  23. BuildRequires: transfig
  24. ##BuildRequires: tex(latex)
  25. ##BuildRequires: tex(xetex)
  26. BuildRequires: texlive-common >= 2013
  27. ## appendix.sty, changebar.sty, footmisc.sty, multirow.sty,
  28. ## overpic.sty, subfigure.sty, titlesec.sty
  29. BuildRequires: texlive-collection-latexextra
  30. ## stmaryrd.sty
  31. BuildRequires: texlive-collection-mathextra
  32. BuildRequires: texlive-collection-htmlxml
  33. Requires: libxslt docbook-dtds ImageMagick
  34. ##Requires: tex(xetex)
  35. Requires: texlive-common >= 2009
  36. Requires: texlive-collection-latexextra
  37. Requires: transfig
  38. BuildRequires: texlive-collection-mathextra
  39. ##Requires: passivetex
  40. Requires: texlive-collection-htmlxml
  41. ## $ rpm -qf --qf "%{name}\n" $(kpsewhich $(grep "usepackage" $(rpm -ql dblatex | grep sty) | sed -e "s,.*{,," -e "s,}.*$,.sty,")) | sort | uniq
  42. Requires: texlive-collection-langcjk texlive-collection-bibtexextra
  43. %description
  44. dblatex is a program that transforms your SGML/XMLDocBook
  45. documents to DVI, PostScript or PDF by translating them
  46. into pure LaTeX as a first process. MathML 2.0 markups
  47. are supported, too. It started as a clone of DB2LaTeX.
  48. Authors:
  49. --------
  50. Benoît Guillon <marsgui at users dot sourceforge dot net>
  51. Andreas Hoenen <andreas dot hoenen at arcor dot de>
  52. %prep
  53. %setup -q
  54. %patch0 -p1 -b .external-which
  55. %patch10 -p1 -b .no-deb
  56. %__rm -rf lib/contrib
  57. %build
  58. %{__python} setup.py build
  59. %install
  60. %__rm -rf $RPM_BUILD_ROOT
  61. #%{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  62. %{__python} setup.py install --root $RPM_BUILD_ROOT
  63. # these are already in tetex-latex:
  64. for file in bibtopic.sty enumitem.sty ragged2e.sty passivetex/ xelatex/; do
  65. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/misc/$file
  66. done
  67. %__mkdir_p $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex
  68. for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.sty' ` ; do
  69. %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
  70. done
  71. ## also move .xetex files
  72. for file in ` find $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/ -name '*.xetex' ` ; do
  73. %__mv $file $RPM_BUILD_ROOT%{_datadir}/texmf/tex/latex/dblatex/`basename $file` || exit 1;
  74. done
  75. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/dblatex/latex/{misc,contrib/example,style}
  76. %__mkdir_p $RPM_BUILD_ROOT%{_sysconfdir}/dblatex
  77. # shipped in %%docs
  78. %__rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/
  79. %__sed -e 's/\r//' xsl/mathml2/README > README-xsltml
  80. touch -r xsl/mathml2/README README-xsltml
  81. %__cp -p %{SOURCE1} COPYING-docbook-xsl
  82. %clean
  83. %__rm -rf $RPM_BUILD_ROOT
  84. %post
  85. %_tl_touch_run texhash
  86. exit 0
  87. %postun
  88. if [ "$1" = 0 ]; then
  89. %_tl_touch_run texhash
  90. fi
  91. exit 0
  92. %posttrans
  93. %{_tl_exec_texhash}
  94. exit 0
  95. %files
  96. %defattr(-,root,root,-)
  97. %{_mandir}/man1/dblatex.1*
  98. %doc COPYRIGHT docs/manual.pdf COPYING-docbook-xsl README-xsltml
  99. %{python_sitelib}/dbtexmf/
  100. %{python_sitelib}/dblatex-*.egg-info
  101. %{_bindir}/dblatex
  102. %{_datadir}/dblatex/
  103. %{_datadir}/texmf/tex/latex/dblatex/
  104. %dir %{_sysconfdir}/dblatex
  105. %changelog
  106. * Wed Mar 25 2015 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.5-1
  107. - new upstream release
  108. * Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.4-2
  109. - added BuildRequires: texlive-vtlpkg >= 2013
  110. - added some scriptlets to run mktexlsr
  111. * Fri Nov 8 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.4-1
  112. - new upstream release
  113. * Fri Dec 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-3
  114. - added R: texlive-collection-langcjk texlive-collection-bibtexextra [Vine Linux 0002511]
  115. * Sat Feb 25 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-2
  116. - rebuild with Python 2.7.2
  117. * Fri Jan 20 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.3.2-1
  118. - new upstream release
  119. * Thu Jul 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> - 0.3-1
  120. - initial build
  121. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3-3
  122. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  123. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.3-2
  124. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  125. * Mon Apr 12 2010 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.3-1
  126. - Update to 0.3
  127. - Cleanup spec: drop some unnecessary conditionals for old releases (< F-11)
  128. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.10-3
  129. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  130. * Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-2
  131. - remove dblatex-0.2.9-xetex.patch
  132. * Sun May 10 2009 Neal Becker <ndbecker2@gmail.com> - 0.2.10-1
  133. - Update to 0.2.10
  134. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.9-4
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  136. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.2.9-3
  137. - Rebuild for Python 2.6
  138. * Fri Jul 4 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-2
  139. - BR: texlive-xetex -> tex(xetex) for F-10 and later
  140. * Thu Jun 12 2008 Alex Lancaster <alexlan[AT]fedoraproject org> - 0.2.9-1
  141. - Update to latest upstream (0.2.9) (#448953)
  142. - Remove some redundant Requires and BuildRequires (passivetex pulls
  143. in the tetex/tex requires, python dep added automatically)
  144. - For F-9+ BR on tex(latex) and texlive-xetex, fix the installation
  145. scripts to install extra new files.
  146. - Add patch from dblatex mailing list for better handling of a missing
  147. xetex.
  148. - Conditionally add .egg-info file only if F9+ to allow for unified
  149. spec file
  150. * Sun Dec 16 2007 Patrice Dumas <pertusus@free.fr> - 0.2.8-2.1
  151. - don't install in docbook directory, it is a link to a versioned
  152. directory and may break upon docbook update (#425251,#389231)
  153. * Sun Nov 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.8-1
  154. - Update to 0.2.8
  155. * Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-16
  156. - convert spec to utf8
  157. - change to gplv2+
  158. * Mon Nov 12 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-15
  159. - Add copyright info
  160. * Mon Nov 5 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-14
  161. - Req tetex-fonts for texhash
  162. - Fix post, postun
  163. * Sun Nov 4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-13
  164. - Add texhash
  165. * Sun Nov 4 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
  166. - Fix xsl link
  167. * Sat Nov 3 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-12
  168. - Various fixes from pertusus@free.fr:
  169. - rm iconv stuff
  170. - simplify docs installation
  171. * Fri Nov 2 2007 <ndbecker2@gmail.com> - 0.2.7-11
  172. - Various minor fixes
  173. * Thu Nov 1 2007 <ndbecker2@gmail.com> - 0.2.7-10
  174. - Add some reqs and brs
  175. - rmdir /usr/share/dblatex/latex/{misc,contrib/example,style}
  176. * Sat Oct 27 2007 <ndbecker2@gmail.com> - 0.2.7-9
  177. - link /usr/share/dblatex/xsl -> /usr/share/sgml/docbook/xsl-stylesheets/dblatex
  178. - rmdir /usr/share/dblatex/latex/{misc,specs,style}
  179. - own /etc/dblatex
  180. - change $(...) -> `...`
  181. - Preserve timestamps on iconv
  182. * Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-9
  183. - mv all .sty files to datadir/texmf/tex/latex/dblatex
  184. - Add Conflicts tetex-tex4ht
  185. - mv all xsl stuff to datadir/sgml/docbook/xsl-stylesheets/dblatex/
  186. * Mon Oct 15 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
  187. - rm redundant latex files
  188. * Tue Sep 25 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-8
  189. - Fixed encodings in docs directory
  190. - Install docs at correct location
  191. * Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-7
  192. - Revert back to GPLv2
  193. - untabify
  194. * Fri Sep 21 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-6
  195. - Fix source URL
  196. - Install all docs
  197. - Tabify
  198. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-5
  199. - Add BR tetex-latex
  200. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-4
  201. - Add BR tetex, ImageMagick
  202. * Thu Sep 20 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-3
  203. - Add BR libxslt
  204. * Wed Sep 19 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-2
  205. - Add BR python-devel
  206. * Fri Sep 7 2007 Neal Becker <ndbecker2@gmail.com> - 0.2.7-1
  207. - Initial