perl-POE-Test-Loops.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. Name: perl-POE-Test-Loops
  2. Summary: Reusable tests for POE::Loop authors
  3. Version: 1.350
  4. Release: 2%{?_dist_release}
  5. License: GPL+ or Artistic
  6. Group: Development/Libraries
  7. Source0: http://search.cpan.org/CPAN/authors/id/R/RC/RCAPUTO/POE-Test-Loops-%{version}.tar.gz
  8. URL: http://search.cpan.org/dist/POE-Test-Loops
  9. BuildArch: noarch
  10. BuildRequires: perl(constant)
  11. BuildRequires: perl(ExtUtils::MakeMaker)
  12. BuildRequires: perl(File::Path)
  13. BuildRequires: perl(File::Spec)
  14. BuildRequires: perl(File::Temp)
  15. BuildRequires: perl(IO::Handle)
  16. BuildRequires: perl(IO::Socket)
  17. BuildRequires: perl(IO::Socket::INET)
  18. BuildRequires: perl(POE)
  19. BuildRequires: perl(Socket)
  20. BuildRequires: perl(Test::More) >= 0.94
  21. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  22. %if %{_dist_release} > "vl6"
  23. %global __provides_exclude %{?__provides_exclude:__requires_exclude|}^perl\\(POE::MySession\\)
  24. %global __provides_exclude %__provides_exclude|perl\\(POE::Kernel\\)
  25. %global __provides_exclude %__provides_exclude|perl\\(PoeTestWorker\\)
  26. %global __provides_exclude %__provides_exclude|perl\\([DIFMOSU].*\\)
  27. %global __provides_exclude %__provides_exclude|perl\\(Switch\\)
  28. %endif
  29. %description
  30. POE::Test::Loops contains one function, generate(), which will generate
  31. all the loop tests for one or more POE::Loop subclasses. The SYNOPSIS
  32. example is a version of poe-gen-tests, which is a stand-alone utility
  33. to generate the actual tests. The poe-gen-tests manual page also documents
  34. the POE::Test::Loops system in more detail.
  35. %prep
  36. %setup -q -n POE-Test-Loops-%{version}
  37. find . -type f -exec chmod -c -x {} ';'
  38. %if %{_dist_release} <= "vl6"
  39. cat << \EOF > %{name}-prov
  40. #!/bin/sh
  41. %{__perl_provides} $* |\
  42. sed -e '/perl(POE::MySession)/d' |\
  43. sed -e '/perl(POE::Kernel)/d' |\
  44. sed -e '/perl(PoeTestWorker)/d' |\
  45. sed -e '/perl([DIFMOSU].*)/d' |\
  46. sed -e '/perl(Switch)/d'
  47. EOF
  48. %global __perl_provides %{_builddir}/POE-Test-Loops-%{version}/%{name}-prov
  49. chmod +x %{__perl_provides}
  50. %endif
  51. %build
  52. %{__perl} Makefile.PL INSTALLDIRS=vendor
  53. make %{?_smp_mflags}
  54. %install
  55. make pure_install DESTDIR=%{buildroot}
  56. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  57. find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
  58. %{_fixperms} %{buildroot}/*
  59. %check
  60. make test
  61. %files
  62. %doc CHANGES README
  63. %{perl_vendorlib}/*
  64. %{_mandir}/man3/*.3*
  65. %{_bindir}/poe-gen-tests
  66. %{_mandir}/man1/poe-gen-tests.1.gz
  67. %changelog
  68. * Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.350-2
  69. - build with Perl 5.16
  70. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.350-1
  71. - initial build for Vine Linux
  72. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.350-2
  73. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  74. * Wed Dec 21 2011 Petr Šabata <contyk@redhat.com> - 1.350-1
  75. - 1.350 bump
  76. * Fri Aug 5 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.312-2
  77. - filter also Switch from provides, just to be sure
  78. * Wed Jul 27 2011 Petr Sabata <contyk@redhat.com> - 1.312-1
  79. - 1.312 bump (needed by current POE)
  80. - Drop Buildroot and defattr support
  81. - Fix dependencies a bit
  82. - Add RPM 4.9 style filters
  83. - Filter POE::Kernel and PoeTestWorker from Provides
  84. * Thu Jun 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.035-4
  85. - Perl mass rebuild
  86. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.035-3
  87. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  88. * Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.035-2
  89. - 661697 rebuild for fixing problems with vendorach/lib
  90. * Mon Jun 7 2010 Petr Pisar <ppisar@redhat.com> - 1.035-1
  91. - 1.035 bump
  92. - Orthography fix in description
  93. * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.033-2
  94. - Mass rebuild with perl-5.12.0
  95. * Sun Mar 14 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.033-1
  96. - update by Fedora::App::MaintainerTools 0.006
  97. - PERL_INSTALL_ROOT => DESTDIR
  98. - updating to latest GA CPAN version (1.033)
  99. * Sun Sep 27 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.022-1
  100. - update filtering
  101. - auto-update to 1.022 (by cpan-spec-update 0.01)
  102. * Tue Aug 11 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.021-1
  103. - auto-update to 1.021 (by cpan-spec-update 0.01)
  104. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.005-2
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  106. * Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-1
  107. - update for submission
  108. * Fri Apr 10 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.005-0
  109. - initial RPM packaging
  110. - generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)