tzdata-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391
  1. %bcond_without java18
  2. Summary: Timezone data
  3. Summary(ja): タイムゾーンのデータ
  4. Name: tzdata
  5. Version: 2016j
  6. %define tzdata_version 2016j
  7. %define tzcode_version 2016j
  8. Release: 1%{?_dist_release}
  9. License: Public Domain
  10. Group: System Environment/Base
  11. URL: https://www.iana.org/time-zones
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. # These are official upstream.
  15. Source0: ftp://ftp.iana.org/tz/releases/tzdata%{tzdata_version}.tar.gz
  16. Source1: ftp://ftp.iana.org/tz/releases/tzcode%{tzcode_version}.tar.gz
  17. Source2: javazic.tar.gz
  18. Source3: javazic-1.8-37392f2f5d59.tar.xz
  19. Patch100: javazic-fixup.patch
  20. Patch101: rebase-01.patch
  21. Patch102: rebase-02.patch
  22. Patch103: 7090844.patch
  23. Patch104: 7133138.patch
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildArch: noarch
  26. BuildRequires: gawk, glibc, perl
  27. BuildRequires: java-1.8.0-openjdk-devel
  28. BuildRequires: glibc-common >= 2.5.90-7
  29. Conflicts: glibc-common <= 2.3.2-63
  30. %description
  31. This package contains data files with rules for various timezones around
  32. the world.
  33. %description -l ja
  34. このパッケージには世界中のタイムゾーンに関するデータファイルが収録されています.
  35. %package java
  36. Summary: Timezone data for Java
  37. Group: System Environment/Base
  38. %description java
  39. This package contains timezone information for use by Java runtimes.
  40. %prep
  41. %setup -q -c -a 1
  42. mkdir javazic
  43. tar zxf %{SOURCE2} -C javazic
  44. pushd javazic
  45. %patch100
  46. %patch101
  47. %patch102
  48. %patch103
  49. %patch104
  50. # Hack alert! sun.tools may be defined and installed in the
  51. # VM. In order to guarantee that we are using IcedTea/OpenJDK
  52. # for creating the zoneinfo files, rebase all the packages
  53. # from "sun." to "rht.". Unfortunately, gcj does not support
  54. # any of the -Xclasspath options, so we must go this route
  55. # to ensure the greatest compatibility.
  56. mv sun rht
  57. find . -type f -name '*.java' -print0 \
  58. | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
  59. -e 's:sun\.util\.:rht.util.:g'
  60. popd
  61. tar xf %{SOURCE3}
  62. echo "%{name}%{tzdata_version}" >> VERSION
  63. %build
  64. FILES="africa antarctica asia australasia europe northamerica southamerica
  65. pacificnew etcetera backward"
  66. mkdir zoneinfo/{,posix,right}
  67. zic -y ./yearistype -d zoneinfo -L /dev/null -p America/New_York $FILES
  68. zic -y ./yearistype -d zoneinfo/posix -L /dev/null $FILES
  69. zic -y ./yearistype -d zoneinfo/right -L leapseconds $FILES
  70. grep -v tz-art.htm tz-link.htm > tz-link.html
  71. # Java 6/7 tzdata
  72. pushd javazic
  73. javac -source 1.5 -target 1.5 -classpath . `find . -name \*.java`
  74. popd
  75. java -classpath javazic/ rht.tools.javazic.Main -V %{version} \
  76. -d javazi \
  77. $FILES javazic/tzdata_jdk/gmt javazic/tzdata_jdk/jdk11_backward
  78. %if %{with java18}
  79. # Java 8 tzdata
  80. pushd javazic-1.8
  81. javac -source 1.7 -target 1.7 -classpath . `find . -name \*.java`
  82. popd
  83. java -classpath javazic-1.8 build.tools.tzdb.TzdbZoneRulesCompiler \
  84. -srcdir . -dstfile tzdb.dat \
  85. -verbose \
  86. $FILES javazic-1.8/tzdata_jdk/gmt javazic-1.8/tzdata_jdk/jdk11_backward
  87. %endif
  88. %install
  89. rm -fr $RPM_BUILD_ROOT
  90. install -d $RPM_BUILD_ROOT%{_datadir}
  91. cp -prd zoneinfo $RPM_BUILD_ROOT%{_datadir}
  92. install -p -m 644 zone.tab iso3166.tab $RPM_BUILD_ROOT%{_datadir}/zoneinfo
  93. cp -prd javazi $RPM_BUILD_ROOT%{_datadir}/javazi
  94. %if %{with java18}
  95. mkdir -p $RPM_BUILD_ROOT%{_datadir}/javazi-1.8
  96. install -p -m 644 tzdb.dat $RPM_BUILD_ROOT%{_datadir}/javazi-1.8/
  97. %endif
  98. %clean
  99. rm -fr $RPM_BUILD_ROOT
  100. %files
  101. %defattr(-,root,root)
  102. %{_datadir}/zoneinfo
  103. %doc README
  104. %doc Theory
  105. %doc tz-link.html
  106. %files java
  107. %defattr(-,root,root)
  108. %{_datadir}/javazi
  109. %if %{with java18}
  110. %{_datadir}/javazi-1.8
  111. %endif
  112. %changelog
  113. * Mon Nov 28 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 2016j-1
  114. - updated to 2016j.
  115. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-2
  116. - fixed changelog.
  117. - added Vendor and Distribution tag.
  118. * Thu Jul 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016f-1
  119. - updated to 2016f.
  120. * Sun Jun 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016e-1
  121. - updated to 2016e.
  122. - enabled java18 stuff.
  123. * Mon May 9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2016d-1
  124. - updated to 2016d.
  125. * Mon Aug 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015f-1
  126. - updated to 2015f.
  127. * Wed Jun 17 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2015e-1
  128. - updated to 2015e.
  129. * Sun Jun 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2012c-1
  130. - update to tzdata-2012c, tzcode-2012b
  131. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 2010l-2
  132. - rebuilt with rpm-4.8.1-3
  133. * Sat Sep 04 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2010l-1
  134. - update to tzdata-2010l, tzcode-2010l
  135. - added java subpackage
  136. * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2009d-1
  137. - update to tzdata-2009d, tzcode-2009d
  138. - spec in utf-8
  139. * Sun Apr 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2008b-1
  140. - update to tzdata-2008b, tzcode-2008a
  141. * Sun May 06 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2007d-1vl1
  142. - initial build for VineSeed
  143. * Fri Mar 23 2007 Petr Machata <pmachata@redhat.com> - 2007d-1
  144. - Upstream 2007d
  145. - Mongolia has abolished DST.
  146. - Turkey will use EU rules this year, changing at 01:00 UTC rather
  147. than 01:00 standard time.
  148. - Cuba observed DST starting Sunday.
  149. - Resolute, Nunavut switched from Central to Eastern time last
  150. November.
  151. * Mon Feb 26 2007 Petr Machata <pmachata@redhat.com> - 2007c-1
  152. - Upstream 2007c
  153. - Pulaski County, Indiana, switched back to eastern time.
  154. - Turkey switches at 01:00 standard time, not at 01:00 UTC.
  155. - Upstream 2007b
  156. - Changes to the commentary in "leapseconds".
  157. - Upstream 2007a
  158. - Updates to Bahamas, they will be in sync with 2007 US DST change
  159. - New zone Australia/Eucla
  160. - Africa/Asmera renamed to Africa/Asmara, link created
  161. - Atlantic/Faeroe renamed to Atlantic/Faroe, link created
  162. * Wed Nov 29 2006 Petr Machata <pmachata@redhat.com> - 2006p-1
  163. - Upstream 2006p
  164. - Covers changes from 2006m-2 and 2006m-3
  165. - Latitude/longitude changes for Europe/Jersey and Europe/Podgorica
  166. * Wed Nov 22 2006 Petr Machata <pmachata@redhat.com> - 2006m-3
  167. - Patch for Western Australia DST trial
  168. * Tue Oct 10 2006 Petr Machata <pmachata@redhat.com> - 2006m-2
  169. - Proposed upstream patch (#210058)
  170. - Jordan will switch to winter time on October 27, not September 29
  171. - Brazil's DST this year is the first Sunday in November to the last
  172. Sunday in February. (Thanks to Frederico A. C. Neves.)
  173. - ISO 3166 codes for Serbia and Montenegro, zone Europe/Podgorica
  174. - Commentary and past timestamps changes
  175. * Tue Oct 3 2006 Petr Machata <pmachata@redhat.com> - 2006m-1
  176. - Upstream 2006m:
  177. - Adjustments for Egypt, Palestine, Uruguay
  178. - Better description of `until' field in zic (8) manpage
  179. * Thu Sep 21 2006 Petr Machata <pmachata@redhat.com> - 2006l-1
  180. - Upstream 2006k, 2006l:
  181. - Adjustments for Egypt, Palestine, Cuba, Honduras
  182. - Documentation changes
  183. * Tue Aug 22 2006 Petr Machata <pmachata@redhat.com> - 2006j-1
  184. - Upstream 2006j
  185. - Honduras stopped observing DST on Monday at 00:00
  186. - America/Bermuda will follow the US's lead next year
  187. - America/Moncton will use US-style rules next year
  188. - New Zone America/Blanc-Sablon, for Canadians who observe AST all
  189. year
  190. - New zone: America/Atikokan instead of America/Coral_Harbour
  191. - New zones: Europe/Jersey, Europe/Guernsey, Europe/Isle_of_Man
  192. - Historical changes
  193. - Commentary updates
  194. - Upstream 2006i
  195. - localtime.c fixes
  196. - Upstream 2006h
  197. - zic leapsecond fix
  198. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2006g-1.1
  199. - rebuild
  200. * Thu May 11 2006 Petr Machata <pmachata@redhat.com> - 2006g-1
  201. - Honduras chose to follow Guatemala and will observe DST May/6 to Sep/2
  202. - Nicaragua updates
  203. * Tue May 2 2006 Petr Machata <pmachata@redhat.com> - 2006f-1
  204. - Upstream 2006f
  205. - America/Guatemala observes DST between Apr/30 and Oct/1
  206. - Historical changes for Nicaragua
  207. - Update of America/Indiana/Vincennes in zone table
  208. * Thu Apr 20 2006 Petr Machata <pmachata@redhat.com> - 2006d-1
  209. - Upstream 2006d
  210. - Haiti observes DST
  211. - Sri Lanka change actually took effect Apr/15
  212. - All Canada is now scheduled for 2007 US DST rules
  213. - Some historical fixes
  214. * Thu Apr 6 2006 Petr Machata <pmachata@redhat.com> - 2006c-1
  215. - Upstream 2006c
  216. - Time-related changes:
  217. - dozens of historical and commentary changes
  218. - Iran stopped observing DST
  219. - Sri Lanka switches from UTC+6 to UTC+5:30
  220. - America/Thule and America/Edmonton will adopt new US rules,
  221. starting 2007
  222. - Tunisia is adopting regular DST
  223. - Code:
  224. - asctime.c: Chages in format strings to silent gcc warnings
  225. - removing K&R notation from function signatures
  226. - few fixes across the code
  227. * Thu Mar 16 2006 Petr Machata <pmachata@redhat.com> - 2006b-2
  228. - Patch for Sri Lanka time zone change (#184514)
  229. * Wed Feb 22 2006 Petr Machata <pmachata@redhat.com> 2006b-1
  230. - Upstream 2006b:
  231. - using tz64code version, as 32 is legacy according to tzdata ML
  232. - new manual pages for ctime, strftime, tzset
  233. - some source code reorganizations
  234. - no timezone/dst rule updates
  235. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-2
  236. - Small changes in tst-timezone.c
  237. * Thu Feb 02 2006 Petr Machata <pmachata@redhat.com> 2006a-1
  238. - Upstream 2006a:
  239. - private.h(scheck): changing char* to char const*
  240. - Rule changes for Palestine, zone changes for Indiana/US, both
  241. changes for Canada.
  242. - Many related doc changes.
  243. - Naming scheme in spec file doesn't use %%{name}, but tzdata.
  244. * Thu Jan 12 2006 Petr Machata <pmachata@redhat.com> 2005r-3
  245. - 2005r-3
  246. - Meta changes. Renaming tzdata.tar.bz2 file to tzdata$ver-base,
  247. so that it won't clash across updates.
  248. * Thu Jan 5 2006 Petr Machata <pmachata@redhat.com> 2005r-2
  249. - 2005r
  250. - Zones EST, MST, HST, EST5EDT, CST6CDT, MST7MDT, PST8PDT moved to
  251. northamerica to guard against old files with obsolete information
  252. being left in the time zone binary directory.
  253. - Changes for countries that are supposed to join 2007 US DST
  254. change. This includes most of Canada, however entries already in
  255. the database (Alberta, British Columbia, Newfoundland, Northwest
  256. Territories, and Yukon) were left alone for the time being.
  257. - Fixes in zdump.c (abbrok): conditions are chained, and the string
  258. is checked for emptiness.
  259. * Sat Dec 17 2005 Jakub Jelinek <jakub@redhat.com> 2005q-2
  260. - 2005q
  261. - changes for Georgia, Azerbaijan, Jordan, Palestine, Cuba, Nicaragua
  262. - SystemV timezone changes
  263. * Wed Nov 2 2005 Jakub Jelinek <jakub@redhat.com> 2005n-2
  264. - 2005n
  265. - changes for Kyrgyzstan and Uruguay
  266. - fix a typo in the Makefile (used TZDATA env var instead of TZDIR during
  267. make check), update tst-timezone.c from glibc CVS (#172102)
  268. * Tue Sep 6 2005 Jakub Jelinek <jakub@redhat.com> 2005m-2
  269. - 2005m
  270. - changes for USA (extending DST by 4 weeks since 2007), Tunisia,
  271. Australia, Kazakhstan
  272. - historical timezone data changes for Japan, Poland, Northern Ireland and
  273. Mali
  274. - timezone name change for East Timor
  275. * Fri Jul 15 2005 Jakub Jelinek <jakub@redhat.com> 2005k-2
  276. - 2005k
  277. - leap seconds update
  278. * Sat Apr 30 2005 Jakub Jelinek <jakub@redhat.com> 2005i-2
  279. - 2005i
  280. - updates for Iran, Haiti and Nicaragua
  281. * Mon Apr 4 2005 Jakub Jelinek <jakub@redhat.com> 2005h-2
  282. - 2005h
  283. - fixes for Kazakhstan
  284. * Thu Mar 17 2005 Jakub Jelinek <jakub@redhat.com> 2005g-2
  285. - 2005g
  286. - fixes for Uruguay
  287. - include README and Theory from tzcode tarball in %{_docdir};
  288. Theory includes a good summary of how the timezone data files
  289. are supposed to be named
  290. * Tue Mar 1 2005 Jakub Jelinek <jakub@redhat.com> 2005f-2
  291. - 2005f
  292. - more updates for Israel, updates for Azerbaijan
  293. * Wed Jan 26 2005 Jakub Jelinek <jakub@redhat.com> 2005c-3
  294. - 2005c
  295. - updates for Israel and Paraguay
  296. * Mon Nov 29 2004 Jakub Jelinek <jakub@redhat.com> 2004g-1
  297. - 2004g (#141107)
  298. - updates for Cuba
  299. * Mon Oct 11 2004 Jakub Jelinek <jakub@redhat.com> 2004e-2
  300. - 2004e (#135194)
  301. - updates for Brazil, Uruguay and Argentina
  302. * Wed Aug 4 2004 Jakub Jelinek <jakub@redhat.com> 2004b-2
  303. - 2004b
  304. * Mon Oct 6 2003 Jakub Jelinek <jakub@redhat.com> 2003d-1
  305. - 2003d
  306. * Thu Sep 25 2003 Jakub Jelinek <jakub@redhat.com> 2003c-1
  307. - 2003c
  308. - updates for Brazil (#104840)
  309. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-2
  310. - rebuilt
  311. * Mon Jul 28 2003 Jakub Jelinek <jakub@redhat.com> 2003a-1
  312. - initial package