fcgi-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182
  1. Summary: FastCGI development kit
  2. Summary(ja): FastCGI 開発キット
  3. Name: fcgi
  4. Version: 2.4.0
  5. Release: 2%{?_dist_release}
  6. Group: Development/Languages
  7. License: BSD
  8. URL: http://www.fastcgi.com/#TheDevKit
  9. Source0: http://fastcgi.com/dist/fcgi-%{version}.tar.gz
  10. Source1: fcgi-autogen.sh
  11. Patch0: fcgi-2.4.0-autotools.patch
  12. # Patch0 created with Source1 after patching Patch1 and Patch2
  13. Patch1: fcgi-2.4.0-configure.in.patch
  14. Patch2: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
  15. Patch3: fcgi-2.4.0-gcc44_fixes.patch
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  17. # for -perl
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. # don't "provide" private Perl libs
  20. %global _use_internal_dependency_generator 0
  21. %global provfind /bin/sh -c "grep -v '%perl_vendorarch.*\\.so$' | %__find_provides"
  22. %global __find_provides %provfind
  23. %description
  24. FastCGI is a language independent, scalable, open extension to CGI that
  25. provides high performance without the limitations of server specific APIs.
  26. %package devel
  27. Summary: Development files for %{name}
  28. Summary(ja): Development files for %{name}
  29. Group: Development/Libraries
  30. Requires: %{name} = %{version}-%{release}
  31. %description devel
  32. The %{name}-devel package contains libraries and header files for
  33. developing applications that use %{name}.
  34. %package perl
  35. Summary: Perl bindings for %{name}
  36. Summary(ja): Perl bindings for %{name}
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  40. %description perl
  41. The %{name}-perl package contains the perl bindings for fcgi.
  42. %prep
  43. %setup -q
  44. %patch0 -p1
  45. %patch3 -p1 -b .gcc44_fixes
  46. # remove DOS End Of Line Encoding
  47. sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
  48. # fix file permissions
  49. chmod a-x include/fcgios.h libfcgi/os_unix.c
  50. %build
  51. %configure
  52. # does not build with parallel make flags
  53. make
  54. # build the perl bindings
  55. cd perl
  56. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  57. make %{?_smp_mflags}
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. mkdir $RPM_BUILD_ROOT
  61. make install DESTDIR=$RPM_BUILD_ROOT
  62. rm $RPM_BUILD_ROOT/%{_libdir}/libfcgi{++,}.{l,}a
  63. install -p -m 0644 -D doc/cgi-fcgi.1 $RPM_BUILD_ROOT%{_mandir}/man1/cgi-fcgi.1
  64. for manpage in doc/*.3
  65. do
  66. install -p -m 0644 -D $manpage $RPM_BUILD_ROOT%{_mandir}/man3/$(basename $manpage)
  67. done
  68. rm -f -- doc/*.1
  69. rm -f -- doc/*.3
  70. # install the perl bindings
  71. cd perl
  72. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  73. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  74. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  75. find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null ';'
  76. chmod -x *.fpl
  77. %{_fixperms} $RPM_BUILD_ROOT/%{perl_vendorarch}
  78. %post -p /sbin/ldconfig
  79. %postun -p /sbin/ldconfig
  80. %check
  81. # perl tests -- none presently, but that may change
  82. cd perl && make test
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %files
  86. %defattr(-,root,root,-)
  87. %{_bindir}/cgi-fcgi
  88. %{_libdir}/libfcgi.so.*
  89. %{_libdir}/libfcgi++.so.*
  90. %{_mandir}/man1/*
  91. %defattr(0644,root,root,0755)
  92. %doc LICENSE.TERMS README
  93. %files devel
  94. %defattr(-,root,root,-)
  95. %{_includedir}/*
  96. %{_libdir}/libfcgi.so
  97. %{_libdir}/libfcgi++.so
  98. %{_mandir}/man3/*
  99. %exclude %{_mandir}/man3/*.3pm*
  100. %defattr(0644,root,root,0755)
  101. %doc doc/
  102. %files perl
  103. %defattr(-,root,root,-)
  104. %{perl_vendorarch}/*
  105. %exclude %dir %{perl_vendorarch}/auto
  106. %{_mandir}/man3/*.3pm*
  107. %defattr(0644,root,root,0755)
  108. %doc perl/ChangeLog perl/README perl/*.fpl
  109. %changelog
  110. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
  111. - build with perl 5.12.3
  112. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  113. - initial build for Vine Linux
  114. * Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
  115. - Stripping bad provides of private Perl extension libs
  116. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  118. * Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
  119. - Add missing #include <cstdio> to make it compile with gcc 4.4
  120. * Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
  121. - package up the perl bindings in their own subpackage
  122. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
  123. - Autorebuild for GCC 4.3
  124. * Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
  125. - bump release for rebuild
  126. * Tue Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
  127. - remove parallel make flags
  128. * Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
  129. - add some documentation
  130. - add mkdir ${RPM_BUILD_ROOT} to %%install
  131. - install man-pages
  132. * Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
  133. - Initial spec for fedora