hostapd-vl.spec 4.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155
  1. %define base_name hostapd
  2. %define pkg_version 2.1
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
  5. Summary(ja): IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS 認証局
  6. Name: %{base_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. Source0: %{base_name}-%{version}.tar.gz
  10. Source1: %{base_name}-init.sh
  11. Source2: %{base_name}-%{version}.config
  12. Patch0: %{base_name}-%{version}.patch
  13. Patch1: %{base_name}-%{version}.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
  14. License: GPL2
  15. Group: System Environment/Daemons
  16. URL: http://hostap.epitest.fi/hostapd/
  17. Requires: openssl, libnl >= 1.1
  18. Requires(post): %{_syssbindir}/chkconfig
  19. Requires(preun): %{_syssbindir}/chkconfig
  20. BuildRequires: openssl-devel, libnl-devel
  21. BuildRoot: %{_tmppath}/%{base_name}-%{version}-root
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. Packager: miyabi
  25. %description
  26. hostapd is a user space daemon for access point and authentication servers. It implements IEEE 802.11 access point management,
  27. IEEE 802.1X/WPA/WPA2/EAP Authenticators, RADIUS client, EAP server, and RADIUS authentication server.
  28. The current version supports Linux (Host AP, madwifi, mac80211-based drivers) and FreeBSD (net80211).
  29. %description -l ja
  30. hostapd はアクセスポイントと認証サーバのためのユーザスペースデーモンです。
  31. IEEE 802.11 アクセスポイント管理、IEEE 802.1X/WPA/WPA2/EAP 認証局、RADIUS クライアント、EAP サーバ、および RADIUS 認証サーバを実装します。
  32. 最新版は、Linux(Host AP、madwifi、mac80211ベースのドライバー)とFreeBSD(net80211)をサポートします。
  33. %prep
  34. %setup -q
  35. %patch0 -p1
  36. %patch1 -p1
  37. cp %{SOURCE1} .
  38. cp %{SOURCE2} ./%{base_name}/.config
  39. %build
  40. cd %{base_name}
  41. %{__make} %{?_smp_mflags}
  42. %install
  43. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  44. pushd %{base_name}
  45. %{__make} install DESTDIR="${RPM_BUILD_ROOT}"
  46. popd
  47. mkdir -p ${RPM_BUILD_ROOT}%{_initdir}
  48. install %{SOURCE1} ${RPM_BUILD_ROOT}%{_initdir}/%{base_name}
  49. %post
  50. if ! /sbin/chkconfig %{base_name}; then
  51. /sbin/chkconfig --add %{base_name}
  52. fi
  53. if [ "$1" -eq "2" ]; then
  54. %{_initdir}/%{base_name} condrestart
  55. fi
  56. %preun
  57. if [ "$1" -eq "0" ]; then
  58. %{_initdir}/%{base_name} stop
  59. /sbin/chkconfig --del %{base_name}
  60. fi
  61. %clean
  62. [ "${RPM_BUILD_ROOT}" != "/" ] && %{__rm} -rf ${RPM_BUILD_ROOT}
  63. %files
  64. %defattr(-, root, root)
  65. # Directory
  66. %dir %{_sysconfdir}/%{base_name}/
  67. # Program Files
  68. %attr(0755, root, root) %{_sbindir}/%{base_name}
  69. %attr(0755, root, root) %{_bindir}/hostapd_cli
  70. %attr(0755, root, root) %{_initdir}/%{base_name}
  71. # Config Files
  72. %attr(0644, root, root) %config(noreplace) %{_sysconfdir}/%{base_name}/%{base_name}.conf.sample
  73. # Document Files
  74. %doc %{base_name}/ChangeLog COPYING README
  75. %{_mandir}/man8/%{base_name}.8.gz
  76. %{_mandir}/man1/hostapd_cli.1.gz
  77. %changelog
  78. * Wed Apr 23 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-2
  79. - add patch - hostapd-2.1.334ec001bbd31c5bc83d6593e58dfbbf6b8785a2.patch
  80. - fix segfault
  81. * Sat Mar 15 2014 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.1-1
  82. - new upstream release
  83. - change .config
  84. - add ACS support(Supported ACS drivers: ath5k, ath9k, ath10k)
  85. * Sun Mar 17 2013 Masahiro INOUE <miyabi.-.inoue@nifty.com> 2.0-1
  86. - new upstream release
  87. - change filename hostapd.conf -> hostapd.conf.sample
  88. - change .config
  89. - add WPS support
  90. * Sun Dec 2 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.1-1
  91. - new upstream release
  92. * Fri Oct 19 2012 Masahiro INOUE <miyabi.-.inoue@nifty.com> 1.0.0-1
  93. - new upstream release
  94. - add Summary(ja)
  95. - add section - %description -l ja
  96. - add parameter noreplace to %config
  97. - change spec file
  98. * Tue Oct 9 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.7.3-3
  99. - add patch100 for fix CVE-2012-4445 (EPA-TLS message)
  100. * Thu Feb 10 2011 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-2
  101. - fix daemon script
  102. - change spec file
  103. - separation from patch file
  104. - daemon script
  105. - .config
  106. - add Source1 - hostapd-init.sh
  107. - add Source2 - hostapd-0.7.3.config
  108. - add Requires(post) - chkconfig
  109. - add Requires(preun) - chkconfig
  110. * Sun Feb 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
  111. - rebuild with openssl-1.0.0c
  112. * Tue Sep 21 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.7.3-1
  113. - new upstream release
  114. * Sat May 08 2010 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.10-1
  115. - new upstream release
  116. * Sun Nov 15 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.6.9-1
  117. - new upstream release
  118. * Mon Jan 05 2009 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.11-1
  119. - new upstream release
  120. * Wed Apr 16 2008 Masahiro INOUE <miyabi.-.inoue@nifty.com> 0.5.10-1
  121. - initial build for Vine Linux