unixODBC-vl.spec 9.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define __libtoolize true
  2. %define vine26 0
  3. %define kde 1
  4. # disable -kde subpackage on Vine Linux 2.5,2.6/alpha
  5. %if %{vine26}
  6. %ifarch alpha
  7. %define kde 0
  8. %endif
  9. %endif
  10. Summary: A complete ODBC Driver Manager for Linux
  11. Name: unixODBC
  12. Version: 2.2.12
  13. Release: 1%{?_dist_release}
  14. License: LGPL
  15. Group: System Environment/Libraries
  16. Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
  17. Source1: odbcinst.ini
  18. Source2: ODBCConfig.desktop
  19. Source3: DataManager.desktop
  20. Patch1: unixODBC-2.2.11-symbols.patch
  21. Patch2: nortldglobal.patch
  22. Patch100: unixODBC-2.2.5-backslash-typo.patch
  23. URL: http://www.unixODBC.org/
  24. Conflicts: iodbc
  25. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  26. %if %{vine26}
  27. BuildRequires: autoconf253 automake15
  28. %else
  29. BuildRequires: autoconf >= 2.53
  30. BuildRequires: automake >= 1.5
  31. %endif
  32. %if %{kde}
  33. BuildRequires: kdelibs-devel
  34. BuildRequires: qt-devel
  35. BuildRequires: libmng-devel
  36. %endif
  37. %description
  38. The unixODBC Project goals are to develop and promote unixODBC to
  39. be the definitive standard for ODBC on the Linux platform. This is to
  40. include GUI support for KDE.
  41. Install unixODBC if you'd like to access databases through ODBC. This
  42. package include drivers for PostgreSQL and local files.
  43. If you want to develop programs that will access data through ODBC,
  44. you'll also need to have the unixODBC package installed.
  45. %package devel
  46. Summary: Development files for programs which will use the unixODBC library.
  47. Group: Development/Libraries
  48. Requires: unixODBC = %{version}
  49. %description devel
  50. Install unixODBC if you'd like to access databases through ODBC drivers.
  51. If you want to develop programs that will access data through ODBC,
  52. you'll also need to install the unixODBC-devel (this) package.
  53. %package kde
  54. Summary: KDE DriverManager components for ODBC
  55. Group: System Environment/Libraries
  56. Requires: unixODBC = %{version}
  57. #Requires: XFree86-libs qt freetype2 libjpeg libmng libpng zlib
  58. %description kde
  59. Components for the ODBCConfig and DataManager (KDE) Components of unixODBC.
  60. %prep
  61. %setup -q
  62. %patch1 -p1
  63. # 2.2.8 includes a libtool that is too old for some of our architectures.
  64. # Blow it away and replace with build system's libtool. (We intend to use
  65. # the installed libtool anyway, but this makes sure they match.)
  66. rm -rf config.guess config.sub ltmain.sh libltdl
  67. cp -r /usr/share/libtool/* .
  68. # Use newer install-sh and mkinstalldirs, too
  69. if [ -f libltdl/install-sh ]; then
  70. cp -f libltdl/install-sh .
  71. fi
  72. if [ -f libltdl/mkinstalldirs ]; then
  73. cp -f libltdl/mkinstalldirs .
  74. fi
  75. # libltdl patch has to be applied after the above
  76. %patch2 -p1
  77. %build
  78. %if %{vine26}
  79. [ -x /usr/bin/autoconf-2.5? ] && ln -s /usr/bin/autoconf-2.5? autoconf
  80. [ -x /usr/bin/autoheader-2.5? ] && ln -s /usr/bin/autoheader-2.5? autoheader
  81. [ -x /usr/bin/aclocal-1.5 ] && ln -s /usr/bin/aclocal-1.5 aclocal
  82. [ -x /usr/bin/automake-1.5 ] && ln -s /usr/bin/automake-1.5 automake
  83. export PATH=`pwd`:$PATH
  84. %endif
  85. %if %{kde}
  86. # pick up qt path
  87. export QTDIR=
  88. . /etc/profile.d/qt.sh
  89. %endif
  90. aclocal
  91. automake --add-missing
  92. autoconf
  93. pushd libltdl
  94. aclocal
  95. automake
  96. autoconf
  97. popd
  98. %configure --with-gnu-ld=yes --enable-threads=yes --enable-gui=yes --enable-static=yes --enable-drivers
  99. make all
  100. %install
  101. %if %{kde}
  102. # pick up qt path
  103. unset QTDIR || : ; . /etc/profile.d/qt.sh
  104. %endif
  105. rm -rf $RPM_BUILD_ROOT
  106. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
  107. mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons
  108. %makeinstall
  109. cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
  110. #cp DataManager/LinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/icons
  111. #cp odbcinstQ/smallLinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/icons
  112. #install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
  113. #install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/X11/applnk/System
  114. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  115. %clean
  116. rm -rf $RPM_BUILD_ROOT
  117. %post -p /sbin/ldconfig
  118. %postun -p /sbin/ldconfig
  119. %if %{kde}
  120. %post kde -p /sbin/ldconfig
  121. %postun kde -p /sbin/ldconfig
  122. %endif
  123. %files
  124. %defattr(-,root,root)
  125. %doc README COPYING AUTHORS ChangeLog NEWS INSTALL doc
  126. %config(noreplace) %{_sysconfdir}/odbc*
  127. %{_bindir}/dltest
  128. %{_bindir}/isql
  129. %{_bindir}/iusql
  130. %{_bindir}/odbcinst
  131. %{_libdir}/libboundparam.so.*
  132. %{_libdir}/libesoobS.so.*
  133. %{_libdir}/libgtrtst.so.*
  134. %{_libdir}/libmimerS.so.*
  135. %{_libdir}/libnn.so.*
  136. %{_libdir}/libodbc.so.*
  137. %{_libdir}/libodbccr.so.*
  138. %{_libdir}/libodbcdrvcfg1S.so.*
  139. %{_libdir}/libodbcdrvcfg2S.so.*
  140. #%{_libdir}/libodbcextras.so.*
  141. %{_libdir}/libodbcinst.so.*
  142. %{_libdir}/libodbcminiS.so.*
  143. %{_libdir}/libodbcmyS.so.*
  144. %{_libdir}/libodbcnnS.so.*
  145. %{_libdir}/libodbcpsql.so.*
  146. %{_libdir}/libodbcpsqlS.so.*
  147. %{_libdir}/libodbctxt.so.*
  148. %{_libdir}/libodbctxtS.so.*
  149. %{_libdir}/liboplodbcS.so.*
  150. %{_libdir}/liboraodbcS.so.*
  151. %{_libdir}/libsapdbS.so.*
  152. %{_libdir}/libtdsS.so.*
  153. %{_libdir}/libtemplate.so.*
  154. %files devel
  155. %defattr(-,root,root)
  156. %{_bindir}/odbc_config
  157. %{_includedir}/*
  158. %{_libdir}/libboundparam.so
  159. %{_libdir}/libesoobS.so
  160. %{_libdir}/libgtrtst.so
  161. %{_libdir}/libmimerS.so
  162. %{_libdir}/libnn.so
  163. %{_libdir}/libodbc.so
  164. %{_libdir}/libodbccr.so
  165. %{_libdir}/libodbcdrvcfg1S.so
  166. %{_libdir}/libodbcdrvcfg2S.so
  167. #%{_libdir}/libodbcextras.so
  168. %{_libdir}/libodbcinst.so
  169. %{_libdir}/libodbcminiS.so
  170. %{_libdir}/libodbcmyS.so
  171. %{_libdir}/libodbcnnS.so
  172. %{_libdir}/libodbcpsql.so
  173. %{_libdir}/libodbcpsqlS.so
  174. %{_libdir}/libodbctxt.so
  175. %{_libdir}/libodbctxtS.so
  176. %{_libdir}/liboplodbcS.so
  177. %{_libdir}/liboraodbcS.so
  178. %{_libdir}/libsapdbS.so
  179. %{_libdir}/libtdsS.so
  180. %{_libdir}/libtemplate.so
  181. %{_libdir}/*.a
  182. #{_libdir}/*.la
  183. %if %{kde}
  184. %files kde
  185. %defattr(-,root,root)
  186. %{_bindir}/DataManager
  187. %{_bindir}/DataManagerII
  188. %{_bindir}/ODBCConfig
  189. %{_bindir}/odbctest
  190. %{_libdir}/libodbcinstQ.so*
  191. #%{_sysconfdir}/X11/applnk/System/*
  192. %endif
  193. %changelog
  194. * Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
  195. - applied new versioning policy
  196. - removed *.la files from devel package
  197. * Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
  198. - updated to 2.2.12
  199. - rebuilt with new toolchain
  200. * Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
  201. - use installed libltdl
  202. - added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
  203. * Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
  204. - rebuilt with readline 5.1
  205. * Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
  206. - updated to 2.2.11
  207. - not libtoolize
  208. * Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
  209. - added Patch100 to fix typo in doc/Makefile.am from failure on compiling
  210. * Fri Jun 6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
  211. - source upgrade
  212. - remove patch (no need)
  213. - run libtoolize etc for VineSeed
  214. * Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
  215. - enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
  216. * Sun Feb 9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
  217. - source upgrade
  218. - change spec to build both VineSeed and Vine2.5/2.6
  219. - add patch from rawhide 2.2.3-6
  220. * Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
  221. - Requires: libjpeg (not libjpeg-6b)
  222. * Sun Oct 6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
  223. - source upgrade
  224. - add BuildPrereq: autoconf253 automake15
  225. - add PreReq: ldconfig
  226. - fix %files section and clean up spec
  227. - for unixODBC-kde package
  228. - add Requires: unixODBC = %{version}
  229. - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
  230. - delete .desktop files
  231. * Thu Apr 4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
  232. - rebuild with KDE3
  233. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
  234. - updated unixODBC-2.2.0
  235. - fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
  236. * Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
  237. - remove -kde package on alpha
  238. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
  239. - Rebuild for Vine.
  240. * Sun Jun 24 2001 Than Ngo <than@redhat.com>
  241. - rebuild against qt-2.3.1, kde-2.1.x
  242. * Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
  243. - Better default odbcinst.ini
  244. - Minor cleanups
  245. * Wed Jun 6 2001 Trond Eivind Glomsrød <teg@redhat.com>
  246. - 2.0.7
  247. * Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
  248. - Fix for isql segfault on EOF/ctrl-d exit
  249. * Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
  250. - 2.0.6
  251. - add patch for 64 bit archs (dword shouldn't be "long int")
  252. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  253. - rebuild
  254. * Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  255. - 1.8.13
  256. * Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
  257. - enable GUI now that we have KDE compiled with the standard
  258. compiler
  259. - move the applnk entries to the KDE package
  260. * Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  261. - add the missing shared libs to the non-devel package
  262. * Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
  263. - 1.8.12 fixes problems with the postgresql driver
  264. * Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
  265. - disable KDE subpackage to avoid the mess that is C++ binary
  266. compatibility
  267. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  268. - automatic rebuild
  269. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
  270. - improved QTDIR detection
  271. * Thu Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
  272. - 1.8.10
  273. - use %%{_tmppath}
  274. - update URL
  275. - including two missing libraries
  276. * Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
  277. - 1.8.9
  278. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  279. - adopted for Winston, changed to Red Hat packaging standards
  280. * Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
  281. - added a unixODBC-devel RPM to the group, added KDE links and icons to system
  282. - all of which came from recommendations from Fredrick Meunier
  283. - <Fredrick.Meunier@computershare.com.au>
  284. * Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
  285. - unixODBC-1.8.7
  286. - moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.