readahead-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231
  1. Summary: Read a preset list of files into memory.
  2. Summary(ja): あらかじめ指定したファイル群をメモリに先読みするツール
  3. Name: readahead
  4. Version: 1.5.4
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. License: GPLv2+
  8. URL: https://hosted.fedoraproject.org/readahead
  9. Source0: readahead-%{version}.tar.bz2
  10. Source1: readahead_early
  11. Source2: default.early
  12. # default settings for Vine Linux
  13. Patch0: readahead-1.5.0-default.patch
  14. # (mdv) create a temp file to detect if collector is running, autodelect collector enabling file at end of collection
  15. Patch1: readahead-1.4.6-autocollector.patch
  16. # (mdv) don't generate later list
  17. Patch2: readahead-1.4.6-nolater.patch
  18. Patch3: better-cron.patch
  19. Patch4: multiple-ignores.patch
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. Requires(post): /sbin/chkconfig
  22. Requires(pre): /sbin/chkconfig
  23. Requires(triggerpostun): /sbin/chkconfig
  24. Requires: procps, gawk
  25. BuildRequires: e2fsprogs-devel, audit-libs-devel, libblkid-devel
  26. BuildRequires: pkgconfig
  27. %description
  28. readahead reads the contents of a list of files into memory,
  29. which causes them to be read from cache when they are actually
  30. needed. Its goal is to speed up the boot process.
  31. %description -l ja
  32. readahead はあらかじめ指定されたファイルをメモリに読み込んでおき、
  33. 実際に必要になったときにキャッシュから読み込まれるようにします。
  34. このツールの目的は起動プロセスの高速化です。
  35. %prep
  36. %setup -q
  37. %patch0 -p1 -b .default
  38. %patch1 -p1 -b .autocollector
  39. %patch2 -p1 -b .nolater
  40. %patch3 -p1
  41. %patch4 -p1
  42. install -m644 %{SOURCE2} lists/
  43. %build
  44. %configure --sbindir=/sbin
  45. make %{?_smp_mflags} rpm-lists-rebuild FILES="default.early" CFLAGS="$RPM_OPT_FLAGS" RPM_LIB="%{_lib}" RPM_ARCH="%{_arch}"
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. make DESTDIR=$RPM_BUILD_ROOT install
  49. %find_lang %{name}
  50. install -m755 %{SOURCE1} $RPM_BUILD_ROOT/sbin
  51. # file list dir
  52. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
  53. %clean
  54. rm -rf ${RPM_BUILD_ROOT}
  55. %files -f %{name}.lang
  56. %defattr(-,root,root)
  57. %doc COPYING README
  58. #%attr(0644,root,root) %{_sysconfdir}/readahead.d/default.early
  59. /sbin/readahead
  60. /sbin/readahead-collector
  61. /sbin/readahead_early
  62. /etc/event.d/*
  63. /etc/cron.daily/readahead.cron
  64. /etc/cron.monthly/readahead-monthly.cron
  65. %config(noreplace) %{_sysconfdir}/sysconfig/readahead
  66. %config(noreplace) /etc/readahead.conf
  67. %dir %{_localstatedir}/lib/%{name}
  68. %pre
  69. if [ -f /etc/rc.d/init.d/readahead_early ]; then
  70. /sbin/chkconfig --del readahead_early > /dev/null 2>&1 ||:
  71. /sbin/chkconfig --del readahead_later > /dev/null 2>&1 ||:
  72. fi
  73. %preun
  74. if [ "$1" = "0" ] ; then
  75. # for updating older packages with service files
  76. /sbin/service readahead_later stop >/dev/null 2>&1
  77. /sbin/chkconfig --del readahead_later >/dev/null 2>&1
  78. /sbin/service readahead_early stop >/dev/null 2>&1
  79. /sbin/chkconfig --del readahead_early >/dev/null 2>&1
  80. :
  81. fi
  82. %post
  83. if [ "$1" = "1" ]; then
  84. touch /.readahead_collect
  85. fi
  86. %changelog
  87. * Sun Oct 25 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.4-1
  88. - new upstream release
  89. - added %preun to delete old service
  90. - added configure option
  91. - added BuildRequires: libblkid-devel
  92. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.3-1
  93. - new upstream release
  94. - dropt Pacth3,5
  95. - renumbered Patch
  96. - added Patch4 (multiple-ignores.patch) from Debian
  97. * Thu Oct 8 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-2
  98. - fixed Patch number in changelog Thu Sep 24 2009
  99. - added Patch4,5 from Debian
  100. * Thu Sep 24 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.1-1
  101. - new upstream release
  102. - added Patch3 from Fedora
  103. * Sun Sep 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
  104. - new upstream release
  105. - updated and renamed Patch0: readahead-1.5.0-default.patch
  106. * Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-5
  107. - add /usr/share/anthy to exclude list
  108. * Sun Aug 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.9-4
  109. - /etc/readahead.d moved to /var/lib/readahead
  110. * Sat May 9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-3
  111. - fix readahead_early (Source1) to check wheter /etc/readahead.d/*.early
  112. do exist
  113. * Fri May 1 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.4.9-2
  114. - include /etc/readahead.d directory (otherwise /sbin/readahead_early
  115. will exit with non-zero exit status)
  116. * Sat Apr 11 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.4.9-1
  117. - new upstream release
  118. - updated and renamed Patch0: readahead-1.4.9-default.patch
  119. * Sat Dec 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-1
  120. - new upstream release
  121. - remove readahead_later, use preload for this.
  122. - add some patches from mdk
  123. - remove initscripts, will be handle in rc.sysinit
  124. * Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3-1
  125. - initial build for Vine Linux
  126. * Fri Feb 2 2007 Karel Zak <kzak@redhat.com> - 1:1.3-7
  127. - rebuild (update file lists)
  128. * Tue Jan 16 2007 Karel Zak <kzak@redhat.com> - 1:1.3-6
  129. - update file lists (215503)
  130. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1:1.3-5
  131. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  132. * Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-4
  133. - fix #207631 - clean up package build system and use tarball instead
  134. separated source files
  135. * Fri Sep 22 2006 Karel Zak <kzak@redhat.com> 1:1.3-3
  136. - fix #207631 - readahead has no debuginfo
  137. * Mon Jul 20 2006 Karel Zak <kzak@redhat.com> 1:1.3-1
  138. - move lists of files to /etc/readahead.d
  139. - add readahead-check to docs
  140. - ignore duplicate files
  141. * Wed Jul 19 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-3
  142. - fix release for upgrade path (by removing cvs generated release)
  143. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.26
  144. - rebuild
  145. * Thu Mar 16 2006 Karel Zak <kzak@redhat.com>
  146. - update versions in *.in lists
  147. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.24.2
  148. - bump again for double-long bug on ppc(64)
  149. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1:1.2-1.23.1
  150. - rebuilt for new gcc4.1 snapshot and glibc changes
  151. * Fri Jan 13 2006 Karel Zak <kzak@redhat.com>
  152. - check & cleanup list of files by readahead-gen script
  153. * Wed Dec 21 2005 Karel Zak <kzak@redhat.com>
  154. - removed double slashes in the directory names
  155. - removed or fixed the rest of X11R6 directories
  156. * Mon Dec 19 2005 Karel Zak <kzak@redhat.com>
  157. - sync versioned gcc, firefox, openoffice.org, evolution dirs with FC5
  158. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  159. - rebuilt
  160. * Thu Aug 4 2005 Dave Jones <davej@redhat.com>
  161. - Integrated changes from Ville Skytta (#164872)
  162. - Fix inverted logic in readahead_early also.
  163. - readahead_early looks useful in more runlevels than just 5.
  164. - Sync versioned gcc, firefox and openoffice.org dirs with FC4 updates.
  165. * Tue Aug 2 2005 Dave Jones <davej@redhat.com>
  166. - Fix inverted free memory test in startup script. (#164872)
  167. * Wed May 18 2005 Bill Nottingham <notting@redhat.com>
  168. - new readahead.c from Ziga Mahkovec <ziga.mahkovec@klika.si>
  169. - optimizes read access for more throughput
  170. - regenerate file lists (#128444)
  171. - fix lack of newlines (#146744)
  172. - fix lists so that they are architecture-neutral
  173. - move check for > 384MB into the init scripts, not the %%post
  174. * Tue Mar 1 2005 Dave Jones <davej@redhat.com>
  175. - Rebuild for gcc4
  176. * Thu Feb 10 2005 Dave Jones <davej@redhat.com>
  177. - Remove non-existent files from file lists.
  178. * Fri Jan 14 2005 Dave Jones <davej@redhat.com>
  179. - Don't do readahead if we have less than 256MB of memory.
  180. * Sat Dec 18 2004 Dave Jones <davej@redhat.com>
  181. - Initial packaging, based upon kernel-utils.