python-twisted-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: Event-driven networking engine in Python
  5. Summary(ja): Pythonで書かれたイベントドリブンなネットワークエンジン
  6. Name: python-twisted
  7. Version: 8.1.0
  8. Release: %{pkg_release}
  9. Source0: http://tmrc.mit.edu/mirror/twisted/Twisted/8.1/Twisted-%{version}.tar.bz2
  10. License: MIT
  11. Group: Development/Languages
  12. URL: http://twistedmatrix.com/trac/
  13. Requires: python
  14. Requires: python-zope-interface
  15. Requires: pyOpenSSL
  16. BuildRequires: python, python-devel
  17. BuildRequires: python-zope-interface
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. %description
  20. Twisted is a networking engine written in Python, supporting
  21. numerous protocols. It contains a web server, numerous chat
  22. clients, chat servers, mail servers, and more.
  23. Twisted is a platform for developing internet applications.
  24. %description -l ja
  25. Twisted は Python で書かれた、多くのプロトコルをサポートする
  26. ネットワーク・エンジンです。このパッケージにはウェブサーバや
  27. 多種多様なチャット用クライアント、チャットサーバ、メールサーバ
  28. 等が含まれています。
  29. Twisted はウェブアプリケーション開発用のプラットフォームです。
  30. %package docs
  31. Summary: Documentation for Twisted
  32. Summary(ja): Twisted のドキュメント
  33. Group: Applications/Documentation
  34. # workaround to prevent find-requires error
  35. AutoReq: No
  36. %description docs
  37. This package contains various documents and examples for
  38. Twisted.
  39. %description docs -l ja
  40. このパッケージには Twisted の各種ドキュメントやサンプルが
  41. 含まれています。
  42. %prep
  43. %setup -q -n Twisted-%{version}
  44. %build
  45. %{__python} setup.py build
  46. # create plugins cache
  47. python -c "from twisted.plugin import IPlugin, getPlugins;list(getPlugins(IPlugin))" >/dev/null 2>&1
  48. %install
  49. %{__rm} -rf ${RPM_BUILD_ROOT}
  50. %{__python} setup.py install --root ${RPM_BUILD_ROOT}
  51. # install man pages
  52. %{__install} -d -m 755 "$RPM_BUILD_ROOT"/%{_mandir}/man1/
  53. %{__install} -m 644 doc/core/man/*.1 ${RPM_BUILD_ROOT}/%{_mandir}/man1/
  54. %clean
  55. %{__rm} -rf ${RPM_BUILD_ROOT}
  56. %files
  57. %defattr(-,root,root)
  58. %doc INSTALL LICENSE NEWS README
  59. %{_bindir}/bookify
  60. %{_bindir}/cftp
  61. %{_bindir}/ckeygen
  62. %{_bindir}/conch
  63. %{_bindir}/im
  64. %{_bindir}/lore
  65. %{_bindir}/mailmail
  66. %{_bindir}/manhole
  67. %{_bindir}/mktap
  68. %{_bindir}/pyhtmlizer
  69. %{_bindir}/t-im
  70. %{_bindir}/tap2deb
  71. %{_bindir}/tap2rpm
  72. %{_bindir}/tapconvert
  73. %{_bindir}/tkconch
  74. %{_bindir}/trial
  75. %{_bindir}/twistd
  76. %{python_sitearch}/twisted
  77. %{python_sitearch}/Twisted-%{version}-py%{pyver}.egg-info
  78. %{_mandir}/man1/*
  79. %files docs
  80. %defattr(-,root,root)
  81. %doc doc/*
  82. %changelog
  83. * Thu Feb 04 2010 Shu KONNO <owa@bg.wakwak.com> 8.1.0-2
  84. - rebuilt with python-2.6.4-3
  85. * Tue Dec 23 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 8.1.0-1
  86. - initial build for Vine Linux