pilot-link-vl.spec 8.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270
  1. %define ver 0.12.4
  2. %define srcver %{ver}
  3. %define rel 1%{?_dist_release}
  4. %define support_perl 0
  5. Summary: File transfer utilities between Linux and PalmPilots.
  6. Summary(ja): Linux と Palm handheld device を接続する為のユーティリティ
  7. Name: pilot-link
  8. Version: %{ver}
  9. Release: %{rel}
  10. Epoch: 1
  11. Source: http://downloads.pilot-link.org/pilot-link-%{srcver}.tar.bz2
  12. Source1: connect-palm-ppp.tar.bz2
  13. Source2: 60-libpisock.rules.vine
  14. # (fc) 0.10.99 fix python/perl installation
  15. Patch1: pilot-link-0.11.0-perlmd5.patch
  16. Patch2: pilot-link-0.11.0-perlpollute.patch
  17. Patch3: pilot-link-0.11.2-malsync.patch
  18. Patch4: pilot-link-0.11.5-broken.patch
  19. #Patch7: pilot-link-0.11.3-destdir.patch.bz2
  20. #Patch9: pilot-link-0.11.8-configure.patch
  21. License: GPL/LGPL
  22. Group: Applications/Other
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: bison >= 1.35
  25. BuildRequires: libusb-devel >= 0.1
  26. BuildRequires: readline-devel
  27. BuildRequires: bluez-libs-devel
  28. BuildRequires: popt-devel
  29. %if %{support_perl}
  30. BuildRequires: perl
  31. %endif
  32. Requires: libusb >= 0.1
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. This suite of tools allows you to upload and download programs and
  37. data files between a Linux/UNIX machine and the PalmPilot. It has a
  38. few extra utils that will allow for things like syncing the
  39. PalmPilot's calendar app with Ical. Note that you might still need to
  40. consult the sources for pilot-link if you would like the Python, Tcl,
  41. or Perl bindings.
  42. Install pilot-link if you want to synchronize your Palm with your Vine
  43. Linux system.
  44. %description -l ja
  45. このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
  46. プログラムやファイルを転送することができます。このツールには、Palm
  47. handheld device の予定表と Ical との間で同期を可能にするようないくつ
  48. かのユーティリティが付属しています。もし Python や Tcl、あるいは
  49. Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
  50. あることに注意してください。
  51. Palm handheld device を Vine Linux システムで同期させたい場合は
  52. pilot-link をインストールします。
  53. %package devel
  54. Summary: PalmPilot development header files.
  55. Summary(ja): Palm handheld プログラム開発用のヘッダ ファイル
  56. Group: Development/Libraries
  57. Requires: %{name} = %{epoch}:%{version}
  58. Requires: pkgconfig
  59. %description devel
  60. This package contains the development headers that are used to build
  61. the pilot-link package. It also includes the static libraries
  62. necessary to build static pilot apps.
  63. If you want to develop PalmPilot synchronizing applications, you'll
  64. need to install pilot-link-devel.
  65. %description devel -l ja
  66. このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
  67. ヘッダ ファイルが含まれます。また、スタティックな Palm 用アプリケーション
  68. の構築に必要なスタティック ライブラリも含まれます。
  69. Palm handheld deviceと同期するアプリケーションを開発したい場合は、
  70. pilot-link-devel パッケージをインストールする必要があります。
  71. %prep
  72. %setup -q -a 1
  73. %if %{support_perl}
  74. %patch1 -p1 -b .perlmd5
  75. %patch2 -p1 -b .perlpollute
  76. %patch3 -p1 -b .malsync
  77. %endif
  78. #%patch7 -p1 -b .destdir
  79. #patch9 -p1 -b .mathlib
  80. #needed by patch 7 & 8
  81. #aclocal
  82. #automake
  83. #update libtool (needed for linking libpisock++ correctly)
  84. #libtoolize --force
  85. %build
  86. %configure\
  87. --disable-static \
  88. --enable-conduits \
  89. --enable-libusb \
  90. --with-libpng \
  91. --with-bluez \
  92. --without-python \
  93. --without-tcl \
  94. --without-java \
  95. %if %{support_perl}
  96. --with-perl
  97. %else
  98. --without-perl
  99. %endif
  100. make
  101. %install
  102. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  103. %if %{support_perl}
  104. if test -f bindings/Perl/Makefile.PL ; then
  105. cd bindings/Perl
  106. perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
  107. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
  108. make
  109. cd ../..
  110. fi
  111. %endif
  112. %__make install DESTDIR=$RPM_BUILD_ROOT
  113. #%makeinstall -C doc/man
  114. %if %{support_perl}
  115. make install -C bindings/Perl
  116. rm -f %{buildroot}%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
  117. %{buildroot}%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
  118. %endif
  119. # install modified udev rules.
  120. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
  121. install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
  122. # remove files we don't want to include
  123. rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
  124. %post -p /sbin/ldconfig
  125. %postun -p /sbin/ldconfig
  126. %clean
  127. [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
  128. %files
  129. %defattr(-,root,root)
  130. %doc COPYING COPYING.LIB ChangeLog README NEWS AUTHORS doc/README.*
  131. %{_sysconfdir}/udev/rules.d/60-libpisock.rules
  132. %{_libdir}/*.so.*
  133. %{_datadir}/pilot-link
  134. %if %{support_perl}
  135. %{_libdir}/perl5/vendor_perl/*/*/*/PDA
  136. %{_libdir}/perl5/vendor_perl/*/*/PDA
  137. %endif
  138. %{_bindir}/*
  139. %{_mandir}/man*/*
  140. %files devel
  141. %defattr(-, root, root)
  142. #{_libdir}/*.a
  143. %{_libdir}/*.so
  144. #%{_libdir}/*.la
  145. %{_libdir}/pkgconfig/pilot-link.pc
  146. %{_includedir}/*
  147. %{_datadir}/aclocal/*.m4
  148. %changelog
  149. * Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
  150. - new upstream release
  151. - removed static libraries from devel package
  152. - added --with-bluez to %%configure (added also BR: bluez-libs-devel)
  153. * Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
  154. - applied new versioning policy, spec in utf-8
  155. * Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
  156. - add modified udev rules (Source2). <BTS:VineLinux:222>
  157. * Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
  158. - source update.
  159. - change Group to Applications/Other
  160. - use %%configure macro instead of ./configure
  161. - delete unused configure options for itcl and tk.
  162. - use '%%__make install' to use DESTDIR variable.
  163. - comment out '%%makeinstall -C doc/man'(not required to install man).
  164. - add 60-libpisock.rules for udev in %%files.
  165. - add pilot-link.pc in %%files for -devel.
  166. - add Requires libusb and BuildRequires libusb-devel >= 0.1.
  167. * Fri Jan 6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
  168. - rebuild for VineSeed
  169. - add "%%{epoch}:" to Requires in pilot-link-devel
  170. * Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
  171. - convert spec from SJIS to EUC.
  172. * Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
  173. - source update
  174. - add japanese translation(summary & description).
  175. - use License tag instead of Copyright.
  176. - change BuildRequires XFree86-devel to XOrg-devel.
  177. - add BuildRequires readline-devel.
  178. - add new Patch9.(avoid make error "undefined reference to `pow'")
  179. * Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
  180. - disuse %%configure macro to avoid unsuitable prefixed filename
  181. * Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
  182. - source update
  183. * Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
  184. - unfortunately added Epoch 1
  185. (the previous version was 0.9.5.pre5-0vl2. Sigh...)
  186. * Sat Oct 13 2001 <uh@u.dhis.portside.net>
  187. - 0.9.5-0vl1
  188. - upgrade to 0.9.5
  189. - add COPYING.LIB to %doc
  190. * Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
  191. - New upstream release.
  192. - Fixed defattr stuff for devel package.
  193. - Use rpmmacros.
  194. * Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
  195. - upgrade to pilot-link 0.9.3, rewrite spec.
  196. * Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
  197. - strip binaries
  198. * Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
  199. - added missing files from devel subpackage
  200. * Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
  201. - move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
  202. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  203. - auto rebuild in the new build environment (release 5)
  204. * Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
  205. - Injected new description and group.
  206. * Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
  207. - arm fix
  208. * Fri Sep 24 1998 Michael Maher <mike@redhat.com>
  209. - cleaned up spec file, updated package
  210. * Tue May 19 1998 Michael Maher <mike@redhat.com>
  211. - updated rpm
  212. * Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
  213. - added changelog
  214. - updated to 0.8.9
  215. - removed explicit requires for /usr/bin/perl