perl-Bit-Vector-vl.spec 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192
  1. Summary: Efficient bit vector, set of integers and "big int" math library
  2. Name: perl-Bit-Vector
  3. Version: 6.4
  4. Release: 1%{?_dist_release}
  5. License: distributable
  6. Group: Development/Libraries
  7. URL: http://search.cpan.org/~stbey/Bit-Vector/
  8. Source0: http://www.cpan.org/authors/id/STBEY/Bit-Vector-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: perl >= 0:5.00503
  11. BuildRequires: perl-Carp-Clan >= 5.3
  12. Requires: perl
  13. Requires: perl-Carp-Clan >= 5.3
  14. Conflicts: perl-Date-Calc < 5.0
  15. %description
  16. Bit::Vector is an efficient C library which allows you to handle
  17. bit vectors, sets (of integers), "big integer arithmetic" and
  18. boolean matrices, all of arbitrary sizes.
  19. The library is efficient (in terms of algorithmical complexity)
  20. and therefore fast (in terms of execution speed) for instance
  21. through the widespread use of divide-and-conquer algorithms.
  22. The package also includes an object-oriented Perl module for
  23. accessing the C library from Perl, and optionally features
  24. overloaded operators for maximum ease of use.
  25. The C library can nevertheless be used stand-alone, without Perl.
  26. %prep
  27. %setup -q -n Bit-Vector-%{version}
  28. %build
  29. CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
  30. make
  31. %install
  32. rm -rf $RPM_BUILD_ROOT
  33. make DESTDIR=$RPM_BUILD_ROOT pure_install
  34. find $RPM_BUILD_ROOT%{_prefix} -type f -print | \
  35. sed "s@^$RPM_BUILD_ROOT@@g" | \
  36. grep -v perllocal.pod | \
  37. grep -v %{_mandir} | \
  38. grep -v "\.packlist" > Bit-Vector-%{version}-filelist
  39. if [ "$(cat Bit-Vector-%{version}-filelist)X" = "X" ] ; then
  40. echo "ERROR: EMPTY FILE LIST"
  41. exit -1
  42. fi
  43. install -m 0644 blib/man3/* %{buildroot}%{_mandir}/man3
  44. find examples -type f | xargs perl -pi -e "s|^#!(\s)?/usr/local/bin/perl|#!%{__perl}|g"
  45. %check
  46. make test
  47. %clean
  48. rm -rf $RPM_BUILD_ROOT
  49. %files -f Bit-Vector-%{version}-filelist
  50. %defattr(-,root,root)
  51. %doc CHANGES.txt CREDITS.txt README.txt examples Artistic.txt GNU_GPL.txt GNU_LGPL.txt
  52. %dir %{perl_vendorarch}/auto/Bit
  53. %dir %{perl_vendorarch}/auto/Bit/Vector
  54. %dir %{perl_vendorarch}/Bit
  55. %dir %{perl_vendorarch}/Bit/Vector
  56. %{_mandir}/man3/*3pm*
  57. %changelog
  58. * Sat Nov 8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.4-1
  59. - new upstream release
  60. - built with perl-5.10.0
  61. * Sun Jan 2 2005 IWAI, Masaharu <iwai@alib.jp> 6.4-0vl1
  62. - new upstream release
  63. - update Summary and description
  64. - add Requires: perl-Carp-Clan >= 5.3
  65. - add some license documents
  66. * Thu Apr 17 2003 IWAI Masaharu <iwai@alib.jp> 6.3-0vl1
  67. - version up to 6.3
  68. - add directories in %%files section
  69. - add some documents
  70. - add Conflicts: perl-Date-Calc < 5.0
  71. * Thu Apr 11 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 6.1-12vl1
  72. - build Rawhide-6.1-12 for Vine Linux
  73. * Wed Jan 30 2002 cturner@redhat.com
  74. - Specfile autogenerated