python-markdown-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325
  1. %global srcname Markdown
  2. %global pkgname markdown
  3. Name: python-%{pkgname}
  4. Summary: Markdown implementation in Python
  5. Version: 3.3.4
  6. Release: 3%{?_dist_release}
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD
  11. URL: https://python-markdown.github.io/
  12. Source0: %{pypi_source}
  13. BuildArch: noarch
  14. %description
  15. This is a Python implementation of John Gruber’s Markdown. It is
  16. almost completely compliant with the reference implementation, though
  17. there are a few very minor differences.
  18. %package -n python3-%{pkgname}
  19. Summary: Markdown implementation in Python
  20. Group: programming
  21. BuildRequires: python3-devel
  22. BuildRequires: python3-PyYAML
  23. BuildRequires: python3-setuptools
  24. %if 0%{?rhel} && 0%{?rhel} < 9
  25. BuildRequires: python3-importlib-metadata
  26. Requires: python3-importlib-metadata
  27. %endif
  28. %{?python_provide:%python_provide python3-%{pkgname}}
  29. %description -n python3-%{pkgname}
  30. This is a Python implementation of John Gruber's Markdown. It is
  31. almost completely compliant with the reference implementation, though
  32. there are a few known issues.
  33. %prep
  34. %autosetup -p1 -n %{srcname}-%{version}
  35. %build
  36. %py3_build
  37. %install
  38. %py3_install
  39. # process license file
  40. PYTHONPATH=%{buildroot}%{python3_sitelib} \
  41. %{buildroot}%{_bindir}/markdown_py \
  42. LICENSE.md > LICENSE.html
  43. %check
  44. python3 -m unittest discover tests
  45. %files -n python3-%{pkgname}
  46. # temporarily skip packaging docs - see also
  47. # https://github.com/Python-Markdown/markdown/issues/621
  48. #doc python3/build/docs/*
  49. %license LICENSE.*
  50. %{python3_sitelib}/*
  51. %{_bindir}/markdown_py
  52. %changelog
  53. * Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.3.4-3
  54. - initial build for Vine Linux.
  55. * Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-2
  56. - Apply PR6 by Igor Raits <ignatenkobrain@fedoraproject.org>: Support
  57. for building on EPEL8 + upstream tests invocation.
  58. - Remove unused BR on python3-tidy (we'd need pytidylib instead, which
  59. doesn't seem to be packaged).
  60. * Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-1
  61. - Update to 3.3.4.
  62. * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-2
  63. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  64. * Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.3-1
  65. - Update to 3.3.3.
  66. * Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.2-1
  67. - Update to 3.3.2.
  68. * Tue Oct 13 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.1-1
  69. - Update to 3.3.1.
  70. * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.2-4
  71. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  72. * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 3.2.2-3
  73. - Rebuilt for Python 3.9
  74. * Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-2
  75. - Update BRs.
  76. * Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-1
  77. - Update to 3.2.2.
  78. * Sat Feb 22 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.1-1
  79. - Update to 3.2.1.
  80. * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-7
  81. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  82. * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-6
  83. - Rebuilt for Python 3.8.0rc1 (#1748018)
  84. * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-5
  85. - Rebuilt for Python 3.8
  86. * Tue Aug 13 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-4
  87. - Drop versioned binaries.
  88. * Tue Aug 13 2019 Gwyn Ciesla <gwync@protonmail.com> - 3.1.1-3
  89. - Drop Python 2.
  90. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-2
  91. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  92. * Sat May 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-1
  93. - Update to 3.1.1.
  94. * Fri May 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1-2
  95. - Move /usr/bin/markdown_py to python3-markdown (#1705777)
  96. * Tue Mar 26 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1-1
  97. - Update to 3.1.
  98. * Mon Mar 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.0.1-1
  99. - Update to 3.0.1.
  100. - Simplify spec file.
  101. - CLI tool uses Python3 now.
  102. - Update BRs.
  103. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-5
  104. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  105. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-4
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  107. * Sun Jun 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.6.11-3
  108. - Rebuilt for Python 3.7
  109. * Sun Jun 3 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-2
  110. - Try to fix a FTBFS with Python 3.7 (rhbz#1583678).
  111. * Sun Feb 11 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-1
  112. - Update to 2.6.11.
  113. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.9-3
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  115. * Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-2
  116. - Fix BRs.
  117. * Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-1
  118. - Update to 2.6.9.
  119. - Allow building a python3 subpackage on EPEL7+.
  120. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  122. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  124. * Sun Jan 29 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.8-1
  125. - Update to 2.6.8.
  126. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.6.7-2
  127. - Rebuild for Python 3.6
  128. * Sat Sep 24 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.7-1
  129. - Update to 2.6.7.
  130. - Update Source0 URL.
  131. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.6-2
  132. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  133. * Tue Apr 5 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.6-1
  134. - Update to 2.6.6.
  135. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.5-2
  136. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  137. * Sun Nov 29 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.5-1
  138. - Update to 2.6.5.
  139. * Sat Nov 21 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.4-1
  140. - Update to 2.6.4.
  141. - Follow updated Python packaging guidelines.
  142. * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-3
  143. - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
  144. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-2
  145. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  146. * Wed Apr 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.2-1
  147. - Update to 2.6.2.
  148. * Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-2
  149. - Add license file.
  150. * Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-1
  151. - Update to 2.6.1.
  152. - Apply updated Python packaging guidelines.
  153. * Sun Feb 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6-1
  154. - Update to 2.6.
  155. - Update the upstream URL.
  156. * Sun Nov 23 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-1
  157. - Update to 2.5.2.
  158. * Thu Oct 2 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.1-1
  159. - Update to 2.5.1.
  160. * Thu Sep 25 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5-1
  161. - Update to 2.5.
  162. - Add BR on PyYAML.
  163. * Wed Jun 4 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4.1-1
  164. - Update to 2.4.1.
  165. * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 2.4-2
  166. - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
  167. * Tue Apr 15 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4-1
  168. - Update to 2.4.
  169. - Update Python3 conditional.
  170. - Fix wrong line endings.
  171. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-3
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  173. * Fri Jul 19 2013 Thomas Moschny <thomas.moschny@gmx.dee> - 2.3.1-2
  174. - Move python3 runtime dependency to python3 subpackage (rhbz#986376).
  175. * Mon Apr 8 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3.1-1
  176. - Update to 2.3.1.
  177. * Mon Mar 18 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3-1
  178. - Update to 2.3.
  179. - Spec file cleanups.
  180. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-2
  181. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  182. * Fri Nov 23 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
  183. - Update to 2.2.1.
  184. * Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 2.2.0-3
  185. - rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
  186. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
  187. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  188. * Sat Jul 14 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.0-1
  189. - Update to 2.2.0.
  190. - Update url.
  191. - Add patch from upstream git for failing test.
  192. * Wed Feb 8 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.1-1
  193. - Update to 2.1.1.
  194. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
  195. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  196. * Sat Dec 17 2011 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.0-1
  197. - Update to 2.1.0.
  198. - Fix rhel conditional.
  199. - Binary has been renamed.
  200. - Build python3 subpackage.
  201. - Include documentation in HTML instead of Markdown format.
  202. - Run tests.
  203. * Wed Sep 07 2011 Jesse Keating <jkeating@redhat.com> - 2.0.3-4
  204. - Set a version in the rhel macro
  205. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-3
  206. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  207. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.0.3-2
  208. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  209. * Thu Oct 8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.3-1
  210. - Update to 2.0.3.
  211. * Thu Aug 27 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-3
  212. - Add requirement on python-elementtree, which was a separate package
  213. before Python 2.5.
  214. - Re-add changelog entries accidentally removed earlier.
  215. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  216. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  217. * Sat Jul 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-1
  218. - Update to 2.0.1.
  219. - Upstream stripped .py of the cmdline script.
  220. * Sat Apr 25 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-1
  221. - Update to 2.0.
  222. - Adjusted source URL.
  223. - License changed to BSD only.
  224. - Upstream now provides a script to run markdown from the cmdline.
  225. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
  226. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  227. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7-2
  228. - Rebuild for Python 2.6
  229. * Mon Aug 4 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.7-1
  230. - New package.