libvisio-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %global apiversion 0.1
  2. Name: libvisio
  3. Version: 0.1.7
  4. Release: 4%{?_dist_release}
  5. Summary: A library for import of Microsoft Visio diagrams
  6. Summary(ja): Microsoft Visio ダイアグラムをインポートするためのライブラリ
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MPLv2.0
  11. URL: http://wiki.documentfoundation.org/DLP/Libraries/libvisio
  12. Source: http://dev-www.libreoffice.org/src/%{name}/%{name}-%{version}.tar.xz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: doxygen
  15. BuildRequires: cppunit-devel
  16. BuildRequires: gperf
  17. BuildRequires: help2man
  18. BuildRequires: libboost-devel
  19. BuildRequires: libicu-devel
  20. BuildRequires: librevenge-devel
  21. BuildRequires: libxml2-devel
  22. BuildRequires: perl
  23. BuildRequires: zlib-devel
  24. %description
  25. %{name} is library providing ability to interpret and import
  26. Microsoft Visio diagrams into various applications. You can find it
  27. being used in libreoffice.
  28. %package devel
  29. Summary: Development files for %{name}
  30. Summary(ja): %{name} の開発用ファイル
  31. Group: programming
  32. Requires: %{name} = %{version}-%{release}
  33. %description devel
  34. The %{name}-devel package contains libraries and header files for
  35. developing applications that use %{name}.
  36. %package doc
  37. Summary: Documentation of %{name} API
  38. Summary(ja): %{name} API のドキュメント
  39. Group: documentation
  40. BuildArch: noarch
  41. %description doc
  42. The %{name}-doc package contains documentation files for %{name}.
  43. %package tools
  44. Summary: Tools to transform Microsoft Visio diagrams into other formats
  45. Summary(ja): Microsoft Visio ダイアグラムを他のフォーマットに変換するツール
  46. Group: office
  47. Requires: %{name} = %{version}-%{release}
  48. %description tools
  49. Tools to transform Microsoft Visio diagrams into other formats.
  50. Currently supported: XHTML, raw, plain text.
  51. %debug_package
  52. %prep
  53. %setup -q
  54. %build
  55. %configure --disable-static --disable-silent-rules
  56. sed -i \
  57. -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
  58. -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' \
  59. libtool
  60. make %{?_smp_mflags}
  61. export LD_LIBRARY_PATH=`pwd`/src/lib/.libs${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  62. help2man -N -n 'debug the conversion library' -o vsd2raw.1 ./src/conv/raw/.libs/vsd2raw
  63. help2man -N -n 'convert Visio document into SVG' -o vsd2xhtml.1 ./src/conv/svg/.libs/vsd2xhtml
  64. help2man -N -n 'convert Visio document into plain text' -o vsd2text.1 ./src/conv/text/.libs/vsd2text
  65. help2man -N -n 'debug the conversion library' -o vss2raw.1 ./src/conv/raw/.libs/vss2raw
  66. help2man -N -n 'convert Visio stencil into SVG' -o vss2xhtml.1 ./src/conv/svg/.libs/vss2xhtml
  67. help2man -N -n 'convert Visio stencil into plain text' -o vss2text.1 ./src/conv/text/.libs/vss2text
  68. %install
  69. rm -rf %{buildroot}
  70. make install DESTDIR=%{buildroot}
  71. rm -f %{buildroot}/%{_libdir}/*.la
  72. # rhbz#1001240 we install API docs directly from build
  73. rm -rf %{buildroot}/%{_docdir}/%{name}
  74. install -m 0755 -d %{buildroot}/%{_mandir}/man1
  75. install -m 0644 vsd2*.1 vss2*.1 %{buildroot}/%{_mandir}/man1
  76. %check
  77. export LD_LIBRARY_PATH=%{buildroot}%{_libdir}${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  78. # Workaround time formatting problem in the test
  79. export TZ='CET'
  80. make check %{?_smp_mflags}
  81. %clean
  82. rm -rf %{buildroot}
  83. %files
  84. %license COPYING.*
  85. %doc AUTHORS
  86. %{_libdir}/%{name}-%{apiversion}.so.*
  87. %files devel
  88. %doc ChangeLog
  89. %{_includedir}/%{name}-%{apiversion}
  90. %{_libdir}/%{name}-%{apiversion}.so
  91. %{_libdir}/pkgconfig/%{name}-%{apiversion}.pc
  92. %files doc
  93. %doc COPYING.*
  94. %doc docs/doxygen/html
  95. %files tools
  96. %{_bindir}/vsd2raw
  97. %{_bindir}/vsd2text
  98. %{_bindir}/vsd2xhtml
  99. %{_bindir}/vss2raw
  100. %{_bindir}/vss2text
  101. %{_bindir}/vss2xhtml
  102. %{_mandir}/man1/vsd2raw.1*
  103. %{_mandir}/man1/vsd2text.1*
  104. %{_mandir}/man1/vsd2xhtml.1*
  105. %{_mandir}/man1/vss2raw.1*
  106. %{_mandir}/man1/vss2text.1*
  107. %{_mandir}/man1/vss2xhtml.1*
  108. %changelog
  109. * Thu Apr 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-4
  110. - rebuilt with icu-69.
  111. - dropped ldconfig scriptlets.
  112. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-3
  113. - rebuilt with icu-67.
  114. * Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.1.7-2
  115. - rebuilt with icu-66.
  116. * Sun Oct 13 2019 Toshiaki Ara <ara_t@384.jp> - 0.1.7-1
  117. - new upstream release
  118. * Tue Jan 16 2018 Toshiaki Ara <ara_t@384.jp> - 0.1.5-2
  119. - rebuild under current VineSeed
  120. * Sun Jul 03 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.5-1
  121. - new upstream release
  122. - remove Patch0 (0001-fix-test.patch)
  123. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.1.3-1
  124. - new upstream release
  125. - add Patch0 (0001-fix-test.patch) from fedora
  126. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.1.1-2
  127. - Initial build for Vine Linux
  128. * Fri Jan 02 2015 David Tardon <dtardon@redhat.com> - 0.1.1-1
  129. - new upstream release
  130. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-4
  131. - rebuild for ICU 53.1
  132. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-3
  133. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  134. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.0-2
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  136. * Mon May 26 2014 David Tardon <dtardon@redhat.com> - 0.1.0-1
  137. - new upstream release
  138. * Thu May 22 2014 Petr Machata <pmachata@redhat.com> - 0.0.31-4
  139. - Rebuild for boost 1.55.0
  140. * Wed Apr 09 2014 David Tardon <dtardon@redhat.com> - 0.0.31-3
  141. - generate man pages
  142. * Wed Feb 12 2014 Rex Dieter <rdieter@fedoraproject.org> 0.0.31-2
  143. - rebuild (libicu)
  144. * Mon Sep 02 2013 David Tardon <dtardon@redhat.com> - 0.0.31-1
  145. - new release
  146. * Fri Aug 30 2013 David Tardon <dtardon@redhat.com> - 0.0.30-4
  147. - Resolves: rhbz#1001240 duplicate documentation files / potentially conflicting
  148. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.30-3
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  150. * Tue Jul 30 2013 Petr Machata <pmachata@redhat.com> - 0.0.30-2
  151. - Rebuild for boost 1.54.0
  152. * Mon Jul 15 2013 David Tardon <dtardon@redhat.com> - 0.0.30-1
  153. - new release
  154. * Tue Jul 02 2013 David Tardon <dtardon@redhat.com> - 0.0.29-1
  155. - new release
  156. * Wed Jun 05 2013 David Tardon <dtardon@redhat.com> - 0.0.28-1
  157. - new release
  158. * Thu May 16 2013 David Tardon <dtardon@redhat.com> - 0.0.27-1
  159. - new release
  160. * Tue Apr 23 2013 David Tardon <dtardon@redhat.com> - 0.0.26-1
  161. - new release
  162. * Thu Feb 28 2013 David Tardon <dtardon@redhat.com> - 0.0.25-1
  163. - new release
  164. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.24-2
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  166. * Tue Dec 18 2012 David Tardon <dtardon@redhat.com> - 0.0.24-1
  167. - new release
  168. * Mon Dec 03 2012 David Tardon <dtardon@redhat.com> - 0.0.23-1
  169. - new release
  170. * Thu Nov 29 2012 David Tardon <dtardon@redhat.com> - 0.0.22-1
  171. - new upstream release
  172. * Wed Nov 21 2012 David Tardon <dtardon@redhat.com> - 0.0.21-1
  173. - new upstream release
  174. * Tue Nov 06 2012 David Tardon <dtardon@redhat.com> - 0.0.20-1
  175. - new upstream version
  176. * Fri Jul 27 2012 David Tardon <dtardon@redhat.com> - 0.0.19-2
  177. - rebuilt for boost 1.50
  178. * Thu Jul 26 2012 David Tardon <dtardon@redhat.com> - 0.0.19-1
  179. - new upstream version
  180. * Tue Jul 24 2012 David Tardon <dtardon@redhat.com> - 0.0.18-3
  181. - fix endless loop with text fields in VSD6
  182. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.18-2
  183. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  184. * Fri Jun 22 2012 David Tardon <dtardon@redhat.com> 0.0.18-1
  185. - new upstream version
  186. * Fri Jun 01 2012 David Tardon <dtardon@redhat.com> 0.0.17-1
  187. - new upstream version
  188. * Tue Apr 17 2012 David Tardon <dtardon@redhat.com> 0.0.16-1
  189. - new upstream version
  190. * Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.15-2
  191. - Rebuilt for c++ ABI breakage
  192. * Tue Feb 21 2012 David Tardon <dtardon@redhat.com> 0.0.15-1
  193. - new upstream version
  194. * Wed Jan 25 2012 David Tardon <dtardon@redhat.com> 0.0.14-1
  195. - bump version
  196. - initial import
  197. * Wed Dec 21 2011 David Tardon <dtardon@redhat.com> 0.0.11-1
  198. - initial import