tix-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304
  1. %define tcl_major 8.5
  2. %define tk_major 8.5
  3. %define thread_major 2.7
  4. %define tix_major 8.4
  5. %define tixversion %{tix_major}.3
  6. ## can't find all provides
  7. #define _use_internal_dependency_generator 0
  8. Summary: A Tcl/Tk development environment: tix
  9. Summary(ja): Tcl/Tk 開発環境: tix
  10. Name: tix
  11. Version: %{tixversion}
  12. Release: 3%{?_dist_release}
  13. Group: Development/Languages
  14. License: BSD
  15. URL: http://tix.sourceforge.net/
  16. Source0: Tix%{tixversion}-src.tar.gz
  17. Patch20: tix-8.1.4-perf.patch
  18. Patch22: tix-8.2.0b1-dirtree.patch
  19. Buildroot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: tcl >= %{tcl_major}
  21. BuildRequires: tk >= %{tk_major}
  22. BuildRequires: thread >= %{thread_major}
  23. BuildRequires: libX11-devel
  24. Requires: tcl >= %{tcl_major}
  25. Requires: tk >= %{tk_major}
  26. Requires: thread >= %{thread_major}
  27. %description
  28. Tix (Tk Interface Extension), an add-on for the Tk widget set, is an
  29. extensive set of over 40 widgets. In general, Tix widgets are more
  30. complex and more capable than the widgets provided in Tk. Tix widgets
  31. include a ComboBox, a Motif-style FileSelectBox, an MS Windows-style
  32. FileSelectBox, a PanedWindow, a NoteBook, a hierarchical list, a
  33. directory tree and a file manager.
  34. Install the tix package if you want to try out more complicated widgets
  35. for Tk. You'll also need to have the tcl and tk packages installed.
  36. %description -l ja
  37. Tk ウィジェットセットのためのアドオンである、Tix (Tk Interface Extension)
  38. は 40 ウィジェットを超える拡張セットです。Tix ウィジェットの多くが、
  39. Tk から供給されるウィジェットよりも高機能です。Tix ウィジェットは
  40. コンボボックス、Motif スタイルのファイルボックス、MS Windows スタイルの
  41. ファイルボックス、パネルウィンドウ、ノートブック、階層リスト、
  42. ディレクトリツリー、ファイルマネージャを含んでいます。
  43. Tk で、より複雑ななウィジェットを試したい時には、tix パッケージをインストール
  44. してください。tcl と tk のパッケージもインストールする必要があります。
  45. %prep
  46. %setup -q -n Tix%{tixversion}
  47. #patch20 -p1 -b .perf
  48. #patch22 -p1 -b .dirtree
  49. %build
  50. # make the libraries reentrant
  51. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  52. %configure \
  53. --with-tcl=%{_libdir} \
  54. --with-tk=%{_libdir} \
  55. --enable-shared \
  56. --disable-threads \
  57. ;
  58. make %{?_smp_mflags} all
  59. %install
  60. rm -rf ${RPM_BUILD_ROOT}
  61. %makeinstall
  62. SOFILE=libTix%{version}.so
  63. mv $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE $RPM_BUILD_ROOT%{_libdir}
  64. ln -sf ../$SOFILE $RPM_BUILD_ROOT%{_libdir}/Tix%{version}/$SOFILE
  65. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix.so
  66. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libTix%{tix_major}.so
  67. ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix.so
  68. ## internal_dependency_generator can't find provides
  69. #ln -sf ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
  70. cp -p ./$SOFILE $RPM_BUILD_ROOT%{_libdir}/libtix%{tix_major}.so
  71. install -d $RPM_BUILD_ROOT%{_mandir}/man1
  72. install -d $RPM_BUILD_ROOT%{_mandir}/mann
  73. install -m 644 man/tixwish.1 $RPM_BUILD_ROOT%{_mandir}/man1
  74. install -m 644 man/*.n $RPM_BUILD_ROOT%{_mandir}/mann
  75. install -d $RPM_BUILD_ROOT%{_includedir}
  76. install -m 0644 generic/tix.h $RPM_BUILD_ROOT%{_includedir}/tix.h
  77. ## others
  78. SHAREDDIR=$RPM_BUILD_ROOT%{_datadir}/tix-%{version}
  79. install -d $SHAREDDIR/demos/bitmaps
  80. install -d $SHAREDDIR/demos/samples
  81. install -m 755 demos/widget $SHAREDDIR/demos
  82. install -m 644 demos/{*.tcl,tclIndex} $SHAREDDIR/demos
  83. install -m 644 demos/bitmaps/* $SHAREDDIR/demos/bitmaps
  84. install -m 644 demos/samples/* $SHAREDDIR/demos/samples
  85. cp -a tests $SHAREDDIR
  86. ## * old scripts *
  87. ## find . -type d -name CVS | xargs -r rm -frv
  88. ## echo "%%defattr(-,root,root)" > tix.files
  89. ## (find ${RPM_BUILD_ROOT}%{_bindir} \
  90. ## ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  91. ## find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  92. ## | sort | uniq -u >> tix.files
  93. ##
  94. ## set +x +H
  95. ## for n in `cat tix.files`; do
  96. ## test -f $n || continue
  97. ## head -1 $n | grep -q ^#! || continue
  98. ## chmod u+w $n
  99. ## perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  100. ## done
  101. ## set -x -H
  102. ##
  103. ## #==========================================
  104. ## # post process the *.files list, removing build sys references and mark
  105. ## # which are directories
  106. ## set +x
  107. ## for n in *.files; do
  108. ## mv $n $n.in
  109. ## sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  110. ## if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  111. ## echo -n '%dir '
  112. ## fi
  113. ## echo $file
  114. ## done > $n
  115. ## rm -f $n.in
  116. ## done
  117. ## set -x
  118. ##
  119. ## # Man pages can be compressed
  120. ## perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  121. %post -p /sbin/ldconfig
  122. %postun -p /sbin/ldconfig
  123. %clean
  124. rm -rf $RPM_BUILD_ROOT
  125. %files
  126. %defattr(-,root,root,-)
  127. %{_libdir}/libTix*.so
  128. %{_libdir}/libtix*.so
  129. %{_libdir}/Tix%{version}
  130. %{_datadir}/tix-%{tixversion}
  131. %{_mandir}/man1/tixwish.1.gz
  132. %{_mandir}/mann/*.n.gz
  133. %{_includedir}/*.h
  134. %doc ChangeLog README.txt man/html man/index.html
  135. %changelog
  136. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.3-3
  137. - rebuilt with tcl/tk 8.5.15 and thread 2.7.1
  138. * Thu Feb 24 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-2
  139. - added BR: libX11-devel
  140. * Tue Feb 22 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.3-1
  141. - updated tix to 8.4.3
  142. - dropt tix-8.1.4-perf.patch
  143. - dropt tix-8.2.0b1-dirtree.patch
  144. - added "cp -p libTix8.4.3.so libtix8.4.so"
  145. - rebuilt with file-5.05-2
  146. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  147. - rebuilt with tcl/tk-8.4.19-2
  148. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  149. - applied new versioning policy
  150. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  151. - rebuild with tcl/tk-8.4.18
  152. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  153. - rebuild with tcl/tk-8.4.16
  154. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl1
  155. - updated tix to 8.4.2
  156. - rebuilt with new toolchain
  157. * Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl5
  158. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  159. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl4
  160. - changed url to http://tix.sourceforge.net/download.shtml
  161. - rebuild for tcl/tk-8.4.11
  162. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 8.2.0-0vl3
  163. - rebuild for tcl/tk-8.4.6
  164. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl2
  165. - rebuild for tcl/tk-8.4.5
  166. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.2.0-0vl1
  167. - update based on BitWalk's tcltk-8.4.2-83bw
  168. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  169. - splite source package
  170. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  171. - expand some macros.. (FIXME)
  172. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  173. - use %configure macros
  174. - add Patch 47,50
  175. * Thu May 31 2001 <sagami@vinelinux.org>
  176. - 8.0.5_jp-10
  177. - unexpand old %%{configure}, new one causes build failure
  178. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  179. - install manpages into %%{_mandir} and mode 644
  180. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  181. - 8.0.5_jp-9
  182. - modified %install section to handle compressed man pages
  183. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  184. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  185. - changed default fonts
  186. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  187. - added defattr
  188. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  189. - added some symlinks, such as libtcl8.0.so.
  190. - obsoletes version number using _jp, now 8.0.5-31vl1
  191. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  192. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  193. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  194. - fix tclX symlinks.
  195. - compile on systems where SIGPWR == SIGLOST.
  196. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  197. - update tcl/tk to 8.0.5.
  198. - avoid "containing" in Tix (#2332).
  199. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  200. - use /usr/bin/write in kibitz (#1320).
  201. - use cirrus.sprl.umich.edu in weather (#1926).
  202. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  203. - auto rebuild in the new build environment (release 28)
  204. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  205. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  206. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  207. - expect does unaligned access on alpha (#989)
  208. - upgrade tcl/tk/tclX to 8.0.4
  209. - upgrade expect to 5.28.
  210. - add itcl 3.0.1
  211. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  212. - call libtoolize to allow building on the arm
  213. - build for glibc 2.1
  214. - strip binaries
  215. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  216. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  217. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  218. - expect: mkpasswd needs delay before sending password (problem #576)
  219. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  220. - translations modified for de, fr, tr
  221. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  222. - fixed expect binaries exec permissions
  223. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  224. - updated to Tix 4.1.0.006
  225. - updated version numbers of tcl/tk to relflect includsion of p2
  226. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  227. - updated tcl/tk to patch level 2
  228. - updated tclX to 8.0.2
  229. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  230. - fixed filelist for tix... replacing path to the expect binary in scripts
  231. was leaving junk files around.
  232. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  233. - added patch to remove libieee test in configure.in for tcl and tk.
  234. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  235. solution for all systems
  236. - fixed src urls
  237. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  238. - removed version numbers from descriptions
  239. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  240. - updated to tcl/tk 8.0 and related versions of packages
  241. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  242. - built against glibc
  243. - fixed dangling tclx/tkx symlinks