thread-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411
  1. %define tclmajor 8.5
  2. %define majorver 2.7
  3. Summary: A Tcl/Tk development environment: thread
  4. Summary(ja): Tcl/Tk 開発環境: thread
  5. Name: thread
  6. Version: %{majorver}.1
  7. Release: 1%{?_dist_release}
  8. License: BSD
  9. Group: Development/Languages
  10. URL: http://tcl.sourceforge.net/
  11. Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}.tar.gz
  12. Buildroot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: libtool
  14. BuildRequires: util-linux
  15. BuildRequires: perl
  16. BuildRequires: gdbm
  17. BuildRequires: tcl >= %{tclmajor}
  18. BuildRequires: tk >= %{tclmajor}
  19. Requires: tcl >= %{tclmajor}
  20. Requires: tk >= %{tclmajor}
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. You can use this extension to gain script-level access to Tcl threading capabilities.
  25. %prep
  26. %setup -q -n %{name}%{version}
  27. %build
  28. chmod 755 ./configure
  29. %configure \
  30. --with-tcl=%{_libdir} \
  31. --with-tk=%{_libdir} \
  32. --enable-shared \
  33. --enable-threads \
  34. --enable-64bit
  35. make %{?_smp_mflags}
  36. %install
  37. rm -rf ${RPM_BUILD_ROOT}
  38. rm -f *.files
  39. make install DESTDIR=$RPM_BUILD_ROOT
  40. echo "%%defattr(-,root,root)" > thread.files
  41. (find ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  42. find ${RPM_BUILD_ROOT}%{_includedir}/*;
  43. find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  44. | sort | uniq -u >> thread.files
  45. set +x +H
  46. for n in `cat thread.files`; do
  47. test -f $n || continue
  48. head -1 $n | grep -q ^#! || continue
  49. chmod u+w $n
  50. perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  51. done
  52. set -x -H
  53. #
  54. # post process the *.files list, removing build sys references and mark
  55. # which are directories
  56. set +x
  57. for n in *.files; do
  58. mv $n $n.in
  59. sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  60. if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  61. echo -n '%dir '
  62. fi
  63. echo $file
  64. done > $n
  65. rm -f $n.in
  66. done
  67. set -x
  68. #
  69. # Man pages can be compressed
  70. perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  71. %post -p /sbin/ldconfig -n thread
  72. %postun -p /sbin/ldconfig -n thread
  73. %clean
  74. rm -rf ${RPM_BUILD_ROOT}
  75. rm -f *.files
  76. %files -f thread.files -n thread
  77. %doc README ChangeLog doc/html/*
  78. %changelog
  79. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.7.1-1
  80. - updated to 2.7.1
  81. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.5-3
  82. - rebuilt with rpm-4.8.1-3
  83. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-2
  84. - rebuilt with new environment
  85. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1vl5
  86. - applied new versioning policy and spec in utf-8
  87. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl3
  88. - rebuild with tcl/tk-8.4.18
  89. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl2
  90. - rebuild with tcl/tk-8.4.16
  91. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 2.6.5-0vl1
  92. - update thread to 2.6.5
  93. - rebuilt with new toolchain
  94. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl2
  95. - rebuild for tcl/tk-8.4.12, and x86_64 architecture support
  96. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.2-0vl1
  97. - update thread to 2.6.2
  98. - rebuilt for tcl/tk-8.4.11
  99. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 2.5.2-0vl2
  100. - rebuild for tcl/tk-8.4.6
  101. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.2-0vl1
  102. - source update
  103. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.5.1-0vl1
  104. - modified for Vine Linux
  105. - splite source package
  106. * Wed Mar 05 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 83bw
  107. - update Tcl/Tk 8.4.2
  108. * Wed Feb 12 2003 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 82bw
  109. - update thread 2.5
  110. - update expect-20030203 (nightly-cvs)
  111. - remove xotcl
  112. * Wed Nov 20 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 81bw
  113. - add config patch for Trf
  114. - add static libraries of Tcl and Tk
  115. - add tbcload and tclcompiler again
  116. * Fri Nov 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 80bw
  117. - build on RH 8.0
  118. - update expect 5.38.0
  119. - remove tcllib module, which will be separate RPM from this.
  120. - remove tbcload module, which will be separate RPM from this.
  121. - remove tclcompiler module, which will be separate RPM from this.
  122. - add XOTcl 1.0
  123. - add Tcl-Trf 2.1p2
  124. - add Memchan 2.2a4
  125. * Sat Oct 29 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 79bw
  126. - fix to make XIC free, and eliminate XCloseIM when exiting Tk.
  127. * Sat Oct 26 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 78bw
  128. - update Tcl/Tk 8.4.1.
  129. * Fri Oct 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 77bw
  130. - correct install sequence in Tk.
  131. * Sat Sep 25 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 76bw
  132. - add TclPro tools:
  133. - tbcload CVS
  134. - tclcompiler CVS
  135. * Wed Sep 18 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 75bw
  136. - add iwidgets4.0.1.
  137. - correct symbolic link
  138. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 74bw
  139. - fix stub problem in itcl.
  140. * Sun Sep 15 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 73bw
  141. - adjust libary names to meet compatibility.
  142. * Wed Sep 11 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 72bw
  143. - update Tcl/Tk 8.4.0.
  144. - update TclX 8.4.
  145. - update tcllib 1.3.
  146. - add thread2.4.
  147. * Sat Feb 02 2002 Fuhito Suguri <bitwalk@jcom.home.ne.jp> 71bw
  148. - update tcllib 1.2.
  149. * Fri Jan 04 2002 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 70bw
  150. - correct to install all of message catalogs for Img.
  151. * Thu Dec 27 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 69bw
  152. - add tcl-8.3.4-encoding.patch for JIS encoding
  153. * Wed Dec 26 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 68bw
  154. - update itcl 3.2.1
  155. * Mon Nov 11 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 67bw
  156. - add link for tclth8.3 and wish8.3
  157. - add img 1.2.4
  158. * Sun Nov 04 2001 Fuhito Suguri <bitwalk@nyc.odn.ne.jp> 66bw
  159. - update Tcl/Tk 8.3.4
  160. - update tcllib 1.1
  161. - update patch tcl-8.3.4-cruft.patch
  162. - update patch tcl-8.3.4-makecfg.patch
  163. - update patch tk-8.3.4-makecfg.patch
  164. * Mon Aug 29 2001 Adrian Havill <havill@redhat.com>
  165. - hard-coded the compat symlink for tix libdir. (bug 52812)
  166. * Mon Aug 28 2001 Adrian Havill <havill@redhat.com>
  167. - fixed itkwish/itclsh lib problem (bug 52608)
  168. - make itcl install not need tclsh/wish during config/make (bug 52606)
  169. - expect's fixline1 busted for expectk scripts (tkpasswd/tknewsbiff/tkterm)
  170. * Mon Aug 8 2001 Adrian Havill <havill@redhat.com>
  171. - changed rev for tcllib to 1.0
  172. - added execute bit mode for itclsh and itksh compat shells
  173. - re-enable glibc string and math inlines; recent gcc is a-ok.
  174. - optimize at -O2 instead of -O
  175. - rename "soname" patches related to makefile/autoconf changes
  176. - added elf "needed" for tk, tclx, tix, itk
  177. - removed warnings from tclX
  178. * Wed Jul 25 2001 Adrian Havill <havill@redhat.com>
  179. - added itclsh/itkwish for backwards compatibility, fixed rpath (bug 46086)
  180. - fixed 64 bit RPM provides for dependencies
  181. * Thu Jul 19 2001 Adrian Havill <havill@redhat.com>
  182. - updated tclX to the latest version
  183. - fixed tclX 8.3's busted help install
  184. - eliminated make TK_LIB kludge for multiple math libs for tclX
  185. - used %%makeinstall to brute force fix any remaining unflexible makefile dirs
  186. - fixed bad ref count release in tcl (bug 49406)
  187. - improved randomness of expect's mkpasswd script via /dev/random (bug 9507)
  188. - revert --enable-threads, linux is (still) not ready (yet) (bug 49251)
  189. - fixed DirTree in Tix (bug 45570)
  190. * Sun Jul 8 2001 Adrian Havill <havill@redhat.com>
  191. - refresh all sources to latest stable (TODO: separate expect/expectk)
  192. - massage out some build stuff to patches (TODO: libtoolize hacked constants)
  193. - remove patches already rolled into the upstream
  194. - remove unneeded autopasswd
  195. - removed RPATH (bugs 45569, 46085, 46086), added SONAMEs to ELFs
  196. - changed shared object filenames to something less gross
  197. - fixed tclX shell's argv parsing (bug 47710)
  198. - reenable threads which seem to work now
  199. - added all necessary header files for itcl (bug 41374)
  200. - fixed spawn/eof read problem with expect (bug 43310)
  201. - made compile-friendly for IA64
  202. * Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
  203. - Bump release + rebuild for 7.2.
  204. * Fri Mar 23 2001 Bill Nottingham <notting@redhat.com>
  205. - bzip2 sources
  206. * Mon Mar 19 2001 Bill Nottingham <notting@redhat.com>
  207. - build with -D_GNU_SOURCE - fixes expect on ia64
  208. * Mon Mar 19 2001 Preston Brown <pbrown@redhat.com>
  209. - build fix from ahavill.
  210. * Wed Feb 21 2001 Tim Powers <timp@redhat.com>
  211. - fixed weather expect script using wrong server (#28505)
  212. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  213. - added "ja_JP.eucJP" to locale list for tcl
  214. * Tue Feb 13 2001 Adrian Havill <havill@redhat.com>
  215. - rebuild so make check passes
  216. * Fri Oct 20 2000 Than Ngo <than@redhat.com>
  217. - rebuild with -O0 on alpha (bug #19461)
  218. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  219. - summaries from specspo.
  220. * Tue Aug 8 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  221. - remove symlink to libtixsam.so
  222. * Thu Aug 3 2000 Jeff Johnson <jbj@redhat.com>
  223. - merge "best known" patches from searching, stubs were broken.
  224. - tix needs -fwritable-strings (#14352).
  225. - create tixwish symlink.
  226. * Thu Jul 27 2000 Jeff Johnson <jbj@redhat.com>
  227. - rebuild against "working" util-linux col.
  228. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  229. - automatic rebuild
  230. * Fri Jun 16 2000 Jeff Johnson <jbj@redhat.com>
  231. - make sure that tix shared libraries are installed.
  232. - don't mess with %%{_libdir}, it's gonna be a FHS pita.
  233. * Sat Jun 10 2000 Jeff Johnson <jbj@redhat.com>
  234. - move, not symlink, unix/tk8.0 to generate Tix pkgIndex.tcl correctly (#11940).
  235. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  236. - tclX had wrong version.
  237. * Fri Jun 2 2000 Jeff Johnson <jbj@redhat.com>
  238. - FHS packaging changes.
  239. - revert --enable-threads, linux is not ready (yet) (#11789).
  240. - tcl/tk: update to 8.3.1 (#10779).
  241. - expect: update to 5.31.7+ (#11595).
  242. - add tcllib-0.4.
  243. - abstract major tcltk version for soname expansion etc.
  244. * Sat Mar 18 2000 Jeff Johnson <jbj@redhat.com>
  245. - update to (tcl,tk}-8.2.3, expect-5.31, and itcl-3.1.0, URL's as well.
  246. - use perl to drill out pre-pended RPM_BUILD_ROOT.
  247. - configure with --enable-threads (experimental).
  248. - improved version of autopasswd (#4788).
  249. - autopasswd needs to handle password starting with hyphen (#9917).
  250. - handle 553 ftp status in rftp expect script (#7869).
  251. - remove cryptdir/decryptdir, as Linux has not crypt command (#6668).
  252. - correct hierarchy spelling (#7082).
  253. - fix "expect -d ...", format string had int printed as string (#7775).
  254. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  255. - rebuild for sparc baud rates > 38400.
  256. * Mon Feb 7 2000 Bill Nottingham <notting@redhat.com>
  257. - handle compressed manpages
  258. * Thu Feb 03 2000 Elliot Lee <sopwith@redhat.com>
  259. - Make changes from bug number 7602
  260. - Apply patch from bug number 7537
  261. - Apply fix from bug number 7157
  262. - Add fixes from bug #7601 to the runtcl patch
  263. * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
  264. - fix descriptions
  265. - man pages are compressed (whatapain)
  266. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  267. - fix tclX symlinks.
  268. - compile on systems where SIGPWR == SIGLOST.
  269. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  270. - update tcl/tk to 8.0.5.
  271. - avoid "containing" in Tix (#2332).
  272. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  273. - use /usr/bin/write in kibitz (#1320).
  274. - use cirrus.sprl.umich.edu in weather (#1926).
  275. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  276. - auto rebuild in the new build environment (release 28)
  277. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  278. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  279. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  280. - expect does unaligned access on alpha (#989)
  281. - upgrade tcl/tk/tclX to 8.0.4
  282. - upgrade expect to 5.28.
  283. - add itcl 3.0.1
  284. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  285. - call libtoolize to allow building on the arm
  286. - build for glibc 2.1
  287. - strip binaries
  288. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  289. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  290. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  291. - expect: mkpasswd needs delay before sending password (problem #576)
  292. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  293. - translations modified for de, fr, tr
  294. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  295. - fixed expect binaries exec permissions
  296. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  297. - updated to Tix 4.1.0.006
  298. - updated version numbers of tcl/tk to relflect includsion of p2
  299. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  300. - updated tcl/tk to patch level 2
  301. - updated tclX to 8.0.2
  302. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  303. - fixed filelist for tix... replacing path to the expect binary in scripts
  304. was leaving junk files around.
  305. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  306. - added patch to remove libieee test in configure.in for tcl and tk.
  307. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  308. solution for all systems
  309. - fixed src urls
  310. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  311. - removed version numbers from descriptions
  312. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  313. - updated to tcl/tk 8.0 and related versions of packages
  314. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  315. - built against glibc
  316. - fixed dangling tclx/tkx symlinks