tclx-vl.spec 7.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241
  1. %define tcl_major 8.5
  2. %define tk_major 8.5
  3. %define thread_major 2.7
  4. %define tclx_major 8.4
  5. %define tclxvers %{tclx_major}
  6. Summary: A Tcl/Tk development environment: tclX
  7. Summary(ja): Tcl/Tk 開発環境: tclX
  8. Name: tclx
  9. Version: %{tclxvers}.1
  10. Release: 1%{?_dist_release}
  11. Group: Development/Languages
  12. License: BSD
  13. Source0: http://downloads.sourceforge.net/project/tclx/TclX/8.4.1/%{name}%{version}.tar.bz2
  14. Buildroot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: tcl >= %{tcl_major}
  16. BuildRequires: tk >= %{tk_major}
  17. BuildRequires: thread >= %{thread_major}
  18. Requires: tcl >= %{tcl_major}
  19. Requires: tk >= %{tk_major}
  20. Requires: thread >= %{thread_major}
  21. Distribution: Vine Linux
  22. Vendor: Project Vine
  23. %description -n tclx
  24. TclX is a set of extensions which make it easier to use the Tcl
  25. scripting language for common UNIX/Linux programming tasks. TclX
  26. enhances Tcl support for files, network access, debugging, math, lists,
  27. and message catalogs. TclX can be used with both Tcl and Tcl/Tk
  28. applications.
  29. Install TclX if you are developing applications with Tcl/Tk. You'll
  30. also need to install the tcl and tk packages.
  31. %description -n tclx -l ja
  32. TclX は一般的な UNIX/Linux プログラミング作業のおいて、Tcl スクリプト言語
  33. をより簡単に使用するための拡張キットです。TclX は、ファイルや、ネットワーク
  34. アクセス、デバッグ、数値計算、リスト、メッセージカタログの Tcl サポートを拡
  35. 張します。TclX は Tcl と Tcl/Tk アプリケーションの両方で使うことができます。
  36. Tcl/Tk のアプリケーションを開発するときには、TclXもインストールしてください。
  37. tcl と tk のパッケージも必要です。
  38. %prep
  39. %setup -q -n %{name}%{tclxvers}
  40. %build
  41. # make the libraries reentrant
  42. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
  43. # tclX
  44. %configure \
  45. --with-tcl=%{_libdir} --with-tk=%{_libdir} \
  46. --enable-shared --enable-tk --enable-threads --enable-64bit
  47. make
  48. %install
  49. rm -rf ${RPM_BUILD_ROOT}
  50. mkdir -p ${RPM_BUILD_ROOT}
  51. rm -f *.files
  52. # TclX
  53. %makeinstall
  54. #if [ "%_mandir" = "%{_prefix}/share/man" ]; then
  55. # ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; tar cf - ./man[13n] ) |
  56. # ( cd ${RPM_BUILD_ROOT}%{_mandir}; tar xf - )
  57. # ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; rm -rf ./man[13n] )
  58. #fi
  59. echo "%%defattr(-,root,root)" > tclx.files
  60. (find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_includedir} \
  61. ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
  62. find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
  63. | sort | uniq -u >> tclx.files
  64. set +x +H
  65. for n in `cat tclx.files`; do
  66. test -f $n || continue
  67. head -1 $n | grep -q ^#! || continue
  68. chmod u+w $n
  69. perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
  70. done
  71. set -x -H
  72. # post process the *.files list, removing build sys references and mark
  73. # which are directories
  74. set +x
  75. for n in *.files; do
  76. mv $n $n.in
  77. sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
  78. if [ -d ${RPM_BUILD_ROOT}/$file ]; then
  79. echo -n '%dir '
  80. fi
  81. echo $file
  82. done > $n
  83. rm -f $n.in
  84. done
  85. set -x
  86. # Man pages can be compressed
  87. perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
  88. %post -p /sbin/ldconfig -n tclx
  89. %postun -p /sbin/ldconfig -n tclx
  90. %clean
  91. rm -rf $RPM_BUILD_ROOT
  92. %files -f tclx.files -n tclx
  93. %doc ChangeLog README
  94. %changelog
  95. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.1-1
  96. - updated to 8.4.1
  97. - rebuilt with tcl/tk 8.5.15 and thread 2.7.1
  98. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 8.4-3
  99. - rebuilt with rpm-4.8.1-3
  100. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
  101. - rebuilt with tcl/tk-8.4.19-2
  102. * Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
  103. - applied new versioning policy
  104. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
  105. - updated tclx to tclx-20070227.tar.gz
  106. - rebuild with tcl/tk-8.4.18
  107. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
  108. - rebuild with tcl/tk-8.4.16
  109. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  110. - update based on BitWalk's tcltk-8.4.2-83bw
  111. * Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
  112. - split source package.
  113. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  114. - expand some macros.. (FIXME)
  115. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  116. - use %configure macros
  117. - add Patch 47,50
  118. * Thu May 31 2001 <sagami@vinelinux.org>
  119. - 8.0.5_jp-10
  120. - unexpand old %%{configure}, new one causes build failure
  121. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  122. - install manpages into %%{_mandir} and mode 644
  123. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  124. - 8.0.5_jp-9
  125. - modified %install section to handle compressed man pages
  126. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  127. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  128. - changed default fonts
  129. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  130. - added defattr
  131. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  132. - added some symlinks, such as libtcl8.0.so.
  133. - obsoletes version number using _jp, now 8.0.5-31vl1
  134. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  135. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  136. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  137. - fix tclX symlinks.
  138. - compile on systems where SIGPWR == SIGLOST.
  139. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  140. - update tcl/tk to 8.0.5.
  141. - avoid "containing" in Tix (#2332).
  142. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  143. - use /usr/bin/write in kibitz (#1320).
  144. - use cirrus.sprl.umich.edu in weather (#1926).
  145. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  146. - auto rebuild in the new build environment (release 28)
  147. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  148. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  149. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  150. - expect does unaligned access on alpha (#989)
  151. - upgrade tcl/tk/tclX to 8.0.4
  152. - upgrade expect to 5.28.
  153. - add itcl 3.0.1
  154. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  155. - call libtoolize to allow building on the arm
  156. - build for glibc 2.1
  157. - strip binaries
  158. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  159. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  160. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  161. - expect: mkpasswd needs delay before sending password (problem #576)
  162. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  163. - translations modified for de, fr, tr
  164. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  165. - fixed expect binaries exec permissions
  166. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  167. - updated to Tix 4.1.0.006
  168. - updated version numbers of tcl/tk to relflect includsion of p2
  169. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  170. - updated tcl/tk to patch level 2
  171. - updated tclX to 8.0.2
  172. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  173. - fixed filelist for tix... replacing path to the expect binary in scripts
  174. was leaving junk files around.
  175. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  176. - added patch to remove libieee test in configure.in for tcl and tk.
  177. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  178. solution for all systems
  179. - fixed src urls
  180. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  181. - removed version numbers from descriptions
  182. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  183. - updated to tcl/tk 8.0 and related versions of packages
  184. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  185. - built against glibc
  186. - fixed dangling tclx/tkx symlinks