expect-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373
  1. %{!?tcl_version: %define tcl_version %(echo 'puts $tcl_version' | tclsh)}
  2. %{!?tcl_sitearch: %define tcl_sitearch %{_libdir}/tcl%{tcl_version}}
  3. %define tcl_major 8.4
  4. %define majorver 5.45
  5. Summary: A Tcl/Tk development environment: expect
  6. Summary(ja): Tcl/Tk 開発環境: expect
  7. Name: expect
  8. Version: %{majorver}
  9. Release: 1%{?_dist_release}
  10. License: Public Domain
  11. Group: Development/Languages
  12. # URL: probably more useful is http://sourceforge.net/projects/expect/
  13. URL: http://expect.nist.gov/
  14. Source: http://downloads.sourceforge.net/%{name}/%{name}%{version}.tar.gz
  15. # Patch0: fixes change log file permissions
  16. Patch0: expect-5.43.0-log_file.patch
  17. # Patch1: fixes install location, change pkgIndex
  18. Patch1: expect-5.43.0-pkgpath.patch
  19. # Patch2: fixes minor man page formatting issue
  20. Patch2: expect-5.45-man-page.patch
  21. # Patch3: fixes segmentation fault during matching characters
  22. Patch3: expect-5.45-match-gt-numchars-segfault.patch
  23. # Patch4: fixes memory leak when using -re, http://sourceforge.net/p/expect/patches/13/
  24. Patch4: expect-5.45-re-memleak.patch
  25. # Patch5: use vsnprintf instead of vsprintf to avoid buffer overflow
  26. Patch5: expect-5.45-exp-log-buf-overflow.patch
  27. # Patch6: fixes segfaults if Tcl is built with stubs and Expect is used directly
  28. # from C program rhbz#1091060
  29. Patch6: expect-5.45-segfault-with-stubs.patch
  30. # Patch7: fixes leaked fd, patch by Matej Mužila, rhbz#1001220
  31. Patch7: expect-5.45-fd-leak.patch
  32. # examples patches
  33. # Patch100: changes random function
  34. Patch100: expect-5.32.2-random.patch
  35. # Patch101: fixes bz674184 - mkpasswd fails randomly
  36. Patch101: expect-5.45-mkpasswd-dash.patch
  37. # Patch102: fixes bz703702 - let user know that telnet is needed for
  38. # running some examples
  39. Patch102: expect-5.45-check-telnet.patch
  40. # Patch103: use full path to 'su', it's safer
  41. Patch103: expect-5.45-passmass-su-full-path.patch
  42. # Patch104: rhbz 963889, fixes inaccuracy in mkpasswd man page
  43. Patch104: expect-5.45-mkpasswd-man.patch
  44. Buildroot: %{_tmppath}/%{name}-%{version}-root
  45. BuildRequires: tcl >= %{tcl_major}
  46. BuildRequires: tk >= %{tcl_major}
  47. BuildRequires: autoconf
  48. BuildRequires: chrpath
  49. BuildRequires: libX11-devel
  50. BuildRequires: libXft-devel
  51. Vendor: Project Vine
  52. Distribution: Vine Linux
  53. %description -n expect
  54. Expect is a tcl extension for automating interactive applications such
  55. as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect is also useful
  56. for testing the named applications. Expect makes it easy for a script
  57. to control another program and interact with it.
  58. Install the expect package if you'd like to develop scripts which interact
  59. with interactive applications. You'll also need to install the tcl
  60. package.
  61. %package devel
  62. Summary: Development files for expect library.
  63. Summary(ja): expect ライブラリの開発用ファイル
  64. Group: Development/Libraries
  65. Requires: expect = %{version}-%{release}
  66. Obsoletes: expect <= 5.43-0vl4
  67. %description devel
  68. This package contains development files for the expect library.
  69. %package -n expectk
  70. Summary: A program-script interaction and testing utility
  71. Group: Development/Tools
  72. Requires: expect = %{version}-%{release}
  73. Obsoletes: expect <= 5.43-0vl4
  74. %description -n expectk
  75. This package originally contained expectk and some scripts
  76. that used it. As expectk was removed from upstream tarball
  77. in expect-5.45, now the package contains just these scripts.
  78. Please use tclsh with package require Tk and Expect instead
  79. of expectk.
  80. %prep
  81. %setup -q -n expect%{version}
  82. %patch0 -p1 -b .log_file
  83. %patch1 -p1 -b .pkgpath
  84. %patch2 -p1 -b .man-page
  85. %patch3 -p1 -b .match-gt-numchars-segfault
  86. %patch4 -p1 -b .re-memleak
  87. %patch5 -p1 -b .exp-log-buf-overflow
  88. %patch6 -p1 -b .segfault-with-stubs
  89. %patch7 -p1 -b .fd-leak
  90. # examples fixes
  91. %patch100 -p1 -b .random
  92. %patch101 -p1 -b .mkpasswd-dash
  93. %patch102 -p1 -b .check-telnet
  94. %patch103 -p1 -b .passmass-su-full-path
  95. %patch104 -p1 -b .mkpasswd-man
  96. # -pkgpath.patch touch configure.in
  97. aclocal
  98. autoconf
  99. ( cd testsuite
  100. autoconf -I.. )
  101. %build
  102. %configure --with-tcl=%{_libdir} --with-tk=%{_libdir} --enable-shared \
  103. --with-tclinclude=%{_includedir}/tcl-private/generic
  104. make %{?_smp_mflags}
  105. %check
  106. make test
  107. %install
  108. rm -rf ${RPM_BUILD_ROOT}
  109. make install DESTDIR="$RPM_BUILD_ROOT"
  110. # move
  111. mv "$RPM_BUILD_ROOT"%{tcl_sitearch}/expect%{version}/libexpect%{version}.so "$RPM_BUILD_ROOT"%{_libdir}
  112. # for linking with -lexpect
  113. ln -s libexpect%{majorver}.1.15.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
  114. # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
  115. rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
  116. rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
  117. rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
  118. # remove rpath
  119. chrpath --delete $RPM_BUILD_ROOT%{_libdir}/libexpect%{version}.so
  120. %post -p /sbin/ldconfig -n expect
  121. %postun -p /sbin/ldconfig -n expect
  122. %clean
  123. rm -rf $RPM_BUILD_ROOT
  124. %files
  125. %%defattr(-,root,root)
  126. %doc FAQ HISTORY NEWS README
  127. %{_bindir}/expect
  128. %{_bindir}/autoexpect
  129. %{_bindir}/dislocate
  130. %{_bindir}/ftp-rfc
  131. %{_bindir}/kibitz
  132. %{_bindir}/lpunlock
  133. %{_bindir}/mkpasswd
  134. %{_bindir}/passmass
  135. %{_bindir}/rftp
  136. %{_bindir}/rlogin-cwd
  137. %{_bindir}/timed-read
  138. %{_bindir}/timed-run
  139. %{_bindir}/unbuffer
  140. %{_bindir}/weather
  141. %{_bindir}/xkibitz
  142. %dir %{tcl_sitearch}/expect%{version}
  143. %{tcl_sitearch}/expect%{version}/pkgIndex.tcl
  144. %{_libdir}/libexpect%{version}.so
  145. %{_mandir}/man1/autoexpect.1.gz
  146. %{_mandir}/man1/dislocate.1.gz
  147. %{_mandir}/man1/expect.1.gz
  148. %{_mandir}/man1/kibitz.1.gz
  149. %{_mandir}/man1/mkpasswd.1.gz
  150. %{_mandir}/man1/passmass.1.gz
  151. %{_mandir}/man1/tknewsbiff.1.gz
  152. %{_mandir}/man1/unbuffer.1.gz
  153. %{_mandir}/man1/xkibitz.1.gz
  154. %files devel
  155. %defattr(-,root,root,-)
  156. %{_libdir}/libexpect.so
  157. %{_mandir}/man3/libexpect.3*
  158. %{_includedir}/*
  159. %files -n expectk
  160. %defattr(-,root,root,-)
  161. %{_bindir}/multixterm
  162. %{_bindir}/tknewsbiff
  163. %{_bindir}/tkpasswd
  164. %{_bindir}/xpstat
  165. %{_mandir}/man1/multixterm.1*
  166. %{_mandir}/man1/tknewsbiff.1*
  167. %changelog
  168. * Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.45-1
  169. - updated to 5.45
  170. - rebuilt with tcl/tk 8.5.15
  171. * Fri Jan 4 2013 IWAI, Masaharu <iwai@alib.jp> 5.44.1.15-1
  172. - update to 5.44.1.15:sync ed Hat Enterprise Linux 6 expect-5.44.1.15-4.el6
  173. - add BuildRequires: tk, chrpath
  174. - update License: Public Domain
  175. - drop obsolete patches
  176. - random patch (Patch0)
  177. - spawn-43310 patch (Patch6)
  178. - setpgrp patch (Patch8)
  179. - lib spec patch (Patch10)
  180. - libdir patch (Patch11)
  181. - add some patches from RHEL expect-5.44.1.15-4.el6
  182. - fixes log file permissions patch (Patch500)
  183. - fixes install location patch (Patch501)
  184. - tk init patch (Patch502)
  185. - match gt numchars segfault patch (Patch503)
  186. - man page patch (Patch504)
  187. - random patch (Patch600)
  188. - unbuffer exit code patch (Patch601)
  189. - passmass su full path Patch (Patch602)
  190. - update build and install section: sync RHEL expect-5.44.1.15-4.el6
  191. - add Vendor and Distribution tags
  192. * Tue Apr 19 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.43-5
  193. - add missing BuildRequires: libX11-devel
  194. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 5.43-4
  195. - rebuilt with rpm-4.8.1-3
  196. * Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.43-3
  197. - rebuilt with tcl/tk-8.4.19-2
  198. * Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
  199. - rebuilt with new toolchain
  200. - changed devel Group to Development/Libraries
  201. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
  202. - applied new versioning policy and spec in utf-8
  203. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
  204. - rebuilt with tcl/tk-8.4.18
  205. * Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
  206. - split to expect-devel and expectk sub package.
  207. - add libexpect.so to expect-devel (<BTS:wishes:0136>)
  208. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
  209. - rebuilt with tcl/tk-8.4.16
  210. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
  211. - rebuilt with new toolchain
  212. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
  213. - rebuild for tcl/tk-8.4.12
  214. - added --enable-64bit to configure's option
  215. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
  216. - updated expect to 5.43.0
  217. - dropped expect-5.39.0-64bit-82547.patch (for fixed)
  218. - dropped expect-5.32.2-kibitz.patch (for fixed)
  219. - dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
  220. - rebuilt with tcl/tk 8.4.11
  221. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
  222. - rebuild for tcl/tk-8.4.6
  223. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
  224. - update based on fedora
  225. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  226. - update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
  227. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  228. - splite source package
  229. - add include files
  230. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  231. - expand some macros.. (FIXME)
  232. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  233. - use %configure macros
  234. - add Patch 47,50
  235. * Thu May 31 2001 <sagami@vinelinux.org>
  236. - 8.0.5_jp-10
  237. - unexpand old %%{configure}, new one causes build failure
  238. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  239. - install manpages into %%{_mandir} and mode 644
  240. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  241. - 8.0.5_jp-9
  242. - modified %install section to handle compressed man pages
  243. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  244. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  245. - changed default fonts
  246. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  247. - added defattr
  248. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  249. - added some symlinks, such as libtcl8.0.so.
  250. - obsoletes version number using _jp, now 8.0.5-31vl1
  251. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  252. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  253. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  254. - fix tclX symlinks.
  255. - compile on systems where SIGPWR == SIGLOST.
  256. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  257. - update tcl/tk to 8.0.5.
  258. - avoid "containing" in Tix (#2332).
  259. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  260. - use /usr/bin/write in kibitz (#1320).
  261. - use cirrus.sprl.umich.edu in weather (#1926).
  262. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  263. - auto rebuild in the new build environment (release 28)
  264. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  265. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  266. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  267. - expect does unaligned access on alpha (#989)
  268. - upgrade tcl/tk/tclX to 8.0.4
  269. - upgrade expect to 5.28.
  270. - add itcl 3.0.1
  271. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  272. - call libtoolize to allow building on the arm
  273. - build for glibc 2.1
  274. - strip binaries
  275. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  276. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  277. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  278. - expect: mkpasswd needs delay before sending password (problem #576)
  279. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  280. - translations modified for de, fr, tr
  281. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  282. - fixed expect binaries exec permissions
  283. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  284. - updated to Tix 4.1.0.006
  285. - updated version numbers of tcl/tk to relflect includsion of p2
  286. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  287. - updated tcl/tk to patch level 2
  288. - updated tclX to 8.0.2
  289. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  290. - fixed filelist for tix... replacing path to the expect binary in scripts
  291. was leaving junk files around.
  292. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  293. - added patch to remove libieee test in configure.in for tcl and tk.
  294. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  295. solution for all systems
  296. - fixed src urls
  297. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  298. - removed version numbers from descriptions
  299. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  300. - updated to tcl/tk 8.0 and related versions of packages
  301. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  302. - built against glibc
  303. - fixed dangling tclx/tkx symlinks