mplayer-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411
  1. %define name mplayer
  2. %define version 1.0
  3. #%%define extver %{nil}
  4. %define extver rc2
  5. #% define release 4%{?extver:.%{extver}}%{?_dist_release}
  6. %define svndate 20100401
  7. %define release 33.%{svndate}%{?_dist_release}
  8. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  9. %define ttfontdir /usr/share/fonts
  10. %define ttfontlist TrueType-vlgothic/VL-PGothic-Regular \\\
  11. TrueType-sazanami-gothic/sazanami-gothic
  12. %endif
  13. %if %{?_dist_release} == "vl4"
  14. %define ttfontdir /usr/X11R6/lib/X11/fonts/TrueType
  15. %define ttfontlist VL-PGothic-Regular ipagp sazanami-gothic luxirr
  16. %endif
  17. Summary: The Movie Player
  18. Summary(ja): 動画プレイヤー
  19. Name: %{name}
  20. Version: %{version}
  21. Release: %{release}
  22. #Source0: http://www.mplayerhq.hu/MPlayer/releases/MPlayer-%{version}%{extver}.tar.bz2
  23. Source0: mplayer-export-%{svndate}.tar.bz2
  24. Source1: http://www.mplayerhq.hu/MPlayer/skins/Blue-1.7.tar.bz2
  25. Source10: mplayer-snapshot.sh
  26. Patch2: %{name}-config.patch
  27. Patch8: %{name}-manlinks.patch
  28. Patch10: %{name}-qcelp.patch
  29. Patch14: %{name}-nodvdcss.patch
  30. License: GPLv2+
  31. Group: Applications/Multimedia
  32. URL: http://www.mplayerhq.hu/
  33. BuildRequires: gtk2-devel
  34. BuildRequires: freetype2-devel
  35. BuildRequires: SDL-devel
  36. BuildRequires: alsa-lib-devel
  37. BuildRequires: esound-devel
  38. BuildRequires: cdparanoia-devel
  39. BuildRequires: libvorbis-devel
  40. BuildRequires: libjpeg-devel
  41. BuildRequires: libpng-devel
  42. BuildRequires: giflib-devel
  43. BuildRequires: zlib-devel
  44. BuildRequires: libdvdread
  45. BuildRequires: libmpcdec-devel
  46. BuildRequires: twolame-devel
  47. BuildRequires: yasm
  48. BuildRequires: libvdpau-devel
  49. BuildRequires: libXScrnSaver-devel
  50. # *-devel packages provided by other self-build-* should only be listed
  51. # in self-build-%{name}.spec as PreReq.
  52. ##Requires: self-build-mplayer-codecs
  53. ##BuildRequires: self-build-libdvdcss
  54. ##BuildRequires: self-build-libdvdnav
  55. ##BuildRequires: self-build-faac
  56. ##BuildRequires: self-build-lame
  57. ##BuildRequires: self-build-libdca
  58. ##BuildRequires: self-build-x264 >= 0.0.0-4.20090110
  59. ##BuildRequires: self-build-xvidcore >= 0.9.2
  60. ##BuildRequires: self-build-faad2 >= 2.6
  61. ##BuildRequires: self-build-libmad
  62. Requires: TrueType-vlgothic
  63. %if %{?_dist_release} == "vl6" || %{?_dist_release} == "vl5"
  64. Requires: mesa-libGL
  65. BuildRequires: xorg-x11-devel
  66. BuildRequires: mesa-libGL-devel
  67. %endif
  68. %if %{?_dist_release} == "vl4"
  69. Requires: XOrg-gl
  70. BuildRequires: XOrg-devel
  71. BuildRequires: XOrg-gl-devel
  72. %endif
  73. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  74. %description
  75. MPlayer can play most standard video formats out of the box and almost
  76. all others with the help of external codecs.
  77. MPlayer currently works best from the command line, but visual feedback
  78. for many functions is available from its onscreen status display (OSD),
  79. which is also used for displaying subtitles.
  80. MPlayer also has a GUI with skin support and several unofficial alternative
  81. graphical frontends are available.
  82. MEncoder is a command line video encoder for advanced users that can
  83. be built from the MPlayer source tree. Unofficial graphical frontends
  84. exist but arenot included.
  85. MPlayer supports most common formats, like DVDs, MPEG-1/2/4, etc, but
  86. support for some newer codecs are not yet inpmlemented.
  87. You should install mplayer-codecs package if you want to play videos
  88. using those new codecs.
  89. %description -l ja
  90. MPlayer は一般的なフォーマットの動画ならそのままですぐ再生できます。
  91. またそれ以外のほとんど全てのフォーマットも外部 Codec を使用すること
  92. で生できます。
  93. 現在の MPlayer はコマンドラインから使うのが一番便利ですが、多くの操作
  94. は字幕と同様に、オンスクリーン・ディスプレイ (OSD) によりその結果が画
  95. 面上で確認できます。
  96. MPlayer には スキンを変更できる GUI も用意されていますし、また複数の
  97. 非公式なフロントエンドも利用できます。
  98. MEncoder は上級者向けのコマンドラインの動画用エンコーダーです。
  99. 非公式な GUI フロントエンドもありますが、このパッケージには含まれて
  100. いません。
  101. MPlayer は何もしなくても DVD や MPEG-1/2/4 のように一般的なフォーマット
  102. を再生できます。ただし一部の最新のフォーマットへの対応はまだ実装されて
  103. いないので、そのような動画を再生したい場合は mplayer-codecs パッケージ
  104. をインストールする必要があります。
  105. %prep
  106. #% setup -q -n MPlayer-%{version}%{extver}
  107. %setup -q -n mplayer-export-%{svndate}
  108. %patch2 -p1 -b .config
  109. %patch8 -p1 -b .manlinks
  110. %patch10 -p1 -b .qclp
  111. %patch14 -p1 -b .nodvdcss
  112. %build
  113. ./configure \
  114. --prefix=%{_prefix} \
  115. --confdir=%{_sysconfdir}/mplayer \
  116. --enable-runtime-cpudetection \
  117. --extra-cflags="$RPM_OPT_FLAGS" \
  118. --disable-libdvdcss-internal \
  119. --disable-dvdread-internal \
  120. --enable-dvdread \
  121. --enable-dvdnav \
  122. \
  123. --disable-faac-lavc \
  124. --disable-mp3lame-lavc \
  125. --disable-x264-lavc \
  126. \
  127. --disable-faad-internal \
  128. \
  129. --disable-libopenjpeg \
  130. \
  131. --disable-bitmap-font \
  132. --disable-termcap \
  133. --enable-xvmc \
  134. --with-xvmclib=XvMCW \
  135. \
  136. --enable-largefiles \
  137. --enable-menu \
  138. --enable-gui \
  139. --language=ja,en \
  140. ;
  141. %{__make} %{?_smp_mflags}
  142. %install
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %{__make} install prefix=${RPM_BUILD_ROOT}%{_prefix} \
  145. BINDIR=${RPM_BUILD_ROOT}%{_bindir} \
  146. DATADIR=${RPM_BUILD_ROOT}%{_datadir}/mplayer \
  147. CONFDIR=${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer \
  148. LIBDIR=${RPM_BUILD_ROOT}%{_libdir} \
  149. MANDIR=${RPM_BUILD_ROOT}%{_mandir}
  150. ## install some default config files
  151. %{__install} -d -m 755 ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  152. %{__install} -pm 644 etc/example.conf \
  153. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer/mplayer.conf
  154. %{__install} -pm 644 etc/{input,menu,codecs}.conf \
  155. ${RPM_BUILD_ROOT}%{_sysconfdir}/mplayer
  156. # install default skin
  157. %{__mkdir} -p ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  158. pushd ${RPM_BUILD_ROOT}%{_datadir}/mplayer/skins
  159. %{__tar} xjf %{SOURCE1}
  160. %{__ln_s} Blue default
  161. popd
  162. # make sybolic link to ttf font for subtitle
  163. for i in %{ttfontlist}; do
  164. if [ -e %{ttfontdir}/$i.ttf ];then
  165. %__ln_s -f %{ttfontdir}/$i.ttf ${RPM_BUILD_ROOT}%{_datadir}/mplayer/subfont.ttf;
  166. break;
  167. fi;
  168. done
  169. ## install TOOLS
  170. for file in aconvert.sh divx2svcd.sh mencvcd.sh midentify.sh mpconsole.sh qepdvcd.sh subsearch.sh ; do
  171. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .sh`
  172. done
  173. for file in calcbpp.pl countquant.pl dvd2divxscript.pl ; do
  174. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .pl`
  175. done
  176. for file in vobshift.py ; do
  177. %__install -pm 755 TOOLS/$file $RPM_BUILD_ROOT%{_bindir}/`basename $file .py`
  178. done
  179. %__mkdir -p $RPM_BUILD_ROOT%{_datadir}/mplayer
  180. %__install -pm 644 TOOLS/*.fp $RPM_BUILD_ROOT%{_datadir}/mplayer/
  181. %clean
  182. %{__rm} -rf ${RPM_BUILD_ROOT}
  183. %files
  184. %defattr(-,root,root)
  185. %doc AUTHORS Changelog Copyright LICENSE README
  186. %config(noreplace) %{_sysconfdir}/mplayer/mplayer.conf
  187. %config(noreplace) %{_sysconfdir}/mplayer/codecs.conf
  188. %config(noreplace) %{_sysconfdir}/mplayer/input.conf
  189. %config(noreplace) %{_sysconfdir}/mplayer/menu.conf
  190. %{_bindir}/mplayer
  191. %{_bindir}/gmplayer
  192. %{_bindir}/mencoder
  193. %{_datadir}/mplayer/skins/Blue
  194. %{_datadir}/mplayer/skins/default
  195. %{_datadir}/mplayer/subfont.ttf
  196. %{_datadir}/applications/mplayer.desktop
  197. %{_datadir}/pixmaps/mplayer.xpm
  198. %{_mandir}/man1/mplayer.1*
  199. %{_mandir}/man1/mencoder.1*
  200. ## TOOLS
  201. %{_bindir}/aconvert
  202. %{_bindir}/calcbpp
  203. %{_bindir}/countquant
  204. %{_bindir}/divx2svcd
  205. %{_bindir}/dvd2divxscript
  206. %{_bindir}/mencvcd
  207. %{_bindir}/midentify
  208. %{_bindir}/mpconsole
  209. %{_bindir}/qepdvcd
  210. %{_bindir}/subsearch
  211. %{_bindir}/vobshift
  212. %{_datadir}/mplayer/*.fp
  213. %changelog
  214. * Fri Apr 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-33.20100401
  215. - updated source snapshot 20100401
  216. * Sat Mar 27 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-32.20100326
  217. - updated source snapshot 20100326
  218. * Thu Mar 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-31.20100317
  219. - updated source snapshot 20100317
  220. * Wed Feb 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-30.20100216
  221. - updated source snapshot 20100216
  222. - moved scripts from TOOLS
  223. - added --disable-libopenjpeg in configure options
  224. * Tue Feb 02 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-29.20100201
  225. - updated source snapshot 20100201
  226. - dropped obsolete patches
  227. - added BuildRequires:
  228. - libvdpau-devel
  229. - libXScrnSaver-devel
  230. * Sat Dec 26 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-28.20091031
  231. - update mplayer-config-20091215-vine.patch
  232. - update mplayer-20091215-x86_32-compile.patch
  233. - added --enable-runtime-cpudetection in configure options
  234. * Sun Nov 01 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-27.20091031
  235. - source snapshot 20091031
  236. - updated mplayer-20091031-x86_32-compile.patch
  237. * Sun Oct 04 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-26.20091003
  238. - source snapshot 20091003
  239. * Sun Sep 13 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-25.20090905
  240. - change release to sync with self-build-mplayer
  241. * Sun Sep 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-24.20090905
  242. - source snapshot 20090905
  243. - added settings for vl6
  244. * Thu Aug 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-23.20090821
  245. - source snapshot 20090821
  246. - replaced BR: libungif-devel with BR: giflib-devel
  247. * Thu Jul 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-22.20090722
  248. - source snapshot 20090722
  249. * Fri Jul 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-21.20090702
  250. - source snapshot 20090702
  251. * Fri Jun 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-20.20090611
  252. - source snapshot 20090611
  253. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-19.20090522
  254. - added Requires: TrueType-vlgothic
  255. * Sat May 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-18.20090522
  256. - source snapshot 20090522
  257. - build with x264 >= 0.0.0-9.20090522
  258. - updated mplayer-20090522-nodvdcss.patch
  259. * Thu May 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-17.20090502
  260. - change release to sync with self-build-mplayer
  261. * Sun May 03 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-16.20090502
  262. - source snapshot 20090502
  263. - updated mplayer-20090503-x86_32-compile.patch
  264. - updated mplayer-20090502-nodvdcss.patch
  265. * Thu Apr 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-15.20090327
  266. - applied mplayer-config-vine.patch
  267. * Sat Mar 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-14.20090327
  268. - source snapshot 20090327
  269. - updated mplayer-20090327-x86_32-compile.patch
  270. - updated mplayer-20090325-nodvdcss.patch
  271. - dropped gmplayer-about-vine.patch
  272. - install some default config files
  273. - added configure options:
  274. - --disable-termcap
  275. - --enable-xvmc
  276. - --with-xvmclib=XvMCW
  277. - archived doc/mplayer-1.0/TOOLS directory to doc/TOOLS.tar.bz2
  278. - fixed %%files for *.conf
  279. * Fri Mar 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-13.20090305
  280. - source snapshot 20090305
  281. * Sat Feb 28 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-12.20090227
  282. - source snapshot 20090227
  283. * Tue Feb 17 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-11.20090216
  284. - source snapshot 20090216
  285. * Sun Feb 08 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-10.20090206
  286. - source snapshot 20090206
  287. - dropped mplayer-man-zh_CN.patch
  288. - updated mplayer-20090206-nodvdcss.patch
  289. - changed to PreReq: self-build-faad2 from faad2-devel
  290. - added PreReq: self-build-libmad
  291. * Sun Feb 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-9.20090131
  292. - source snapshot 20090131
  293. * Thu Jan 29 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-8.20090122
  294. - change release to sync with self-build-mplayer
  295. * Fri Jan 23 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-7.20090122
  296. - source snapshot
  297. - update mplayer-20090122-nodvdcss.patch
  298. - added BuildRequires:
  299. - faad2-devel
  300. - libmpcdec-devel
  301. - twolame-devel
  302. - yasm
  303. - faac-devel (as PreReq in self-build-%{name})
  304. - lame-devel (as PreReq in self-build-%{name})
  305. - libdca-devel (as PreReq in self-build-%{name})
  306. - x264-devel >= 0.0.0-4.20090110 (as PreReq in self-build-%{name})
  307. - xvidcore-devel >= 0.9.2 (as PreReq in self-build-%{name})
  308. * Sat Jan 10 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-6.20090109
  309. - source snapshot
  310. - added --disable-faac-lavc --disable-mp3lame-lavc --disable-x264-lavc
  311. --disable-faad-internal in configure options
  312. - dropped gmplayer-add-flv-extension.patch
  313. * Sun Dec 14 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-5.20081001
  314. - source snapshot
  315. - fixed License
  316. - added some patches from RPM Fusion
  317. - updated gmplayer-about-vine.patch for 20081001 snapshot
  318. - added BuildRequires: libdvdread
  319. - added BuildRequires: self-build-libdvdcss self-build-libdvdnav
  320. - added --disable-dvdread-internal --enable-dvdread --enable-dvdnav
  321. in configure options
  322. #- applied mplayer-avoid-Warning_MVs_not_available.patch for VineSeed
  323. * Mon Nov 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-4.rc2
  324. - fixed License
  325. - added some devel packages to support OpenGL
  326. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-3.rc2
  327. - spec in utf8
  328. - fix sybolic link of subfont for vl5
  329. * Wed May 07 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-2.rc2vl4
  330. - add "Patch105: CVE-2008-1558.patch".
  331. * Fri May 02 2008 Atsushi SHICHI <ats777@gmail.com> 1.0-1.rc2vl4
  332. - build with new versioning policy.
  333. - fix Source[01] URLs.
  334. - add "Patch200: gmplayer-about-vine.patch".
  335. - add "Patch201: gmplayer-add-flv-extension.patch".
  336. * Sun Feb 17 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.0-0vl0.3rc2
  337. - add four official security patches (CVE-2008-0485, CVE-2008-0486,
  338. CVE-2008-0629, CVE-2008-0630)
  339. - add mplayer-1.0rc2-20080211-stream_cddb.patch
  340. * Tue Feb 12 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.2rc2
  341. - change source download URL. <BTS:VineLinux:603>
  342. * Sun Jan 27 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.1rc2
  343. - fix CONFDIR for make install. <BTS:wishes:33>
  344. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 1.0-0vl0.0rc2
  345. - initial build for Vine Linux