xorg-x11-drv-intel-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548
  1. %define moduledir %(pkg-config xorg-server --variable=moduledir )
  2. %define driverdir %{moduledir}/drivers
  3. %define gputoolsdate 20100625
  4. Summary: Xorg X11 Intel video driver
  5. Summary(ja): Xorg X11 Intel ビデオドライバ
  6. Name: xorg-x11-drv-intel
  7. Epoch: 1
  8. Version: 2.16.0
  9. Release: 2%{?_dist_release}
  10. URL: http://intellinuxgraphics.org/
  11. License: MIT
  12. Group: User Interface/X Hardware Support
  13. Source0: http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
  14. Source2: intel.xinf
  15. Source3: intel-gpu-tools-%{gputoolsdate}.tar.bz2
  16. # Clamp VGA pixel clock to 250MHz,
  17. # anything higher's going to look awful anyway. (#559426)
  18. Patch10: intel-2.11.0-vga-clock-max.patch
  19. # import from ubuntu/debian package
  20. Patch101: intel-2.15.0-copy-fb.patch
  21. # vine patch
  22. ExclusiveArch: %{ix86} x86_64 ia64
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  24. BuildRequires: autoconf, automake, libtool
  25. BuildRequires: xorg-x11-server-sdk >= 1.7.99
  26. BuildRequires: libXvMC-devel
  27. BuildRequires: libGL-devel >= 7.10
  28. BuildRequires: libdrm-devel >= 2.4.25
  29. BuildRequires: kernel-headers >= 2.6.33
  30. BuildRequires: libudev-devel
  31. BuildRequires: libxcb-devel >= 1.5
  32. BuildRequires: xcb-util-devel
  33. Requires: hwdata
  34. Requires: xorg-x11-server-Xorg
  35. Requires: xcb-util
  36. Obsoletes: xorg-x11-drv-i810
  37. Provides: xorg-x11-drv-i810
  38. #Conflicts: kudzu < 1.2.42-1
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. %description
  42. X.Org X11 Intel video driver.
  43. %package devel
  44. Summary: Xorg X11 Intel video driver XvMC development package
  45. Summary(ja): Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
  46. Group: Development/System
  47. Requires: %{name} = %{epoch}:%{version}-%{release}
  48. Provides: xorg-x11-drv-intel-devel = %{version}-%{release}
  49. %description devel
  50. X.Org X11 Intel video driver XvMC development package.
  51. %package -n intel-gpu-tools
  52. Summary: Debugging tools for Intel graphics chips
  53. Group: Development/Tools
  54. %description -n intel-gpu-tools
  55. Debugging tools for Intel graphics chips
  56. %prep
  57. %setup -q -n xf86-video-intel-%{version} -b3
  58. %patch10 -p1 -b .vga-clock
  59. %patch101 -p1 -b .copy-fb
  60. %build
  61. autoreconf -vi
  62. %configure \
  63. --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
  64. --enable-dri --enable-xvmc --enable-sna --enable-vmap
  65. make
  66. pushd ../intel-gpu-tools-%{gputoolsdate}
  67. autoreconf -v --install
  68. %configure
  69. make
  70. popd
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. make install DESTDIR=$RPM_BUILD_ROOT
  74. mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
  75. install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
  76. pushd ../intel-gpu-tools-%{gputoolsdate}
  77. make install DESTDIR=$RPM_BUILD_ROOT
  78. popd
  79. find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %triggerpostun -- XOrg < 7.0
  83. if (grep -q i810 /etc/X11/xorg.conf)
  84. then
  85. cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
  86. sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
  87. fi ||:
  88. %files
  89. %defattr(-,root,root,-)
  90. %{driverdir}/intel_drv.so
  91. %{_datadir}/hwdata/videoaliases/intel.xinf
  92. %{_libdir}/libI810XvMC.so.*
  93. %{_libdir}/libIntelXvMC.so.*
  94. %{_mandir}/man4/i*
  95. %files devel
  96. %defattr(-,root,root,-)
  97. %{_libdir}/libI810XvMC.so
  98. %{_libdir}/libIntelXvMC.so
  99. %files -n intel-gpu-tools
  100. %defattr(-,root,root,-)
  101. %{_bindir}/intel_*
  102. %{_mandir}/man1/intel_*.1*
  103. %changelog
  104. * Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
  105. - add --enable-sna --enable-vmap
  106. * Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  107. - new upstream release
  108. * Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
  109. - rebuild with xcb-util-0.3.8
  110. - drop Patch200
  111. * Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
  112. - update to disable copy_fb on sandybridge/ivybridge
  113. * Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
  114. - update intel.xinf
  115. - add patch10 from fedora
  116. - Clamp VGA pixel clock to 250MHz,
  117. anything higher's going to look awful anyway. (#559426)
  118. * Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
  119. - drop patch1-3 and replaced with new patch1 from git master
  120. - add Patch200 to disable DRI on SandyBridge/IvyBridge
  121. - update intel-gpu-tools
  122. * Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
  123. - add Patch1-3 from upstream
  124. * Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
  125. - new upstream release
  126. - drop upstream patches: 107-115
  127. - temporary disabled patch101
  128. - BR: libdrm >= 2.4.25
  129. * Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
  130. - add Patch101-115 from ubuntu/debian package
  131. - Patch101: Plymouth integration patch
  132. - Patch107: Check null return from uxa_acquire_solid()
  133. - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
  134. - Patch109: Fix font corruption (missing glyphs) on rotated screens.
  135. - Patch110,114: Cherry picks to fix a large number of build warnings.
  136. - Patch111: Fix clipped window plane offset
  137. - Patch112: Fix issue where vertical green line and strange colors
  138. shows up when playing gstreamer with certain videos,
  139. when dragged. (LP 460677)
  140. - Patch113: Fixes GPU lockup during login with
  141. "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
  142. error messages listed in the gpu dump text. (LP 710321)
  143. - Patch115: Don't fill up Xorg.0.log with
  144. "get vblank counter failed: Invalid argument" warnings.
  145. * Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
  146. - rebuild with xserver-1.10.0
  147. * Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
  148. - new upstream release
  149. * Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
  150. - new upstream release
  151. * Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
  152. - rebuild with xserver-1.9.2
  153. * Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
  154. - new upstream release
  155. - add Patch40: fix uxa planemask (backported)
  156. - add Patch61: add support for backlight on macbooks
  157. - add Patch62: disable page flipping for stability
  158. * Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
  159. - new upstream release
  160. - drop patch70
  161. * Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
  162. - rebuild again with xserver-1.8rc
  163. * Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
  164. - add intel-gpu-tools as sub-package
  165. - rebuild with libdrm-2.4.18
  166. * Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
  167. - new upstream release
  168. - import Patch1,2,60,70 from fedora
  169. - add BR: kernel-headers >= 2.6.33 (new drm header required)
  170. - add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
  171. - add BR; libudev-devel and autoreconf for Patch60
  172. * Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
  173. - rebuild with libdrm-2.4.17
  174. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
  175. - new upstream release
  176. * Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
  177. - new upstream release (hopefully fixes severe issues w/ efifb)
  178. - drop all patches already upstreamed; import Patch20/21 from Fedora
  179. * Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
  180. - import Patch121,122 from ubuntu
  181. - build with libdrm-2.4.12 which fixes vt switch crash
  182. * Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
  183. - apply patch114 to fix Xv with non-GEM kernel
  184. * Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
  185. - update to 2.6.3
  186. - add patch106,107,115,118,119,120 from ubuntu
  187. - add Patch106: remove triple buffering
  188. - add Patch107: remove page flipping
  189. - add Patch115: fix crash Xv overlay
  190. - add Patch118: drop legacy3d
  191. - add Patch119: fix crashes in drm bo
  192. - add Patch120: fix vt switch
  193. - add patch130-134 from upstream git
  194. - add Patch130: fix another vt switch leak
  195. - add Patch131: Create known output configuration at EnterVT time
  196. - add Patch132: fix leak of some 965 render state on VT switch
  197. - add Patch133: fix crash with fake bufmgr and UXA
  198. - add Patch134: fix EnterVT/LeaveVT
  199. - add Patch135: add new chip supoprt
  200. * Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
  201. - revert to 2.6.1, add Epoch
  202. - add Patch103-121 from ubuntu
  203. * Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
  204. - new upstream release
  205. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
  206. - new upstream release
  207. * Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
  208. - new upstream release
  209. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
  210. - add Patch5 - Dont die on irq handler failure
  211. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
  212. - new upstream release
  213. - add BR: libdrm-devel >= 2.4.0-3
  214. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
  215. - import Patch10,11,12 from ubuntu
  216. * Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
  217. - new upstream release
  218. - add triggerpostun script to replace i810 driver to intel driver
  219. * Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
  220. - new upstream release
  221. * Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  222. - new upstream release
  223. - rename i810.xinf to intel.xinf
  224. - update intel.xinf (add Intel 4 series)
  225. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
  226. - rebuild with new xserver
  227. * Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
  228. - new upstream release
  229. * Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
  230. - new upstream release
  231. * Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
  232. - new upstream release
  233. * Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  234. - initial build for Vine Linux
  235. * Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
  236. - Rebuild for new server ABI.
  237. - intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
  238. * Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
  239. - hook up ch7017 (bz#408471)
  240. * Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
  241. - xf86-video-intel 2.2.0
  242. * Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
  243. - xf86-video-intel 2.1.99.
  244. - Drop the i810 driver. Time to move on.
  245. - Require xserver 1.4.99.1
  246. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
  247. - intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
  248. * Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
  249. - intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
  250. for textured Xv to use as an offscreen pixmap so xv actually works under
  251. compiz - granted it may be unusably slow but at least stuff shows up.
  252. * Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
  253. - intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
  254. - intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
  255. * Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
  256. - intel-2.1.1-quirk-update.patch - update quirks from master
  257. * Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
  258. - i810.xinf: Flip everything over to -intel by default now. Still install
  259. i810 driver just in case.
  260. * Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
  261. - intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
  262. * Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
  263. - xf86-video-intel 2.1.1.
  264. * Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
  265. - xf86-video-intel 2.1.0.
  266. * Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
  267. - Update Requires and BuildRequires.
  268. * Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
  269. - Update to git master. Many Xv and DVO fixes. Adds support for 945GME,
  270. 965GME, G33, Q33, and Q35 chips.
  271. * Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
  272. - intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
  273. DRI clients are active, for better battery life.
  274. * Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
  275. - Rebuild for final RANDR 1.2 ABI. Fixes segfault at startup. (#238575)
  276. * Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
  277. - xf86-video-intel 2.0.0. Change the version number to match, why not.
  278. - Add a Virtual provides for xorg-x11-drv-intel, since we should probably
  279. rename this at some point.
  280. * Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
  281. - i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
  282. 915GM.
  283. * Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
  284. - i810.xinf: More intel whitelisting (#214011, #234877)
  285. * Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
  286. - xf86-video-intel-1.9.94 (RC4). Adds support for 965GM.
  287. - i810.xinf: Point 965GM support at the intel driver since it's not present
  288. in old i810.
  289. * Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
  290. - xf86-video-intel-1.9.93 (RC3).
  291. * Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
  292. - fix typo with 945GM pci id from my laptop
  293. * Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
  294. - xf86-video-intel 1.9.92 (RC2).
  295. * Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
  296. - Updated modesetting driver to one that will actually work with a 1.3 server.
  297. * Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
  298. - Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
  299. - Remove ivch and ch7017 from the install since they aren't hooked up to the
  300. code anywhere
  301. - Disown the module
  302. * Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
  303. - update modesetting driver to git snapshot from today
  304. * Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
  305. - i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
  306. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
  307. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  308. * Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
  309. - Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
  310. actually require kudzu to run.
  311. * Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
  312. - i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
  313. * Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
  314. - i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
  315. - i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
  316. driver match the corresponding terrible heuristic in the server.
  317. * Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
  318. - intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
  319. correctly distinguish between Mac Mini and Macbook Pro.
  320. * Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
  321. - i810.xinf: PCI IDs for i965.
  322. * Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
  323. - i810.xinf: Uppercase PCI IDs.
  324. * Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
  325. - Update i810 to 1.6.5, should fix DRI.
  326. - Add kuzdu requires.
  327. - i810.xinf: Start whitelisting devices over to intel.
  328. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
  329. - intel-driver-rename.patch: Fix the driver name in more places so it'll,
  330. you know, load.
  331. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
  332. - intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
  333. LFP special casing in favor of the blacklist.
  334. * Wed Aug 9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
  335. - Admit defeat, kinda. Package both i810 stable and modesetting drivers.
  336. The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
  337. and is selected with Driver "intel" in xorg.conf. Individual devices will
  338. whitelist over to "intel" until that branch gets merged into head.
  339. - Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
  340. - intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
  341. the BIOS is known to lie.
  342. * Tue Aug 8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
  343. - Today's snapshot: I2C bus creation fix.
  344. * Wed Aug 2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
  345. - intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
  346. clock when computing the modes list.
  347. - intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
  348. in centimeters as the size of the display in pixels.
  349. * Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
  350. - Disable spread-spectrum LVDS, various crash and hang fixes, saner output
  351. probing.
  352. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
  353. - Update again for a mode comparison bugfix.
  354. * Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
  355. - Update to today's git; crash fixes, better pre-915 support, slightly better
  356. autoconfigurability.
  357. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
  358. - rebuild
  359. * Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
  360. - Fix Revision number to match naming policy.
  361. * Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
  362. - Add back modesetting changes.
  363. * Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
  364. - Roll back modesetting changes and build for fc5 aiglx repo.
  365. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
  366. - Snapshot of the git modesetting branch.
  367. * Fri Jul 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
  368. - Update i810.xinf to include entries for E7221 and 945GM.
  369. * Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
  370. - Add with_dri macro to spec file, and conditionalize build time DRI support
  371. * Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
  372. - Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
  373. to pick up proto-devel as well.
  374. * Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
  375. - Rebuild for 7.1 ABI fix.
  376. * Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
  377. - Bump for fc5-bling build.
  378. * Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
  379. - Update to 1.6.0 from 7.1RC1.
  380. * Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
  381. - Add patch to add missing #include's, specifically assert.h.
  382. * Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
  383. - Update to CVS snapshot of 20060322.
  384. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
  385. - rebuilt for new gcc4.1 snapshot and glibc changes
  386. * Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
  387. - Added 8086:2772 mapping to i810.xinf for bug (#178451)
  388. * Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
  389. - Added 8086:2592 mapping to i810.xinf for bug (#172884)
  390. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
  391. - Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
  392. * Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
  393. - Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
  394. - Removed 'x' suffix from manpage dirs to match RC4 upstream.
  395. * Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
  396. - Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
  397. * Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
  398. - Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
  399. - Fix *.la file removal.
  400. - Added 'devel' subpackage for XvMC .so
  401. - Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
  402. * Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
  403. - Update BuildRoot to use Fedora Packaging Guidelines.
  404. - Deglob file manifest.
  405. - Limit "ExclusiveArch" to x86, x86_64, ia64
  406. * Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
  407. - Initial spec file for i810 video driver generated automatically
  408. by my xorg-driverspecgen script.