R-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534
  1. %define pkg_name R
  2. %define pkg_version 3.3.1
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: ftp://cran.r-project.org/pub/R/src/base/R-3/%{name}-%{version}.tar.gz
  13. Source1: R.desktop
  14. # Patch0: R-release.diff.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: gcc-c++
  17. BuildRequires: gcc-gfortran libgfortran
  18. BuildRequires: texinfo
  19. BuildRequires: tcl-devel tk-devel
  20. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  21. BuildRequires: readline-devel ncurses-devel
  22. BuildRequires: zlib-devel bzip2-devel xz-devel
  23. BuildRequires: pcre-devel
  24. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  25. BuildRequires: cairo-devel pango-devel
  26. BuildRequires: libicu-devel
  27. BuildRequires: curl-devel
  28. BuildRequires: texlive-common
  29. BuildRequires: texlive-collection-basic
  30. BuildRequires: texlive-collection-latexextra
  31. BuildRequires: texlive-collection-fontsextra
  32. BuildRequires: texlive-collection-plainextra
  33. BuildRequires: texlive-collection-fontsrecommended
  34. BuildRequires: java-1.7.0-openjdk-devel
  35. Requires: libgfortran
  36. Requires: libicu
  37. Requires: tcl tk
  38. Vendor: Project Vine
  39. Distribution: Vine Linux
  40. Packager: ara_t
  41. %description
  42. 'GNU S' - A language and environment for statistical computing and
  43. graphics. R is similar to the award-winning S system, which was
  44. developed at Bell Laboratories by John Chambers et al. It provides
  45. a wide variety of statistical and graphical techniques (linear and
  46. nonlinear modelling, statistical tests, time series analysis,
  47. classification, clustering, ...).
  48. R is designed as a true computer language with control-flow
  49. constructions for iteration and alternation, and it allows users to
  50. add additional functionality by defining new functions.
  51. For computationally intensive tasks, C, C++ and Fortran code
  52. can be linked and called at run time.
  53. %description -l ja
  54. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  55. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  56. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  57. 幅広い統計解析・視覚化手法を提供する。
  58. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  59. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  60. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  61. 使用することができる。
  62. %package devel
  63. Summary: files for development of R packages.
  64. Summary(ja): Rパッケージ開発用ファイル
  65. Group: Development/Libraries
  66. Requires: R = %{version}-%{release}
  67. %description devel
  68. Install R-devel if you are going to develop or compile R packages.
  69. This is just a stub package containing the documentation on
  70. "Writing R Extensions". However, installing it will ensure that
  71. the build environment for R packages is correct.
  72. %description -l ja devel
  73. Rパッケージを開発したりコンパイルする場合には、このR-develを
  74. インストールします。R-exts.pdf ("Writing R Extensions": 英文)
  75. が含まれているだけのサブパッケージですが、正しくRパッケージを
  76. 開発するための助けになるでしょう。
  77. %package -n libRmath
  78. Summary: standalone math library from the R project
  79. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  80. Group: System Environment/Libraries
  81. %description -n libRmath
  82. A standalone library of mathematical and statistical functions derived
  83. from the R project. This packages provides the shared libRmath library.
  84. %description -l ja -n libRmath
  85. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  86. 共有ライブラリを提供する。
  87. %package -n libRmath-devel
  88. Summary: standalone math library from the R project
  89. Summary(ja): libRmathの開発ライブラリ
  90. Group: Development/Libraries
  91. Requires: libRmath = %{version}-%{release}
  92. %description -n libRmath-devel
  93. A standalone library of mathematical and statistical functions derived
  94. from the R project. This packages provides the header files.
  95. %description -l ja -n libRmath-devel
  96. libRmathのヘッダファイル(Rmath.h)
  97. %package -n libRmath-static
  98. Summary: Static R Standalone math library
  99. Summary(ja): libRmath の静的ライブラリ
  100. Group: Development/Libraries
  101. Requires: libRmath-devel = %{version}-%{release}
  102. %description -n libRmath-static
  103. A standalone library of mathematical and statistical functions derived
  104. from the R project. This package provides the static libRmath library.
  105. %prep
  106. %{__rm} -rf ${RPM_BUILD_ROOT}
  107. %setup -q
  108. # %patch0 -p1
  109. %build
  110. export R_PDFVIEWER="%{_bindir}/xdg-open"
  111. export R_PRINTCMD="lpr"
  112. export R_BROWSER="%{_bindir}/xdg-open"
  113. %{configure} --enable-R-shlib --with-tcltk
  114. %{__make} %{?_smp_mflags}
  115. (cd src/nmath/standalone; %{__make} %{?_smp_mflags})
  116. LANG=C %{__make} check
  117. %{__make} pdf
  118. # We can only "make info" if we have an up to date version of texinfo
  119. %{?INFO: %{__make} info}
  120. %install
  121. %{make_install}
  122. %{__make} install-pdf %{?INFO:install-info} DESTDIR=${RPM_BUILD_ROOT}
  123. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  124. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  125. #Install libRmath files
  126. (cd src/nmath/standalone; %{make_install})
  127. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  128. echo "%{_libdir}/R/lib" > \
  129. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  130. #Fix lication of R_HOME_DIR in shell wrapper
  131. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  132. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  133. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  134. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  135. > ${RPM_BUILD_ROOT}%{_bindir}/R
  136. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  137. # add R into menu
  138. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  139. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  140. %{__cp} -a %{SOURCE1} ${RPM_BUILD_ROOT}%{_datadir}/applications/
  141. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  142. %clean
  143. %{__rm} -rf ${RPM_BUILD_ROOT}
  144. %post
  145. %if 0%{?INFO}
  146. # Create directory entries for info files
  147. # (optional doc files, so we must check that they are installed)
  148. for doc in admin data exts FAQ intro lang; do
  149. file=%{_infodir}/R-${doc}.info.gz
  150. if [ -e $file ]; then
  151. /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
  152. fi
  153. done
  154. %endif
  155. %{_syssbindir}/ldconfig
  156. %preun
  157. %if 0%{?INFO}
  158. if [ $1 = 0 ]; then
  159. # Delete directory entries for info files (if they were installed)
  160. for doc in admin data exts FAQ intro lang; do
  161. file=%{_infodir}/R-${doc}.info.gz
  162. if [ -e ${file} ]; then
  163. /sbin/install-info --delete R-${doc} %{_infodir}/dir 2>/dev/null
  164. fi
  165. done
  166. fi
  167. %endif
  168. %postun -p %{_syssbindir}/ldconfig
  169. %post -n libRmath -p %{_syssbindir}/ldconfig
  170. %postun -n libRmath -p %{_syssbindir}/ldconfig
  171. %files
  172. %defattr(-, root, root)
  173. %{_bindir}/R
  174. %{_bindir}/Rscript
  175. %{_libdir}/R
  176. %{_datadir}/applications/*
  177. %{_datadir}/icons/*
  178. %{?INFO:%{_infodir}/R-*.info*}
  179. %{_mandir}/man1/*
  180. /etc/ld.so.conf.d/*
  181. %files devel
  182. %defattr(-, root, root)
  183. %doc doc/manual/R-exts.pdf
  184. %files -n libRmath
  185. %defattr(-, root, root)
  186. %{_libdir}/libRmath.so
  187. %files -n libRmath-devel
  188. %defattr(-, root, root)
  189. %{_libdir}/pkgconfig/*.pc
  190. %{_includedir}/Rmath.h
  191. %files -n libRmath-static
  192. %defattr(-, root, root)
  193. %{_libdir}/libRmath.a
  194. %changelog
  195. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  196. - Updated to 3.3.1
  197. - delete BuildRequires: texlive-collection-lang*
  198. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  199. - add BuildRequires: texlive-collection-lang*
  200. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  201. - Updated to 3.3.0
  202. - add BuildRequires: pcre-devel xz-devel
  203. - change logo of menu item to Rlogo.svg
  204. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  205. - correct SPEC file
  206. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  207. - Updated to 3.2.4-revised
  208. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  209. - Updated to 3.2.4
  210. - fixed build error in src/extra/xz
  211. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  212. - add BuildRequires: curl-devel
  213. - add BuildRequires: libgomp
  214. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  215. - Updated to 3.2.3
  216. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  217. - rebuild with icu-56.1
  218. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  219. - Updated to 3.2.2
  220. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  221. - add configure options: --with-tcltk
  222. - add BuildRequires: tcl-devel tk-devel
  223. - add Requires: tcl tk
  224. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  225. - Updated to 3.2.1
  226. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  227. - add "LIBS=-lbz2" to configure option
  228. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  229. - Updated to 3.2.0
  230. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  231. - Updated to 3.1.3
  232. - added BuildRequires: texlive-collection-fontsextra for Vine6
  233. - changed option "make check-all" to "make check"
  234. - to avoid error in checking of mgcv package
  235. - changed orders of BuildRequires
  236. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  237. - rebuild with icu-54.1
  238. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  239. - Updated to 3.1.2
  240. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  241. - Updated to 3.1.1
  242. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  243. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  244. - add patch (2014-04-26)
  245. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  246. - Updated to 3.1.0
  247. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  248. - Updated to 3.0.3
  249. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  250. - rebuild current VineSeed
  251. - add patch (2014-01-06)
  252. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  253. - add Requires: libicu
  254. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  255. - combine spec files Vine6 and VineSeed
  256. - correct the days of the week in changelog
  257. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  258. - delete BuildRequires: texlive-collection-texinfo
  259. - add BuildRequires: texlive-collection-plainextra
  260. - add BuildRequires: texlive-collection-latexextra
  261. - add BuildRequires: texlive-collection-fontsrecommended
  262. - for VineSeed
  263. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  264. - Updated to 3.0.2
  265. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  266. - Updated to 3.0.1
  267. - add BuildRequires: java-1.6.0-openjdk-devel
  268. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  269. - Updated to 3.0.0
  270. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  271. - Updated to 2.15.3
  272. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  273. - use BuildRequires ncurses-devel instead of libtermcap-devel
  274. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  275. - Updated to 2.15.2
  276. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  277. - changed group to Applications/Edutainment
  278. - added R to menu
  279. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  280. - Updated to 2.15.1
  281. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  282. - Updated to 2.15.0
  283. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  284. - Updated to 2.14.2
  285. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  286. - Updated to 2.14.1
  287. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  288. - Updated to 2.14.0
  289. - add BuildRequires: texlive-collection-fontsextra
  290. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  291. - Updated to 2.13.2
  292. - add BuildRequires: texlive-common
  293. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  294. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  295. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  296. - synchronized to VinePlus/5 package
  297. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  298. - Updated to 2.13.1
  299. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  300. - Updated to 2.13.0
  301. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  302. - Updated to 2.12.2
  303. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  304. - add BuildRequires: libicu-devel
  305. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  306. - synchronized to VinePlus/5 package
  307. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  308. - Updated to 2.12.1
  309. - added --enable-R-shlib option to %%configure
  310. - added static subpackage
  311. - use BR: texlive instead of tetex on VineSeed
  312. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  313. - rebuilt with rpm-4.8.1 for pkg-config
  314. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  315. - recompiled because tcl/tk were not linked
  316. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  317. - Updated to 2.11.0
  318. - added Requires: libgfortran
  319. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  320. - Updated to 2.10.1
  321. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  322. - patched to 2.10.0
  323. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  324. - spec in UTF-8
  325. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  326. - Updated to 2.10.0
  327. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  328. - Updated to 2.9.2
  329. - deleted BuildRequires: lapack-devel blas-devel
  330. - rewrote SPEC file
  331. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  332. - Updated to 2.5.1
  333. - added BuildRequires: gcc-gfortran for VineSeed
  334. - added BuildRequires: lapack-devel blas-devel
  335. v- fixed %preun script
  336. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  337. - Updated to 2.4.1
  338. - Added INFO option
  339. - Exclude Japanese Rprofile.site
  340. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  341. - Updated to 2.4.0
  342. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  343. - Added optimization flags
  344. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  345. - Packaged for VineLinux3.2
  346. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  347. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  348. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  349. - Packaged for VineLinux3.2
  350. - Slipped texinfo
  351. - Fixed preun error
  352. - Preset Japanese fonts
  353. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  354. - Packaged for VineLinux3.2
  355. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  356. - Restored CAPABILITIES file lost in 2.2.1beta
  357. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  358. - Configure uses --without-blas by default.
  359. - Install pdf manuals.
  360. - All toplevel documentation files are installed into _libdir/R
  361. as they may be required by R (qv note on AUTHORS and THANKS below).
  362. - Legacy scripts for rebuilding package indices removed.
  363. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  364. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  365. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  366. - The files AUTHORS and THANKS need to be installed into _libdir/R
  367. as they are required by the function contributors(). Previously
  368. they were installed only as documentation files.
  369. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  370. - Corrected date error in SPEC file.
  371. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  372. - Dropped support for Red Hat boxed set.
  373. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  374. including support for shared R library.
  375. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  376. with the default optimization flags, so there is a temporary work-around.
  377. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  378. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  379. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  380. - Install R-data.info file as well.
  381. - Make info processing conditional on texinfo version, not platform release,
  382. so that if a new enough version is installed, we will build and install info.
  383. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  384. - Built R 2.1.0. R now supports internationalization, so the patch
  385. to set the locale to "C" is now dropped.
  386. - install.packages() exits gracefully with a helpful message if
  387. the file INSTALL is not present, so this is now included in the
  388. R-devel package.
  389. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  390. - Added support for Scientific Linux (http://www.scientificlinux.org)
  391. A distribution based on RHEL. Thanks to Jon Peatfield.
  392. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  393. - Fixed file ownership in R-devel and libRmath packages
  394. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  395. - R-devel package is now a stub package with no files, except a documentation
  396. file (RPM won't accept sub-packages with no files). R now conflicts
  397. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  398. - Created libRmath subpackage with shared library.
  399. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  400. - Created R-devel and libRmath-devel subpackages
  401. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  402. - Built R 2.0.1
  403. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  404. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  405. gives "lpr".
  406. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  407. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  408. - Info support is now conditional on the macro Rinfo, which is only
  409. defined for Fedora 1 and 2.
  410. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  411. - Built R 2.0.0
  412. - There is no longer a BUGS file, so this is not installed as a
  413. documentation file.