akonadi-vl.spec 8.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278
  1. %define _qt4_ver 4.7.2
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
  4. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. Name: akonadi
  6. Summary: PIM Storage Service
  7. Summary(ja): PIM ストレージサービス
  8. Version: 1.5.0
  9. Release: 2%{?_dist_release}
  10. Group: System Environment/Libraries
  11. License: LGPLv2+
  12. URL: http://download.akonadi-project.org/
  13. Source0: http://download.akonadi-project.org/akonadi-%{version}.tar.bz2
  14. %define mysql_conf_timestamp 20110107
  15. # shrink default initial db size a bit (approx 140mb->28mb)
  16. Patch1: akonadi-mysql_conf.patch
  17. ## upstream patches
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: cmake >= 2.6.0
  20. BuildRequires: qt4-devel >= 4.4
  21. BuildRequires: automoc4
  22. BuildRequires: MySQL-devel
  23. BuildRequires: MySQL-server
  24. # for xsltproc
  25. BuildRequires: libxslt
  26. BuildRequires: shared-mime-info
  27. BuildRequires: libboost-devel libboost-program-options
  28. BuildRequires: soprano-devel >= 2.5.0
  29. BuildRequires: sqlite3-devel
  30. BuildRequires: libICE-devel libXext-devel
  31. # when/if akonadi grows support for other backends, consider splitting
  32. # these similar to how phonon is done currently.
  33. Requires: qt4-MySQL
  34. # not *strictly* required, but we need a functional default configuration
  35. #Requires: MySQL-server
  36. Requires(post): /sbin/ldconfig
  37. Requires(postun): /sbin/ldconfig
  38. %description
  39. %{summary}.
  40. Requires an available instance of mysql server at runtime.
  41. Akonadi can spawn a per-user one automatically if the mysql-server
  42. package is installed on the machine.
  43. See also: %{_sysconfdir}/akonadi/mysql-global.conf
  44. %package sqlite
  45. Summary: a sliglty adjusted QSQLITE driver for akonadi
  46. Group: System Environment/Libraries
  47. Requires: %{name} = %{version}-%{release}
  48. Requires: qt4 = %{_qt4_version}
  49. %description sqlite
  50. %{summary}.
  51. %package devel
  52. Summary: Developer files for %{name}
  53. Summary(ja): %{name} の開発用ファイル
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. Requires: qt4-devel
  57. %description devel
  58. %{summary}.
  59. %prep
  60. %setup -q
  61. %patch1 -p1 -b .mysql_conf
  62. touch -d %{mysql_conf_timestamp} server/src/storage/mysql-global.conf
  63. %build
  64. %ifarch x86_64
  65. PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
  66. %endif
  67. mkdir -p %{_target_platform}
  68. pushd %{_target_platform}
  69. %cmake \
  70. -DCONFIG_INSTALL_DIR=%{_sysconfdir} \
  71. -DINSTALL_QSQLITE_IN_QT_PREFIX:PATH=%{_qt4_plugindir} \
  72. ..
  73. popd
  74. make %{?_smp_mflags} -C %{_target_platform}
  75. %install
  76. rm -rf $RPM_BUILD_ROOT
  77. make install DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  78. mkdir -p $RPM_BUILD_ROOT%{_datadir}/akonadi/agents
  79. touch -d %{mysql_conf_timestamp} $RPM_BUILD_ROOT%{_sysconfdir}/akonadi/mysql-local.conf
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %post -p /sbin/ldconfig
  83. %posttrans
  84. update-mime-database %{_datadir}/mime &> /dev/null || :
  85. %postun
  86. /sbin/ldconfig ||:
  87. if [ $1 -eq 0 ] ; then
  88. update-mime-database %{_datadir}/mime &> /dev/null ||:
  89. fi
  90. %files
  91. %defattr(-,root,root,-)
  92. %doc AUTHORS lgpl-license
  93. %dir %{_sysconfdir}/akonadi
  94. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global.conf
  95. %config(noreplace) %{_sysconfdir}/akonadi/mysql-global-mobile.conf
  96. %config(noreplace) %{_sysconfdir}/akonadi/mysql-local.conf
  97. %{_bindir}/akonadi_agent_launcher
  98. %{_bindir}/akonadi_agent_server
  99. %{_bindir}/akonadi_control
  100. %{_bindir}/akonadi_rds
  101. %{_bindir}/akonadictl
  102. %{_bindir}/akonadiserver
  103. %{_libdir}/libakonadi*.so.1*
  104. %{_datadir}/dbus-1/interfaces/org.freedesktop.Akonadi.*.xml
  105. %{_datadir}/dbus-1/services/org.freedesktop.Akonadi.*.service
  106. %{_datadir}/mime/packages/akonadi-mime.xml
  107. %{_datadir}/akonadi
  108. %files sqlite
  109. %defattr(-,root,root,-)
  110. %{_qt4_plugindir}/sqldrivers/libqsqlite3.so
  111. %files devel
  112. %defattr(-,root,root,-)
  113. %{_includedir}/akonadi
  114. %{_libdir}/pkgconfig/akonadi.pc
  115. %{_libdir}/libakonadi*.so
  116. %{_libdir}/cmake/Akonadi
  117. %changelog
  118. * Thu Mar 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-2
  119. - rebuilt with qt4-4.7.2
  120. * Mon Jan 31 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.5.0-1
  121. - new upstream release
  122. * Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-2
  123. - rebuilt with rpm-4.8.1
  124. * Sun Aug 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4.0-1
  125. - new upstream release
  126. - added BR: sqlite3-devel
  127. - added sqlite subpackage
  128. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  129. - new upstream release
  130. * Sun Apr 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-3
  131. - updated Patch1
  132. - added BR: MySQL-server
  133. * Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> - 1.3.1-2
  134. - added qmake path to PATH (if x86_64)
  135. * Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.3.1-1
  136. - new upstream release
  137. - built with new toolchain
  138. * Thu Sep 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.1-1
  139. - new upstream release
  140. * Wed Sep 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 1.2.0-4
  141. - use %%cmake macro
  142. - removed MySQL-server from BuildRequires:
  143. * Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-3
  144. - fixed Requires
  145. * Sat Aug 15 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.2.0-2
  146. - Initial build for Vine
  147. * Thu Jul 30 2009 Lukáš Tinkl <ltinkl@redhat.com> - 1.2.0-1
  148. - Akonadi 1.2.0
  149. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.95-2
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  151. * Thu Jun 25 2009 Than Ngo <than@redhat.com> - 1.1.95-1
  152. - 1.1.95
  153. * Wed Jun 03 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.90-1
  154. - akonadi-1.1.90
  155. * Tue May 26 2009 Rex Dieter <rdieter@fedoraproject.org> 1.1.85-3
  156. - akonadi.pc.cmake: s/AKONADI_LIB_VERSION_STRING/AKONADI_VERSION_STRING/
  157. * Tue May 12 2009 Than Ngo <than@redhat.com> 1.1.85-2
  158. - fix rpm file list
  159. * Wed May 06 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.85-1
  160. - akonadi-1.1.85
  161. * Thu Apr 30 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.2-1
  162. - akonadi-1.1.2
  163. - optimize scriptlets a bit
  164. * Wed Feb 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-6
  165. - rev startup patch
  166. - BR: cmake >= 2.6.0
  167. - preserve timestamp's on mysql*.conf's
  168. * Tue Feb 24 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-5
  169. - own %%_sysconfig/akonadi/mysql-local.conf
  170. - startup patch: reset conf only when needed, and clear mysql log file on update
  171. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-4
  172. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  173. * Fri Feb 20 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-3
  174. - shrink default db initial size a bit (approx 140mb->28mb)
  175. - drop extraneous RPATH-cmake baggage
  176. * Wed Jan 21 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.1-1
  177. - 1.1.1
  178. * Sun Jan 04 2009 Rex Dieter <rdieter@fedoraproject.org> - 1.1.0-1
  179. - 1.1.0
  180. * Tue Dec 16 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.81-1
  181. - 1.0.81
  182. * Mon Dec 08 2008 Rex Dieter <rdieter@fedoraproject.org> - 1.0.80-3
  183. - restore Requires: mysql-server
  184. * Mon Dec 01 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> - 1.0.80-2
  185. - own /usr/share/akonadi and /usr/share/akonadi/agents (#473595)
  186. * Wed Nov 26 2008 Than Ngo <than@redhat.com> - 1.0.80-1
  187. - 1.0.80
  188. * Wed Oct 22 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-4
  189. - drop Requires: mysql-server (for now), mention in %%description
  190. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-3
  191. - Requires: mysql-server
  192. * Wed Jul 30 2008 Rex Dieter <rdieter@fedoraproject.org> 1.0.0-2
  193. - BR: mysql-server
  194. - Requires: qt4-mysql
  195. - cleanup spec
  196. * Wed Jul 23 2008 Than Ngo <than@redhat.com> - 1.0.0-1
  197. - 1.0.0
  198. * Wed Jun 18 2008 Rex Dieter <rdieter@fedoraproject.org> 0.82.0-1
  199. - akonadi-0.82.0
  200. * Tue Jun 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.2.20080526svn812787
  201. - BR automoc, drop automoc hack
  202. * Mon May 26 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.81.0-0.1.20080526svn812787
  203. - update to revision 812787 from KDE SVN (to match KDE 4.1 Beta 1)
  204. - restore builtin automoc4 for now
  205. - update file list, require pkgconfig in -devel (.pc file now included)
  206. * Mon May 5 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-2
  207. - -devel: remove bogus Requires: pkgconfig
  208. * Sat May 3 2008 Kevin Kofler <Kevin@tigcc.ticalc.org> 0.80.0-1
  209. - first Fedora package