libxcrypt-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617
  1. %bcond_with fipstest
  2. %if 0%{?__isa_bits} == 64
  3. %bcond_without check
  4. %else
  5. %bcond_with check
  6. %endif
  7. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  8. # Build with new api?
  9. %bcond_without new_api
  10. # Build the compat package?
  11. %bcond_without compat_pkg
  12. # Run memcheck?
  13. # Valgrind does not work well on %%{power64} arches.
  14. %ifnarch %{power64}
  15. %bcond_without memcheck
  16. %else
  17. %bcond_with memcheck
  18. %endif
  19. # Shared object version of libcrypt.
  20. %if %{with new_api}
  21. %global soc 2
  22. %global sol 0
  23. %global sof 0
  24. %global sov %{soc}.%{sol}.%{sof}
  25. %if %{with compat_pkg}
  26. %global csoc 1
  27. %global csol 1
  28. %global csof 0
  29. %global csov %{csoc}.%{csol}.%{csof}
  30. %endif
  31. %else
  32. %global soc 1
  33. %global sol 1
  34. %global sof 0
  35. %global sov %{soc}.%{sol}.%{sof}
  36. %endif
  37. # Hash methods and API supported by libcrypt.
  38. # NEVER EVER touch this, if you do NOT know what you are doing!
  39. %if %{with new_api}
  40. %global hash_methods fedora,glibc,strong
  41. %global obsolete_api no
  42. %if %{with compat_pkg}
  43. %global compat_methods glibc
  44. %global compat_api glibc
  45. %endif
  46. %else
  47. %global hash_methods all
  48. %global obsolete_api glibc
  49. %endif
  50. # Needed for the distribution README file.
  51. %global distname .vine
  52. # Needed for out-of-tree builds.
  53. %global _configure ../"configure"
  54. # Common configure options.
  55. %global common_configure_options \\\
  56. --libdir=/%{_lib} \\\
  57. --disable-failure-tokens \\\
  58. --disable-silent-rules \\\
  59. --enable-shared \\\
  60. --enable-static \\\
  61. %if %{with memcheck} \
  62. --enable-valgrind \\\
  63. %else \
  64. --disable-valgrind \\\
  65. %endif \
  66. --srcdir=.. \\\
  67. --with-pkgconfigdir=%{_libdir}/pkgconfig
  68. %if %{with fipstest}
  69. # Add generation of HMAC checksums of the final stripped
  70. # binaries. %%define with lazy globbing is used here
  71. # intentionally, because using %%global does not work.
  72. BuildRequires: fipscheck
  73. %define __spec_install_post \
  74. %{?__debug_package:%{__debug_install_post}} \
  75. %{__arch_install_post} \
  76. %{__os_install_post} \
  77. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.a \
  78. %{__ln_s} .libcrypt.a.hmac \\\
  79. %{buildroot}/%{_lib}/.libxcrypt.a.hmac \
  80. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{sov} \
  81. %{__ln_s} .libcrypt.so.%{sov}.hmac \\\
  82. %{buildroot}/%{_lib}/.libcrypt.so.%{soc}.hmac \
  83. if [[ %{with new_api} == 1 && %{with compat_pkg} == 1 ]]; then \
  84. %{_bindir}/fipshmac %{buildroot}/%{_lib}/libcrypt.so.%{csov} \
  85. %{__ln_s} .libcrypt.so.%{csov}.hmac \\\
  86. %{buildroot}/%{_lib}/.libcrypt.so.%{csoc}.hmac \
  87. fi \
  88. %{nil}
  89. %endif
  90. Name: libxcrypt
  91. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  92. Version: 4.4.17
  93. Release: 1%{?_dist_release}
  94. Group: system
  95. Vendor: Project Vine
  96. Distribution: Vine Linux
  97. # For explicit license breakdown, see the
  98. # LICENSING file in the source tarball.
  99. License: LGPLv2+ and BSD and Public Domain
  100. URL: https://github.com/besser82/%{name}
  101. Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
  102. # Patch 0000 - 2999: Backported patches from upstream.
  103. # Patch 3000 - 5999: Backported patches from pull requests.
  104. # Patch 6000 - 9999: Downstream patches.
  105. BuildRequires: libtool
  106. %if %{with memcheck}
  107. BuildRequires: valgrind
  108. %endif
  109. %if %{with check}
  110. BuildRequires: glibc-debuginfo
  111. %endif
  112. # We do not need to keep this forever.
  113. # We need a version of glibc, that doesn't build libcrypt anymore.
  114. Requires: glibc%{?_isa} >= 2.26.9000-46
  115. %if 0%{?fedora} >= 30
  116. Recommends: mkpasswd
  117. %endif
  118. %description
  119. libxcrypt is a modern library for one-way hashing of passwords. It
  120. supports a wide variety of both modern and historical hashing methods:
  121. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  122. %if %{with new_api}
  123. md5crypt, and descrypt.
  124. %else
  125. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  126. %endif
  127. It provides the traditional Unix crypt and crypt_r interfaces, as well
  128. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  129. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  130. libxcrypt is intended to be used by login(1), passwd(1), and other
  131. similar programs; that is, to hash a small number of passwords during
  132. an interactive authentication dialogue with a human. It is not suitable
  133. for use in bulk password-cracking applications, or in any other situation
  134. where speed is more important than careful handling of sensitive data.
  135. However, it is intended to be fast and lightweight enough for use in
  136. servers that must field thousands of login attempts per minute.
  137. %if %{with new_api}
  138. This version of the library does not provide the legacy API functions
  139. that have been provided by glibc's libcrypt.so.1.
  140. %endif
  141. %if %{with new_api} && %{with compat_pkg}
  142. %package compat
  143. Summary: Compatibility library providing legacy API functions
  144. Group: system
  145. Requires: %{name}%{?_isa} == %{version}-%{release}
  146. %description compat
  147. This package contains the library providing the compatibility API
  148. for applications that are linked against glibc's libxcrypt, or that
  149. are still using the unsafe and deprecated, encrypt, encrypt_r,
  150. setkey, setkey_r, and fcrypt functions, which are still required by
  151. recent versions of POSIX, the Single UNIX Specification, and various
  152. other standards.
  153. All existing binary executables linked against glibc's libcrypt should
  154. work unmodified with the library supplied by this package.
  155. %endif
  156. %package devel
  157. Summary: Development files for %{name}
  158. Group: programming
  159. Conflicts: man-pages < 4.15-3
  160. Requires: %{name}%{?_isa} == %{version}-%{release}
  161. Requires: glibc-devel%{?_isa}
  162. %description devel
  163. The %{name}-devel package contains libraries and header files for
  164. developing applications that use %{name}.
  165. %package static
  166. Summary: Static library for -static linking with %{name}
  167. Group: programming
  168. Requires: %{name}-devel%{?_isa} == %{version}-%{release}
  169. Requires: glibc-static%{?_isa}
  170. %description static
  171. This package contains the libxcrypt static library for -static
  172. linking.
  173. You don't need this, unless you link statically, which is highly
  174. discouraged.
  175. %package -n compat32-%{name}
  176. Summary: Extended crypt library for descrypt, md5crypt, bcrypt, and others
  177. Group: system
  178. %description -n compat32-%{name}
  179. libxcrypt is a modern library for one-way hashing of passwords. It
  180. supports a wide variety of both modern and historical hashing methods:
  181. yescrypt, gost-yescrypt, scrypt, bcrypt, sha512crypt, sha256crypt,
  182. %if %{with new_api}
  183. md5crypt, and descrypt.
  184. %else
  185. md5crypt, SunMD5, sha1crypt, NT, bsdicrypt, bigcrypt, and descrypt.
  186. %endif
  187. It provides the traditional Unix crypt and crypt_r interfaces, as well
  188. as a set of extended interfaces pioneered by Openwall Linux, crypt_rn,
  189. crypt_ra, crypt_gensalt, crypt_gensalt_rn, and crypt_gensalt_ra.
  190. libxcrypt is intended to be used by login(1), passwd(1), and other
  191. similar programs; that is, to hash a small number of passwords during
  192. an interactive authentication dialogue with a human. It is not suitable
  193. for use in bulk password-cracking applications, or in any other situation
  194. where speed is more important than careful handling of sensitive data.
  195. However, it is intended to be fast and lightweight enough for use in
  196. servers that must field thousands of login attempts per minute.
  197. %if %{with new_api}
  198. This version of the library does not provide the legacy API functions
  199. that have been provided by glibc's libcrypt.so.1.
  200. %endif
  201. %package -n compat32-%{name}-devel
  202. Summary: Development files for cpmpat32-%{name}
  203. Group: programming
  204. Requires: %{name}-devel == %{version}-%{release}
  205. Requires: compat32-glibc-devel
  206. %description -n compat32-%{name}-devel
  207. The compat32-%{name}-devel package contains libraries and header files for
  208. developing applications that use compat32-%{name}.
  209. %debug_package
  210. %prep
  211. %autosetup -p 1
  212. ./autogen.sh
  213. %if %{with new_api}
  214. %{__cat} << EOF >> README%{distname}
  215. This version of the %{name} package ships the libcrypt.so.2
  216. library and does not provide the legacy API functions that have
  217. been provided by glibc's libcrypt.so.1. The removed functions
  218. by name are encrypt, encrypt_r, setkey, setkey_r, and fcrypt.
  219. %if %{with compat_pkg}
  220. If you are using a third-party application that links against
  221. those functions, or that is linked against glibc's libcrypt,
  222. you may need to install the %{name}-compat package manually.
  223. All existing binary executables linked against glibc's libcrypt
  224. should work unmodified with the libcrypt.so.1 library supplied
  225. by the %{name}-compat package.
  226. %endif
  227. EOF
  228. %endif
  229. %{__mkdir_p} %{_vpath_builddir}{,-compat}
  230. %build
  231. # Build the default system library.
  232. pushd %{_vpath_builddir}
  233. %configure \
  234. %{common_configure_options} \
  235. --enable-hashes=%{hash_methods} \
  236. --enable-obsolete-api=%{obsolete_api}
  237. %make_build
  238. popd
  239. %if %{with new_api} && %{with compat_pkg}
  240. # Build the compatibility library.
  241. pushd %{_vpath_builddir}-compat
  242. %configure \
  243. %{common_configure_options} \
  244. --enable-hashes=%{compat_methods} \
  245. --enable-obsolete-api=%{compat_api}
  246. %make_build
  247. popd
  248. %endif
  249. %install
  250. rm -rf %{buildroot}
  251. %if %{with new_api} && %{with compat_pkg}
  252. # Install the compatibility library.
  253. %make_install -C %{_vpath_builddir}-compat
  254. # Cleanup everything we do not need from the compatibility library.
  255. %{__rm} -fr %{buildroot}%{_bindir} \
  256. %{buildroot}%{_includedir} \
  257. %{buildroot}/%{_lib}/lib{,x}crypt.{a,so} \
  258. %{buildroot}%{_libdir}/pkgconfig \
  259. %{buildroot}%{_mandir} \
  260. %{buildroot}%{_sbindir}
  261. %endif
  262. # Install the default system library.
  263. %make_install -C %{_vpath_builddir}
  264. # Get rid of libtool crap.
  265. %{_bindir}/find %{buildroot} -name '*.la' -print -delete
  266. %if %{with check}
  267. %check
  268. %if %{with new_api} && %{with compat_pkg}
  269. for dir in %{_vpath_builddir} %{_vpath_builddir}-compat; do
  270. %else
  271. for dir in %{_vpath_builddir}; do
  272. %endif
  273. %make_build -C ${dir} check || \
  274. {
  275. rc=$?;
  276. echo "-----BEGIN TESTLOG: ${dir}-----";
  277. %{__cat} ${dir}/test-suite.log;
  278. echo "-----END TESTLOG: ${dir}-----";
  279. exit $rc;
  280. }
  281. %if %{with memcheck}
  282. %make_build -C ${dir} check-valgrind-memcheck || \
  283. {
  284. rc=$?;
  285. echo "-----BEGIN TESTLOG: ${dir}-----";
  286. %{__cat} ${dir}/test-suite-memcheck.log;
  287. echo "-----END TESTLOG: ${dir}-----";
  288. exit $rc;
  289. }
  290. %endif
  291. done
  292. %endif
  293. %post -p /sbin/ldconfig
  294. %postun -p /sbin/ldconfig
  295. %if %{with new_api} && %{with compat_pkg}
  296. %post compat -p /sbin/ldconfig
  297. %postun compat -p /sbin/ldconfig
  298. %endif
  299. %if 0%{?build_compat32}
  300. %post -n compat32-%{name} -p /sbin/ldconfig
  301. %postun -n compat32-%{name} -p /sbin/ldconfig
  302. %endif
  303. %files
  304. %doc NEWS README* THANKS
  305. %license AUTHORS COPYING.LIB LICENSING
  306. %if %{with fipstest}
  307. /%{_lib}/.libcrypt.so.%{soc}.hmac
  308. /%{_lib}/.libcrypt.so.%{sov}.hmac
  309. %endif
  310. /%{_lib}/libcrypt.so.%{soc}
  311. /%{_lib}/libcrypt.so.%{sov}
  312. %{_mandir}/man5/crypt.5.*
  313. %if %{with new_api} && %{with compat_pkg}
  314. %files compat
  315. %if %{with fipstest}
  316. /%{_lib}/.libcrypt.so.%{csoc}.hmac
  317. /%{_lib}/.libcrypt.so.%{csov}.hmac
  318. %endif
  319. /%{_lib}/libcrypt.so.%{csoc}
  320. /%{_lib}/libcrypt.so.%{csov}
  321. %endif
  322. %files devel
  323. %doc ChangeLog TODO
  324. /%{_lib}/lib*crypt.so
  325. %{_includedir}/*crypt.h
  326. %{_libdir}/pkgconfig/libcrypt.pc
  327. %{_libdir}/pkgconfig/%{name}.pc
  328. %{_mandir}/man3/crypt*.3*
  329. %files static
  330. %if %{with fipstest}
  331. /%{_lib}/.lib*crypt.a.hmac
  332. %endif
  333. /%{_lib}/lib*crypt.a
  334. %if 0%{?build_compat32}
  335. %files -n compat32-%{name}
  336. %if %{with fipstest}
  337. /%{_lib}/.libcrypt.so.%{soc}.hmac
  338. /%{_lib}/.libcrypt.so.%{sov}.hmac
  339. %endif
  340. /%{_lib}/libcrypt.so.%{soc}
  341. /%{_lib}/libcrypt.so.%{sov}
  342. %files -n compat32-%{name}-devel
  343. /%{_lib}/lib*crypt.so
  344. %{_libdir}/pkgconfig/libcrypt.pc
  345. %{_libdir}/pkgconfig/%{name}.pc
  346. %endif
  347. %changelog
  348. * Tue Feb 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.17-1
  349. - new upstream release.
  350. * Sat Mar 28 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.15-1
  351. - new upstream release.
  352. * Sat Jan 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.4.2-6
  353. - initial build for Vine Linux.
  354. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-5
  355. - Build the compat package with glibc hashing methods only
  356. - Add an option to disable the compat-package for future use
  357. * Mon Jan 14 2019 Björn Esser <besser82@fedoraproject.org> - 4.4.2-4
  358. - Bump SO-name for Fedora >= 30 and enable compat package (#1666033)
  359. - Add distribution README file
  360. - Update description of the compat package
  361. - Conditionally remove non-built hashing methods from description
  362. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-3
  363. - Remove architecture bits from Recommends
  364. * Sun Dec 23 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-2
  365. - Update summary
  366. * Sat Dec 22 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.2-1
  367. - New upstream release
  368. * Thu Dec 06 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.1-1
  369. - New upstream release
  370. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-5
  371. - Sync -fno-plt patch with upstream commit
  372. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-4
  373. - Backport upstream commit to fix a memory leak from a static pointer
  374. * Tue Dec 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-3
  375. - Backport upstream PR to build with -fno-plt optimization
  376. * Mon Nov 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-2
  377. - Backport upstream commit to use a safer strcpy for the NT method
  378. - Backport upstream generating base64 encoded output for NT gensalt
  379. - Backport upstream commit to require less rbytes for NT gensalt
  380. - Backport upstream commit to test incremental hmac-sha256 computation
  381. - Add Recommends: mkpasswd for Fedora >= 30
  382. * Tue Nov 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.4.0-1
  383. - New upstream release
  384. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.4-1
  385. - New upstream release
  386. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-4
  387. - Bump release for proper obsoletion of former common sub-package
  388. * Wed Nov 14 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-3
  389. - Add two upstream patches with minor fixes
  390. - Add HMAC checksum file for the static library
  391. - Drop the common sub-package
  392. - Some spec-file optimizations
  393. * Tue Nov 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-2
  394. - Add a patch to define crypt_gensalt_r as macro, so applications
  395. link the identical crypt_gensalt_rn directly
  396. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.3-1
  397. - New upstream release
  398. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.2-1
  399. - New upstream release
  400. * Sun Nov 11 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-2
  401. - Backport two patches from upstream fixing the gensalt function for
  402. NT to properly terminate its returned output
  403. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.1-1
  404. - New upstream release
  405. * Sat Nov 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.3.0-1
  406. - New upstream release
  407. * Fri Oct 26 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.3-1
  408. - New upstream release
  409. * Thu Oct 25 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-2
  410. - Add patch updating to recent development version
  411. - Run valgrind-memcheck
  412. - Use bootstrap script
  413. * Thu Oct 18 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.2-1
  414. - New upstream release
  415. * Mon Oct 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-3
  416. - Drop compat-devel package
  417. - Set configure options from globals
  418. * Sun Sep 30 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-2
  419. - Build out-of-tree
  420. - Split off noarch-bits into common sub-package
  421. - Update %%description
  422. - Prepare to remove legacy API from library and to provide a compatibilty
  423. package for the legacy API
  424. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.1-1
  425. - New upstream release
  426. - Add new manpages
  427. * Sat Sep 29 2018 Björn Esser <besser82@fedoraproject.org> - 4.2.0-1
  428. - New upstream release
  429. * Fri Aug 24 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.2-1
  430. - New upstream release
  431. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-4
  432. - Move *.3 manpages to devel subpackage (#1613762)
  433. - Add needed Conflicts: man-pages < 4.15-3
  434. * Wed Aug 08 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-3
  435. - Make crypt{,_r} return NULL on failure (#1611784)
  436. * Sat Aug 04 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-2
  437. - Add manpages for crypt{,_r,_ra}.3 (#1610307)
  438. * Wed Aug 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.1-1
  439. - New upstream release
  440. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.1.0-1
  441. - New upstream release
  442. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-6
  443. - Make testsuite fail on error again
  444. - Update patch0 with more upstream fixes
  445. * Fri Jul 13 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-5
  446. - Add patch to update to recent development branch
  447. - Re-enable SUNMD5 support as it is BSD licensed now
  448. - Build compatibility symbols for glibc only
  449. - Skip failing testsuite once
  450. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.1-4
  451. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  452. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-3
  453. - Remove CDDL from license list (#1592445)
  454. * Fri Jun 29 2018 Florian Weimer <fweimer@redhat.com> - 4.0.1-2
  455. - Remove SUNMD5 support (#1592445)
  456. * Wed May 16 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.1-1
  457. - New upstream release
  458. * Sat Feb 17 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-5
  459. - Switch to %%ldconfig_scriptlets
  460. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.0-4
  461. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  462. * Thu Feb 01 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-3
  463. - Add patch to fix unintialize value in badsalt test
  464. * Wed Jan 31 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-2
  465. - Add patch to fix bcrypt test with GCC8
  466. * Sat Jan 27 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-1
  467. - New upstream release
  468. * Mon Jan 22 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.0.0-0.204.20180120git3436e7b
  469. - Fix Obsoletes
  470. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.203.20180120git3436e7b
  471. - Update to new snapshot fixing cast-align
  472. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.202.20180120gitde99d27
  473. - Update to new snapshot (rhbz#1536752)
  474. * Sat Jan 20 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.201.20171109git15447aa
  475. - Use archful Obsoletes for libcrypt
  476. - Add versioned Requires on glibc packages not shipping libcrypt
  477. - Add comments about the packaging logic for replacing former libcrypt
  478. * Fri Jan 12 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.200.20171109git15447aa
  479. - Initial import (rhbz#1532794)
  480. - Add Obsoletes/Provides for libcrypt
  481. * Wed Jan 10 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.101.20171109git15447aa
  482. - Fix style of %%git_{rel,ver}
  483. * Tue Jan 09 2018 Björn Esser <besser82@fedoraproject.org> - 4.0.0-0.100.git20171109.15447aa
  484. - Initial rpm release (rhbz#1532794)
  485. - Start revision at 0.100 to superseed builds from COPR