suricata-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579
  1. %bcond_with systemd
  2. %bcond_with libprelude
  3. Summary: Intrusion Detection System
  4. Name: suricata
  5. Version: 6.0.5
  6. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: network,security
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2
  11. URL: https://suricata-ids.org/
  12. Source0: https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
  13. Source1: suricata.sysconfig
  14. Source2: fedora.notes
  15. Source3: suricata-tmpfiles.conf
  16. Source1000: suricata.init
  17. Source1001: suricata.logrotate
  18. Source1002: post_start
  19. Source1003: pre_stop
  20. # Irrelevant docs are getting installed, drop them
  21. Patch1: suricata-2.0.9-docs.patch
  22. # Suricata service file needs some options supplied
  23. Patch2: suricata-4.1.1-service.patch
  24. # Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
  25. # include it via sys/socket.h in a future release. This is temporary
  26. # and should not be needed on other kernel/glibc combos.
  27. Patch3: suricata-4.1.4-socket.patch
  28. BuildRequires: gcc gcc-c++
  29. BuildRequires: rust cargo
  30. BuildRequires: libyaml-devel python3-pyyaml
  31. BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
  32. BuildRequires: zlib-devel pcre-devel libcap-ng-devel
  33. BuildRequires: lz4-devel libpcap-devel
  34. BuildRequires: nspr-devel nss-devel file-devel
  35. BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
  36. # Next line is for eBPF support
  37. %ifarch x86_64
  38. BuildRequires: clang llvm libbpf-devel
  39. %endif
  40. BuildRequires: autoconf automake libtool
  41. %if %{with systemd}
  42. BuildRequires: systemd
  43. %endif
  44. BuildRequires: hiredis-devel
  45. BuildRequires: libevent-devel
  46. %if %{with libprelude}
  47. BuildRequires: libprelude-devel
  48. %endif
  49. BuildRequires: gnutls-devel
  50. %ifarch x86_64
  51. BuildRequires: hyperscan-devel
  52. %endif
  53. Requires: python3-pyyaml
  54. Requires(pre): /usr/sbin/useradd
  55. %if %{with systemd}
  56. Requires(post): systemd
  57. Requires(preun): systemd
  58. Requires(postun): systemd
  59. %endif
  60. %description
  61. The Suricata Engine is an Open Source Next Generation Intrusion
  62. Detection and Prevention Engine. This engine is not intended to
  63. just replace or emulate the existing tools in the industry, but
  64. will bring new ideas and technologies to the field. This new Engine
  65. supports Multi-threading, Automatic Protocol Detection (IP, TCP,
  66. UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
  67. Matching, and GeoIP identification.
  68. %debug_package
  69. %prep
  70. %setup -q
  71. install -m 644 %{SOURCE2} doc/
  72. %patch1 -p1
  73. %patch2 -p1
  74. %patch3 -p1
  75. sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
  76. %ifarch x86_64
  77. sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
  78. %endif
  79. autoreconf -fv --install
  80. %build
  81. %configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
  82. --disable-coccinelle --enable-nfqueue --enable-af-packet \
  83. --with-libnspr-includes=/usr/include/nspr4 \
  84. --with-libnss-includes=/usr/include/nss3 \
  85. --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
  86. %if %{with libprelude}
  87. --enable-prelude \
  88. %endif
  89. --enable-rust \
  90. %ifarch x86_64
  91. --enable-ebpf-build --enable-ebpf \
  92. %endif
  93. --enable-python
  94. %make_build
  95. %install
  96. make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
  97. # Setup etc directory
  98. mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
  99. #install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
  100. for f in rules/*.rules; do
  101. touch %{buildroot}%{_sysconfdir}/%{name}/$f
  102. done
  103. install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
  104. install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}/
  105. mkdir -p %{buildroot}%{_libexecdir}/%{name}
  106. install -m 755 %{SOURCE1002} %{buildroot}%{_libexecdir}/%{name}/
  107. install -m 755 %{SOURCE1003} %{buildroot}%{_libexecdir}/%{name}/
  108. mkdir -p %{buildroot}%{_sysconfdir}/%{name}/{start,stop}.d
  109. %if %{with systemd}
  110. mkdir -p %{buildroot}%{_unitdir}
  111. install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
  112. sed -i \
  113. -e 's|/var/run/|/run/|' \
  114. -e '/ExecStart=/a ExecStartPost=%{_libexecdir}/%{name}/post_start' \
  115. -e '/ExecReload=/a ExecStop=%{_libexecdir}/%{name}/pre_stop' \
  116. %{buildroot}%{_unitdir}/%{name}.service
  117. %else
  118. mkdir -p %{buildroot}%{_initdir}
  119. install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
  120. %endif
  121. mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
  122. install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  123. # Set up logging
  124. mkdir -p %{buildroot}/%{_var}/log/%{name}
  125. mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
  126. #install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  127. #sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  128. install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  129. # Remove a couple things so they don't get picked up
  130. rm -rf %{buildroot}%{_includedir}
  131. rm -f %{buildroot}%{_libdir}/libhtp.la
  132. rm -f %{buildroot}%{_libdir}/libhtp.a
  133. rm -f %{buildroot}%{_libdir}/libhtp.so
  134. rm -rf %{buildroot}%{_libdir}/pkgconfig
  135. # Setup suricata-update data directory
  136. mkdir -p %{buildroot}/%{_var}/lib/%{name}
  137. # Setup tmpdirs
  138. %if %{with systemd}
  139. mkdir -p %{buildroot}%{_tmpfilesdir}
  140. install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  141. %endif
  142. mkdir -p %{buildroot}/run
  143. install -d -m 0755 %{buildroot}/run/%{name}/
  144. cp suricata-update/README.rst doc/suricata-update-README.rst
  145. %check
  146. make check
  147. %pre
  148. getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
  149. %post
  150. %if %{with systemd}
  151. %systemd_post suricata.service
  152. %else
  153. if [ $1 -gt 0 ]; then
  154. /sbin/chkconfig --add suricata
  155. fi
  156. %endif
  157. %preun
  158. %if %{with systemd}
  159. %systemd_preun suricata.service
  160. %else
  161. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  162. /sbin/service suricata stop
  163. /sbin/chkconfig suricata off ||:
  164. /sbin/chkconfig --del suricata
  165. fi
  166. %endif
  167. %postun
  168. %if %{with systemd}
  169. %systemd_postun_with_restart suricata.service
  170. %else
  171. if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
  172. /sbin/service suricata restart
  173. fi
  174. %endif
  175. %files
  176. %doc doc/Basic_Setup.txt doc/suricata-update-README.rst
  177. %doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
  178. %{!?_licensedir:%global license %%doc}
  179. %license COPYING
  180. %attr(644,root,root) %{_mandir}/man1/*
  181. %{_sbindir}/suricata
  182. %{_bindir}/suricatasc
  183. %{_bindir}/suricatactl
  184. %{_bindir}/suricata-update
  185. %{_libdir}/libhtp*
  186. %{python3_sitelib}/suricatasc/*
  187. %{python3_sitelib}/suricata/*
  188. %{python3_sitelib}/*egg-info
  189. %dir %{_libexecdir}/%{name}
  190. %attr(0755,root,root) %{_libexecdir}/%{name}/post_start
  191. %attr(0755,root,root) %{_libexecdir}/%{name}/pre_stop
  192. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
  193. %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
  194. %ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
  195. %config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
  196. %config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
  197. %attr(750,suricata,suricata) %dir %{_var}/log/%{name}
  198. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
  199. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
  200. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/start.d
  201. %attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/stop.d
  202. %attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
  203. %attr(2770,suricata,suricata) %dir /run/%{name}/
  204. %if %{with systemd}
  205. %attr(644,root,root) %{_unitdir}/suricata.service
  206. %{_tmpfilesdir}/%{name}.conf
  207. %else
  208. %attr(0755,root,root) %{_initdir}/%{name}
  209. %endif
  210. %{_datadir}/%{name}/rules
  211. %changelog
  212. * Thu Apr 21 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.5-1
  213. - new upstream release.
  214. * Thu Nov 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.4-1
  215. - new upstream release.
  216. * Sun Jul 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.3-1
  217. - new upstream release.
  218. * Thu Mar 18 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.2-1
  219. - new upstream release.
  220. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 6.0.1-1
  221. - new upstream release.
  222. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
  223. - rebuilt with python-3.8.
  224. * Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
  225. - new upstream release.
  226. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
  227. - rebuilt with libevent-2.1.11.
  228. * Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
  229. - new upstream release.
  230. * Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
  231. - initial build for Vine Linux.
  232. * Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
  233. - New feature release (which also fixes a security issue)
  234. - Enable ebpf on x86_64 only
  235. - Disable building on ppc64le due to rust problems
  236. * Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
  237. - Fix FTBFS bz 1736727
  238. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
  239. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  240. * Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
  241. - Rebuild for libprelude so bump
  242. * Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
  243. - Upstream bugfix release
  244. * Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
  245. - Upstream bugfix release
  246. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
  247. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  248. * Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
  249. - Upstream bugfix release
  250. - Updated source to use official download site
  251. * Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
  252. - Adjust permissions on /run/suricata and /var/lib/suricata to group writable
  253. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
  254. - Remove ragel requirement
  255. * Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
  256. - Make log directory group readable
  257. - Allow users of the suricata group to run suricata-update
  258. - Add lz4-devel BuildRequires to support pcap compression
  259. - Update service file for systemd security protections
  260. - Upstream bugfix update
  261. * Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
  262. - Use the upstream service and logrote files (#1330331)
  263. - Make the log directory readable by members of the suricata group (#1651394)
  264. * Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
  265. - Add cargo BuildRequires
  266. * Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
  267. - Latest upstream major release
  268. - Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
  269. * Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
  270. - Consolidate branches so that everything is in sync (#1614935)
  271. * Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
  272. - fixes bz#1614935
  273. * Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
  274. - upstream security fix release
  275. - addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
  276. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
  277. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  278. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
  279. - bumped release for build against hyperscan 5.0.0
  280. * Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  281. - added gcc-c++ buildrequires
  282. * Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
  283. - fixes bz#1543250 and bz#1543251
  284. - multiple upstream bugfixes
  285. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
  286. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  287. * Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
  288. - Added prelude support
  289. * Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
  290. - Upstream bugfix release
  291. * Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
  292. - Upstream bugfix update
  293. * Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
  294. - Make suricata user own /run/suricata (#1396150)
  295. * Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
  296. - Latest upstream major release
  297. - Build now has hyperscan and redis support
  298. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
  299. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  300. * Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
  301. - Upstream bugfix update
  302. * Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
  303. - Upstream bugfix update
  304. * Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
  305. - Upstream security update
  306. * Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
  307. - New upstream feature release
  308. - Rotate /var/log/suricata/eve.json (#1396151)
  309. - Fix ownership of /run/suricata (#1396150)
  310. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
  311. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  312. * Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
  313. - New upstream bug fix release
  314. * Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
  315. - New upstream bug fix release
  316. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
  317. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  318. * Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
  319. - New upstream bug fix release
  320. * Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
  321. - New upstream bug fix release
  322. * Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
  323. - New upstream bug fix release
  324. * Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
  325. - Fixed Bug 1227085 - Have Suricata start after the network is online
  326. * Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
  327. - New upstream bug fix release
  328. * Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
  329. - Run suricata under suricata user
  330. * Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
  331. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  332. * Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
  333. - New upstream bug fix release
  334. * Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
  335. - New upstream bug fix release
  336. * Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
  337. - New upstream bug fix release
  338. * Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
  339. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  340. * Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
  341. - New upstream security bug fix release
  342. * Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
  343. - New upstream security bug fix release for CVE-2015-0928
  344. * Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
  345. - New upstream bug fix release
  346. - Don't use the system libhtp library
  347. * Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
  348. - New upstream bug fix release
  349. - Use the system libhtp library
  350. * Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
  351. - New upstream bug fix release
  352. - Fixes CVE-2014-6603 out-of-bounds access in SSH parser
  353. * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
  354. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  355. * Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
  356. - New upstream bug fix release
  357. * Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
  358. - Specfile cleanups (#1113413)
  359. * Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
  360. - New upstream bug fix release
  361. - Enable liblua support
  362. * Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
  363. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  364. * Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
  365. - New upstream bug fix release
  366. * Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
  367. - Major new upstream release with new features
  368. * Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
  369. - luajit available only on selected arches
  370. * Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
  371. - Enable luajit support
  372. * Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
  373. - New upstream bug fix release
  374. * Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
  375. - New upstream bug fix release
  376. * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
  377. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  378. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
  379. - Drop prelude support
  380. * Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
  381. - New upstream bug fix release
  382. * Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
  383. - New upstream bug fix release
  384. * Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
  385. - New upstream bugfix release
  386. - Enable libgeoip support
  387. - Switch to stack-protector-all
  388. * Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
  389. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  390. * Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
  391. - New upstream feature enhancement release
  392. * Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
  393. - New upstream bugfix release
  394. * Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
  395. - New upstream release
  396. * Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
  397. - New upstream release
  398. * Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
  399. - Add nss-devel build require and systemd macros
  400. * Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
  401. - New upstream release
  402. * Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
  403. - New upstream release
  404. - Switch startup to use systemd
  405. * Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
  406. - New upstream release
  407. * Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
  408. - Rebuild for updated libnet.
  409. * Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
  410. - Rebuild against PCRE 8.30
  411. * Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
  412. - New upstream release
  413. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
  414. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  415. * Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
  416. - Enable AF_PACKET support
  417. * Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
  418. - New upstream release
  419. * Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
  420. - New upstream release
  421. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
  422. - New upstream release
  423. * Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
  424. - don't override -march set by the buildsystem (fixes build on non-x86)
  425. * Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
  426. - New upstream release
  427. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
  428. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  429. * Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
  430. - New upstream release (#651978)
  431. * Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
  432. - New upstream release
  433. * Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
  434. - New upstream release
  435. * Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
  436. - New upstream release
  437. * Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
  438. - Initial packaging