qtsoap-vl.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990
  1. %define _qt4_ver 4.7.2
  2. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
  3. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_version})
  4. %define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/plugins)
  5. Name: qtsoap
  6. Summary: The Simple Object Access Protocol Qt-based client side library
  7. Version: 2.7
  8. Release: 3%{?_dist_release}
  9. Group: System Environment/Libraries
  10. License: LGPLv2 with exceptions or GPLv3
  11. URL: http://qt.nokia.com/products/appdev/add-on-products/catalog/4/Utilities/qtsoap/
  12. Source0: http://get.qt.nokia.com/qt/solutions/lgpl/qtsoap-%{version}_1-opensource.tar.gz
  13. Patch0: qtsoap-2.7_1-opensource-install-pub-headers.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: qt4-devel
  16. %description
  17. The SOAP (Simple Object Access Protocol) library uses the XML standard
  18. for describing how to exchange messages. Its primary usage is to invoke web
  19. services and get responses from Qt-based applications.
  20. %package devel
  21. Summary: Development files for %{name}
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: qt4-devel = %{_qt4_version}
  25. %description devel
  26. Development files for %{name}.
  27. %prep
  28. %setup -q -n qtsoap-%{version}_1-opensource
  29. # headers are not installed for shared library
  30. %patch0 -p1 -b .install-pub-headers
  31. sed -i 's:$$DESTDIR:%{_libdir}:g' buildlib/buildlib.pro
  32. %build
  33. # we want shared library
  34. echo "SOLUTIONS_LIBRARY = yes" > config.pri
  35. echo "QTSOAP_LIBNAME = \$\$qtLibraryTarget(qtsoap)" >> common.pri
  36. echo "VERSION=%{version}" >> common.pri
  37. qmake PREFIX=%{_prefix}
  38. make %{?_smp_mflags}
  39. %install
  40. rm -rf %{buildroot}
  41. make INSTALL_ROOT=%{buildroot} install
  42. %clean
  43. rm -rf %{buildroot}
  44. %post -p /sbin/ldconfig
  45. %postun -p /sbin/ldconfig
  46. %files
  47. %defattr(-,root,root,-)
  48. %doc README.TXT LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  49. %{_libdir}/libqtsoap.so.*
  50. %files devel
  51. %defattr(-,root,root,-)
  52. %doc LGPL_EXCEPTION.txt LICENSE.GPL3 LICENSE.LGPL
  53. %{_libdir}/libqtsoap.so
  54. %{_qt4_headerdir}/QtSoap/
  55. %changelog
  56. * Sat Jul 30 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 2.7-3
  57. - Initial build for Vine Linux
  58. * Thu Jul 14 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-2
  59. - libqtsoap library name
  60. * Thu May 19 2011 Jaroslav Reznik <jreznik@redhat.com> - 2.7-1
  61. - fix version
  62. * Tue Oct 26 2010 Jaroslav Reznik <jreznik@redhat.com> - 1.7-1
  63. - Initial spec file