graphviz-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332
  1. Name: graphviz
  2. Summary: Graph Visualization Tools
  3. Version: 2.30.1
  4. Release: 1%{?_dist_release}
  5. Group: Applications/Graphics
  6. License: CPL
  7. URL: http://www.graphviz.org/
  8. Source: http://www.graphviz.org/pub/%{name}/stable/SOURCES/%{name}-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildRequires: bison
  11. BuildRequires: cairo-devel
  12. BuildRequires: expat-devel
  13. BuildRequires: flex
  14. BuildRequires: fontconfig-devel
  15. BuildRequires: freetype2-devel
  16. BuildRequires: gd-devel
  17. BuildRequires: gtk2-devel
  18. BuildRequires: guile-devel
  19. BuildRequires: libjpeg-turbo-devel
  20. BuildRequires: libpng-devel
  21. BuildRequires: libSM-devel
  22. BuildRequires: libtool-ltdl-devel >= 2.2.6a
  23. BuildRequires: libXaw-devel
  24. BuildRequires: libXext-devel
  25. BuildRequires: librsvg2-devel
  26. BuildRequires: m4
  27. BuildRequires: perl
  28. BuildRequires: python-devel
  29. BuildRequires: ruby-devel
  30. BuildRequires: swig
  31. BuildRequires: tcl >= 8.4
  32. BuildRequires: tk >= 8.4
  33. BuildRequires: zlib-devel
  34. Requires: urw-fonts
  35. # only for this release
  36. BuildConflicts: graphviz-devel
  37. Vendor: Project Vine
  38. Distribution: Vine Linux
  39. %description
  40. A collection of tools and tcl packages for the manipulation and layout
  41. of graphs (as in nodes and edges, not as in barcharts).
  42. %package devel
  43. Group: Development/Libraries
  44. Summary: Development tools for version %{version} of %{name}
  45. Requires: %{name} = %{version}
  46. %description devel
  47. The %{name}-devel package contains the header files
  48. and man3 pages necessary for developing programs
  49. using version %{version} of the %{name} libraries.
  50. %package doc
  51. Summary: PDF and HTML documents for graphviz
  52. Group: Applications/Documentation
  53. %description doc
  54. Provides some additional PDF and HTML documentation for graphviz.
  55. %package guile
  56. Group: Applications/Graphics
  57. Summary: Guile extension for graphviz
  58. Requires: %{name} = %{version}-%{release}, guile
  59. %description guile
  60. Guile extension for graphviz.
  61. %package perl
  62. Group: Applications/Graphics
  63. Summary: Perl extension for graphviz
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  66. %description perl
  67. Perl extension for graphviz.
  68. %package python
  69. Group: Applications/Graphics
  70. Summary: Python extension for graphviz
  71. Requires: %{name} = %{version}-%{release}
  72. Requires: python
  73. %description python
  74. Python extension for graphviz.
  75. %package ruby
  76. Group: Applications/Multimedia
  77. Summary: Ruby extension for graphviz
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: ruby
  80. %description ruby
  81. Ruby extension for graphviz.
  82. %package tcl
  83. Group: Applications/Graphics
  84. Summary: Tcl extension & tools for graphviz
  85. Requires: tcl >= 8.4, tk >= 8.4
  86. Requires: %{name} = %{version}
  87. %description tcl
  88. Various tcl packages (extensions) for the graphviz tools.
  89. %prep
  90. %setup -q
  91. # using archdir instead of sitearchdir for Vine
  92. sed -i -e "s|sitearchdir|archdir|g" config/config_ruby.rb
  93. %build
  94. # Rewrite config_ruby.rb to work with Ruby 1.9
  95. sed -i 's|expand(|expand(Config::|' config/config_ruby.rb
  96. sed -i 's|sitearchdir|vendorarchdir|' config/config_ruby.rb
  97. export CPPFLAGS=-I`ruby -e "puts File.join(RbConfig::CONFIG['includedir'], RbConfig::CONFIG['sitearch'])" || echo /dev/null`
  98. # XXX ix86 only used to have -ffast-math, let's use everywhere
  99. %{expand: %%define optflags %{optflags} -ffast-math}
  100. %configure \
  101. --with-x \
  102. --disable-static \
  103. --with-mylibgd \
  104. --with-ipsepcola \
  105. --with-pangocairo \
  106. --with-gdk-pixbuf \
  107. --without-mylibgd \
  108. --without-ming \
  109. --disable-sharp \
  110. --enable-guile \
  111. --enable-io \
  112. --disable-java \
  113. --disable-lua \
  114. --disable-ocaml \
  115. --enable-perl \
  116. --disable-php \
  117. --enable-python \
  118. --disable-r \
  119. --enable-ruby \
  120. --enable-tcl
  121. make %{?_smp_mflags}
  122. %install
  123. rm -rf $RPM_BUILD_ROOT __doc
  124. make DESTDIR=$RPM_BUILD_ROOT \
  125. docdir=$RPM_BUILD_ROOT%{_docdir}/%{name} \
  126. pkgconfigdir=%{_libdir}/pkgconfig \
  127. install
  128. find ${RPM_BUILD_ROOT} -type f -name "*.la" -exec rm -f {} ';'
  129. chmod -x $RPM_BUILD_ROOT%{_datadir}/%{name}/lefty/*
  130. cp -a $RPM_BUILD_ROOT%{_datadir}/%{name}/doc __doc
  131. rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/doc
  132. %clean
  133. rm -rf $RPM_BUILD_ROOT
  134. # run "dot -c" to generate plugin config in %{_libdir}/%{name}/config
  135. %post
  136. /sbin/ldconfig
  137. %{_bindir}/dot -c
  138. # if there is no dot after everything else is done, then remove config
  139. %postun
  140. if [ $1 -eq 0 ]; then
  141. rm -f %{_libdir}/graphviz/config || :
  142. fi
  143. /sbin/ldconfig
  144. %files
  145. %defattr(-,root,root)
  146. %doc AUTHORS COPYING ChangeLog NEWS README
  147. %{_bindir}/*
  148. %dir %{_datadir}/%{name}
  149. %{_datadir}/%{name}/gvpr
  150. %{_datadir}/%{name}/lefty
  151. %{_mandir}/man1/*
  152. %{_mandir}/man7/*
  153. %dir %{_libdir}/%{name}
  154. %{_libdir}/*.so.*
  155. %{_libdir}/%{name}/*.so.*
  156. %exclude %{_libdir}/graphviz/*/*
  157. %files devel
  158. %defattr(-,root,root)
  159. %{_includedir}/%{name}
  160. %{_libdir}/*.so
  161. %{_libdir}/%{name}/*.so
  162. %{_libdir}/pkgconfig/*.pc
  163. %{_datadir}/%{name}/graphs
  164. %{_mandir}/man3/*.3.gz
  165. %files doc
  166. %defattr(-,root,root,-)
  167. %doc __doc/*
  168. %files guile
  169. %defattr(-,root,root,-)
  170. %{_libdir}/graphviz/guile/
  171. %{_mandir}/man3/gv.3guile*
  172. %files perl
  173. %defattr(-,root,root,-)
  174. %{_libdir}/graphviz/perl/
  175. %{perl_vendorarch}/*
  176. %{_mandir}/man3/gv.3perl*
  177. %files python
  178. %defattr(-,root,root,-)
  179. %{_libdir}/graphviz/python/
  180. %{_libdir}/python*/*
  181. %{_mandir}/man3/gv.3python*
  182. %files ruby
  183. %defattr(-,root,root,-)
  184. %{_libdir}/graphviz/ruby/
  185. %{_libdir}/*ruby*/*
  186. %{_mandir}/man3/gv.3ruby*
  187. %files tcl
  188. %defattr(-,root,root)
  189. %{_libdir}/%{name}/tcl/*
  190. %{_libdir}/tcl*/*
  191. %{_datadir}/%{name}/demo
  192. # hack to include gv.3tcl only if available
  193. # always includes tcldot.3tcl, gdtclft.3tcl
  194. %{_mandir}/man3/*.3tcl*
  195. %{_mandir}/man3/tkspline.3tk*
  196. %changelog
  197. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  198. - new upstream release
  199. * Mon Jan 7 2013 IWAI, Masaharu <iwai@alib.jp> 2.28.0-3
  200. - build with Tcl/Tk 8.5.7-1
  201. - stop running autoreconf
  202. - add Vendor and Distribution tags
  203. * Sun Nov 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.0-2
  204. - re-enable ruby binding, which is accidentally disabled in 2.28.0-1
  205. - rewrite config_ruby.rb to build with ruby-1.9.3
  206. - add search path for ruby/config.h to CPPFLAGS for configure
  207. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  208. - new upstream release
  209. - remove Patch10 (graphviz-2.26.3_dont_regard_tiger_as_the_only_ppc.patch)
  210. - add BuildRequires: librsvg2-devel
  211. * Sun Oct 10 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.26.3-2
  212. - add Patch10 to avoid build failure on ppc
  213. * Sat Oct 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.26.3-1
  214. - new upstream release
  215. - built with rpm-4.8.1
  216. - split doc, guile, perl, python, ruby subpackage
  217. * Thu Apr 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-3
  218. - rebuild with libtool-2.2.6a
  219. * Sun Nov 09 2008 Shu KONNO <owa@bg.wakwak.com> 2.20.3-1
  220. - new upstream release
  221. * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
  222. - rebuild with libXaw.so.7 (libXaw-1.0.5)
  223. * Wed Jul 16 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.20.2-1
  224. - new upstream release
  225. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.16.1-0vl1
  226. - new upstream release
  227. - build with expat-2.0.1
  228. - add man7
  229. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 2.12-0vl2
  230. - rebuild with tcl/tk-8.4.16
  231. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.12-0vl1
  232. - new upstream release
  233. - add BuildPrereq: swig
  234. - delete BuildPrereq: gd-progs gd-devel
  235. - add --with-mylibgd and --disable-FEATURE to configure option
  236. - update %%files
  237. * Sun Jul 30 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.6-0vl2
  238. - added BuildPrereq: ruby-devel
  239. * Tue Oct 11 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6-0vl1
  240. - new upstream release
  241. - add BuildPrereq: libtool-ltdl-devel
  242. - move pkgconfig files to %%{_libdir}/pkgconfig
  243. - add --disable-rpath --disable-static to configure option
  244. - add %%post to every package
  245. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2-0vl1
  246. - new upstream release
  247. - BuildPrereq: tcl >= 8.4, tk >= 8.4
  248. - add BuildPrereq: gd-progs gd-devel flex bison pkgconfig
  249. - update %%files
  250. - remove lines about Vine2.6
  251. - change License to CPL
  252. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.12-0vl1
  253. - source upgrade
  254. - remove patch0 and commented lines
  255. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl2
  256. - build for VineSeed
  257. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.10-0vl1
  258. - source upgrade
  259. - change spec to build both VineSeed and Vine2.5/2.6
  260. - add BuildPrereq: expat-devel and Requires: libexpat
  261. - add patch0 to build against freetype2-2.1.7
  262. - stop using autogen.sh script
  263. - add BuildPrereq: tcl >= 8.3 tk >= 8.3 (VineSeed)
  264. - add graphviz-tcl package (VineSeed)
  265. * Thu Aug 7 2003 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 1.9-0vl2
  266. - rebuild for new Vine
  267. * Wed Mar 05 2003 Kunio Murasawa <murasawa@fa2.so-net.ne.jp> 1.9-0vl1
  268. - import from offical site (src.rpm)