gpsd-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  3. Summary: Service daemon for mediating access to a GPS
  4. Summary(ja): GPS にアクセスするためのサービスデーモン
  5. Name: gpsd
  6. Version: 3.8
  7. Release: 1%{?_dist_release}
  8. Group: System Environment/Daemons
  9. License: BSD
  10. URL: http://developer.berlios.de/projects/gpsd/
  11. Source0: http://download.berlios.de/gpsd/%{name}-%{version}.tar.gz
  12. Source10: gpsd.init
  13. Source11: gpsd.sysconfig
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: scons
  16. BuildRequires: chrpath
  17. BuildRequires: dbus-devel dbus-glib-devel ncurses-devel xmlto python-devel
  18. BuildRequires: libusb1-devel desktop-file-utils
  19. BuildRequires: libudev-devel
  20. Requires: udev
  21. Requires(post): /sbin/ldconfig
  22. Requires(post): /sbin/chkconfig
  23. Requires(preun): initscripts
  24. Requires(preun): /sbin/chkconfig
  25. Requires(postun): /sbin/ldconfig
  26. %description
  27. gpsd is a service daemon that mediates access to a GPS sensor
  28. connected to the host computer by serial or USB interface, making its
  29. data on the location/course/velocity of the sensor available to be
  30. queried on TCP port 2947 of the host computer. With gpsd, multiple
  31. GPS client applications (such as navigational and wardriving software)
  32. can share access to a GPS without contention or loss of data. Also,
  33. gpsd responds to queries with a format that is substantially easier to
  34. parse than NMEA 0183.
  35. %package devel
  36. Summary: Client libraries in C and Python for talking to a running gpsd or GPS
  37. Group: Development/Libraries
  38. Requires: %{name} = %{version}-%{release}
  39. Requires: pkgconfig
  40. %description devel
  41. This package provides C header files and python modules for the gpsd shared
  42. libraries that manage access to a GPS for applications
  43. %package clients
  44. Summary: Clients for gpsd
  45. Summary(ja): gpsd 用クライアント
  46. Group: Applications/System
  47. %description clients
  48. xgps is a simple test client for gpsd with an X interface. It displays
  49. current GPS position/time/velocity information and (for GPSes that
  50. support the feature) the locations of accessible satellites.
  51. xgpsspeed is a speedometer that uses position information from the GPS.
  52. It accepts an -h option and optional argument as for gps, or a -v option
  53. to dump the package version and exit. Additionally, it accepts -rv
  54. (reverse video) and -nc (needle color) options.
  55. cgps resembles xgps, but without the pictorial satellite display. It
  56. can run on a serial terminal or terminal emulator.
  57. %prep
  58. %setup -q
  59. %build
  60. scons %{_smp_mflags} \
  61. prefix=%{_prefix} \
  62. bindir=%{_bindir} \
  63. includedir=%{_includedir} \
  64. libdir=%{_libdir} \
  65. sbindir=%{_sbindir} \
  66. mandir=%{_mandir} \
  67. docdir=%{_docdir} \
  68. pkgconfigdir=%{_libdir}/pkgconfig
  69. scons build
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. export DESTDIR=$RPM_BUILD_ROOT
  73. scons install
  74. # init scripts
  75. %{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/init.d
  76. %{__install} -p -m 0755 %{SOURCE10} \
  77. %{buildroot}%{_sysconfdir}/init.d/gpsd
  78. %{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/sysconfig
  79. %{__install} -p -m 0644 %{SOURCE11} \
  80. %{buildroot}%{_sysconfdir}/sysconfig/gpsd
  81. # udev rules
  82. %{__install} -d -m 0755 %{buildroot}%{_sysconfdir}/udev/rules.d
  83. %{__install} -p -m 0644 gpsd.rules \
  84. %{buildroot}%{_sysconfdir}/udev/rules.d/99-gpsd.rules
  85. # hotplug script
  86. %{__install} -d -m 0755 %{buildroot}/lib/udev
  87. %{__install} -p -m 0755 gpsd.hotplug %{buildroot}/lib/udev
  88. # remove .la files
  89. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  90. # fix non-executable python script
  91. %{__chmod} +x %{buildroot}%{python_sitearch}/gps/gps.py
  92. # Install the .desktop files
  93. desktop-file-install \
  94. --dir %{buildroot}%{_datadir}/applications \
  95. packaging/X11/xgps.desktop
  96. desktop-file-install \
  97. --dir %{buildroot}%{_datadir}/applications \
  98. packaging/X11/xgpsspeed.desktop
  99. # Install logo icon for .desktop files
  100. %{__install} -d -m 0755 %{buildroot}%{_datadir}/gpsd
  101. %{__install} -p -m 0644 packaging/X11/gpsd-logo.png %{buildroot}%{_datadir}/gpsd/gpsd-logo.png
  102. %clean
  103. rm -rf %{buildroot}
  104. %post
  105. /sbin/ldconfig
  106. /sbin/chkconfig --add %{name}
  107. %preun
  108. if [ $1 = 0 ]; then
  109. /sbin/service %{name} stop > /dev/null 2>&1 || true
  110. /sbin/chkconfig --del %{name}
  111. fi
  112. %postun -p /sbin/ldconfig
  113. %files
  114. %defattr(-,root,root,-)
  115. %doc README INSTALL COPYING
  116. %config(noreplace) %{_sysconfdir}/init.d/%{name}
  117. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  118. %config(noreplace) %{_sysconfdir}/udev/rules.d/*
  119. %{_sbindir}/gpsd
  120. %{_sbindir}/gpsdctl
  121. %{_bindir}/gegps
  122. %{_bindir}/gpsprof
  123. %{_bindir}/gpsmon
  124. %{_bindir}/gpsctl
  125. %{_libdir}/libgps*.so.*
  126. /lib/udev/gpsd*
  127. %{python_sitearch}/gps*
  128. %exclude %{python_sitearch}/gps/fake*
  129. %{_mandir}/man8/gpsd.8*
  130. %{_mandir}/man8/gpsdctl.8*
  131. %{_mandir}/man8/gpsinit.8*
  132. %{_mandir}/man1/gegps.1*
  133. %{_mandir}/man1/gpsprof.1*
  134. %{_mandir}/man1/gpsmon.1*
  135. %{_mandir}/man1/gpsctl.1*
  136. %files devel
  137. %defattr(-,root,root,-)
  138. %doc TODO
  139. %{_bindir}/gpsfake
  140. %{_libdir}/libgps*.so
  141. %{_libdir}/pkgconfig/*.pc
  142. %{python_sitearch}/gps/fake*
  143. %{_includedir}/gps.h
  144. %{_includedir}/libgpsmm.h
  145. %{_mandir}/man1/gpsfake.1*
  146. %{_mandir}/man3/libQgpsmm.3*
  147. %{_mandir}/man3/libgps.3*
  148. %{_mandir}/man3/libgpsmm.3*
  149. %{_mandir}/man3/libgpsd.3*
  150. %{_mandir}/man5/gpsd_json.5*
  151. %{_mandir}/man5/srec.5*
  152. %files clients
  153. %defattr(-,root,root,-)
  154. %{_bindir}/cgps
  155. %{_bindir}/gpscat
  156. %{_bindir}/gpsdecode
  157. %{_bindir}/gpspipe
  158. %{_bindir}/gpxlogger
  159. %{_bindir}/lcdgps
  160. %{_bindir}/xgps
  161. %{_bindir}/xgpsspeed
  162. %{_mandir}/man1/gps.1*
  163. %{_mandir}/man1/gpsdecode.1*
  164. %{_mandir}/man1/gpspipe.1*
  165. %{_mandir}/man1/lcdgps.1*
  166. %{_mandir}/man1/xgps.1*
  167. %{_mandir}/man1/xgpsspeed.1*
  168. %{_mandir}/man1/cgps.1*
  169. %{_mandir}/man1/gpscat.1*
  170. %{_datadir}/applications/*.desktop
  171. %dir %{_datadir}/gpsd
  172. %{_datadir}/gpsd/gpsd-logo.png
  173. %changelog
  174. * Sun Mar 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.8-1
  175. - new upstream release
  176. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.7-1
  177. - update to 3.7
  178. - remove old patches
  179. - add BuildRequires: scons, chrpath
  180. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-3
  181. - rebuild with python-2.7.2
  182. * Tue Sep 28 2010 Shu KONNO <owa@bg.wakwak.com> 2.95-2
  183. - rebuilt with rpm-4.8.1 for pkg-config
  184. * Sun Aug 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.95-1
  185. - new upstream release
  186. - merge spec, patch, source from fedora
  187. * Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.37-3
  188. - add BuildRequires: libXp-devel
  189. * Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 2.37-2
  190. - rebuilt with python-2.6.4
  191. * Mon Feb 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.37-1
  192. - initial build for Vine Linux
  193. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.37-3
  194. - Rebuild for Python 2.6
  195. * Wed Mar 19 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-2
  196. - moving gpspacket.so python lib to main package
  197. - adding zero.patch to make ZEROIZE error go away on fedora 7
  198. * Wed Feb 27 2008 Douglas E. Warner <silfreed@silfreed.net> - 2.37-1
  199. - update to 2.37
  200. - removed install-gpsd_config.h.patch
  201. - installed pkgconfig files in devel package
  202. - added patch to install python modules in sitearch
  203. - removing rpath from inclucded libtool
  204. - moving X11 app-defaults to datadir
  205. - using macros for commands in install; using install instead of cp and mkdir
  206. - cleaning up spaces/tabs for rpmlint
  207. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.34-9
  208. - Autorebuild for GCC 4.3
  209. * Sun Aug 19 2007 Matthew Truch <matt at truch.net> - 2.34-8
  210. - Patch Makefile to also install gpsd_config.h as needed by
  211. libgpsmm.h. Redhat BZ 253433.
  212. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-7
  213. - Make sure the logo is actually included (via the spec file).
  214. I need to wake up before I try even trivial updates.
  215. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-6
  216. - Learn how to use search and replace (aka fix all instances of
  217. gpsd-logo.png spelled incorrectly as gspd-logo.png).
  218. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-5
  219. - Fix desktop file and logo file name.
  220. * Sat Jun 30 2007 Matthew Truch <matt at truch.net> - 2.34-4
  221. - Include icon for .desktop files per BZ 241428
  222. * Tue Mar 20 2007 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.34-3
  223. - Bump release for FE5 -> Fedora 7 upgrade path.
  224. * Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-2
  225. - BR python-devel instead of python to make it build.
  226. * Tue Feb 27 2007 Matthew Truch <matt at truch.net> - 2.34-1
  227. - Upgrade to 2.34.
  228. - Get rid of %%makeinstall (which was never needed).
  229. - Possibly fix hotplug issuses (BZ 219750).
  230. - Use %%python_sitelib for python site-files stuff.
  231. * Sat Dec 9 2006 Matthew Truch <matt at truch.net> - 2.33-6
  232. - Rebuild to pull in new version of python.
  233. * Tue Sep 26 2006 Matthew Truch <matt at truch.net> - 2.33-5
  234. - Remove openmotif requirment, and switch to lesstif.
  235. * Mon Aug 28 2006 Matthew Truch <matt at truch.net> - 2.33-4
  236. - Bump release for rebuild in prep. for FC6.
  237. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-3
  238. - Actually, was a missing BR glib-dbus-devel. Ooops.
  239. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-2
  240. - Missing BR glib-devel
  241. * Thu Jul 20 2006 Matthew Truch <matt at truch.net> - 2.33-1
  242. - Update to version 2.33
  243. * Wed Apr 19 2006 Matthew Truch <matt at truch.net> - 2.32-5
  244. - Don't --enable-tnt in build as it causes some gpses to not work
  245. properly with sattelite view mode. See bugzilla bug 189220.
  246. * Thu Apr 13 2006 Matthew Truch <matt at truch.net> - 2.32-4
  247. - Add dbus-glib to BuildRequires as needed for build.
  248. * Sun Apr 9 2006 Matthew Truch <matt at truch.net> - 2.32-3
  249. - Include xmlto and python in buildrequires so things build right.
  250. - Don't package static library file.
  251. * Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-2
  252. - Use ye olde %%{?dist} tag.
  253. * Wed Apr 5 2006 Matthew Truch <matt at truch.net> - 2.32-1
  254. - Initial Fedora Extras specfile