xorg-x11-xinit-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. %define pkgname xinit
  2. Summary: X.Org X11 X Window System xinit startup scripts
  3. Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
  4. Name: xorg-x11-%{pkgname}
  5. Version: 1.2.1
  6. Release: 1%{?_dist_release}
  7. License: MIT/X11
  8. Group: User Interface/X
  9. URL: http://www.x.org
  10. Source0: ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
  11. Source10: xinitrc-common
  12. Source11: xinitrc
  13. Source12: Xclients
  14. Source13: Xmodmap
  15. Source14: Xresources
  16. # NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
  17. # here instead of the xdm package.
  18. Source16: Xsession
  19. Source17: localuser.sh
  20. Source18: xinit-compat.desktop
  21. Source100: ck-xinit-session.c
  22. Patch1: xinit-1.0.2-client-session.patch
  23. Patch2: xinit-1.0.7-poke-ck.patch
  24. Patch3: xinit-1.0.9-unset.patch
  25. Patch10: xinit-1.0.7-vine.patch
  26. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  27. BuildRequires: pkgconfig
  28. BuildRequires: libX11-devel
  29. BuildRequires: ConsoleKit-devel
  30. BuildRequires: autoconf
  31. BuildRequires: automake
  32. BuildRequires: libtool
  33. BuildRequires: dbus-devel
  34. BuildRequires: xorg-x11-util-macros
  35. # NOTE: startx needs xauth in order to run, but that is not picked up
  36. # automatically by rpm. (Bug #173684)
  37. Requires: xauth
  38. # next two are for localuser.sh
  39. Requires: coreutils
  40. Requires: xorg-x11-server-utils
  41. Requires: ConsoleKit-x11
  42. Requires: ConsoleKit-libs
  43. Requires: dbus-x11
  44. # NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
  45. # modularization. These Obsoletes lines ensure upgrades work smoothly.
  46. Obsoletes: XFree86, XOrg
  47. # NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
  48. # so the xinitrc package became unnecessary. The xdm configs/scripts move
  49. # to the xdm package.
  50. Obsoletes: xinitrc
  51. Provides: xinitrc
  52. %description
  53. X.Org X11 X Window System xinit startup scripts
  54. %description -l ja
  55. X.Org X11 X Window System の xinit スタートアップ・スクリプト
  56. %package session
  57. Summary: Display manager support for ~/.xsession and ~/.Xclients
  58. Group: User Interface/X
  59. %description
  60. X.Org X11 X Window System xinit startup scripts
  61. %description session
  62. Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
  63. %prep
  64. %setup -q -n %{pkgname}-%{version}
  65. %patch1 -p1 -b .client-session
  66. #%patch2 -p1 -b .poke-ck
  67. %patch3 -p1 -b .unset
  68. %patch10 -p1 -b .vine
  69. %build
  70. autoreconf -i
  71. %configure
  72. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  73. # Makefile.am and submit it in a bug report or check into CVS.
  74. make XINITDIR=/etc/X11/xinit
  75. %{__cc} -o ck-xinit-session \
  76. `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
  77. $RPM_SOURCE_DIR/ck-xinit-session.c \
  78. `pkg-config --libs ck-connector dbus-1`
  79. %install
  80. rm -rf $RPM_BUILD_ROOT
  81. # FIXME: Upstream should default to XINITDIR being this. Make a patch to
  82. # Makefile.am and submit it in a bug report or check into CVS.
  83. %makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
  84. install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
  85. install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
  86. # Install custom xinitrc, etc.
  87. {
  88. install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
  89. for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
  90. install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
  91. done
  92. install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
  93. install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
  94. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
  95. install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
  96. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
  97. }
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %files
  101. %defattr(-,root,root,-)
  102. %doc COPYING README ChangeLog
  103. %{_bindir}/startx
  104. %{_bindir}/xinit
  105. %{_bindir}/ck-xinit-session
  106. %dir %{_sysconfdir}/X11
  107. %dir %{_sysconfdir}/X11/xinit
  108. %{_sysconfdir}/X11/xinit/xinitrc
  109. %{_sysconfdir}/X11/xinit/xinitrc-common
  110. %config(noreplace) %{_sysconfdir}/X11/Xmodmap
  111. %config(noreplace) %{_sysconfdir}/X11/Xresources
  112. %dir %{_sysconfdir}/X11/xinit/Xclients.d
  113. %{_sysconfdir}/X11/xinit/Xclients
  114. %{_sysconfdir}/X11/xinit/Xsession
  115. %dir %{_sysconfdir}/X11/xinit/xinitrc.d
  116. %{_sysconfdir}/X11/xinit/xinitrc.d/*
  117. #%dir %{_mandir}/man1
  118. %{_mandir}/man1/startx.1*
  119. %{_mandir}/man1/xinit.1*
  120. %files session
  121. %defattr(-, root, root)
  122. %{_datadir}/xsessions/xinit-compat.desktop
  123. %changelog
  124. * Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  125. - new upstream release
  126. - updated SOURCE12, SOURCE100
  127. - Install xinitrc-common non-executable.
  128. - added a new subpackage to add ~/.xsessions and ~/.Xclients
  129. to session list
  130. * Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  131. - new upstream release
  132. * Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
  133. - add Requires: dbus-x11
  134. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
  135. - add LXDE to Xclients
  136. * Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
  137. - new upstream release
  138. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
  139. - fix typo in Xsession (<BTS:644>)
  140. * Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
  141. - new upstream release
  142. * Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
  143. - spec in UTF-8
  144. - modify Source16: add CK_XINIT_SESSION calls
  145. * Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
  146. - add Patch10 to set display resolution.
  147. * Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
  148. - initial build for Vine Linux
  149. * Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
  150. - Try opening the console-kit session after the user's UID has already
  151. been granted access to the server by localuser.sh, so that console-kit-daemon
  152. can connect and ask the server for information just by having switch to the
  153. user's UID (#287941).
  154. * Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
  155. - xinit 1.0.7
  156. * Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
  157. - Rebuild for build id
  158. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
  159. - Bump release
  160. * Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
  161. - Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
  162. * Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
  163. - Fix bug 212167, CVE-2006-5214
  164. * Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
  165. - Fix Xsession to run the login shell inside the setgid ssh-agent, rather
  166. than the other way around. This preserves LD_LIBRARY_PRELOAD.
  167. Patch from Stefan Becker, bug 164869.
  168. * Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
  169. - Remove xinput.sh. Bug 244963.
  170. * Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
  171. - localuser.sh: Run silently.
  172. * Sat Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
  173. - Don't install INSTALL
  174. * Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
  175. - disable SCIM by default in non-Asian languages #237054
  176. If you want to use SCIM, use im-chooser to enable it.
  177. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
  178. - Man pages are now in section 1, not in section 1x
  179. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
  180. - Also BR xorg-x11-util-macros since we autoreconf
  181. * Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
  182. - Add ConsoleKit support (#233183)
  183. * Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
  184. - Bump EVR to fix 6 to 7 updates.
  185. * Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
  186. - start client in its own session with no controlling tty
  187. (bug 214649)
  188. * Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
  189. - Update Xsession to not use switchdesk for the hard coded kde and twm
  190. cases.
  191. * Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
  192. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  193. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
  194. - Bump and rebuild.
  195. * Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
  196. - Move hardcoded xsetroot background color to fallback cases (#205901).
  197. * Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
  198. - Start ssh-agent for startx also (#169259).
  199. * Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
  200. - Fix SourceN line for localuser.sh to not collide.
  201. * Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
  202. - Added localuser.sh.
  203. * Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
  204. - Added fix to Xclients script, based on patch from bug (#190799)
  205. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
  206. - rebuild
  207. * Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
  208. - Implemented changes to xinput.sh based on suggestions from (#194458)
  209. * Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
  210. - Added documentation to doc macro.
  211. * Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
  212. - Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
  213. * Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
  214. - Added "BuildRequires: pkgconfig" for bug (#194187)
  215. * Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
  216. - Update xinit to 1.0.2
  217. * Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
  218. - Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
  219. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
  220. - bump again for double-long bug on ppc(64)
  221. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
  222. - rebuilt for new gcc4.1 snapshot and glibc changes
  223. * Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
  224. - Updated to xinit 1.0.1 from X11R7.0
  225. * Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
  226. - Updated to xinit 1.0.0 from X11R7 RC4.
  227. - Changed manpage dir from man1x to man1 to match upstream default.
  228. * Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
  229. - Add "Requires: xauth" for startx, to fix bug (#173684)
  230. * Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
  231. - Do not provide xinit anymore, gdm has been fixed and that breaks things
  232. with the obsoletes
  233. * Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
  234. - Added Xsession script from xinitrc, as it is very similar codebase, which
  235. shares "xinitrc-common" anyway, and all of the display managers use it.
  236. * Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
  237. - Updated to xinit 0.99.3 from X11R7 RC2.
  238. * Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
  239. - Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
  240. monolithic and modular X. This will be removed however for FC5.
  241. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
  242. - Import custom Red Hat xinit scripts from xinitrc package.
  243. - Obsolete xinitrc package, as we include the scripts/configs here now.
  244. - Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
  245. * Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
  246. - Updated to xinit 0.99.2 from X11R7 RC1.
  247. - Change manpage location to 'man1x' in file manifest.
  248. * Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
  249. - Use Fedora-Extras style BuildRoot tag.
  250. - Update BuildRequires to use new library package names.
  251. - Tidy up spec file a bit.
  252. * Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
  253. - Initial build.