scim-bridge-vl.spec 9.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306
  1. %define name scim-bridge
  2. %define version 0.4.16
  3. %define release 9%{?_dist_release}
  4. # build qt3 immodule ("--without qt3" to disable qt3)
  5. %bcond_without qt3
  6. # ugly hack for Qt3 version auto-detection -- inagaki
  7. %define _qt3_notfound %(eval "rpm -q qt-devel > /dev/null"; echo $?)
  8. %if %{_qt3_notfound}
  9. %define _qt3_version 3.3.8
  10. %else
  11. %define _qt3_version %(rpm -q --queryformat "%%{version}" qt-devel)
  12. %endif
  13. %define _qt3_prefix %{_libdir}/qt-%{_qt3_version}
  14. %define _qt3_plugindir %{_qt3_prefix}/plugins
  15. # build qt4 immodule ("--without qt4" to disable qt4)
  16. %bcond_without qt4
  17. # ugly hack for Qt4 version auto-detection -- inagaki
  18. %define _qt4_notfound %(eval "pkg-config --exists Qt"; echo $?)
  19. %if %{_qt4_notfound}
  20. %define _qt4_version 4.6.1
  21. %define _qt4_prefix %{_libdir}/qt-%{_qt4_version}
  22. %define _qt4_plugindir %{_qt4_prefix}/plugins
  23. %else
  24. %define _qt4_version %(pkg-config --modversion --silence-errors Qt)
  25. %define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt)
  26. %define _qt4_plugindir %(pkg-config --variable plugindir --silence-errors Qt)
  27. %endif
  28. Summary: yet another IM client of SCIM
  29. Summary(ja): もう一つ別の SCIM IM クライアント
  30. Name: %{name}
  31. Version: %{version}
  32. Release: %{release}
  33. Source0: http://1jaist.dl.sourceforge.net/sourceforge/scim/%{name}-%{version}.tar.gz
  34. # Patch from Fedora 10
  35. Patch0: scim-bridge-0.4.15-fix-gdm.patch
  36. Patch1: scim-bridge-0.4.15-bz461373.patch
  37. # Patch from Mandriva 2009
  38. Patch2: bug-351920-should-return-retval.patch
  39. Patch3: scim-bridge-0.4.15.2-linkage.patch
  40. # Patch from Fedora development
  41. Patch4: scim-bridge-0.4.15-EOF.patch
  42. Patch5: scim-bridge-0.4.15-hotkey-help.patch
  43. Patch6: scim-bridge-0.4.16-fix-gtk-key-snooper.patch
  44. Patch7: scim-bridge-0.4.16-fixes-null-imengine.patch
  45. URL: http://www.scim-im.org/projects/scim_bridge
  46. License: GPL/LGPL
  47. Group: System Environment/Libraries
  48. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  49. Prefix: %{_prefix}
  50. Requires: scim >= 1.4
  51. BuildRequires: scim-devel >= 1.4
  52. BuildRequires: pkgconfig >= 0.9.0
  53. BuildRequires: gtk2-devel >= 2.14.0
  54. %description
  55. Scim-bridge is yet another IM client of SCIM.
  56. The im-module of scim-bridge communicates with scim via socket.
  57. %description -l ja
  58. scim-bridge は、もう一つ別の SCIM IM クライアントです。
  59. scim-bridge の im-module はソケット経由で SCIM と通信します。
  60. %package gtk
  61. Summary: SCIM Bridge GTK IM Module
  62. Summary(ja): SCIM Bridge GTK IM モジュール
  63. Group: System Environment/Libraries
  64. Requires: %{name} = %{version}-%{release}
  65. Requires: gtk2 >= 2.14.0
  66. Requires(post): gtk2 >= 2.14.0
  67. Requires(postun): gtk2 >= 2.14.0
  68. Obsoletes: %{name} <= 0.1.7
  69. %description gtk
  70. This package provides the SCIM Bridge GTK IM module.
  71. %description -l ja gtk
  72. このパッケージには SCIM Bridge の GTK IM モジュールが含まれています。
  73. %if !%{without qt3}
  74. %package qt
  75. Summary: SCIM Bridge Qt IM Module
  76. Summary(ja): SCIM Bridge Qt IM モジュール
  77. Group: System Environment/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: qt = %{_qt3_version}
  80. BuildRequires: qt-devel
  81. %description qt
  82. This package provides the SCIM Bridge Qt IM module.
  83. %description -l ja qt
  84. このパッケージには SCIM Bridge の Qt IM モジュールが含まれています。
  85. %endif
  86. %if !%{without qt4}
  87. %package qt4
  88. Summary: SCIM Bridge Qt4 IM Module
  89. Summary(ja): SCIM Bridge Qt4 IM モジュール
  90. Group: System Environment/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Requires: qt4 = %{_qt4_version}
  93. BuildRequires: qt4-devel
  94. %description qt4
  95. This package provides the SCIM Bridge Qt4 IM module.
  96. %description -l ja qt4
  97. このパッケージには SCIM Bridge の Qt4 IM モジュールが含まれています。
  98. %endif
  99. %prep
  100. %setup -q
  101. %patch0 -p1 -b .0-fix-gdm
  102. %patch1 -p1
  103. %patch2 -p1
  104. %patch3
  105. %patch4 -p1
  106. %patch5 -p1
  107. pushd client-gtk
  108. %patch6 -p0
  109. popd
  110. %patch7 -p1
  111. %build
  112. %if !%{without qt3}
  113. export QT3_PREFIX=%{_qt3_prefix}
  114. %endif
  115. %if !%{without qt4}
  116. export QT4_PREFIX=%{_qt4_prefix}
  117. %endif
  118. %configure --disable-static \
  119. %if %{without qt3}
  120. --disable-qt3-immodule \
  121. %else
  122. --enable-qt3-immodule \
  123. %endif
  124. %if %{without qt4}
  125. --disable-qt4-immodule \
  126. %else
  127. --enable-qt4-immodule \
  128. %endif
  129. --enable-gtk2-immodule
  130. %__make
  131. %install
  132. %__rm -rf %{buildroot}
  133. #%%makeinstall moduledir=%{buildroot}%{_libdir}/gtk-2.0/immodules
  134. %__make DESTDIR=%{buildroot} install
  135. # remove unneeded files
  136. %__rm -f %{buildroot}%{_libdir}/gtk-2.0/immodules/*.{a,la}
  137. %__rm -f %{buildroot}%{_qt3_plugindir}/inputmethods/*.{a,la}
  138. %__rm -f %{buildroot}%{_qt4_plugindir}/inputmethods/*.{a,la}
  139. %clean
  140. %__rm -rf %{buildroot}
  141. %post gtk
  142. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  143. %postun gtk
  144. %{_bindir}/gtk-query-immodules-2.0 > %{_sysconfdir}/gtk-2.0/%{_arch}/gtk.immodules
  145. %files
  146. %defattr(-,root,root)
  147. %doc AUTHORS COPYING ChangeLog NEWS README doc/LICENSE*
  148. %{_bindir}/scim-bridge
  149. %files gtk
  150. %defattr(-,root,root)
  151. %{_libdir}/gtk-2.0/immodules/im-scim-bridge.so
  152. %if !%{without qt3}
  153. %files qt
  154. %defattr(-,root,root)
  155. %{_qt3_plugindir}/inputmethods/*.so
  156. %endif
  157. %if !%{without qt4}
  158. %files qt4
  159. %defattr(-,root,root)
  160. %{_qt4_plugindir}/inputmethods/*.so
  161. %endif
  162. %changelog
  163. * Fri May 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-9
  164. - added Patch6,7 from Fedora development, Patch8 from Debian
  165. - to fix Text input in firefox becomes increasingly sluggish (Patch6)
  166. - to fix Process /usr/bin/scim-bridge was killed by signal 11 (Patch7)
  167. - added configure --disable-static option
  168. * Sun Jan 31 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-8
  169. - updated Qt version detection macros to build properly
  170. * Fri Jan 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-7
  171. - rebuilt with qt4-4.6.1
  172. * Sun Nov 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.16-6
  173. - rebuilt with qt4-4.5.3
  174. * Tue Oct 13 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-5
  175. - cleaned up spec
  176. - renumbered patch
  177. - added Patch5 from Fedora
  178. * Wed Sep 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.16-4
  179. - rebuild with qt4-4.5.2
  180. * Mon Apr 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-3
  181. - dropt qt3rel/qt4rel part of Requires in subpackages qt, qt4
  182. * Sun Apr 26 2009 Shu KONNO <owa@bg.wakwak.com> 0.4.16-2
  183. - rebuild with qt-3.3.8-3vl5, because scim-bridge-qt requires "Rq: qt = %{qt3ver}-%{qt3rel}"
  184. * Sun Apr 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.16-1
  185. - new upstream release
  186. - dropt Pacth3,4,5 (these patches are merged)
  187. * Fri Apr 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-2
  188. - spec in UTF-8
  189. - fixed description in scim-bridge-qt4
  190. - added patch6,7 (import Fedora, Mandriva patches)
  191. * Mon Feb 2 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.4.15.2-1
  192. - new upstream release
  193. - added patch0,1,2,3,4,5 (import Fedora, Mandriva, scim-devel patches)
  194. * Wed Oct 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-4
  195. - rebuild with qt4-4.4.2
  196. * Fri Oct 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-3
  197. - add qt4 immodule
  198. - build gtk,qt3,qt4 immodule by default
  199. * Sat Sep 27 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.15-2
  200. - rebuild with gtk+-2.14
  201. * Sat Apr 05 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.15-1
  202. - new upstream release
  203. - apply new versioning policy
  204. * Fri Jan 18 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl2
  205. - drop unnecessary BuildRequires for qt3-immodule package
  206. - fix typo: 0.4.14-0vl1 changelog <BTS:VineLinux:#592>
  207. * Wed Jan 9 2008 IWAI, Masaharu <iwai@alib.jp> 0.4.14-0vl1
  208. - new upstream release
  209. - drop unnecessary Qt fix patch ( Patch0 ): upstream merged
  210. - update BuildRequires
  211. - drop doxygen
  212. - add XOrg-gl-devel for building qt3-immodule
  213. - move libmng-devel for building qt3-immodule
  214. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl2
  215. - rebuild for Vine Linux 4.2.
  216. * Tue Oct 09 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl3
  217. - add patch0 to fix symbol lookup error with qt3.
  218. * Wed Sep 26 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl0
  219. - rebuild for Vine Linux 4.2.
  220. * Sat Sep 15 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4.13-0vl1
  221. - new upstrm release
  222. - detect qt version at build time.
  223. - add --disable-qt4-immodule configure option.
  224. - add BuildRequires libmng-devel.
  225. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl2
  226. - rebuild with libstdc++34
  227. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.12-0vl1
  228. - new upstream release
  229. * Tue Dec 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl2
  230. - change License to GPL/LGPL
  231. - add doc/LICENSE.* as documents
  232. * Mon Dec 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.4.8-0vl1
  233. - new upstream release
  234. - add BuildRequires: doxygen, qt-devel
  235. - add new sub-packages:
  236. - gtk: GTK IM module (obsoletes: %%{name} <= 0.1.7)
  237. - qt: Qt IM module
  238. * Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.7-0vl1
  239. - new upstream release
  240. - add documents
  241. - running gtk-query-immodules-2.0 in post and postun scripts
  242. - add PreReq: gtk2 > 2.2
  243. * Fri Apr 21 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.6-0vl1
  244. - new upstream release
  245. * Thu Apr 6 2006 IWAI, Masaharu <iwai@alib.jp> 0.1.4-0vl1
  246. - initial release