python-numeric-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. %define name python-numeric
  2. %define version 24.2
  3. %define release 2%{?_dist_release}
  4. Summary: Numerical Extension to Python
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. License: Python
  9. URL: http://numpy.sourceforge.net
  10. Group: Development/Languages
  11. Source0: Numeric-%{version}.tar.gz
  12. Source1: numpy.pdf.bz2
  13. Patch: Numeric-23.7-blasfix.patch
  14. Requires: python
  15. BuildRequires: python-devel >= 2.6
  16. Buildroot: %{_tmppath}/%{name}-%{version}-root
  17. %description
  18. A collection of extension modules to provide high-performance multidimensional
  19. numeric arrays to the Python programming language.
  20. %package devel
  21. Summary: Development files for Python numerical facilities
  22. Group: Development/Libraries
  23. Requires: %{name} = %{version}-%{release}
  24. %description devel
  25. A collection of extension modules to provide high-performance multidimensional
  26. numeric arrays to the Python programming language.
  27. Devel files
  28. %prep
  29. %setup -q -n Numeric-%{version}
  30. #patch -p1 -b .blasfix
  31. cp %{SOURCE1} .
  32. bunzip2 numpy.pdf.bz2
  33. %build
  34. env CFLAGS="$RPM_OPT_FLAGS" /usr/bin/python setup.py build
  35. #python setup.py build
  36. #for Package in FFT LALITE MA RANLIB RNG; do
  37. # (cd Packages/$Package; python setup.py build)
  38. #done
  39. %install
  40. rm -rf $RPM_BUILD_ROOT
  41. python setup.py install --root=$RPM_BUILD_ROOT
  42. #for Package in FFT LALITE MA RANLIB RNG; do
  43. # (cd Packages/$Package; python setup.py install --root=%{buildroot})
  44. #done
  45. %clean
  46. rm -rf %{buildroot}
  47. %files
  48. %defattr(-, root, root)
  49. %doc MANIFEST README Demo numpy.pdf
  50. %{_libdir}/python*/site-packages/Numeric
  51. %{_libdir}/python*/site-packages/Numeric.pth
  52. %files devel
  53. %defattr(-, root, root)
  54. %{_includedir}/python*/Numeric
  55. %changelog
  56. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 24.2-2
  57. - build for python-2.6
  58. * Sun Jul 20 2008 Shu KONNO <owa@bg.wakwak.com> 24.2-1vl5
  59. - rebuilt with python-2.5.2
  60. - applied new versioning policy
  61. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 24.2-0vl2
  62. - rebuilt for VineSeed
  63. * Sun Jun 3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 24.2-0vl1
  64. - new upstream release
  65. * Thu Nov 16 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 23.7-1vl3
  66. - added Requires: %{name} = %{version}-%{release} to devel package
  67. * Sun Jun 18 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 23.7-1vl2
  68. - rebuild with python-2.4.3
  69. - changed Group of devel package
  70. * Thu Apr 7 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 23.7-1vl0.1
  71. - rebuild for Vine Plus/3.0
  72. * Mon Apr 4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 23.7-1vl1
  73. - build with python-2.4
  74. - s/Copyright/License/
  75. - updated URL:
  76. - added Patch from Fedora Core
  77. * Fri Feb 1 2002 Jun Nishii <jun@vinelinux.org> 17.2.0-0vl1
  78. - downgrade to make with python-1.5.x
  79. * Fri Jan 25 2002 Lenny Cartier <lenny@mandrakesoft.com> 20.3-2mdk
  80. - fix permission on source files
  81. * Fri Jan 11 2002 Lenny Cartier <lenny@mandrakesoft.com> 20.3-1mdk
  82. - updated by RA <> 20.3-1mdk :
  83. - update
  84. - fixed doc file name
  85. * Fri Sep 28 2001 RA <ralf_ahlbrink@web.de> 20.2.1-1mdk
  86. - Release 20.2.1
  87. - new docs
  88. * Mon Aug 20 2001 Frederic Crozat <fcrozat@mandrakesoft.com> 20.1.0-1mdk
  89. - Release 20.1.0
  90. * Mon Jul 30 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.3.0-4mdk
  91. - rebuild
  92. * Tue Apr 03 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.3.0-3mdk
  93. - remove patch condition if LAPACK/BLAS is present (thx G.Vermeulen)
  94. * Sat Mar 17 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.3.0-2mdk
  95. - split package
  96. * Thu Feb 22 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.3.0-1mdk
  97. - updated to 17.3.0
  98. - used patches from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
  99. * Mon Feb 12 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.2.0-1mdk
  100. - used srpm from Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr>
  101. - updated to 17.2.0
  102. * Mon Jan 15 2001 Lenny Cartier <lenny@mandrakesoft.com> 17.0-1mdk
  103. - new in contribs
  104. * Fri Oct 27 2000 Gerard Vermeulen <gvermeul@labs.polycnrs-gre.fr> 17.1.1-1gv
  105. - CVS-source sucked on Oct 27 2000
  106. - fix: depends on '#include "Numeric/arrayobject.h"' being installed
  107. - fix: Fortran LAPACK/BLAS
  108. - FIXME: Gist?