python-django-vl.spec 2.4 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. Summary: A high-level Python Web framework
  2. Summary(ja): Python の高度なウェブフレームワーク
  3. Name: python-django
  4. Version: 1.1.1
  5. Release: 2%{?_dist_release}
  6. Group: Development/Languages
  7. BuildArch: noarch
  8. License: BSD
  9. URL: http://www.djangoproject.com/
  10. Source0: Django-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. Packager: <owa>
  15. %description
  16. Django is a high-level Python Web framework that encourages rapid
  17. development and a clean, pragmatic design. It focuses on automating as
  18. much as possible and adhering to the DRY (Don't Repeat Yourself)
  19. principle.
  20. %description -l ja
  21. Django はハイレベルな Python Web フレームワークであり、素早い開発と
  22. クリーンで実用的な設計を勧めています。Django は可能な限りの自動化と
  23. 無駄な繰返しを徹底的に排除することに注目しています。
  24. %package docs
  25. Summary: Documentation for Django
  26. Group: Documentation
  27. Requires: %{name} = %{version}-%{release}
  28. %description docs
  29. This package contains the documentation for the Django high-level
  30. Python Web framework.
  31. %prep
  32. %setup -q -n Django-%{version}
  33. %build
  34. %{__python} setup.py build
  35. %install
  36. rm -rf $RPM_BUILD_ROOT
  37. %{__python} setup.py install --skip-build --root $RPM_BUILD_ROOT
  38. # Documentation
  39. mkdir -p $RPM_BUILD_ROOT%{_datadir}/%{name}
  40. chmod +x examples/manage.py
  41. mv examples $RPM_BUILD_ROOT%{_datadir}/%{name}/
  42. # Permission fixes
  43. pushd $RPM_BUILD_ROOT%{python_sitelib}/django
  44. chmod +x conf/project_template/manage.py
  45. chmod +x bin/compile-messages.py
  46. chmod +x bin/daily_cleanup.py
  47. chmod +x bin/django-admin.py
  48. chmod +x bin/make-messages.py
  49. chmod +x bin/unique-messages.py
  50. popd
  51. %clean
  52. rm -rf $RPM_BUILD_ROOT
  53. %files
  54. %defattr(-,root,root,-)
  55. %doc AUTHORS LICENSE README
  56. %{_bindir}/django-admin.py
  57. %{python_sitelib}/django
  58. %{python_sitelib}/Django-%{version}-py%{pyver}.egg-info
  59. %files docs
  60. %defattr(-,root,root,-)
  61. %doc docs/*
  62. %{_datadir}/%{name}
  63. %changelog
  64. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.1-2
  65. - rebuild with python-2.6
  66. * Sun Oct 18 2009 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1
  67. - updated Django to 1.1.1
  68. * Fri Jul 31 2009 Shu KONNO <owa@bg.wakwak.com> 1.1-1
  69. - updated Django to 1.1
  70. - added japanese description
  71. * Fri Nov 28 2008 Shu KONNO <owa@bg.wakwak.com> 1.0.2-1vl5
  72. - updated Django to 1.0.2-final
  73. * Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.0-1vl5
  74. - packaged new