pygtk2-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273
  1. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  2. %define buildglade %(pkg-config libglade-2.0 && echo 1 || echo 0)
  3. %define pyver %(python -c 'import sys;print(sys.version[0:3])')
  4. Summary: Python bindings for the GTK+ widget set.
  5. Summary(ja): GTK+ ウィジットセットの Python 実装
  6. Name: pygtk2
  7. Version: 2.17.0
  8. Release: 1%{?_dist_release}
  9. License: LGPL (version 2.1)
  10. Group: Development/Languages
  11. Source: ftp://ftp.gnome.org/pub/GNOME/sources/pygtk/2.17/pygtk-%{version}.tar.bz2
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. Requires: pygobject
  14. Requires: pycairo
  15. Requires: python-numeric
  16. Buildrequires: python-devel >= 2.5
  17. Buildrequires: libglade2-devel >= 2.5.0
  18. BuildRequires: gtk2-devel >= 2.16.0
  19. BuildRequires: pygobject-devel >= 2.16.0
  20. BuildRequires: pycairo-devel >= 1.8.2
  21. BuildRequires: python-numeric
  22. BuildRequires: docbook-style-xsl
  23. BuildRequires: libxslt
  24. Buildrequires: automake >= 1.6.3-5
  25. Obsoletes: pygtk
  26. %description
  27. PyGTK is an extension module for python that gives you access to the GTK+
  28. widget set. Just about anything you can write in C with GTK+ you can write
  29. in python with PyGTK (within reason), but with all the benefits of python.
  30. %description -l ja
  31. PyGTK は GTK+ ウィジットセットへアクセス可能にする python の拡張モジュール
  32. です。 C で GTK+ を使用して書けることは、大概 python で PyGTK を利用して書
  33. けます。 python のおかげでもあります。
  34. %package libglade
  35. Summary: A wrapper for the libglade library for use with PyGTK
  36. Summary(ja): PyGTK を利用するための libglade ライブラリのラッパ
  37. Group: Development/Libraries
  38. Requires: pygtk2 = %{version}
  39. %description libglade
  40. This module contains a wrapper for the libglade library. Libglade allows
  41. a program to construct its user interface from an XML description, which
  42. allows the programmer to keep the UI and program logic separate.
  43. %description -l ja libglade
  44. このモジュールは libglade ライブラリのためのラッパを含んでいます。libglade は
  45. プログラムのユーザインタフェースを XML 記述で構成することを可能にします。この
  46. ためプログラマは、プログラムの UI とロジックを分離させておくことができます。
  47. %package devel
  48. Summary: files needed to build wrappers for GTK+ addon libraries
  49. Summary(ja): GTK+ の追加ライブラリのラッパ作成に必要なファイル
  50. Group: Development/Libraries
  51. Requires: pygtk2 = %{version}
  52. Requires: pygobject-devel >= 2.12.0
  53. %description devel
  54. This package contains files required to build wrappers for GTK+ addon
  55. libraries so that they interoperate with pygtk.
  56. %description -l ja devel
  57. このパッケージには GTK+ の追加ライブラリのラッパを作るために必要なファイルを含
  58. みます。これらは PyGTK との仲介をします。
  59. %prep
  60. %setup -q -n pygtk-%{version}
  61. %build
  62. [ -x /usr/bin/python%{pyver} ] && export PYTHON=/usr/bin/python%{pyver}
  63. #aclocal && automake && autoconf
  64. %configure --enable-thread --enable-numpy
  65. export tagname=CC
  66. make LIBTOOL=/usr/bin/libtool
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. export tagname=CC
  70. make LIBTOOL=/usr/bin/libtool DESTDIR=$RPM_BUILD_ROOT install
  71. find $RPM_BUILD_ROOT -name '*.la' -or -name '*.a' -exec rm {} \;
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %files
  75. %defattr(-,root,root)
  76. %doc AUTHORS NEWS README MAPPING ChangeLog
  77. %doc examples
  78. %defattr(644, root, root, 755)
  79. %dir %{python_sitearch}/gtk-2.0
  80. %dir %{python_sitearch}/gtk-2.0/gtk
  81. %{python_sitearch}/gtk-2.0/gtk/*.py*
  82. %dir %{_libdir}/pygtk
  83. %dir %{_libdir}/pygtk/2.0
  84. %{_libdir}/pygtk/2.0/*
  85. %defattr(755, root, root, 755)
  86. %{_bindir}/pygtk-demo
  87. %{python_sitearch}/gtk-2.0/atk.so
  88. %{python_sitearch}/gtk-2.0/pango.so
  89. %{python_sitearch}/gtk-2.0/gtk/_gtk.so
  90. %{python_sitearch}/gtk-2.0/gtkunixprint.so
  91. %{python_sitearch}/gtk-2.0/pangocairo.so
  92. %if %{buildglade}
  93. %files libglade
  94. %defattr(755, root, root, 755)
  95. %{_libdir}/python?.?/site-packages/gtk-2.0/gtk/glade.so
  96. %endif
  97. %files devel
  98. %defattr(644, root, root, 755)
  99. %dir %{_includedir}/pygtk-2.0
  100. %dir %{_includedir}/pygtk-2.0/pygtk
  101. %{_includedir}/pygtk-2.0/pygtk/*.h
  102. %{_libdir}/pkgconfig/pygtk-2.0.pc
  103. %dir %{_datadir}/pygtk
  104. %dir %{_datadir}/pygtk/2.0
  105. %dir %{_datadir}/pygtk/2.0/defs
  106. %{_datadir}/pygtk/2.0/defs/*.defs
  107. %{_datadir}/pygtk/2.0/defs/pangocairo.override
  108. %{_datadir}/gtk-doc/html/pygtk
  109. %defattr(755, root, root, 755)
  110. %{_bindir}/pygtk-codegen-2.0
  111. %changelog
  112. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
  113. - new upstream release
  114. * Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
  115. - new upstream release
  116. - rebuild with python-2.6
  117. * Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-1
  118. - new upstream release
  119. * Fri Jul 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.12.1-2vl5
  120. - rebuilt with python-2.5.2
  121. * Sat Mar 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-1vl5
  122. - rebuilt with python-2.4.5
  123. - used %%{?_dist_release} macro
  124. * Fri Jan 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-0vl1
  125. - new upstream release
  126. * Sun Nov 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.0-0vl1
  127. - new upstream release
  128. * Sat Jul 7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.5-0vl1
  129. - new upstream release
  130. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.4-0vl2
  131. - added Requires pygobject-devel to devel package
  132. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.4-0vl1
  133. - new upstream release
  134. - add Requires/BuildRequires pygobject,pycairo
  135. * Thu Jun 22 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl1
  136. - new upstream release 2.8.6
  137. * Fri Jan 13 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.4-0vl1
  138. - new upstream release 2.8.4
  139. - added japanese summary and description
  140. * Tue Oct 18 2005 Shu KONNO <owa@bg.wakwak.com> 2.8.2-0vl1
  141. - new upstream release 2.8.2
  142. * Sat Oct 8 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.1-0vl1
  143. - new upstream release 2.8.1
  144. - added %clean sectioin
  145. * Sat Sep 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.0-0vl1
  146. - new upstream release 2.8.0
  147. * Mon Apr 04 2005 Shu KONNO <owa@bg.wakwak.com> 2.6.1-0vl1
  148. - new upstream release 2.6.1
  149. * Sun Apr 03 2005 Shu KONNO <owa@bg.wakwak.com> 2.4.1-0vl2
  150. - rebuild with python-2.4.1-0vl1
  151. * Sun Dec 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  152. - new upstream release
  153. * Sat Jun 12 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.0-1vl1
  154. - updated to 2.2.0
  155. * Sat Apr 17 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl4
  156. - rebuild with python-2.3.3-0vl1
  157. * Sat Apr 10 2004 Shu KONNO <owa@bg.wakwak.com> 2.0.0-1vl3.1
  158. - rebuild with python-2.3.3-0vl0.3 (for TestPkg)
  159. * Thu Sep 18 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-1vl3
  160. - added missing %%defattr
  161. * Wed Sep 17 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.0.0-1vl2
  162. - added Provides and Obsoletes pygtk
  163. * Sun Sep 16 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0.0-1vl1
  164. - new upstream release (based on Redhat Rawhide 2.0.0-1)
  165. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 1.99.16-10
  166. - Fix libtool
  167. * Fri Jul 18 2003 Jeremy Katz <katzj@redhat.com> 1.99.16-8
  168. - part of the fixnew patch wasn't applied upstream, apply it (#99400)
  169. * Thu Jan 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.99.14-0vl1
  170. - new upstream release
  171. - build for Vine Linux
  172. * Thu Oct 31 2002 Matt Wilson <msw@redhat.com>
  173. - rebuild for multilib
  174. - use %%configure
  175. * Fri Aug 30 2002 Matt Wilson <msw@redhat.com>
  176. - fix pixbuf leaks (#72137)
  177. - five more pixbuf leaks plugged
  178. * Wed Aug 28 2002 Jonathan Blandford <jrb@redhat.com>
  179. - remover Packager tag
  180. * Tue Aug 27 2002 Jonathan Blandford <jrb@redhat.com>
  181. - add binding for gdk_atom_intern
  182. * Mon Jul 29 2002 Matt Wilson <msw@redhat.com>
  183. - 0.99.12
  184. * Wed Jul 17 2002 Matt Wilson <msw@redhat.com>
  185. - new version from CVS
  186. * Thu Jun 27 2002 Tim Waugh <twaugh@redhat.com>
  187. - Fix bug #65770.
  188. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  189. - automated rebuild
  190. * Mon Jun 17 2002 Matt Wilson <msw@redhat.com>
  191. - new version from CVS
  192. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  193. - automated rebuild
  194. * Wed May 22 2002 Jeremy Katz <katzj@redhat.com>
  195. - 1.99.10
  196. * Wed Feb 27 2002 Matt Wilson <msw@redhat.com>
  197. - 1.99.8
  198. * Mon Jan 28 2002 Matt Wilson <msw@redhat.com>
  199. - added atkmodule.so to file list
  200. * Thu Oct 18 2001 Matt Wilson <msw@redhat.com>
  201. - fix devel filelist to match new header location
  202. * Mon Oct 15 2001 Matt Wilson <msw@redhat.com>
  203. - get the headers from their new version-specific location
  204. * Thu Oct 11 2001 Matt Wilson <msw@redhat.com>
  205. - fixed typo in devel filelist
  206. - added macro that tests to see if we have libglade2, make the
  207. filelist a condition of that
  208. - changed name to 'pygtk2' to avoid name conflict with pygtk