kdevplatform-vl.spec 4.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177
  1. Name: kdevplatform
  2. Summary: Libraries for use by KDE development tools
  3. Version: 1.0.0
  4. Release: 3%{?_dist_release}
  5. Group: Development/Tools
  6. License: GPLv2
  7. URL: http://www.kde.org/
  8. Source0: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.0.0/src/kdevplatform-%{version}.tar.bz2
  9. Source1: ftp://ftp.kde.org/pub/kde/stable/kdevelop/4.0.0/src/kdevplatform-%{version}.tar.bz2.md5sum
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. BuildRequires: libboost-devel
  12. BuildRequires: gettext
  13. BuildRequires: kdelibs4-devel
  14. # ?? kompare support seems disabled
  15. BuildRequires: kdesdk-devel >= 4.4
  16. BuildRequires: pcre-devel
  17. BuildRequires: subversion-devel
  18. BuildRequires: apr-util-devel
  19. Requires: %{name}-libs = %{version}-%{release}
  20. Requires(postun): gtk2
  21. Requires(posttrans): gtk2
  22. %description
  23. KDE Development platform, the foundations upon which
  24. KDevelop and Quanta are built.
  25. %package libs
  26. Summary: Runtime libraries for %{name}
  27. Group: System Environment/Libraries
  28. Requires: kdelibs4
  29. %description libs
  30. %{summary}.
  31. %package devel
  32. Group: Development/Libraries
  33. Summary: Developer files for %{name}
  34. Requires: %{name}-libs = %{version}-%{release}
  35. Requires: libboost-devel
  36. Requires: commoncpp2-devel
  37. Requires: kdelibs4-devel
  38. Requires: subversion-devel
  39. %description devel
  40. %{summary}.
  41. %prep
  42. %setup -q -n kdevplatform-%{version}
  43. %build
  44. mkdir -p %{_target_platform}
  45. pushd %{_target_platform}
  46. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  47. %cmake \
  48. -DCMAKE_BUILD_TYPE=release \
  49. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  50. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  51. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  52. -DLIB_INSTALL_DIR:PATH=%{_libdir} \
  53. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  54. -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \
  55. ..
  56. popd
  57. make %{?_smp_mflags} -C %{_target_platform}
  58. %install
  59. rm -rf %{buildroot}
  60. make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
  61. %find_lang %{name} --all-name --with-kde
  62. %clean
  63. rm -rf %{buildroot}
  64. %post
  65. touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
  66. %post libs -p /sbin/ldconfig
  67. %postun
  68. if [ $1 -eq 0 ] ; then
  69. touch --no-create %{_datadir}/icons/hicolor &>/dev/null
  70. gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
  71. fi
  72. %postun libs -p /sbin/ldconfig
  73. %posttrans
  74. gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null || :
  75. %files -f %{name}.lang
  76. %defattr(-,root,root,-)
  77. %doc COPYING.PLUGINS COPYING.SRC
  78. %{_datadir}/kde4/apps/kdev*/
  79. %{_datadir}/kde4/services/*.desktop
  80. %{_datadir}/kde4/servicetypes/*.desktop
  81. %{_datadir}/icons/hicolor/*/*/*
  82. %files libs
  83. %defattr(-,root,root,-)
  84. %{_libdir}/lib*.so.*
  85. %{_libdir}/kde4/*.so
  86. %files devel
  87. %defattr(-,root,root,-)
  88. %{_libdir}/lib*.so
  89. %{_includedir}/kde4/kdevplatform/
  90. %{_libdir}/cmake/kdevplatform/
  91. %changelog
  92. * Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-3
  93. - removed R: kdevplatform from libs package
  94. * Sat May 8 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.0.0-2
  95. - Initial build for Vine Linux
  96. * Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 1.0.0-1
  97. - kdevplatform-1.0.0
  98. * Sat Apr 17 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.10.2-1
  99. - kdevplatform-0.10.2
  100. * Thu Apr 08 2010 Rex Dieter <rdieter@fedoraproject.org. - 0.10.0-1
  101. - kdevplatform-0.10.0
  102. * Mon Mar 08 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.99-1
  103. - kdevplatform-0.9.99
  104. * Mon Feb 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.98-1
  105. - kdevplatform-0.9.98
  106. * Sat Jan 16 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.9.97-2
  107. - rebuild (boost)
  108. - BR: kdelibs4-devel
  109. * Thu Jan 07 2010 Rex Dieter <rdieter@fedoraproject.org> 0.9.97-1
  110. - kdevplatform-0.9.97
  111. - kdevplatform: file conflict with kdelibs (FindKDevPlatform.cmake) (#541690)
  112. * Sun Nov 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.95-0.6.20091015svn1035382
  113. - rebuild (fc13+, qt-4.6.0-rc1)
  114. * Thu Oct 15 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.5.20091015svn1035382
  115. - New snapshot
  116. * Sun Oct 11 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.4.beta5
  117. - Fix finding Kompare includes
  118. * Tue Sep 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.3.beta5
  119. - Use official release
  120. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.2
  121. - Add icon scriptlets
  122. * Mon Sep 14 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.95-0.1
  123. - Update tarball
  124. * Fri May 29 2009 Ben Boeckel <MathStuf@gmail.com> - 0.9.93-0.1
  125. - 1.0 Beta 3
  126. * Sat Feb 21 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.91-0.2.20090221svn929301
  127. - Post KDevplatform 1.0 Beta 1 snapshot
  128. * Fri Jan 09 2009 Lorenzo Villani <lvillani@binaryhelix.net> - 0.9.85-1
  129. - 0.9.85 snapshot