123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331 |
- %define srcname gstreamer
- %define _glib2 2.4.7
- %define _libxml2 2.6.15
- ## exclude arches that don't work for now.
- #ExcludeArch: x86_64 ia64 alpha s390 s390x
- Name: gstreamer08
- Version: 0.8.12
- # keep in sync with the VERSION. gstreamer can append a .0.1 to CVS snapshots.
- %define major 0.8
- Release: 2%{?_dist_release}
- Summary: GStreamer streaming media framework runtime.
- Summary(ja): GStreamer ストリーミングメディアフレームワークランタイム
- Group: System Environment/Libraries
- License: LGPL
- URL: http://gstreamer.net/
- Source:http://gstreamer.freedesktop.org/src/gstreamer/%{srcname}-%{version}.tar.bz2
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- # alpha
- Patch10: gstreamer-0.6.3-alpha-noWerror.patch
- %define po_package %{srcname}-%{major}
- Requires: glib2 >= %_glib2
- Requires: libxml2 >= %_libxml2
- Requires: popt > 1.6
- BuildRequires: glib2-devel >= %_glib2
- BuildRequires: libxml2-devel >= %_libxml2
- BuildRequires: bison
- BuildRequires: gtk-doc >= 1.1
- BuildRequires: zlib-devel
- BuildRequires: popt-devel > 1.6
- BuildRequires: flex
- BuildRequires: ghostscript
- Obsoletes: gstreamer-tools
- Conflicts: gstreamer < 0.9
- ### documentation requirements
- # documentaion build don't work well on 0.8.9
- # so, disabled following dependency
- #BuildRequires: openjade
- #BuildRequires: docbook-style-dsssl docbook-dtd31-sgml docbook-style-xsl
- #BuildRequires: docbook-utils
- #BuildRequires: transfig xfig
- %description
- GStreamer is a streaming-media framework, based on graphs of filters which
- operate on media data. Applications using this library can do anything
- from real-time sound processing to playing videos, and just about anything
- else media-related. Its plugin-based architecture means that new data
- types or processing capabilities can be added simply by installing new
- plugins.
- %package devel
- Summary: Libraries/include files for GStreamer streaming media framework.
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- Requires: glib2-devel >= %_glib2
- Requires: libxml2-devel >= %_libxml2
- %description devel
- GStreamer is a streaming-media framework, based on graphs of filters which
- operate on media data. Applications using this library can do anything
- from real-time sound processing to playing videos, and just about anything
- else media-related. Its plugin-based architecture means that new data
- types or processing capabilities can be added simply by installing new
- plugins.
- This package contains the libraries and includes files necessary to develop
- applications and plugins for GStreamer.
- %prep
- %setup -q -n %{srcname}-%{version}
- %ifarch alpha
- %patch10 -p1
- %endif
- %build
- %configure \
- --with-cachedir=%{_var}/cache/gstreamer-%{major} \
- --with-configdir=/etc/gstreamer \
- --disable-plugin-builddir \
- --disable-tests --disable-examples \
- --disable-docs-build \
- --disable-static \
- --with-html-dir=$RPM_BUILD_ROOT%{_datadir}/gtk-doc/html \
- --disable-debug
- make %{?_smp_mflags}
- %install
- [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
- %makeinstall
- mkdir -p $RPM_BUILD_ROOT%{_var}/cache/gstreamer-%{major}
- /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.a
- /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/gstreamer-%{major}/*.la
- /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
- /bin/rm -f $RPM_BUILD_ROOT%{_libdir}/libgstmedia-info*.so.0.0.0
- %find_lang %{po_package}
- # remove gst-* provided by newer gstreamer
- for i in complete compprep feedback inspect launch md5sum register typefind xmlinspect xmllaunch ; do
- %__rm -f %{buildroot}%{_bindir}/gst-$i
- done
- %clean
- [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
- %post
- /sbin/ldconfig
- env DISPLAY= %{_bindir}/gst-register-%{major} > /dev/null 2> /dev/null
- %postun -p /sbin/ldconfig
- %files -f %{po_package}.lang
- %defattr(-, root, root)
- %doc AUTHORS ChangeLog COPYING README NEWS
- %doc TODO ABOUT-NLS REQUIREMENTS DOCBUILDING
- %{_bindir}/*
- %dir %{_libdir}/gstreamer-%{major}
- %{_libdir}/gstreamer-%{major}/*.so*
- %{_libdir}/*.so.*
- %{_mandir}/man1/*
- %dir %{_var}/cache/gstreamer-%{major}
- %files devel
- %defattr(-, root, root)
- %dir %{_includedir}/%{srcname}-%{major}
- %{_includedir}/%{srcname}-%{major}/*
- #{_libdir}/*.a
- %{_libdir}/*.so
- %{_libdir}/pkgconfig/gstreamer*.pc
- %{_datadir}/aclocal/*.m4
- %changelog
- * Tue May 5 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-2
- - removed lib*.a files
- - changed Group to System Environment/Libraries
- * Wed Sep 24 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.12-1
- - new upstream release
- - applied new versioning policy
- - spec in UTF-8
- * Fri Jan 20 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl3
- - fix typo
- - add Conflicts: gstreamer < 0.9
- * Mon Jan 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl2
- - build for compatibility (gstreamer->gstreamer08)
- - remove %%{_bindir}/gst-* provided by newer gstreamer
- * Fri Nov 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.8.11-0vl1
- - new upstream release
- * Thu May 5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.10-0vl1
- - new upstream release
- * Thu Feb 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.8.9-0vl1
- - new upstream release
- - removed dependancy related to documentaion build
- * Wed Nov 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.7-0vl1
- - new upstream release
- * Tue Dec 09 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.6.4-0vl1
- - new upstream release
- * Sat Sep 06 2003 Tomoya TAKA <taka@vinelinux.org> 0.6.3-0vl2
- - update alpha-noWerror patch (Patch10)
- * Thu Sep 04 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-0vl1
- - new upstream release
- * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.2-0vl1
- - new upstream release
- * Sat Feb 22 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.0-0vl1
- - new upstream release
- * Sat Feb 01 2003 Tomoya TAKA <taka@vinelinux.org> 0.5.2-0vl2
- - build without -Werror on alpha (Patch10)
- * Fri Jan 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
- - new upstream release
- * Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl3
- - merge gstreamer-tools into gstreamer, obsoletes gstreamer-tools
- * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
- - fix broken %files entries..
- * Sun Jan 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
- - new upstream release
- * Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.0-10vl1
- - build for Vine Linux
- * Thu Dec 19 2002 Elliot Lee <sopwith@redhat.com> 0.5.0-10
- - Add patch1 to fix C++ plugins on ia64
- * Wed Dec 18 2002 Jonathan Blandford <jrb@redhat.com>
- - %post -p was wrong
- * Tue Dec 17 2002 Jonathan Blandford <jrb@redhat.com> 0.5.0-7
- - explicitly add %{_libdir}/libgstreamer-{major}.so
- - explicitly add %{_libdir}/libgstcontrol-{major}.so
- * Mon Dec 16 2002 Jonathan Blandford <jrb@redhat.com>
- - bump release
- * Fri Dec 13 2002 Jonathan Blandford <jrb@redhat.com>
- - move .so files out of -devel
- * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
- - new version 0.5.0
- - require docbook-style-xsl
- - add gstreamer-tools package too
- - New patch to use the right docbook prefix.
- * Tue Dec 10 2002 Jonathan Blandford <jrb@redhat.com>
- - downgrade to a release candidate. Should work better on other arches
- - build without Werror
- * Mon Dec 9 2002 Jonathan Blandford <jrb@redhat.com>
- - update to new version. Remove ExcludeArch
- * Tue Dec 3 2002 Havoc Pennington <hp@redhat.com>
- - excludearch some arches
- * Mon Dec 2 2002 Havoc Pennington <hp@redhat.com>
- - import into CVS and build "officially"
- - use smp_mflags
- - temporarily disable docs build, doesn't seem to work
- * Thu Nov 7 2002 Jeremy Katz <katzj@redhat.com>
- - 0.4.2
- * Mon Sep 23 2002 Jeremy Katz <katzj@redhat.com>
- - 0.4.1
- * Sun Sep 22 2002 Jeremy Katz <katzj@redhat.com>
- - minor cleanups
- * Sat Jun 22 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - moved header location
- * Mon Jun 17 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - added popt
- - removed .la
- * Fri Jun 07 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - added release of gstreamer to req of gstreamer-devel
- - changed location of API docs to be in gtk-doc like other gtk-doc stuff
- - reordered SPEC file
- * Mon Apr 29 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - moved html docs to gtk-doc standard directory
- * Tue Mar 5 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - move version defines of glib2 and libxml2 to configure.ac
- - add BuildRequires for these two libs
- * Sun Mar 3 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - put html docs in canonical place, avoiding %doc erasure
- - added devhelp support, current install of it is hackish
- * Sat Mar 2 2002 Christian Schaller <Uraeus@linuxrising.org>
- - Added documentation to build
- * Mon Feb 11 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - added libgstbasicscheduler
- - renamed libgst to libgstreamer
- * Fri Jan 04 2002 Christian Schaller <Uraeus@linuxrising.org>
- - Added configdir parameter as it seems the configdir gets weird otherwise
- * Thu Jan 03 2002 Thomas Vander Stichele <thomas@apestaart.org>
- - split off gstreamer-editor from core
- - removed gstreamer-gnome-apps
- * Sat Dec 29 2001 Rodney Dawes <dobey@free.fr>
- - Cleaned up the spec file for the gstreamer core/plug-ins split
- - Improve spec file
- * Sat Dec 15 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Split of more plugins from the core and put them into their own modules
- - Includes colorspace, xfree and wav
- - Improved package Require lines
- - Added mp3encode (lame based) to the SPEC
- * Wed Dec 12 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Thomas merged mpeg plugins into one
- * Sat Dec 08 2001 Christian Schaller <Uraeus@linuxrising.org>
- - More minor cleanups including some fixed descriptions from Andrew Mitchell
- * Fri Dec 07 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Added logging to the make statement
- * Wed Dec 05 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Updated in preparation for 0.3.0 release
- * Fri Jun 29 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Updated for 0.2.1 release
- - Split out the GUI packages into their own RPM
- - added new plugins (FLAC, festival, quicktime etc.)
- * Sat Jun 09 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Visualisation plugins bundled out togheter
- - Moved files sections up close to their respective descriptions
- * Sat Jun 02 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Split the package into separate RPMS,
- putting most plugins out by themselves.
- * Fri Jun 01 2001 Christian Schaller <Uraeus@linuxrising.org>
- - Updated with change suggestions from Dennis Bjorklund
- * Tue Jan 09 2001 Erik Walthinsen <omega@cse.ogi.edu>
- - updated to build -devel package as well
- * Sun Jan 30 2000 Erik Walthinsen <omega@cse.ogi.edu>
- - first draft of spec file
|