grub-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184
  1. %ifarch %{ix86}
  2. %define _host_cpu i386
  3. %else
  4. %define _host_cpu %{_arch}
  5. %endif
  6. %define defshell defaultmenu.sh
  7. Summary: grub - a Multiboot boot loader.
  8. Summary(ja): grub - マルチブートローダ
  9. Name: grub
  10. Version: 0.97
  11. Release: 2%{?_dist_release}
  12. License: GPL
  13. Group: System Environment/Base
  14. URL: http://www.gnu.org/software/grub/
  15. Source0: ftp://alpha.gnu.org/gnu/grub/%{name}-%{version}.tar.gz
  16. Source1: %{defshell}
  17. Patch10: grub-0.97-prototypes.patch
  18. Patch100: ext3_256byte_inode.diff
  19. ExclusiveArch: %{ix86} x86_64
  20. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  21. PreReq: install-info, sed, grep
  22. Requires: mktemp
  23. BuildRequires: ncurses-devel
  24. %ifarch x86_64
  25. BuildRequires: compat32-glibc-devel
  26. %endif
  27. %description
  28. GNU GRUB is a Multiboot boot loader.
  29. It was derived from GRUB, GRand Unified Bootloader, which was
  30. originally designed and implemented by Erich Stefan Boleyn.
  31. Briefly, bootloader is the first software program that runs when
  32. a computer starts. It is responsible for loading and transferring
  33. control to the operating system kernel software (such as the Hurd
  34. or the Linux). The kernel, in turn, initializes the rest of the
  35. operating system (usually GNU).
  36. %description -l ja
  37. GNU GRUB はマルチブートローダです。
  38. この名前は GRand Unified Bootloader (壮大な 統一されたブート
  39. ローダ) に由来し、元来は Erich Stefan Boleyn によって、設計・
  40. 実装されたものです。
  41. 手短に言えば、ブートローダとはコンピュータが起動する際に最初
  42. に実行されるプログラムで、(Hurd や Linux のような) オペレー
  43. ティングシステムのカーネルをディスクから読み込んで制御を渡す
  44. 作業を担当します。カーネルは、それを受けて、オペレーティング
  45. システムの他の部分 (通常は GNU) を初期化します。
  46. %prep
  47. %setup -q
  48. %patch10 -p1 -b .prototypes
  49. %patch100 -p1 -b .ext3_256byte_inode
  50. %build
  51. GCCVERS=$(gcc --version | head -1 | cut -d\ -f3 | cut -d. -f1)
  52. CFLAGS="-Os"
  53. if [ "$GCCVERS" == "4" ]; then
  54. CFLAGS="$CFLAGS -Wno-pointer-sign"
  55. fi
  56. %ifarch x86_64
  57. CFLAGS="$CFLAGS -static"
  58. %endif
  59. export CFLAGS
  60. %configure --disable-auto-linux-mem-opt
  61. %__make
  62. %install
  63. rm -rf $RPM_BUILD_ROOT
  64. %makeinstall
  65. %{__install} -p -m 644 docs/menu.lst %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
  66. %{__install} -p -m 744 %{SOURCE1} %{buildroot}%{_libdir}/grub/%{_host_cpu}-%{_target_vendor}
  67. %clean
  68. rm -rf $RPM_BUILD_ROOT
  69. %post
  70. /sbin/install-info %{_infodir}/grub.info.gz %{_infodir}/dir
  71. /sbin/install-info %{_infodir}/multiboot.info.gz %{_infodir}/dir
  72. %{_libdir}/grub/%{_host_cpu}-%{_target_vendor}/%{defshell}
  73. %preun
  74. if [ $1 = 0 ]; then
  75. /sbin/install-info --delete %{_infodir}/grub.info.gz %{_infodir}/dir
  76. /sbin/install-info --delete %{_infodir}/multiboot.info.gz %{_infodir}/dir
  77. fi
  78. %files
  79. %defattr(-,root,root)
  80. %doc COPYING INSTALL README AUTHORS BUGS ChangeLog NEWS THANKS TODO MAINTENANCE
  81. %{_bindir}/*
  82. %{_sbindir}/*
  83. %{_libdir}/grub
  84. %{_infodir}/*.info*
  85. %{_mandir}/man*/*
  86. %changelog
  87. * Wed Jan 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-2
  88. - add patch100 to support newer e2fsprogs
  89. * Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.97-1vl5
  90. - applied new versioning policy, spec in utf-8
  91. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl8
  92. - fix _host_cpu trick
  93. * Tue May 22 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl7
  94. - add x86_64 to ExclusiveArch:
  95. - add BuildRequires: compat32-glibc-devel for x86_64
  96. - add "-static" to CFLAGS for x86_64
  97. - use special CFLAGS
  98. - add Patch10 to run configure with new binutils
  99. * Thu Sep 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.97-0vl6
  100. - add PreReq: grep, sed for defaultmenu.sh
  101. * Tue Sep 5 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl5
  102. - add initrd in menu.lst file created by defaultmenu.sh
  103. * Thu Jun 26 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl4
  104. - fix date of previous changelog entry
  105. - escape macro of past changelog entries
  106. - change Source1: menu.lst.vine to defautmenu.sh
  107. - invoke defaultmenu.sh on %%post scriptlet
  108. * Thu Jun 21 2006 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl3
  109. - remove Requires: ncurses, gpm, bash
  110. * Thu May 12 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.97-0vl2
  111. - upstream release
  112. - add MAINTENANCE to %%doc
  113. - drop Patch0 (merged in upstream source)
  114. * Sun Mar 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl3
  115. - savedefault patch from upstream CVS: http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/stage2/stage2.c.diff?r1=1.45&r2=1.46&diff_format=u
  116. stage2/stage2.c (cmain): Initialize DEFAULT_FILE to an empty
  117. string. Reported by NATORI Shin <natori@adm.s.u-tokyo.ac.jp>.
  118. * Sun Feb 20 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.96-0vl2
  119. - upstream release
  120. - drop Patch0 (merged)
  121. - added sample file /usr/lib/grub/i386-pc/menu.lst.vine
  122. - change installation destination of menu.lst from %%datadir to %%libdir
  123. * Wed Jan 19 2005 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl3
  124. - applied Patch0 from upstream CVS:
  125. http://savannah.gnu.org/cgi-bin/viewcvs/grub/grub/util/grub-install.in.diff?r1=1.46&r2=1.47&diff_format=u
  126. util/grub-install.in (convert): Fix the sed statement for
  127. Linux. The expression was ambigious in some cases.
  128. * Wed Aug 18 2004 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.95-0vl2
  129. - catch up to upstream release
  130. - delete %%_target_platform macro
  131. - delete gzip info files from %%install macro
  132. - add BuildRequires: ncurses-devel
  133. - add Requires: ncurses, gpm, mktemp, bash
  134. - add PreReq: install-info
  135. - %%configure with --disable-auto-linux-mem-opt option
  136. * Thu Jul 12 2001 <sagami@vinelinux.org>
  137. - 0.90-0vl1: %%configure with a trick for _host_cpu, %%makeinstall
  138. * Tue Apr 24 2001 <sagami@vinelinux.org>
  139. - 0.5.96-0vl1: use some macros
  140. * Wed Oct 11 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl2]
  141. - build for Vine 2.1beta
  142. * Tue Oct 10 2000 Yoshihiro Kajiki <kajiki@ylug.org> [0vl1]
  143. - update to 0.5.95 and build for Vine 2.0
  144. - add Japanese summary and description
  145. - based on grub-0.5.94-2, Kondara Zoo
  146. * Sun Jun 4 2000 AYUHANA Tomonori <l@kondara.org>
  147. * /usr/doc/grub-*/menu.lst -> /usr/share/grub/i386-pc/menu.lst
  148. * Thu May 18 2000 AYUHANA Tomonori <l@kondara.org>
  149. - upgrade to 0.5.93.1 to 0.5.94