gnome-phone-manager-vl.spec 7.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. Name: gnome-phone-manager
  2. Summary: Gnome Phone Manager
  3. Summary(ja): Gnome Phone マネージャー
  4. Version: 0.60
  5. Release: 4%{?_dist_release}
  6. License: GPLv2+
  7. Group: Applications/System
  8. Source: http://ftp.gnome.org/pub/GNOME/sources/gnome-phone-manager/%{version}/%{name}-%{version}.tar.bz2
  9. URL: http://usefulinc.com/software/phonemgr/
  10. #----------------------------------------------------------------------------
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. #----------------------------------------------------------------------------
  13. BuildRequires: gtk2-devel
  14. BuildRequires: libgnomeui-devel
  15. BuildRequires: libgnome-devel
  16. BuildRequires: gnome-bluetooth-devel
  17. BuildRequires: libbtctl-devel
  18. BuildRequires: bluez-libs-devel
  19. BuildRequires: gnokii-devel
  20. BuildRequires: gstreamer-devel >= 0.10
  21. BuildRequires: gnome-icon-theme >= 2.19.1
  22. # For libebook (evolution address book)
  23. BuildRequires: evolution-data-server-devel
  24. BuildRequires: gtkspell-devel
  25. BuildRequires: telepathy-glib-devel
  26. # search telepathy
  27. # empathy - GNOME インスタントメッセージクラアイント
  28. # libtelepathy - Telepathy クライアントを簡単に記述するための GLibライブラリ
  29. # libtelepathy-devel - Development files for libtelepathy
  30. # telepathy-filesystem - Telepathy ファイルシステムレイアウト
  31. # telepathy-gabble - Jabber/XMPP 接続マネージャ
  32. # telepathy-glib - Telepathy の GLib バインディング
  33. # telepathy-glib-devel - Development files for telepathy-glib
  34. # telepathy-haze - マルチプロトコル Libpurple 接続マネージャ
  35. # telepathy-mission-control - Central control for Telepathy connection manager
  36. # telepathy-mission-control-devel - Development files for telepathy-mission-control
  37. # telepathy-salut - Link-local XMPP telepathy 接続マネージャ
  38. # telepathy-stream-engine - メディアストリーミングを扱うための Telepathy クライア ント
  39. BuildRequires: perl(XML::Parser)
  40. BuildRequires: gettext
  41. BuildRequires: desktop-file-utils
  42. # https://bugzilla.redhat.com/show_bug.cgi?id=436773
  43. Patch0: gpm-telepathy-workaround.patch
  44. #----------------------------------------------------------------------------
  45. %description
  46. This program will connect to your mobile phone over a serial port,
  47. either via a cable, infrared (IrDA) or Bluetooth connection.
  48. For example it listens for text messages, and when they arrive,
  49. displays them on the desktop. A visual indicator is displayed in
  50. the notification area, if one is presently added to the panel.
  51. #----------------------------------------------------------------------------
  52. %package telepathy
  53. Summary: Telepathy connection manager to send and receive SMSes
  54. Group: Applications/System
  55. %description telepathy
  56. This program will connect to your mobile phone over a serial port,
  57. either via a cable, infrared (IrDA) or Bluetooth connection.
  58. This plugin to Telepathy allows you to send and receive messages using any
  59. Instant Messaging application that uses Telepathy, such as Empathy.
  60. #----------------------------------------------------------------------------
  61. %prep
  62. %setup -q
  63. %patch0 -p0
  64. %build
  65. %configure
  66. make %{?_smp_mflags}
  67. #----------------------------------------------------------------------------
  68. %install
  69. %{__rm} -rf $RPM_BUILD_ROOT
  70. make DESTDIR=$RPM_BUILD_ROOT install
  71. # This should be in empathy instead
  72. install -m0644 -D telepathy/sms.profile $RPM_BUILD_ROOT%{_datadir}/mission-control/profiles/sms.profile
  73. %find_lang %{name}
  74. desktop-file-install \
  75. --delete-original \
  76. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  77. --add-category X-VineLinux \
  78. $RPM_BUILD_ROOT%{_datadir}/applications/gnome-phone-manager.desktop
  79. %post
  80. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  81. gconftool-2 --makefile-install-rule \
  82. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  83. >& /dev/null || :
  84. %pre
  85. if [ "$1" -gt 1 ]; then
  86. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  87. gconftool-2 --makefile-uninstall-rule \
  88. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  89. >& /dev/null || :
  90. fi
  91. %preun
  92. if [ "$1" -eq 0 ]; then
  93. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  94. gconftool-2 --makefile-uninstall-rule \
  95. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas \
  96. >& /dev/null || :
  97. fi
  98. %clean
  99. %{__rm} -rf $RPM_BUILD_ROOT
  100. %files -f %{name}.lang
  101. %defattr(-, root, root, -)
  102. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  103. %{_sysconfdir}/gconf/schemas/gnome-phone-manager.schemas
  104. %{_bindir}/gnome-phone-manager
  105. %{_datadir}/applications/*.desktop
  106. %{_datadir}/gnome-phone-manager/
  107. %{_mandir}/man1/gnome-phone-manager.1.gz
  108. %files telepathy
  109. %{_libexecdir}/telepathy-phoney
  110. %{_datadir}/telepathy/managers/*
  111. %{_datadir}/dbus-1/services/*
  112. %{_datadir}/mission-control/profiles/*
  113. #----------------------------------------------------------------------------
  114. # Maintainers: babasaki@mindgear.org
  115. #
  116. #----------------------------------------------------------------------------
  117. %changelog
  118. * Mon Oct 27 2008 Seiichirou Babasaki - 0.60-4
  119. - Import gnome-phone-manager - Packager: Babasaki
  120. - Updated specfile
  121. #----------------------------------------------------------------------------
  122. * Tue Oct 07 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-3
  123. - Rebuild for new libgnokii
  124. * Thu Sep 11 2008 Matthias Clasen <mclasen@redhat.com>
  125. - Rebuild
  126. * Wed Jun 11 2008 - Bastien Nocera <bnocera@redhat.com> - 0.60-1
  127. - Update to 0.60
  128. - Remove vendor from desktop file
  129. * Wed May 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-2
  130. - Rebuild
  131. * Fri Mar 21 2008 - Bastien Nocera <bnocera@redhat.com> - 0.51-1
  132. - Update to 0.51
  133. * Fri Mar 14 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-3
  134. - Add a patch from upstream to fix connection to serial devices (#356861)
  135. * Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-2
  136. - Work-around for telepathy brokeness
  137. * Mon Mar 10 2008 - Bastien Nocera <bnocera@redhat.com> - 0.50-1
  138. - Update to 0.50
  139. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.40-3
  140. - Autorebuild for GCC 4.3
  141. * Wed Dec 12 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-2
  142. - Rebuild against new release of gnokii
  143. * Wed Nov 14 2007 - Bastien Nocera <bnocera@redhat.com> - 0.40-1
  144. - Update to 0.40
  145. - Add experimental telepathy backend in a subpackage
  146. * Mon Oct 29 2007 - Bastien Nocera <bnocera@redhat.com> - 0.30-1
  147. - Update to 0.30
  148. - Fix sending non-ASCII texts (for real)
  149. - Add debugging improvements
  150. * Wed Oct 17 2007 - Bastien Nocera <bnocera@redhat.com> - 0.20-1
  151. - Update to 0.20
  152. * Sun Aug 19 2007 - Bastien Nocera <bnocera@redhat.com> - 0.10-1
  153. - Update to 0.10 (#253400)
  154. - Remove obsolete work-arounds and dependencies
  155. - Update BRs
  156. - Add GConf scriptlets
  157. * Fri Aug 17 2007 Linus Walleij <triad@df.lth.se> 0.8-6
  158. - Update license field from GPL to GPLv2+
  159. * Sun Nov 15 2006 Linus Walleij <triad@df.lth.se> 0.8-5
  160. - Rebuild to pick up libbtctl i/f bump.
  161. * Sun Oct 29 2006 Linus Walleij <triad@df.lth.se> 0.8-4
  162. - Rebuild to pick up libedataserver i/f bump.
  163. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-3
  164. - Pick up intltool.
  165. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-2
  166. - Pick up libtool.
  167. * Sun Oct 8 2006 Linus Walleij <triad@df.lth.se> 0.8-1
  168. - New upstream version including patch.
  169. - The icon is an an even weirder place now!
  170. - Have to run som autotools on this one to get it working.
  171. * Tue Sep 5 2006 Linus Walleij <triad@df.lth.se> 0.7-5
  172. - Patch to compile with new version of E-D-S.
  173. * Thu Aug 10 2006 Linus Walleij <triad@df.lth.se> 0.7-4
  174. - Missing BR
  175. * Thu Aug 3 2006 Linus Walleij <triad@df.lth.se> 0.7-3
  176. - Updated after feedback from Chris Weyl
  177. - Bogus problem with cellphone.png icon image
  178. * Sat Jul 29 2006 Linus Walleij <triad@df.lth.se> 0.7-2
  179. - Updated after feedback from Parag and Paul
  180. * Tue Jun 27 2006 Linus Walleij <triad@df.lth.se> 0.7-1
  181. - 0.7 Release
  182. - Took Matthews nrpm package and Fedora Extrasificated it
  183. * Fri Sep 09 2005 Matthew Hall <matt@nrpms.net> 0.6-1
  184. - 0.6 Release
  185. * Mon Jun 20 2005 Matthew Hall <matt@nrpms.net> 0.4-1
  186. - 0.4 Release